fix
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2  
3 %global release 2chroot
4
5 Summary: RPM installer/updater
6 Name: yum
7 Version: 3.2.25
8 Release: %release
9 License: GPLv2+
10 Group: System Environment/Base
11 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
12 Source1: yum.conf.fedora
13 Source2: yum-updatesd.conf.fedora
14 Patch0: installonlyn-enable.patch
15 Patch1: yum-mirror-priority.patch
16 Patch2: yum-manpage-files.patch
17 Patch3: yum-multilib-policy-best.patch
18 Patch4: no-more-exactarchlist.patch
19 Patch5: geode-arch.patch
20 Patch10: yum-3.2.25-chroot.patch
21
22 URL: http://yum.baseurl.org/
23 BuildArch: noarch
24 BuildRequires: python
25 BuildRequires: gettext
26 BuildRequires: intltool
27 Conflicts: pirut < 1.1.4
28 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
29 Requires: python-iniparse
30 Requires: python-sqlite
31 Requires: python-urlgrabber >= 3.9.0-8
32 Requires: yum-metadata-parser >= 1.1.0
33 Requires: pygpgme
34 Obsoletes: yum-skip-broken, yum-basearchonly
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
36
37 %description
38 Yum is a utility that can check for and automatically download and
39 install updated RPM packages. Dependencies are obtained and downloaded 
40 automatically prompting the user as necessary.
41
42 %package updatesd
43 Summary: Update notification daemon
44 Group: Applications/System
45 Requires: yum = %{version}-%{release}
46 Requires: dbus-python
47 Requires: pygobject2
48 Requires(preun): /sbin/chkconfig
49 Requires(post): /sbin/chkconfig
50 Requires(preun): /sbin/service
51 Requires(post): /sbin/service
52
53 %description updatesd
54 yum-updatesd provides a daemon which checks for available updates and 
55 can notify you when they are available via email, syslog or dbus. 
56
57 %prep
58 %setup -q
59 %patch1 -p0
60 #%%%patch2 -p0
61 %patch3 -p0
62 %patch4 -p0
63 %patch5 -p1
64 %patch10 -p1
65
66 %build
67 make
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 make DESTDIR=$RPM_BUILD_ROOT install
72 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
73 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
74
75 # for now, move repodir/yum.conf back
76 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
77 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
78
79 # yum-updatesd has moved to the separate source version
80 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
81 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
82 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
83 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
84 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
85 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
86
87 %find_lang %name
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files -f %{name}.lang
93 %defattr(-, root, root, -)
94 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
95 %config(noreplace) %{_sysconfdir}/yum.conf
96 %dir %{_sysconfdir}/yum
97 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
98 %dir %{_sysconfdir}/yum.repos.d
99 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
100 %dir %{_datadir}/yum-cli
101 %{_datadir}/yum-cli/*
102 %{_bindir}/yum
103 %{python_sitelib}/yum
104 %{python_sitelib}/rpmUtils
105 %dir /var/cache/yum
106 %dir /var/lib/yum
107 %{_mandir}/man*/yum.*
108 %{_mandir}/man*/yum-shell*
109 # plugin stuff
110 %dir %{_sysconfdir}/yum/pluginconf.d 
111 %dir /usr/lib/yum-plugins
112
113 %changelog
114 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
115 - 3.2.25
116
117 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
118 - revert yum. import patch b/c it breaks a bunch of things
119
120 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
121 - fix up broken build b/c of version-groups.conf file
122
123 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
124 - fixes for odd outputs from ts.run and logs for what we store in history
125
126 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
127 - new head patch - fixes some issues with history and chroots
128
129 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
130 - latest head patch - includes yum history feature.
131
132 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
133 - new head patch - translation updates and a few bug fixes
134
135 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
136 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
137
138
139 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
140 - modify cachedir to include variables
141
142 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
143 - 3.2.24
144
145 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
146 - fix globbing issue 520810
147
148 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
149 - one more head update - fixes some fairly ugly but kind of minor bugs
150
151 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
152 - update to latest head pre 3.2.24
153 - add requirement on python-urlgrabber 3.9.0 and up
154
155 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
156 - latest head - right after freeze
157
158 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
159 - latest head - right before freeze :)
160
161 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
162 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
163
164 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
165 - remove exactarchlist by request for rawhide
166
167 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
168 - update to latest head - make livecd creation work again in rawhide
169 - disable one of the man page patches until after 3.2.24 is released b/c
170   of the changes to the man page in the head patch
171
172
173 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
174 - Update to latest head:
175 - Fix old recursion bug, found by new code.
176 - Resolves: bug#507220
177
178 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
179 - Update to latest head:
180 - Unbreak delPackage() excludes.
181 - Other fixes/etc.
182
183 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
184 - Actually apply the HEAD patch included yesterday :).
185
186 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
187 - update to latest head
188
189 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
190 - truncate changelog
191
192 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
193 - add patch to close rpmdb completely
194
195 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
196 - 3.2.23
197
198 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
199 - jump up to almost 3.2.23. 
200 - had to move patch0 around a bit until we rebase to 3.2.23
201
202 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
203 - fix typo for yum-complete-transaction message.
204
205 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
206 - fix for file:// urls which makes things in pungi/mash work
207
208 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
209 - yum-HEAD minus the yumdb patches
210
211 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
212 - 3.2.22 - 3 patches beyond 3.2.21-16
213
214 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
215 - fix for 490490
216
217 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
218 - update to upstream git to fix conditionals problem on anaconda installs
219
220 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
221 - latest HEAD
222
223 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
224 - f11beta build
225
226 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
227 - second verse, same as the first
228
229 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
230 - merge up a lot of fixes from latest HEAD
231
232 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
233 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
234
235 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
236 - merge up to latest yum head - sort of a pre 3.2.22
237
238 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
239 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
240
241 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
242 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
243
244 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
245 - patch to keep anaconda (and other callers) happy
246 - remove old 6hr patch which is now upstream
247
248 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
249 - patch to latest HEAD to test a number of fixes for alpha
250
251 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
252 - add a small patch to make things play a bit nicer with the logging module
253   in 2.6
254
255
256 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
257 - bump to 3.2.21
258
259 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
260 - merge latest from upstream
261 - move to 6hr metadata
262
263 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
264 - merge patch from upstream and remove now old obsoletes patch
265
266 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
267 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
268
269 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
270 - Rebuild for Python 2.6
271
272 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
273 - update head patch
274
275 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
276 - full patch against HEAD for skipbroken fixes (among others)
277
278 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
279 - Fix listTransaction for skipped packages.
280
281 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
282 - 3.2.20
283
284 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
285 - update HEAD patch
286
287 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
288 - rebase against 3.2.X HEAD
289
290 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
291 - pull patch from git to bring us up to current(ish)
292
293 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
294 - add patch to fix yum install name.arch matching
295
296 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
297 - add patch to fix mash's parser use.
298
299 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
300 - 3.2.19
301
302 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
303 - 3.2.18
304
305 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
306 - add patch from upstream for bug in compare_providers
307
308 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
309 - 3.2.17
310
311 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
312 - Add a couple more upstream patches for even more multilib fixes
313
314 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
315 - Add another patch from upstream for multilib policy and noarch
316
317 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
318 - stupid, stupid, stupid
319
320
321 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
322 - 3.2.16
323
324 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
325 - nine is the luckiest number that there will ever be
326
327 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
328 - after many tries - this one fixes translations AND pungi
329
330 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
331 - once more, with feeling
332
333 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
334 - another big-head-patch
335
336 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
337 - apply patch to bring this up to where HEAD is now.
338
339 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
340 - remove committed patch
341 - obsoletes yum-basearchonly
342
343 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
344 - fix minor typo in comps.py for jkeating
345
346 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
347 - 3.2.13
348
349 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
350 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
351
352
353 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
354 - multilib_policy=best is  now the default
355
356 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
357 - add jeff sheltren's patch to close rh bug 428825
358
359 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
360 - set failovermethod to 'priority' to make jkeating happy
361
362 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
363 - fix mutually obsoleting providers (like glibc!)
364
365 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
366 - 3.2.12
367
368 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
369 - 3.2.11
370
371 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
372 - Remove yumupd.py
373
374 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
375 - 3.2.10
376 - add pygpgme dep
377