7ce76d037a56b64a9f58a0e45d207a3a7fb0daa4
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2  
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.27
6 Release: 14%{?dist}
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12 Patch0: installonlyn-enable.patch
13 Patch1: yum-mirror-priority.patch
14 Patch2: yum-manpage-files.patch
15 Patch3: yum-multilib-policy-best.patch
16 Patch4: no-more-exactarchlist.patch
17 Patch5: geode-arch.patch
18 Patch6: BZ-528738-bugtracker.patch
19
20 Patch32: yum-distro-sync.patch
21 Patch33: yum-install-cmd-exit+provides-msgs+docs.patch
22 Patch34: yum-history-user.patch
23 Patch35: yum-PK-search-API.patch
24 Patch36: yum-history-list-errors+summary-user-column.patch
25 Patch37: yum-groupremove-leaf-only.patch
26 Patch38: yum-md-reget+yumvars+searchPrco.patch
27
28 Patch39: BZ-588911-yum.log-perms.patch
29 Patch40: BZ-577627-installroot-double-prefix.patch
30 Patch41: BZ-588910-nocontext-tsflag.patch
31 Patch42: BZ-588908-many-install-update-speedup.patch
32 Patch43: BZ-590340-move-rpmdb-from-cache.patch
33 Patch44: BZ-590339-edge-case-depsolving.patch
34 Patch45: BZ-593522-install-obs-arch.patch
35 Patch46: BZ-595553-akmods-cache-defense.patch
36 Patch47: BZ-602354-plugin-hooks-verify-transaction.patch
37 Patch48: BZ-584262-downgrade-dep-chain-remove.patch
38 Patch49: BZ-572770-int-flags-miscutils.patch
39 Patch50: BZ-598639-rpm-bindings-api-change-fix.patch
40 Patch51: BZ-603002-group_remove_leaf-empty-transaction.patch
41 Patch52: BZ-604080-localinstall-obsoleted.patch
42 Patch53: BZ-614496-traceback-no-proc-mounted.patch
43
44
45 Patch64: yum-ppc64-preferred.patch
46 Patch65: yum-3.2.27-i18n-off.patch
47
48 Patch100: yum-3.2.27_el6-chroot.patch
49
50 URL: http://yum.baseurl.org/
51 BuildArch: noarch
52 BuildRequires: python
53 BuildRequires: gettext
54 BuildRequires: intltool
55 Conflicts: pirut < 1.1.4
56 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
57 Requires: python-iniparse
58 Requires: python-sqlite
59 Requires: python-urlgrabber >= 3.9.0-8
60 Requires: yum-metadata-parser >= 1.1.0
61 Requires: pygpgme
62 Obsoletes: yum-skip-broken, yum-basearchonly
63 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
64
65 %description
66 Yum is a utility that can check for and automatically download and
67 install updated RPM packages. Dependencies are obtained and downloaded 
68 automatically prompting the user as necessary.
69
70 %package updatesd
71 Summary: Update notification daemon
72 Group: Applications/System
73 Requires: yum = %{version}-%{release}
74 Requires: dbus-python
75 Requires: pygobject2
76 Requires(preun): /sbin/chkconfig
77 Requires(post): /sbin/chkconfig
78 Requires(preun): /sbin/service
79 Requires(post): /sbin/service
80
81 %description updatesd
82 yum-updatesd provides a daemon which checks for available updates and 
83 can notify you when they are available via email, syslog or dbus. 
84
85 %prep
86 %setup -q
87 %patch1 -p0
88 %patch2 -p1
89 %patch3 -p0
90 %patch4 -p0
91 %patch5 -p1
92 %patch6 -p1
93 %patch32 -p1
94 %patch33 -p1
95 %patch34 -p1
96 %patch35 -p1
97 %patch36 -p1
98 %patch37 -p1
99 %patch38 -p1
100 %patch39 -p1
101 %patch40 -p1
102 %patch41 -p1
103 %patch42 -p1
104 %patch43 -p1
105 %patch44 -p1
106 %patch45 -p1
107 %patch46 -p1
108 %patch47 -p1
109 %patch48 -p1
110 %patch49 -p1
111 %patch50 -p1
112 %patch51 -p1
113 %patch52 -p1
114 %patch53 -p1
115 %patch64 -p0
116 %patch65 -p1
117
118 %patch100 -p1
119
120 %build
121 make
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 make DESTDIR=$RPM_BUILD_ROOT install
126 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
127 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
128
129 # for now, move repodir/yum.conf back
130 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
131 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
132
133 # yum-updatesd has moved to the separate source version
134 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
135 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
136 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
137 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
138 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
139 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
140
141 # Ghost files:
142 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
143 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
144 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
145 touch $RPM_BUILD_ROOT/var/lib/yum/uuid
146
147 %find_lang %name
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files -f %{name}.lang
153 %defattr(-, root, root, -)
154 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
155 %config(noreplace) %{_sysconfdir}/yum.conf
156 %dir %{_sysconfdir}/yum
157 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
158 # %dir %{_sysconfdir}/yum/protected.d
159 %dir %{_sysconfdir}/yum.repos.d
160 %dir %{_sysconfdir}/yum/vars
161 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
162 %{_sysconfdir}/bash_completion.d
163 %dir %{_datadir}/yum-cli
164 %{_datadir}/yum-cli/*
165 %{_bindir}/yum
166 %{python_sitelib}/yum
167 %{python_sitelib}/rpmUtils
168 %dir /var/cache/yum
169 %dir /var/lib/yum
170 %ghost /var/lib/yum/uuid
171 %ghost /var/lib/yum/history
172 %ghost /var/lib/yum/plugins
173 %ghost /var/lib/yum/yumdb
174 %{_mandir}/man*/yum.*
175 %{_mandir}/man*/yum-shell*
176 # plugin stuff
177 %dir %{_sysconfdir}/yum/pluginconf.d 
178 %dir /usr/lib/yum-plugins
179
180 %changelog
181 * Tue Aug 24 2010 Seth Vidal <svidal@redhat.com> - 3.2.27-14
182 - fixed 588911 patch to be correct patch
183 - add patch file for 572770 to take the old date from the wrong patch from 588911
184
185 * Tue Jul 27 2010 James Antill <james.antill@redhat.com> - 3.2.27-13
186 - Don't traceback when proc isn't mounted.
187 - Resolves: rhbz#614496
188 - Own the /etc/yum/vars dir.
189 - Resolves: rhbz#611906
190
191 * Wed Jun 16 2010 James Antill <james.antill@redhat.com> - 3.2.27-12
192 - Stop allowing installation of obsoleted, only by installed.
193 - Resolves: rhbz#604080
194
195 * Fri Jun 11 2010 James Antill <james.antill@redhat.com> - 3.2.27-10
196 - Stop downgrade dep. chain removals
197 - Resolves: rhbz#584262
198 - Fix for rpm bindings api change
199 - Resolves: rhbz#598639
200 - Add plugin hooks for verify transaction pre/post.
201 - Resolves: rhbz#602354
202 - Fix groupremove_leaf_only when it empties the transaction.
203 - Resolves: rhbz#603002
204
205 * Tue May 25 2010 James Antill <james.antill@redhat.com> - 3.2.27-9
206 - Fix installs of obsoleted multiarch packages.
207 - Resolves: rhbz#593522
208 - Create a defense against akmod style postinst install hacks.
209 - Resolves: rhbz#595553
210
211 * Tue May 11 2010 James Antill <james.antill@redhat.com> - 3.2.27-8
212 - Move rpmdb cache/indexes to /var/lib
213 - Resolves: rhbz#590340
214 - Fix old missing recheck in depsolve
215 - Resolves: rhbz#590339
216
217 * Tue May  4 2010 James Antill <james.antill@redhat.com> - 3.2.27-7
218 - A few minor bugfixes from upstream
219 - yum.log perms
220 - Resolves: rhbz#588911
221 - installroot double prefixing, on anaconda/kickstart install
222 - Resolves: rhbz#577627
223 - Add nocontexts flag to tsflags, if available.
224 - Resolves: rhbz#588910
225 - Speedup many install/update of same pkg.
226 - Resolves: rhbz#588908
227 - Correct os.path.link => os.path.islink typo, for dynamic yum vars.
228 - Resolves: rhbz#588907
229
230 * Fri Apr 16 2010 James Antill <james.antill@redhat.com> - 3.2.27-4
231 - A few minor bugfixes from upstream
232 - Add dynamic FS based yumvars
233 - Resolves: rhbz#576703
234
235 * Fri Mar 26 2010 James Antill <james.antill@redhat.com> - 3.2.27-3
236 - 3.2.27 from Fedora, and a couple of minor patches
237 - Resolves: rhbz#576703
238
239 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
240 - 3.2.27 from upstream (more or less the same as 3.2.26-6 but with a new number
241
242 * Thu Mar 11 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-6
243 - should be the final HEAD update before 3.2.27
244
245 * Thu Feb 24 2010 James Antill <james@fedoraproject.org> - 3.2.26-5
246 - new HEAD, minor features and speed.
247
248 * Wed Feb 17 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-4
249 - new HEAD to fix the fix to the fix
250
251 * Tue Feb 16 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
252 - latest head - including fixes to searchPrcos
253
254 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
255 - grumble.
256
257 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
258 - final 3.2.26
259
260 * Mon Feb  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-14
261 - $uuid, pkgtags searching, latest HEAD patch - pre 3.2.26
262
263 * Fri Jan 28 2010 James Antill <james at fedoraproject.org> - 3.2.25-13
264 - A couple of bugfixes, most notably:
265 -  you can now install gpg keys again!
266 -  bad installed file requires don't get cached.
267
268 * Fri Jan 22 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-12
269 - someone forgot to push their changes
270
271 * Fri Jan 22 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-11
272 - more fixes, more fun
273
274 * Fri Jan 15 2010 James Antill <james at fedoraproject.org> - 3.2.25-10
275 - latest head
276 - Fixes for pungi, rpmdb caching and kernel-PAE-devel duplicates finding
277 - among others.
278
279 * Mon Jan  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-8
280 - latest head
281
282 * Thu Dec 10 2009 James Antill <james at fedoraproject.org> - 3.2.25-7
283 - Fixes the mash bug, lookup in the tsInfo too. :(
284 - And fix the txmbr/po confusion ... third build the charm.
285
286 * Fri Dec  4 2009 James Antill <james at fedoraproject.org> - 3.2.25-4
287 - Fixes for yum clean all, BZ 544173
288 - Also allow "yum clean rpmdb" to work, bad tester, bad.
289
290 * Thu Dec  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-2
291 - rebuild yum with latest HEAD patch
292 - add rpmdb caching patch james wrote to see if it breaks everyone :)
293
294
295 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
296 - 3.2.25
297
298 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
299 - revert yum. import patch b/c it breaks a bunch of things
300
301 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
302 - fix up broken build b/c of version-groups.conf file
303
304 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
305 - fixes for odd outputs from ts.run and logs for what we store in history
306
307 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
308 - new head patch - fixes some issues with history and chroots
309
310 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
311 - latest head patch - includes yum history feature.
312
313 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
314 - new head patch - translation updates and a few bug fixes
315
316 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
317 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
318
319
320 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
321 - modify cachedir to include variables
322
323 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
324 - 3.2.24
325
326 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
327 - fix globbing issue 520810
328
329 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
330 - one more head update - fixes some fairly ugly but kind of minor bugs
331
332 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
333 - update to latest head pre 3.2.24
334 - add requirement on python-urlgrabber 3.9.0 and up
335
336 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
337 - latest head - right after freeze
338
339 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
340 - latest head - right before freeze :)
341
342 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
343 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
344
345 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
346 - remove exactarchlist by request for rawhide
347
348 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
349 - update to latest head - make livecd creation work again in rawhide
350 - disable one of the man page patches until after 3.2.24 is released b/c
351   of the changes to the man page in the head patch
352
353
354 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
355 - Update to latest head:
356 - Fix old recursion bug, found by new code.
357 - Resolves: bug#507220
358
359 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
360 - Update to latest head:
361 - Unbreak delPackage() excludes.
362 - Other fixes/etc.
363
364 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
365 - Actually apply the HEAD patch included yesterday :).
366
367 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
368 - update to latest head
369
370 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
371 - truncate changelog
372
373 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
374 - add patch to close rpmdb completely
375
376 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
377 - 3.2.23
378
379 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
380 - jump up to almost 3.2.23. 
381 - had to move patch0 around a bit until we rebase to 3.2.23
382
383 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
384 - fix typo for yum-complete-transaction message.
385
386 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
387 - fix for file:// urls which makes things in pungi/mash work
388
389 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
390 - yum-HEAD minus the yumdb patches
391
392 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
393 - 3.2.22 - 3 patches beyond 3.2.21-16
394
395 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
396 - fix for 490490
397
398 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
399 - update to upstream git to fix conditionals problem on anaconda installs
400
401 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
402 - latest HEAD
403
404 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
405 - f11beta build
406
407 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
408 - second verse, same as the first
409
410 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
411 - merge up a lot of fixes from latest HEAD
412
413 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
414 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
415
416 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
417 - merge up to latest yum head - sort of a pre 3.2.22
418
419 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
420 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
421
422 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
423 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
424
425 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
426 - patch to keep anaconda (and other callers) happy
427 - remove old 6hr patch which is now upstream
428
429 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
430 - patch to latest HEAD to test a number of fixes for alpha
431
432 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
433 - add a small patch to make things play a bit nicer with the logging module
434   in 2.6
435
436
437 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
438 - bump to 3.2.21
439
440 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
441 - merge latest from upstream
442 - move to 6hr metadata
443
444 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
445 - merge patch from upstream and remove now old obsoletes patch
446
447 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
448 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
449
450 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
451 - Rebuild for Python 2.6
452
453 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
454 - update head patch
455
456 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
457 - full patch against HEAD for skipbroken fixes (among others)
458
459 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
460 - Fix listTransaction for skipped packages.
461
462 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
463 - 3.2.20
464
465 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
466 - update HEAD patch
467
468 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
469 - rebase against 3.2.X HEAD
470
471 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
472 - pull patch from git to bring us up to current(ish)
473
474 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
475 - add patch to fix yum install name.arch matching
476
477 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
478 - add patch to fix mash's parser use.
479
480 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
481 - 3.2.19
482
483 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
484 - 3.2.18
485
486 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
487 - add patch from upstream for bug in compare_providers
488
489 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
490 - 3.2.17
491
492 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
493 - Add a couple more upstream patches for even more multilib fixes
494
495 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
496 - Add another patch from upstream for multilib policy and noarch
497
498 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
499 - stupid, stupid, stupid
500
501
502 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
503 - 3.2.16
504
505 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
506 - nine is the luckiest number that there will ever be
507
508 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
509 - after many tries - this one fixes translations AND pungi
510
511 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
512 - once more, with feeling
513
514 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
515 - another big-head-patch
516
517 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
518 - apply patch to bring this up to where HEAD is now.
519
520 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
521 - remove committed patch
522 - obsoletes yum-basearchonly
523
524 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
525 - fix minor typo in comps.py for jkeating
526
527 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
528 - 3.2.13
529
530 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
531 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
532
533
534 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
535 - multilib_policy=best is  now the default
536
537 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
538 - add jeff sheltren's patch to close rh bug 428825
539
540 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
541 - set failovermethod to 'priority' to make jkeating happy
542
543 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
544 - fix mutually obsoleting providers (like glibc!)
545
546 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
547 - 3.2.12
548
549 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
550 - 3.2.11
551
552 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
553 - Remove yumupd.py
554
555 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
556 - 3.2.10
557 - add pygpgme dep
558