Merge remote-tracking branch 'origin/f12' into rhel6
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 # the regular f14 yum is already tagged 5
4 %global release 99chroot
5  
6 Summary: RPM installer/updater
7 Name: yum
8 Version: 3.2.28
9 Release: %release
10 License: GPLv2+
11 Group: System Environment/Base
12 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
13 Source1: yum.conf.fedora
14 Source2: yum-updatesd.conf.fedora
15 Patch0: installonlyn-enable.patch
16 Patch1: yum-mirror-priority.patch
17 Patch3: yum-multilib-policy-best.patch
18 Patch4: no-more-exactarchlist.patch
19 Patch5: geode-arch.patch
20 Patch6: yum-HEAD.patch
21 Patch7: yum-PK-auto-close-fix.patch
22
23 Patch10: yum-3.2.28-chroot.patch
24
25 Patch20: yum-manpage-files.patch
26
27 URL: http://yum.baseurl.org/
28 BuildArch: noarch
29 BuildRequires: python
30 BuildRequires: gettext
31 BuildRequires: intltool
32 Conflicts: pirut < 1.1.4
33 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
34 Requires: python-iniparse
35 Requires: python-sqlite
36 Requires: python-urlgrabber >= 3.9.0-8
37 Requires: yum-metadata-parser >= 1.1.0
38 Requires: pygpgme
39 Obsoletes: yum-skip-broken <= 1.1.18
40 Obsoletes: yum-basearchonly <= 1.1.9
41 Obsoletes: yum-plugin-basearchonly <= 1.1.24
42 Obsoletes: yum-allow-downgrade < 1.1.20-0
43 Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
44 Obsoletes: yum-plugin-protect-packages < 1.1.27-0
45 Obsoletes: yum-plugin-download-order <= 0.2-2
46 Provides: yum-skip-broken
47 Provides: yum-basearchonly
48 Provides: yum-allow-downgrade
49 Provides: yum-plugin-allow-downgrade
50 Provides: yum-protect-packages
51 Provides: yum-plugin-protect-packages
52 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
53
54 %description
55 Yum is a utility that can check for and automatically download and
56 install updated RPM packages. Dependencies are obtained and downloaded 
57 automatically, prompting the user for permission as necessary.
58
59 %package updatesd
60 Summary: Update notification daemon
61 Group: Applications/System
62 Requires: yum = %{version}-%{release}
63 Requires: dbus-python
64 Requires: pygobject2
65 Requires(preun): /sbin/chkconfig
66 Requires(post): /sbin/chkconfig
67 Requires(preun): /sbin/service
68 Requires(post): /sbin/service
69
70 %description updatesd
71 yum-updatesd provides a daemon which checks for available updates and 
72 can notify you when they are available via email, syslog or dbus. 
73
74 %prep
75 %setup -q
76 %patch1 -p0
77 %patch3 -p0
78 %patch4 -p0
79 %patch5 -p1
80 %patch6 -p1
81 %patch7 -p1
82
83 %patch10 -p1
84
85 %patch20 -p1
86
87 %build
88 make
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 make DESTDIR=$RPM_BUILD_ROOT install
93 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
95
96 # for now, move repodir/yum.conf back
97 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
98 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
99
100 # yum-updatesd has moved to the separate source version
101 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
102 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
103 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
104 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
105 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
106 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
107
108 # Ghost files:
109 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
110 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
111 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
112 touch $RPM_BUILD_ROOT/var/lib/yum/uuid
113
114 %find_lang %name
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files -f %{name}.lang
120 %defattr(-, root, root, -)
121 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
122 %config(noreplace) %{_sysconfdir}/yum.conf
123 %dir %{_sysconfdir}/yum
124 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
125 %dir %{_sysconfdir}/yum/protected.d
126 %dir %{_sysconfdir}/yum.repos.d
127 %dir %{_sysconfdir}/yum/vars
128 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
129 %{_sysconfdir}/bash_completion.d
130 %dir %{_datadir}/yum-cli
131 %{_datadir}/yum-cli/*
132 %{_bindir}/yum
133 %{python_sitelib}/yum
134 %{python_sitelib}/rpmUtils
135 %dir /var/cache/yum
136 %dir /var/lib/yum
137 %ghost /var/lib/yum/uuid
138 %ghost /var/lib/yum/history
139 %ghost /var/lib/yum/plugins
140 %ghost /var/lib/yum/yumdb
141 %{_mandir}/man*/yum.*
142 %{_mandir}/man*/yum-shell*
143 # plugin stuff
144 %dir %{_sysconfdir}/yum/pluginconf.d 
145 %dir /usr/lib/yum-plugins
146
147 %changelog
148 * Tue Sep 14 2010 James Antill <james at fedoraproject.org> - 3.2.28-4
149 - Fix auto-close bug with GPG key installs.
150 - Resolves: bug#622179
151 - Fix obsoletes on basearchonly.
152 - Resolves: bug#629138
153
154 * Fri Aug 27 2010 Seth Vidal <skvidal at fedoraproject.org> 
155 - obsoleted yum-plugin-download-order
156
157 * Thu Aug 12 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-3
158 - latest head
159 - fix gpg key import
160 - more unicode fixes
161 - output slightly more clear depsovling error msgs
162 - sync up spec file with f13,f14
163
164 * Mon Aug  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-2
165 - fixes sqlite historydb conversion bug
166 - patches up some unicide issues
167
168
169 * Fri Jul 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-1
170 - 3.2.28
171
172 * Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
173 - fix regets on metadata when we run into an old file that's larger
174   than the new one
175
176 * Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
177 - broke searching in PK, this patch fixes it.
178
179 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
180 - update to 3.2.27 - lots of fixes since 3.2.26
181
182 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
183 - up to head-as-f13-has and include the skip-broken fix
184
185
186 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
187 - grumble.
188
189 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
190 - final 3.2.26
191
192 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
193 - 3.2.25
194
195 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
196 - revert yum. import patch b/c it breaks a bunch of things
197
198 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
199 - fix up broken build b/c of version-groups.conf file
200
201 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
202 - fixes for odd outputs from ts.run and logs for what we store in history
203
204 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
205 - new head patch - fixes some issues with history and chroots
206
207 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
208 - latest head patch - includes yum history feature.
209
210 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
211 - new head patch - translation updates and a few bug fixes
212
213 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
214 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
215
216
217 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
218 - modify cachedir to include variables
219
220 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
221 - 3.2.24
222
223 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
224 - fix globbing issue 520810
225
226 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
227 - one more head update - fixes some fairly ugly but kind of minor bugs
228
229 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
230 - update to latest head pre 3.2.24
231 - add requirement on python-urlgrabber 3.9.0 and up
232
233 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
234 - latest head - right after freeze
235
236 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
237 - latest head - right before freeze :)
238
239 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
240 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
241
242 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
243 - remove exactarchlist by request for rawhide
244
245 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
246 - update to latest head - make livecd creation work again in rawhide
247 - disable one of the man page patches until after 3.2.24 is released b/c
248   of the changes to the man page in the head patch
249
250
251 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
252 - Update to latest head:
253 - Fix old recursion bug, found by new code.
254 - Resolves: bug#507220
255
256 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
257 - Update to latest head:
258 - Unbreak delPackage() excludes.
259 - Other fixes/etc.
260
261 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
262 - Actually apply the HEAD patch included yesterday :).
263
264 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
265 - update to latest head
266
267 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
268 - truncate changelog
269
270 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
271 - add patch to close rpmdb completely
272
273 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
274 - 3.2.23
275
276 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
277 - jump up to almost 3.2.23. 
278 - had to move patch0 around a bit until we rebase to 3.2.23
279
280 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
281 - fix typo for yum-complete-transaction message.
282
283 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
284 - fix for file:// urls which makes things in pungi/mash work
285
286 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
287 - yum-HEAD minus the yumdb patches
288
289 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
290 - 3.2.22 - 3 patches beyond 3.2.21-16
291
292 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
293 - fix for 490490
294
295 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
296 - update to upstream git to fix conditionals problem on anaconda installs
297
298 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
299 - latest HEAD
300
301 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
302 - f11beta build
303
304 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
305 - second verse, same as the first
306
307 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
308 - merge up a lot of fixes from latest HEAD
309
310 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
311 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
312
313 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
314 - merge up to latest yum head - sort of a pre 3.2.22
315
316 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
317 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
318
319 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
320 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
321
322 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
323 - patch to keep anaconda (and other callers) happy
324 - remove old 6hr patch which is now upstream
325
326 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
327 - patch to latest HEAD to test a number of fixes for alpha
328
329 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
330 - add a small patch to make things play a bit nicer with the logging module
331   in 2.6
332
333
334 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
335 - bump to 3.2.21
336
337 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
338 - merge latest from upstream
339 - move to 6hr metadata
340
341 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
342 - merge patch from upstream and remove now old obsoletes patch
343
344 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
345 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
346
347 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
348 - Rebuild for Python 2.6
349
350 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
351 - update head patch
352
353 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
354 - full patch against HEAD for skipbroken fixes (among others)
355
356 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
357 - Fix listTransaction for skipped packages.
358
359 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
360 - 3.2.20
361
362 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
363 - update HEAD patch
364
365 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
366 - rebase against 3.2.X HEAD
367
368 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
369 - pull patch from git to bring us up to current(ish)
370
371 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
372 - add patch to fix yum install name.arch matching
373
374 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
375 - add patch to fix mash's parser use.
376
377 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
378 - 3.2.19
379
380 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
381 - 3.2.18
382
383 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
384 - add patch from upstream for bug in compare_providers
385
386 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
387 - 3.2.17
388
389 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
390 - Add a couple more upstream patches for even more multilib fixes
391
392 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
393 - Add another patch from upstream for multilib policy and noarch
394
395 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
396 - stupid, stupid, stupid
397
398
399 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
400 - 3.2.16
401
402 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
403 - nine is the luckiest number that there will ever be
404
405 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
406 - after many tries - this one fixes translations AND pungi
407
408 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
409 - once more, with feeling
410
411 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
412 - another big-head-patch
413
414 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
415 - apply patch to bring this up to where HEAD is now.
416
417 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
418 - remove committed patch
419 - obsoletes yum-basearchonly
420
421 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
422 - fix minor typo in comps.py for jkeating
423
424 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
425 - 3.2.13
426
427 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
428 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
429
430
431 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
432 - multilib_policy=best is  now the default
433
434 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
435 - add jeff sheltren's patch to close rh bug 428825
436
437 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
438 - set failovermethod to 'priority' to make jkeating happy
439
440 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
441 - fix mutually obsoleting providers (like glibc!)
442
443 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
444 - 3.2.12
445
446 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
447 - 3.2.11
448
449 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
450 - Remove yumupd.py
451
452 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
453 - 3.2.10
454 - add pygpgme dep
455