c81e0af935470b3e5b5de6e1889147f6a112372d
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2  
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.27
6 Release: 1%{?dist}
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12 Patch0: installonlyn-enable.patch
13 Patch1: yum-mirror-priority.patch
14 Patch2: yum-manpage-files.patch
15 Patch3: yum-multilib-policy-best.patch
16 Patch4: no-more-exactarchlist.patch
17 Patch5: geode-arch.patch
18 Patch6: yum-HEAD.patch
19 Patch10: yum-3.2.27-chroot.patch
20
21 URL: http://yum.baseurl.org/
22 BuildArch: noarch
23 BuildRequires: python
24 BuildRequires: gettext
25 BuildRequires: intltool
26 Conflicts: pirut < 1.1.4
27 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
28 Requires: python-iniparse
29 Requires: python-sqlite
30 Requires: python-urlgrabber >= 3.9.0-8
31 Requires: yum-metadata-parser >= 1.1.0
32 Requires: pygpgme
33 Obsoletes: yum-skip-broken, yum-basearchonly
34 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
35
36 %description
37 Yum is a utility that can check for and automatically download and
38 install updated RPM packages. Dependencies are obtained and downloaded 
39 automatically prompting the user as necessary.
40
41 %package updatesd
42 Summary: Update notification daemon
43 Group: Applications/System
44 Requires: yum = %{version}-%{release}
45 Requires: dbus-python
46 Requires: pygobject2
47 Requires(preun): /sbin/chkconfig
48 Requires(post): /sbin/chkconfig
49 Requires(preun): /sbin/service
50 Requires(post): /sbin/service
51
52 %description updatesd
53 yum-updatesd provides a daemon which checks for available updates and 
54 can notify you when they are available via email, syslog or dbus. 
55
56 %prep
57 %setup -q
58 %patch1 -p0
59 #%%%patch2 -p0
60 %patch3 -p0
61 %patch4 -p0
62 %patch5 -p1
63 #%%%%patch6 -p1
64 %patch10 -p1
65
66 %build
67
68 make
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 make DESTDIR=$RPM_BUILD_ROOT install
73 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
74 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
75
76 # for now, move repodir/yum.conf back
77 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
78 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
79
80 # yum-updatesd has moved to the separate source version
81 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
82 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
83 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
84 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
85 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
86 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
87
88 %find_lang %name
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files -f %{name}.lang
94 %defattr(-, root, root, -)
95 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
96 %config(noreplace) %{_sysconfdir}/yum.conf
97 %dir %{_sysconfdir}/yum
98 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
99 %dir %{_sysconfdir}/yum.repos.d
100 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
101 %{_sysconfdir}/bash_completion.d
102 %dir %{_datadir}/yum-cli
103 %{_datadir}/yum-cli/*
104 %{_bindir}/yum
105 %{python_sitelib}/yum
106 %{python_sitelib}/rpmUtils
107 %dir /var/cache/yum
108 %dir /var/lib/yum
109 %{_mandir}/man*/yum.*
110 %{_mandir}/man*/yum-shell*
111 # plugin stuff
112 %dir %{_sysconfdir}/yum/pluginconf.d 
113 %dir /usr/lib/yum-plugins
114
115 %changelog
116 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
117 - update to 3.2.27 - lots of fixes since 3.2.26
118
119 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
120 - up to head-as-f13-has and include the skip-broken fix
121
122
123 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
124 - grumble.
125
126 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
127 - final 3.2.26
128
129 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
130 - 3.2.25
131
132 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
133 - revert yum. import patch b/c it breaks a bunch of things
134
135 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
136 - fix up broken build b/c of version-groups.conf file
137
138 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
139 - fixes for odd outputs from ts.run and logs for what we store in history
140
141 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
142 - new head patch - fixes some issues with history and chroots
143
144 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
145 - latest head patch - includes yum history feature.
146
147 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
148 - new head patch - translation updates and a few bug fixes
149
150 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
151 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
152
153
154 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
155 - modify cachedir to include variables
156
157 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
158 - 3.2.24
159
160 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
161 - fix globbing issue 520810
162
163 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
164 - one more head update - fixes some fairly ugly but kind of minor bugs
165
166 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
167 - update to latest head pre 3.2.24
168 - add requirement on python-urlgrabber 3.9.0 and up
169
170 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
171 - latest head - right after freeze
172
173 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
174 - latest head - right before freeze :)
175
176 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
177 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
178
179 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
180 - remove exactarchlist by request for rawhide
181
182 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
183 - update to latest head - make livecd creation work again in rawhide
184 - disable one of the man page patches until after 3.2.24 is released b/c
185   of the changes to the man page in the head patch
186
187
188 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
189 - Update to latest head:
190 - Fix old recursion bug, found by new code.
191 - Resolves: bug#507220
192
193 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
194 - Update to latest head:
195 - Unbreak delPackage() excludes.
196 - Other fixes/etc.
197
198 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
199 - Actually apply the HEAD patch included yesterday :).
200
201 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
202 - update to latest head
203
204 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
205 - truncate changelog
206
207 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
208 - add patch to close rpmdb completely
209
210 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
211 - 3.2.23
212
213 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
214 - jump up to almost 3.2.23. 
215 - had to move patch0 around a bit until we rebase to 3.2.23
216
217 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
218 - fix typo for yum-complete-transaction message.
219
220 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
221 - fix for file:// urls which makes things in pungi/mash work
222
223 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
224 - yum-HEAD minus the yumdb patches
225
226 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
227 - 3.2.22 - 3 patches beyond 3.2.21-16
228
229 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
230 - fix for 490490
231
232 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
233 - update to upstream git to fix conditionals problem on anaconda installs
234
235 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
236 - latest HEAD
237
238 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
239 - f11beta build
240
241 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
242 - second verse, same as the first
243
244 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
245 - merge up a lot of fixes from latest HEAD
246
247 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
248 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
249
250 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
251 - merge up to latest yum head - sort of a pre 3.2.22
252
253 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
254 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
255
256 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
257 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
258
259 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
260 - patch to keep anaconda (and other callers) happy
261 - remove old 6hr patch which is now upstream
262
263 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
264 - patch to latest HEAD to test a number of fixes for alpha
265
266 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
267 - add a small patch to make things play a bit nicer with the logging module
268   in 2.6
269
270
271 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
272 - bump to 3.2.21
273
274 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
275 - merge latest from upstream
276 - move to 6hr metadata
277
278 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
279 - merge patch from upstream and remove now old obsoletes patch
280
281 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
282 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
283
284 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
285 - Rebuild for Python 2.6
286
287 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
288 - update head patch
289
290 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
291 - full patch against HEAD for skipbroken fixes (among others)
292
293 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
294 - Fix listTransaction for skipped packages.
295
296 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
297 - 3.2.20
298
299 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
300 - update HEAD patch
301
302 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
303 - rebase against 3.2.X HEAD
304
305 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
306 - pull patch from git to bring us up to current(ish)
307
308 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
309 - add patch to fix yum install name.arch matching
310
311 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
312 - add patch to fix mash's parser use.
313
314 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
315 - 3.2.19
316
317 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
318 - 3.2.18
319
320 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
321 - add patch from upstream for bug in compare_providers
322
323 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
324 - 3.2.17
325
326 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
327 - Add a couple more upstream patches for even more multilib fixes
328
329 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
330 - Add another patch from upstream for multilib policy and noarch
331
332 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
333 - stupid, stupid, stupid
334
335
336 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
337 - 3.2.16
338
339 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
340 - nine is the luckiest number that there will ever be
341
342 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
343 - after many tries - this one fixes translations AND pungi
344
345 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
346 - once more, with feeling
347
348 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
349 - another big-head-patch
350
351 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
352 - apply patch to bring this up to where HEAD is now.
353
354 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
355 - remove committed patch
356 - obsoletes yum-basearchonly
357
358 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
359 - fix minor typo in comps.py for jkeating
360
361 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
362 - 3.2.13
363
364 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
365 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
366
367
368 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
369 - multilib_policy=best is  now the default
370
371 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
372 - add jeff sheltren's patch to close rh bug 428825
373
374 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
375 - set failovermethod to 'priority' to make jkeating happy
376
377 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
378 - fix mutually obsoleting providers (like glibc!)
379
380 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
381 - 3.2.12
382
383 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
384 - 3.2.11
385
386 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
387 - Remove yumupd.py
388
389 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
390 - 3.2.10
391 - add pygpgme dep
392