e10ad7cf870d409a2ddc3aee5b9277b94600ecef
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 %global release 3chroot
4  
5 Summary: RPM installer/updater
6 Name: yum
7 Version: 3.2.27
8 Release: %release
9 License: GPLv2+
10 Group: System Environment/Base
11 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
12 Source1: yum.conf.fedora
13 Source2: yum-updatesd.conf.fedora
14 Patch0: installonlyn-enable.patch
15 Patch1: yum-mirror-priority.patch
16 Patch2: yum-manpage-files.patch
17 Patch3: yum-multilib-policy-best.patch
18 Patch4: no-more-exactarchlist.patch
19 Patch5: geode-arch.patch
20 Patch6: yum-HEAD.patch
21 Patch7: yum-do-not-overwrite-keys.patch
22 Patch10: yum-3.2.27-chroot.patch
23
24 URL: http://yum.baseurl.org/
25 BuildArch: noarch
26 BuildRequires: python
27 BuildRequires: gettext
28 BuildRequires: intltool
29 Conflicts: pirut < 1.1.4
30 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
31 Requires: python-iniparse
32 Requires: python-sqlite
33 Requires: python-urlgrabber >= 3.9.0-8
34 Requires: yum-metadata-parser >= 1.1.0
35 Requires: pygpgme
36 Obsoletes: yum-skip-broken, yum-basearchonly
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
38
39 %description
40 Yum is a utility that can check for and automatically download and
41 install updated RPM packages. Dependencies are obtained and downloaded 
42 automatically prompting the user as necessary.
43
44 %package updatesd
45 Summary: Update notification daemon
46 Group: Applications/System
47 Requires: yum = %{version}-%{release}
48 Requires: dbus-python
49 Requires: pygobject2
50 Requires(preun): /sbin/chkconfig
51 Requires(post): /sbin/chkconfig
52 Requires(preun): /sbin/service
53 Requires(post): /sbin/service
54
55 %description updatesd
56 yum-updatesd provides a daemon which checks for available updates and 
57 can notify you when they are available via email, syslog or dbus. 
58
59 %prep
60 %setup -q
61 %patch1 -p0
62 #%%%patch2 -p0
63 %patch3 -p0
64 %patch4 -p0
65 %patch5 -p1
66 #%%%%patch6 -p1
67 %patch7 -p1
68
69 %patch10 -p1
70
71 %build
72 make
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 make DESTDIR=$RPM_BUILD_ROOT install
77 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
78 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
79
80 # for now, move repodir/yum.conf back
81 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
82 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
83
84 # yum-updatesd has moved to the separate source version
85 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
86 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
87 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
88 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
89 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
90 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
91
92 %find_lang %name
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files -f %{name}.lang
98 %defattr(-, root, root, -)
99 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
100 %config(noreplace) %{_sysconfdir}/yum.conf
101 %dir %{_sysconfdir}/yum
102 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
103 %dir %{_sysconfdir}/yum.repos.d
104 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
105 %{_sysconfdir}/bash_completion.d
106 %dir %{_datadir}/yum-cli
107 %{_datadir}/yum-cli/*
108 %{_bindir}/yum
109 %{python_sitelib}/yum
110 %{python_sitelib}/rpmUtils
111 %dir /var/cache/yum
112 %dir /var/lib/yum
113 %{_mandir}/man*/yum.*
114 %{_mandir}/man*/yum-shell*
115 # plugin stuff
116 %dir %{_sysconfdir}/yum/pluginconf.d 
117 %dir /usr/lib/yum-plugins
118
119 %changelog
120 * Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
121 - broke searching in PK, this patch fixes it.
122
123 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
124 - update to 3.2.27 - lots of fixes since 3.2.26
125
126 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
127 - up to head-as-f13-has and include the skip-broken fix
128
129
130 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
131 - grumble.
132
133 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
134 - final 3.2.26
135
136 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
137 - 3.2.25
138
139 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
140 - revert yum. import patch b/c it breaks a bunch of things
141
142 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
143 - fix up broken build b/c of version-groups.conf file
144
145 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
146 - fixes for odd outputs from ts.run and logs for what we store in history
147
148 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
149 - new head patch - fixes some issues with history and chroots
150
151 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
152 - latest head patch - includes yum history feature.
153
154 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
155 - new head patch - translation updates and a few bug fixes
156
157 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
158 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
159
160
161 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
162 - modify cachedir to include variables
163
164 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
165 - 3.2.24
166
167 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
168 - fix globbing issue 520810
169
170 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
171 - one more head update - fixes some fairly ugly but kind of minor bugs
172
173 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
174 - update to latest head pre 3.2.24
175 - add requirement on python-urlgrabber 3.9.0 and up
176
177 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
178 - latest head - right after freeze
179
180 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
181 - latest head - right before freeze :)
182
183 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
184 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
185
186 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
187 - remove exactarchlist by request for rawhide
188
189 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
190 - update to latest head - make livecd creation work again in rawhide
191 - disable one of the man page patches until after 3.2.24 is released b/c
192   of the changes to the man page in the head patch
193
194
195 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
196 - Update to latest head:
197 - Fix old recursion bug, found by new code.
198 - Resolves: bug#507220
199
200 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
201 - Update to latest head:
202 - Unbreak delPackage() excludes.
203 - Other fixes/etc.
204
205 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
206 - Actually apply the HEAD patch included yesterday :).
207
208 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
209 - update to latest head
210
211 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
212 - truncate changelog
213
214 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
215 - add patch to close rpmdb completely
216
217 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
218 - 3.2.23
219
220 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
221 - jump up to almost 3.2.23. 
222 - had to move patch0 around a bit until we rebase to 3.2.23
223
224 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
225 - fix typo for yum-complete-transaction message.
226
227 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
228 - fix for file:// urls which makes things in pungi/mash work
229
230 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
231 - yum-HEAD minus the yumdb patches
232
233 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
234 - 3.2.22 - 3 patches beyond 3.2.21-16
235
236 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
237 - fix for 490490
238
239 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
240 - update to upstream git to fix conditionals problem on anaconda installs
241
242 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
243 - latest HEAD
244
245 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
246 - f11beta build
247
248 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
249 - second verse, same as the first
250
251 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
252 - merge up a lot of fixes from latest HEAD
253
254 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
255 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
256
257 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
258 - merge up to latest yum head - sort of a pre 3.2.22
259
260 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
261 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
262
263 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
264 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
265
266 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
267 - patch to keep anaconda (and other callers) happy
268 - remove old 6hr patch which is now upstream
269
270 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
271 - patch to latest HEAD to test a number of fixes for alpha
272
273 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
274 - add a small patch to make things play a bit nicer with the logging module
275   in 2.6
276
277
278 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
279 - bump to 3.2.21
280
281 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
282 - merge latest from upstream
283 - move to 6hr metadata
284
285 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
286 - merge patch from upstream and remove now old obsoletes patch
287
288 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
289 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
290
291 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
292 - Rebuild for Python 2.6
293
294 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
295 - update head patch
296
297 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
298 - full patch against HEAD for skipbroken fixes (among others)
299
300 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
301 - Fix listTransaction for skipped packages.
302
303 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
304 - 3.2.20
305
306 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
307 - update HEAD patch
308
309 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
310 - rebase against 3.2.X HEAD
311
312 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
313 - pull patch from git to bring us up to current(ish)
314
315 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
316 - add patch to fix yum install name.arch matching
317
318 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
319 - add patch to fix mash's parser use.
320
321 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
322 - 3.2.19
323
324 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
325 - 3.2.18
326
327 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
328 - add patch from upstream for bug in compare_providers
329
330 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
331 - 3.2.17
332
333 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
334 - Add a couple more upstream patches for even more multilib fixes
335
336 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
337 - Add another patch from upstream for multilib policy and noarch
338
339 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
340 - stupid, stupid, stupid
341
342
343 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
344 - 3.2.16
345
346 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
347 - nine is the luckiest number that there will ever be
348
349 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
350 - after many tries - this one fixes translations AND pungi
351
352 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
353 - once more, with feeling
354
355 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
356 - another big-head-patch
357
358 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
359 - apply patch to bring this up to where HEAD is now.
360
361 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
362 - remove committed patch
363 - obsoletes yum-basearchonly
364
365 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
366 - fix minor typo in comps.py for jkeating
367
368 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
369 - 3.2.13
370
371 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
372 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
373
374
375 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
376 - multilib_policy=best is  now the default
377
378 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
379 - add jeff sheltren's patch to close rh bug 428825
380
381 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
382 - set failovermethod to 'priority' to make jkeating happy
383
384 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
385 - fix mutually obsoleting providers (like glibc!)
386
387 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
388 - 3.2.12
389
390 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
391 - 3.2.11
392
393 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
394 - Remove yumupd.py
395
396 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
397 - 3.2.10
398 - add pygpgme dep
399