sync with f12
[yum.git] / yum.spec
index 540dd67..33848be 100644 (file)
--- a/yum.spec
+++ b/yum.spec
@@ -1,10 +1,10 @@
 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
-%global release 4chroot
+%global release 5chroot
  
 Summary: RPM installer/updater
 Name: yum
-Version: 3.2.27
+Version: 3.2.28
 Release: %release
 License: GPLv2+
 Group: System Environment/Base
@@ -13,14 +13,15 @@ Source1: yum.conf.fedora
 Source2: yum-updatesd.conf.fedora
 Patch0: installonlyn-enable.patch
 Patch1: yum-mirror-priority.patch
-Patch2: yum-manpage-files.patch
 Patch3: yum-multilib-policy-best.patch
 Patch4: no-more-exactarchlist.patch
 Patch5: geode-arch.patch
 Patch6: yum-HEAD.patch
-Patch7: yum-do-not-overwrite-keys.patch
-Patch8: reget-metadata-size-fix.patch
-Patch10: yum-3.2.27-chroot.patch
+Patch7: yum-PK-auto-close-fix.patch
+
+Patch10: yum-3.2.28-chroot.patch
+
+Patch20: yum-manpage-files.patch
 
 URL: http://yum.baseurl.org/
 BuildArch: noarch
@@ -34,13 +35,25 @@ Requires: python-sqlite
 Requires: python-urlgrabber >= 3.9.0-8
 Requires: yum-metadata-parser >= 1.1.0
 Requires: pygpgme
-Obsoletes: yum-skip-broken, yum-basearchonly
+Obsoletes: yum-skip-broken <= 1.1.18
+Obsoletes: yum-basearchonly <= 1.1.9
+Obsoletes: yum-plugin-basearchonly <= 1.1.24
+Obsoletes: yum-allow-downgrade < 1.1.20-0
+Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
+Obsoletes: yum-plugin-protect-packages < 1.1.27-0
+Obsoletes: yum-plugin-download-order <= 0.2-2
+Provides: yum-skip-broken
+Provides: yum-basearchonly
+Provides: yum-allow-downgrade
+Provides: yum-plugin-allow-downgrade
+Provides: yum-protect-packages
+Provides: yum-plugin-protect-packages
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 %description
 Yum is a utility that can check for and automatically download and
 install updated RPM packages. Dependencies are obtained and downloaded 
-automatically prompting the user as necessary.
+automatically, prompting the user for permission as necessary.
 
 %package updatesd
 Summary: Update notification daemon
@@ -60,16 +73,16 @@ can notify you when they are available via email, syslog or dbus.
 %prep
 %setup -q
 %patch1 -p0
-#%%%patch2 -p0
 %patch3 -p0
 %patch4 -p0
 %patch5 -p1
-#%%%%patch6 -p1
+%patch6 -p1
 %patch7 -p1
-%patch8 -p1
 
 %patch10 -p1
 
+%patch20 -p1
+
 %build
 make
 
@@ -91,6 +104,12 @@ rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
 
+# Ghost files:
+mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
+mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
+mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
+touch $RPM_BUILD_ROOT/var/lib/yum/uuid
+
 %find_lang %name
 
 %clean
@@ -102,7 +121,9 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %{_sysconfdir}/yum.conf
 %dir %{_sysconfdir}/yum
 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
+%dir %{_sysconfdir}/yum/protected.d
 %dir %{_sysconfdir}/yum.repos.d
+%dir %{_sysconfdir}/yum/vars
 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
 %{_sysconfdir}/bash_completion.d
 %dir %{_datadir}/yum-cli
@@ -112,6 +133,10 @@ rm -rf $RPM_BUILD_ROOT
 %{python_sitelib}/rpmUtils
 %dir /var/cache/yum
 %dir /var/lib/yum
+%ghost /var/lib/yum/uuid
+%ghost /var/lib/yum/history
+%ghost /var/lib/yum/plugins
+%ghost /var/lib/yum/yumdb
 %{_mandir}/man*/yum.*
 %{_mandir}/man*/yum-shell*
 # plugin stuff
@@ -119,6 +144,30 @@ rm -rf $RPM_BUILD_ROOT
 %dir /usr/lib/yum-plugins
 
 %changelog
+* Tue Sep 14 2010 James Antill <james at fedoraproject.org> - 3.2.28-4
+- Fix auto-close bug with GPG key installs.
+- Resolves: bug#622179
+- Fix obsoletes on basearchonly.
+- Resolves: bug#629138
+
+* Fri Aug 27 2010 Seth Vidal <skvidal at fedoraproject.org> 
+- obsoleted yum-plugin-download-order
+
+* Thu Aug 12 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-3
+- latest head
+- fix gpg key import
+- more unicode fixes
+- output slightly more clear depsovling error msgs
+- sync up spec file with f13,f14
+
+* Mon Aug  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-2
+- fixes sqlite historydb conversion bug
+- patches up some unicide issues
+
+
+* Fri Jul 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-1
+- 3.2.28
+
 * Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
 - fix regets on metadata when we run into an old file that's larger
   than the new one