fix another typo
[plcapi.git] / PLCAPI.spec
1 %define url $URL$
2
3 %define name PLCAPI
4 %define version 5.0
5 %define taglevel 18
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Central API
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %(echo %{url} | cut -d ' ' -f 2)
22
23 Obsoletes: plcapilib
24
25 # We use set everywhere
26 Requires: python >= 2.4
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 Requires: postgresql-python
29 Requires: python-psycopg2
30 Requires: python-pycurl
31 Requires: httpd
32 Requires: mod_python
33 # mod_wsgi will replace mod_python when we are ready
34 Requires: mod_wsgi
35 Requires: mod_ssl
36 Requires: SOAPpy
37 Requires: python-simplejson
38 # for the RebootNodeWithPCU method
39 Requires: pcucontrol >= 1.0-6
40 # for OMF integration
41 Requires: pyaspects >= 0.4
42 Requires: python-twisted-words
43 Requires: python-twisted-web
44 # ldap
45 Requires: python-ldap
46
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %define php_extension_dir %(php-config --extension-dir)
124
125 %files
126 %defattr(-,root,root,-)
127 %dir %{_datadir}/plc_api
128 %dir /var/log/omf/
129 %{_datadir}/plc_api/*
130 %{_bindir}/plcsh
131 %{php_extension_dir}/xmlrpc.so
132 %{_sysconfdir}/php.d/xmlrpc.ini
133 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
134 /etc/plc.d
135 /etc/planetlab/db-config.d
136 /var/www/html/wsdl/plcapi.wsdl
137 /usr/bin/omf_slicemgr.py*
138 /usr/bin/reset_xmpp_pubsub_nodes.py*
139
140
141 %changelog
142 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
143 - fix RefreshPeer that was not working in 5.0-17
144
145 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
146 - RefreshPeer is able to cope with 2 peers running different releases of the api
147 - DeletePerson can be used on duplicates
148 - first appearance of ModPythonJson.py
149
150 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
151 - set accessors return the new value
152 - tweaks in the pubsub groups management
153
154 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
155 - convert hostnames to lower case and use ILIKE instead of LIKE
156
157 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
158 - use hrn in pubsub groups
159
160 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
161 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
162 - - OMF fixes
163
164 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
165 - automatically set vsys tag for omf controlled slices
166
167 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
168 - addition of the 'ssh_key' slice tag
169 - first draft of the LDAP interface
170
171 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
172 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
173 - and readable through GetLeaseGranularity
174 - GetSlivers to expose reservation_policy and lease_granularity
175 - GetBootMedium fixed for reservable nodes
176 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
177 - new Apache mod_wsgi python interface
178
179 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
180 - the leases system
181
182 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
183 - previous tag had gone wrong
184
185 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
186 - fix pubsub hostname
187
188 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
189 - tweaks for the omf support (xmpp groups and RC-controlled slices)
190 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
191 - GetNodeFlavour exposes fcdistro
192
193 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
194 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
195
196 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
197 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
198 - pyaspect hooks allow to  maintain the namespace xmpp groups
199 - new omf_slicemgr is a proxy to xmpp, used by these hooks
200 - nodes have their hrn exposed in the 'hrn' tag
201 - node hrn exposed in GetSlivers, as well as the overall xmpp config
202 - system slice 'drl' gets created by db-config
203 - daniel's changes to Filter for supporting wildcards in lists
204 - AddSliceTag consistency check tweaked
205
206 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
207 - major cleanup
208 - get rid of all 4.2-related legacy code
209 - reset the migrations code, planetlab5.sql somes with (5,100)
210 - uses hashlib module when available
211
212 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
213 - first working version of 5.0:
214 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
215 - nodefamily is 3-fold with pldistro-fcdistro-arch
216 - site and person tags
217 - new methods GetSliceFamily and GetNodeFlavour
218 - deprecated the dummynet stuff that were for the external dummyboxes
219 - tags definition : more consistency between db-config scripts and accessors
220 - (get accessor to create the tag type too if absent)
221 - logging an event for AddSliceToNodes
222
223 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
224 - support for fedora 12
225 - fix subtle bug in filtering with ] and quotes
226
227 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
228 - * patch for php-5.3 (the one in f12)
229 - * validate email addresses with regex
230 - * add PersonTags and SiteTags
231 - * add additional accessors for node tags (kvariant, serial, ..)
232
233 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
234 - Redacting password, session, and authstring values from the event log.
235
236 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
237 - let AddSite set ext_consortium_id - required for the poorman registration pages
238 - drop version constraint on Requires: postgresql-python
239 - don't log system calls nor ReportRunLevel
240
241 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
242 - Fix requires for CentOS.
243
244 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
245 - Require postgresql 8.2 (for array operators && and @>)
246
247 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
248 - Filter now supports the | and & features to match in sequence values
249 - bugfix in the postgresql wrapper for sequence filter values
250 - reviewed GetSlivers to export admin keys more efficiently
251 - fix checking roles in UpdateSliceTag
252
253 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
254 - - Some typos in the documentation were fixed.
255 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
256 - to the tag's min_role_id.
257
258 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
259
260 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
261 - Ongoing work to add upcalls, using new SFA class
262 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
263 - reviewed type-checking for the 3 taggable classes node-interface-slice
264 - cleanup ald dummynet stuff
265 - expose the 'extensions' accessors to the API
266 - tweaked checks in AddSliceTag
267 - GetPersons exposes roles by default
268 - bugfix in ReportRunLevel for non-string levels
269 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
270
271 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
272 - new BindObjectToPeer method for sfa
273 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
274
275 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
276 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
277 - reportrunlevel logs its calls only when run_level changes
278 - pycurl more robust wrt to xmlrpclib.Transport
279
280 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
281 - produce a wsdl interface
282 - bugfix in getbootmedium for nodes with interface tags
283
284 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
285 - bugfix for some rare pattern-based filters
286
287 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
288 - improvements in the 4.2 legacy layer
289
290 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
291 - bugfix required for slice tags set on nodegroups
292
293 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
294 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
295
296 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
297 - more powerful legacy layer with 4.2
298
299 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
300 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
301 - migration script has an option for running interactively
302
303 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
304 - skips already added entries
305
306 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
307 - yet another set of fixes for external dummynet boxes
308
309 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
310 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
311 - and tmp file is cleaned up
312
313 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
314 - restore missing ResolveSlices
315
316 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
317 - new method GetDummyBoxMedium
318
319 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
320 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
321
322 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
323 - support for external dummynet boxes back in 4.3 - first draft
324
325 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
326 - fixes for smooth federation between 4.2 and 4.3
327 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
328
329 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
330 - support for BootCD variants (GetBootMedium ['variant:centos5'])
331 - fix corner case with filters like {'~slice_id':[]}
332 - fix transaction leak that caused the db connections pool to exhaust
333 - properly expose all methods, including Legacy/, and not only Methods/
334
335 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
336 - renumbered as 4.3
337 - nodes have new fields run_level (in addition to boot_state) and verified
338 - tweaked migration from 4.2
339 - tuned rpm dependencies
340 - doc generation more explicit about errors like missing python modules
341 - removed obsolete method GetSlicesMD5
342
343 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
344 - unified all tags
345 - renamed interface settings into interface tags and slice attributes into slice tags
346 - nodes have a node_type
347 - various changes on the way to 4.3
348
349 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
350 - Checkpointing : this version still has interface settings and slice attributes
351
352 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
353 - first iteration with taggable nodes/interfaces/slices
354 - embryo for ilinks
355 - cleaned up boot states
356 - migration script moslty complete
357
358 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
359 - fixed doc build by locating locally installed DTDs at build-time
360
361 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
362 - no more doc packaged outside of myplc-docs - doc/ cleaned up
363 - enhancements in doc on filters 
364 - bootcd-aware GetBootMedium merged from onelab
365
366 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
367 - checkpoint while the new myplc-docs package is underway
368 - bugfix: GetSlivers & conf files
369 - doc: removed target files 
370
371 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
372 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
373 - the non-deleted fields were index, resulting in massivly slow queries.
374
375
376 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
377 - plcsh: better handling of options when running as a shell script
378 - getbootmedium exports compute_key
379 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
380
381 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
382 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
383 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
384
385 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
386 - refresh peer script to use a month-dependent logfile
387 - tracking the starting point for UniPi integration of the dummynet boxes
388
389 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
390 - plcsh adds its own path to sys.path
391 - fix so GetNodes can be called from a Node
392
393 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
394 - Initial build.
395
396 %define module_current_branch 4.3