separate postgresql launching and checking
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 35
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
149 - slight tweaks in Persons.py
150
151 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
152 - GetSession has support for more than one day sessions
153 - reset_xmpp_pubsub_nodes is much more efficient
154 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
155 - bugfix - deleting a person in the middle of the signup process
156
157 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
158 - ratelimit aspects
159 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
160 - requires Django for cache_utils
161 - attempt to expose 'pldistro' to sfa
162 - last_time_spent_online, last_time_spent_offline: new fields in Node
163 - new slice tags 'isolate_loopback' and 'cpu_cores'
164 - refresh-peer federation logs dump exceptions
165 - modpython logs have a timestamp
166 - more verbose/accurate php error reporting
167 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
168 - AddNode, UpdateNode: manage tags directly rather than through another method
169 - BootUpdateNode: only update once
170 - GetPersons: techs can access the list of persons on their site
171 - GetSlices and GetSliceTags: techs can see slices on their nodes
172 - GetSlivers: isrootonsite tag; cacheable
173
174 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
175 - rename initscript_body into initscript_code
176
177 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
178 - new initscript_body tag
179
180 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
181 - working draft for GetSliceSshKeys
182
183 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
184 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
185 - (this is for people who cancel their download)
186
187 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
188 - fix db-config sequence : accessors step now merged in, and occurs at the right time
189 - db-config also more robust
190 - no more explicit 'accessors' step in plc.d
191
192 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
193 - session auth: do *not* delete session when node runs a method that does not have 'node' role
194 - session auth: remove support for bootonce in old boot CDs
195 - give a reason when caller_may_write_slice_tag fails
196 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
197
198 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
199 - SetSliceVref needed the node role
200 - protect GetSliceFamily
201 - Fix bugs in tag authorizations
202
203 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
204 - altered checking of optional fields in Interfaces
205 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
206 - has pyxml and python-simplejson as new deps
207
208 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
209 - tweak doc extraction for fedora14
210
211 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
212 - builtin accessors for the myslice page
213 - Get{Node,Interface}Tags allowed to techs
214 - tweak in ratelimitaspect.py
215
216 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
217 - add admin role to accessor-related tags (arch, {fc,pl}distro)
218
219 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
220 - bugfix in {Update,Delete}PersonTag
221 - updated xml doc for filters, accessors and tagtypes
222 - more explicit msg in case of missing roles
223 - improvements in ratelimitaspects.py
224
225 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
226 - fix the roles for ssh_key and hmac tags
227
228 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
229 - tag permissions system based on roles and not min_role_ids
230 - accessors simplified accordingly (no more min_role_id)
231 - new methods AddRoleToTagType and DeleteRoleFromTagType
232 - accessor-related tagtypes are created sooner, and enforced
233 - cleaned up redundancy between db-config.d and accessors
234
235 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
236 - fix RefreshPeer that was not working in 5.0-17
237
238 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
239 - RefreshPeer is able to cope with 2 peers running different releases of the api
240 - DeletePerson can be used on duplicates
241 - first appearance of ModPythonJson.py
242
243 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
244 - set accessors return the new value
245 - tweaks in the pubsub groups management
246
247 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
248 - convert hostnames to lower case and use ILIKE instead of LIKE
249
250 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
251 - use hrn in pubsub groups
252
253 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
254 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
255 - - OMF fixes
256
257 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
258 - automatically set vsys tag for omf controlled slices
259
260 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
261 - addition of the 'ssh_key' slice tag
262 - first draft of the LDAP interface
263
264 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
265 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
266 - and readable through GetLeaseGranularity
267 - GetSlivers to expose reservation_policy and lease_granularity
268 - GetBootMedium fixed for reservable nodes
269 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
270 - new Apache mod_wsgi python interface
271
272 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
273 - the leases system
274
275 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
276 - previous tag had gone wrong
277
278 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
279 - fix pubsub hostname
280
281 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
282 - tweaks for the omf support (xmpp groups and RC-controlled slices)
283 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
284 - GetNodeFlavour exposes fcdistro
285
286 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
287 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
288
289 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
290 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
291 - pyaspect hooks allow to  maintain the namespace xmpp groups
292 - new omf_slicemgr is a proxy to xmpp, used by these hooks
293 - nodes have their hrn exposed in the 'hrn' tag
294 - node hrn exposed in GetSlivers, as well as the overall xmpp config
295 - system slice 'drl' gets created by db-config
296 - daniel's changes to Filter for supporting wildcards in lists
297 - AddSliceTag consistency check tweaked
298
299 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
300 - major cleanup
301 - get rid of all 4.2-related legacy code
302 - reset the migrations code, planetlab5.sql somes with (5,100)
303 - uses hashlib module when available
304
305 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
306 - first working version of 5.0:
307 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
308 - nodefamily is 3-fold with pldistro-fcdistro-arch
309 - site and person tags
310 - new methods GetSliceFamily and GetNodeFlavour
311 - deprecated the dummynet stuff that were for the external dummyboxes
312 - tags definition : more consistency between db-config scripts and accessors
313 - (get accessor to create the tag type too if absent)
314 - logging an event for AddSliceToNodes
315
316 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
317 - support for fedora 12
318 - fix subtle bug in filtering with ] and quotes
319
320 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
321 - * patch for php-5.3 (the one in f12)
322 - * validate email addresses with regex
323 - * add PersonTags and SiteTags
324 - * add additional accessors for node tags (kvariant, serial, ..)
325
326 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
327 - Redacting password, session, and authstring values from the event log.
328
329 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
330 - let AddSite set ext_consortium_id - required for the poorman registration pages
331 - drop version constraint on Requires: postgresql-python
332 - don't log system calls nor ReportRunLevel
333
334 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
335 - Fix requires for CentOS.
336
337 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
338 - Require postgresql 8.2 (for array operators && and @>)
339
340 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
341 - Filter now supports the | and & features to match in sequence values
342 - bugfix in the postgresql wrapper for sequence filter values
343 - reviewed GetSlivers to export admin keys more efficiently
344 - fix checking roles in UpdateSliceTag
345
346 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
347 - - Some typos in the documentation were fixed.
348 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
349 - to the tag's min_role_id.
350
351 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
352
353 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
354 - Ongoing work to add upcalls, using new SFA class
355 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
356 - reviewed type-checking for the 3 taggable classes node-interface-slice
357 - cleanup ald dummynet stuff
358 - expose the 'extensions' accessors to the API
359 - tweaked checks in AddSliceTag
360 - GetPersons exposes roles by default
361 - bugfix in ReportRunLevel for non-string levels
362 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
363
364 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
365 - new BindObjectToPeer method for sfa
366 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
367
368 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
369 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
370 - reportrunlevel logs its calls only when run_level changes
371 - pycurl more robust wrt to xmlrpclib.Transport
372
373 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
374 - produce a wsdl interface
375 - bugfix in getbootmedium for nodes with interface tags
376
377 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
378 - bugfix for some rare pattern-based filters
379
380 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
381 - improvements in the 4.2 legacy layer
382
383 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
384 - bugfix required for slice tags set on nodegroups
385
386 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
387 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
388
389 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
390 - more powerful legacy layer with 4.2
391
392 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
393 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
394 - migration script has an option for running interactively
395
396 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
397 - skips already added entries
398
399 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
400 - yet another set of fixes for external dummynet boxes
401
402 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
403 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
404 - and tmp file is cleaned up
405
406 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
407 - restore missing ResolveSlices
408
409 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
410 - new method GetDummyBoxMedium
411
412 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
413 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
414
415 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
416 - support for external dummynet boxes back in 4.3 - first draft
417
418 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
419 - fixes for smooth federation between 4.2 and 4.3
420 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
421
422 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
423 - support for BootCD variants (GetBootMedium ['variant:centos5'])
424 - fix corner case with filters like {'~slice_id':[]}
425 - fix transaction leak that caused the db connections pool to exhaust
426 - properly expose all methods, including Legacy/, and not only Methods/
427
428 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
429 - renumbered as 4.3
430 - nodes have new fields run_level (in addition to boot_state) and verified
431 - tweaked migration from 4.2
432 - tuned rpm dependencies
433 - doc generation more explicit about errors like missing python modules
434 - removed obsolete method GetSlicesMD5
435
436 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
437 - unified all tags
438 - renamed interface settings into interface tags and slice attributes into slice tags
439 - nodes have a node_type
440 - various changes on the way to 4.3
441
442 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
443 - Checkpointing : this version still has interface settings and slice attributes
444
445 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
446 - first iteration with taggable nodes/interfaces/slices
447 - embryo for ilinks
448 - cleaned up boot states
449 - migration script moslty complete
450
451 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
452 - fixed doc build by locating locally installed DTDs at build-time
453
454 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
455 - no more doc packaged outside of myplc-docs - doc/ cleaned up
456 - enhancements in doc on filters 
457 - bootcd-aware GetBootMedium merged from onelab
458
459 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
460 - checkpoint while the new myplc-docs package is underway
461 - bugfix: GetSlivers & conf files
462 - doc: removed target files 
463
464 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
465 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
466 - the non-deleted fields were index, resulting in massivly slow queries.
467
468
469 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
470 - plcsh: better handling of options when running as a shell script
471 - getbootmedium exports compute_key
472 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
473
474 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
475 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
476 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
477
478 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
479 - refresh peer script to use a month-dependent logfile
480 - tracking the starting point for UniPi integration of the dummynet boxes
481
482 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
483 - plcsh adds its own path to sys.path
484 - fix so GetNodes can be called from a Node
485
486 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
487 - Initial build.
488
489 %define module_current_branch 4.3