using %a from GetBootMedium
[plewww.git] / PLCWWW.spec
1 #
2 # $Id: PLCWWW.spec 1206 2008-03-03 15:49:07Z thierry $
3 #
4 %define module_taglevel_varname subversion
5 %define name PLCWWW
6 %define version onelab.4.2
7 %define subversion 9
8
9 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Summary: PlanetLab Central (PLC) Web Pages
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 License: PlanetLab
16 Group: Applications/Systems
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: http://svn.one-lab.org/svn/new_plc_www/
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.2
31
32 # on centos5, when rebuilding the full monty, we get:
33 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
34 # and the perl-GD rpm is nowhere to be found
35 AutoReqProv: no
36
37 %description
38 The PLCWWW package is made of the web pages that run on top of the 
39 PLCAPI component to provide the Web Interface to MyPLC users.
40
41 %prep
42 %setup -q
43
44 %build
45 echo "There is no build stage for this component"
46 echo "All files just need to be installed as is from the codebase"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 #
52 # plcwww
53 #
54
55 echo "* PLCWWW: Installing web pages"
56 mkdir -p $RPM_BUILD_ROOT/var/www/html
57 # let's be conservative and exclude codebase files, though there should not be any
58 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
59
60 echo "* PLCWWW: Installing drupal config for httpd"
61 install -D -m 644 drupal.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/drupal.conf
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(-,root,root,-)
68 /var/www/html
69 /etc/httpd/conf.d/drupal.conf
70
71 %changelog
72 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
73 - remove explicit dep to bootcd as the rpm name has changed
74
75 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
76 - noarch
77
78 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
79 - should fix yum.conf on nodes after install
80
81 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
82 - uses different path for getbootmedium results - should be safer
83
84 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
85 - comon icon replaced with the one from the comon website
86
87 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
88 - displays rpms in the about page
89
90 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
91 - safer, reference-less, way to implement layout mechnism - see
92 - settings.php for details
93 - setting types properly displayed according to user's role
94 - setting deletion : fixed (was still using code from slice attribute)
95 - more comon buttons : in the nodes and peers index pages
96 - comon_button knows about peer_id
97
98 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
99 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
100
101 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
102 - Initial build.