disable automatic deps generation from rpm that prevents from building on centos5
[plewww.git] / PLCWWW.spec
1 #
2 # $Id: PLCWWW.spec 1206 2008-03-03 15:49:07Z thierry $
3 #
4 %define module_taglevel_varname subversion
5 %define name PLCWWW
6 %define version 4.2
7 %define subversion 8
8
9 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Summary: PlanetLab Central (PLC) Web Pages
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 License: PlanetLab
16 Group: Applications/Systems
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19 BuildArch: noarch
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: http://svn.one-lab.org/svn/new_plc_www/
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: bootcd >= 3.3
31 Requires: PLCAPI >= 4.0
32
33 # on centos5, when rebuilding the full monty, we get:
34 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
35 # and the perl-GD rpm is nowhere to be found
36 AutoReqProv: no
37
38 %description
39 The plcwww packages provides the web pages that run on
40 top of the PLCAPI component to provide the Web User Interface to the
41 PLC installation.
42 This package was formerly embedded together with MyPLC, but there
43 clearly is a need for separate upgrade of this component.
44
45 %prep
46 %setup -q
47
48 %build
49 echo "There is no build stage for this component"
50 echo "All files just need to be installed as is from the codebase"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 #
56 # plcwww
57 #
58
59 echo "* PLCWWW: Installing web pages"
60 mkdir -p $RPM_BUILD_ROOT/var/www/html
61 # let's be conservative and exclude codebase files, though there should not be any
62 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
63
64 echo "* PLCWWW: Installing drupal config for httpd"
65 install -D -m 644 drupal.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/drupal.conf
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(-,root,root,-)
72 /var/www/html
73 /etc/httpd/conf.d/drupal.conf
74
75 %changelog
76 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
77 - noarch
78
79 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
80 - should fix yum.conf on nodes after install
81
82 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
83 - uses different path for getbootmedium results - should be safer
84
85 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
86 - comon icon replaced with the one from the comon website
87
88 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
89 - displays rpms in the about page
90
91 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
92 - safer, reference-less, way to implement layout mechnism - see
93 - settings.php for details
94 - setting types properly displayed according to user's role
95 - setting deletion : fixed (was still using code from slice attribute)
96 - more comon buttons : in the nodes and peers index pages
97 - comon_button knows about peer_id
98
99 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
100 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
101
102 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
103 - Initial build.