spec update
[linux-2.6.git] / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 %define _with_netns 1
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 22
22 %define patchlevel 14
23 %define kversion 2.6.%{sublevel}
24 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
25
26 %define vsversion 2.3.0.29
27
28 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
29 # updated every time the PL kernel is updated.
30 %define vini_pl_patch 561
31
32 %define specrelease 1
33
34 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
35
36 %{!?pldistro:%global pldistro planetlab}
37
38 %define signmodules 0
39 %define make_target bzImage
40 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
41
42 # Override generic defaults with per-arch defaults
43
44 %define image_install_path boot
45
46 #
47 # Three sets of minimum package version requirements in the form of Conflicts:
48 # to versions below the minimum
49 #
50
51 #
52 # First the general kernel 2.6 required versions as per
53 # Documentation/Changes
54 #
55 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
56
57
58 # Then a series of requirements that are distribution specific, either 
59 # because we add patches for something, or the older versions have 
60 # problems with the newer kernel or lack certain things that make 
61 # integration in the distro harder than needed.
62 #
63 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
64
65 #
66 # Several packages had bugs in them that became obvious when the NPTL
67 # threading code got integrated.
68 #
69 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
70
71 #
72 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
73 #
74
75 # MEF commented out
76 # %define xen_conflicts glibc < 2.3.5-1
77
78 #
79 # Packages that need to be installed before the kernel is, because the %post
80 # scripts use them.
81 #
82 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
83
84 URL: http://svn.planet-lab.org/wiki/linux-2.6
85
86 Name: kernel
87 Group: System Environment/Kernel
88 License: GPLv2
89 Version: %{rpmversion}
90 Release: %{release}
91 ExclusiveOS: Linux
92 Provides: kernel = %{version}
93 Provides: kernel-drm = 4.3.0
94 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
95 Provides: kernel-smp = %{rpmversion}-%{release}
96 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
97 Prereq: %{kernel_prereq}
98 Conflicts: %{kernel_dot_org_conflicts}
99 Conflicts: %{package_conflicts}
100 Conflicts: %{nptl_conflicts}
101 # We can't let RPM do the dependencies automatic because it'll then pick up
102 # a correct but undesirable perl dependency from the module headers which
103 # isn't required for the kernel proper to function
104 AutoReqProv: no
105
106 #
107 # List the packages used during the kernel build
108 #
109 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
110 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
111 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
112 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
113
114
115 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
116
117 Source10: kernel-%{kversion}-i586-%{pldistro}.config
118 Source11: kernel-%{kversion}-i686-%{pldistro}.config
119 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
120 %if %{builduml}
121 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
122 %endif
123 %if %{buildxen}
124 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
125 %endif
126
127 # Mainline patches
128 %if "0%{patchlevel}"
129 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
130 %endif
131
132 Patch010: linux-2.6-010-e1000e.patch
133 Patch020: linux-2.6-020-build-id.patch
134 Patch030: linux-2.6-030-netns.patch
135
136 # These are patches picked up from Fedora/RHEL
137 Patch100: linux-2.6-100-build-nonintconfig.patch
138
139 # Linux-VServer
140 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
141
142 # IP sets
143 Patch250: linux-2.6-250-ipsets.patch
144
145 # PlanetLab
146 Patch500: linux-2.6-500-vserver-filesharing.patch
147 Patch510: linux-2.6-510-ipod.patch
148 Patch520: linux-2.6-520-vnet+.patch
149 Patch530: linux-2.6-530-built-by-support.patch
150 Patch540: linux-2.6-540-oom-kill.patch
151 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
152 Patch560: linux-2.6-560-mmconf.patch
153 Patch570: linux-2.6-570-tagxid.patch
154 Patch590: linux-2.6-590-trellis-mm1-netns.patch
155 Patch591: linux-2.6-591-unshare-netns.patch
156 Patch592: linux-2.6-592-ztun-sb.patch
157 Patch593: linux-2.6-593-egre.patch
158
159 %description
160 The kernel package contains the Linux kernel (vmlinuz), the core of any
161 Linux operating system.  The kernel handles the basic functions
162 of the operating system:  memory allocation, process allocation, device
163 input and output, etc.
164
165 %package devel
166 Summary: Development package for building kernel modules to match the kernel.
167 Group: System Environment/Kernel
168 AutoReqProv: no
169 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
170 Provides: kernel-smp-devel = %{rpmversion}-%{release}
171 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
172 Prereq: /usr/bin/find
173
174 %description devel
175 This package provides kernel headers and makefiles sufficient to build modules
176 against the kernel package.
177
178
179 %package doc
180 Summary: Various documentation bits found in the kernel source.
181 Group: Documentation
182
183 %description doc
184 This package contains documentation files from the kernel
185 source. Various bits of information about the Linux kernel and the
186 device drivers shipped with it are documented in these files.
187
188 You'll want to install this package if you need a reference to the
189 options that can be passed to Linux kernel modules at load time.
190
191 %package xenU
192 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
193
194 Group: System Environment/Kernel
195 Provides: kernel = %{version}
196 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
197 Prereq: %{kernel_prereq}
198 Conflicts: %{kernel_dot_org_conflicts}
199 Conflicts: %{package_conflicts}
200 Conflicts: %{nptl_conflicts}
201
202 # MEF commented out 
203 # Conflicts: %{xen_conflicts}
204
205 # We can't let RPM do the dependencies automatic because it'll then pick up
206 # a correct but undesirable perl dependency from the module headers which
207 # isn't required for the kernel proper to function
208 AutoReqProv: no
209
210 %description xenU
211 This package includes a version of the Linux kernel which
212 runs in Xen unprivileged guest VMs.  This should be installed
213 both inside the unprivileged guest (for the modules) and in
214 the guest0 domain.
215
216 %package xenU-devel
217 Summary: Development package for building kernel modules to match the kernel.
218 Group: System Environment/Kernel
219 AutoReqProv: no
220 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
221 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
222 Provides: kernel-devel = %{rpmversion}-%{release}xenU
223 Prereq: /usr/sbin/hardlink, /usr/bin/find
224
225 %description xenU-devel
226 This package provides kernel headers and makefiles sufficient to build modules
227 against the kernel package.
228
229 %package uml
230 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
231
232 Group: System Environment/Kernel
233
234 %description uml
235 This package includes a user mode version of the Linux kernel.
236
237 %package uml-devel
238 Summary: Development package for building kernel modules to match the UML kernel.
239 Group: System Environment/Kernel
240 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
241 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
242 Provides: kernel-devel = %{rpmversion}-%{release}smp
243 AutoReqProv: no
244 Prereq: /usr/sbin/hardlink, /usr/bin/find
245
246 %description uml-devel
247 This package provides kernel headers and makefiles sufficient to build modules
248 against the User Mode Linux kernel package.
249
250 %package uml-modules
251 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
252
253 Group: System Environment/Kernel
254
255 %description uml-modules
256 This package includes a user mode version of the Linux kernel modules.
257
258 %package vserver
259 Summary: A placeholder RPM that provides kernel and kernel-drm
260
261 Group: System Environment/Kernel
262 Provides: kernel = %{version}
263 Provides: kernel-drm = 4.3.0
264 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
265
266 %description vserver
267 VServers do not require and cannot use kernels, but some RPMs have
268 implicit or explicit dependencies on the "kernel" package
269 (e.g. tcpdump). This package installs no files but provides the
270 necessary dependencies to make rpm and yum happy.
271
272
273 %prep
274 # First we unpack the kernel tarball.
275 # If this isn't the first make prep, we use links to the existing clean tarball
276 # which speeds things up quite a bit.
277 if [ ! -d kernel-%{kversion}/vanilla ]; then
278   # Ok, first time we do a make prep.
279   rm -f pax_global_header
280 %setup -q -n %{name}-%{kversion} -c
281   mv linux-%{kversion} vanilla
282 else
283   # We already have a vanilla dir.
284   cd kernel-%{kversion}
285 fi
286
287 KERNEL_PREVIOUS=vanilla
288 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
289 %define ApplyPatch() \
290   rm -fr linux-%{kversion}-%1                           \
291   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
292   patchflag=-p1                                         \
293   test "%2" != "%%2" && patchflag="%2"                  \
294   PATCH="%{expand:%{PATCH%1}}"                          \
295   if test ! -e "$PATCH"; then                           \
296     echo "Patch %1 does not exist!"                     \
297     exit 1                                              \
298   fi                                                    \
299   case "$PATCH" in                                      \
300     *.bz2)  bzcat "$PATCH";;                            \
301     *.gz)   zcat "$PATCH";;                             \
302     *)      cat "$PATCH";;                              \
303   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
304   KERNEL_PREVIOUS=linux-%{kversion}-%1
305
306 # This is where the patches get applied
307 %if "0%{patchlevel}"
308 %ApplyPatch 0
309 %endif
310
311 %ApplyPatch 10
312 %ApplyPatch 20
313
314 %ApplyPatch 100
315
316 %ApplyPatch 200
317
318 %ApplyPatch 250
319
320 %ApplyPatch 500
321 %ApplyPatch 510
322 %ApplyPatch 520
323 %ApplyPatch 530
324 %ApplyPatch 540
325 %ApplyPatch 550
326 %ApplyPatch 560
327 %ApplyPatch 570
328
329
330 %if 0%{?_with_netns}
331 %ApplyPatch 590
332 %ApplyPatch 591
333 %ApplyPatch 592
334 %endif
335
336 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
337 # break with later patches.
338
339 rm -fr linux-%{kversion}
340 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
341 cd linux-%{kversion}
342
343
344 # make sure the kernel has the sublevel we know it has. This looks weird
345 # but for -pre and -rc versions we need it since we only want to use
346 # the higher version when the final kernel is released.
347 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
348 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
349
350 # get rid of unwanted files resulting from patch fuzz
351 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
352
353
354 ###
355 ### build
356 ###
357 %build
358
359 BuildKernel() {
360     MakeTarget=$1
361     Arch=$2
362     Flavour=$3
363
364     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
365     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
366     cd linux-%{_target_cpu}-%{kversion}$Flavour
367
368     # Pick the right config file for the kernel we're building
369     if [ -n "$Flavour" ] ; then
370       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
371       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
372       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
373     else
374       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
375       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
376       DevelLink=
377     fi
378
379     KernelVer=%{version}-%{release}$Flavour
380     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
381
382     # make sure EXTRAVERSION says what we want it to say
383     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
384
385     # and now to start the build process
386
387     make -s mrproper
388     cp %{_sourcedir}/$Config .config
389
390     #Arch=`head -1 .config | cut -b 3-`
391     echo USING ARCH=$Arch
392
393     make -s ARCH=$Arch nonint_oldconfig > /dev/null
394     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
395     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
396
397     # Start installing the results
398
399 %if "%{_enable_debug_packages}" == "1"
400     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
401 %endif
402     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
403     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
404     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
405     if [ -f arch/$Arch/boot/bzImage ]; then
406       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
407     fi
408     if [ -f arch/$Arch/boot/zImage.stub ]; then
409       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
410     fi
411     if [ "$Flavour" = "uml" ] ; then
412         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
413     fi
414
415     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
416     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
417
418     # And save the headers/makefiles etc for building modules against
419     #
420     # This all looks scary, but the end result is supposed to be:
421     # * all arch relevant include/ files
422     # * all Makefile/Kconfig files
423     # * all script/ files
424
425     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
426     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
427     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
428     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
429     # dirs for additional modules per module-init-tools, kbuild/modules.txt
430     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
431     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
432     # first copy everything
433     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
434         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
435     if [ "$Flavour" = "uml" ] ; then
436       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
437     fi
438     # then drop all but the needed Makefiles/Kconfig files
439     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
440     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
441     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
442     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
443     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
444     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
445     if [ -d arch/%{_arch}/scripts ]; then
446       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
447     fi
448     if [ -f arch/%{_arch}/*lds ]; then
449       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
450     fi
451     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
452     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
453     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
454     cd include
455     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
456     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
457     if [ "$Arch" = "x86_64" ]; then
458       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
459     fi
460 %if %{buildxen}
461     if [ "$Flavour" = "xenU" ]; then
462       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
463       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
464     fi
465 %endif
466 %if %{builduml}
467     if [ "$Flavour" = "uml" ] ; then
468       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
469     fi
470 %endif
471     # While arch/powerpc/include/asm is still a symlink to the old
472     # include/asm-ppc{64,} directory, include that in kernel-devel too.
473     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
474       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
475       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
476       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
477       ln -sf ../../../include/asm-ppc* asm
478       popd
479     fi
480
481     # Make sure the Makefile and version.h have a matching timestamp so that
482     # external modules can be built
483     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
484     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
485     cd ..
486
487     #
488     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
489     #
490 %if "%{_enable_debug_packages}" == "1"
491     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
492     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
493 %endif
494 %if %{buildxen}
495     if [ -f vmlinuz ]; then
496       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
497     fi
498 %endif
499
500     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
501
502     # mark modules executable so that strip-to-file can strip them
503     cat modnames | xargs chmod u+x
504
505     # remove files that will be auto generated by depmod at rpm -i time
506     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
507
508     # Move the devel headers out of the root file system
509     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
510     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
511     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
512     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
513 }
514
515 ###
516 # DO it...
517 ###
518
519 # prepare directories
520 rm -rf $RPM_BUILD_ROOT
521 mkdir -p $RPM_BUILD_ROOT/boot
522
523 %if "%{_target_cpu}" == "x86_64"
524 %define kernel_arch %{_target_cpu}
525 %endif
526 %if "%{_target_cpu}" == "i586"
527 %define kernel_arch i386
528 %endif
529 %if "%{_target_cpu}" == "i686"
530 %define kernel_arch i386
531 %endif
532
533 %if %{buildup}
534 BuildKernel %make_target %kernel_arch
535 %endif
536
537 %ifarch i686
538 %if %{builduml}
539 BuildKernel linux um uml
540 %endif
541
542 %if %{buildxen}
543 BuildKernel vmlinuz %kernel_arch xenU
544 %endif
545 %endif
546
547 ###
548 ### install
549 ###
550
551 %install
552
553 cd vanilla
554
555 %if %{buildxen} && "%{_target_cpu}" == "i686"
556 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
557 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
558 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
559 # This directive teaches ldconfig to search in nosegneg subdirectories
560 # and cache the DSOs there with extra bit 0 set in their hwcap match
561 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
562 # search in nosegneg subdirectories and to match this extra hwcap bit
563 # in the ld.so.cache file.
564 hwcap 0 nosegneg
565 EOF
566 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
567 %endif
568
569 %if %{builddoc}
570 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
571
572 # sometimes non-world-readable files sneak into the kernel source tree
573 chmod -R a+r *
574 # copy the source over
575 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
576 %endif
577
578 ###
579 ### clean
580 ###
581
582 %clean
583 rm -rf $RPM_BUILD_ROOT
584
585 ###
586 ### scripts
587 ###
588
589 # load the loop module for upgrades...in case the old modules get removed we have
590 # loopback in the kernel so that mkinitrd will work.
591 %pre
592 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
593 exit 0
594
595 %post
596 if [ -f /etc/sysconfig/kernel ]; then
597   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
598 fi
599
600 # trick mkinitrd in case the current environment does not have device mapper
601 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
602 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
603     if [ ! -f $rootdev ]; then
604         fake_root_lvm=1
605         mkdir -p $(dirname $rootdev)
606         touch $rootdev
607     fi
608 fi
609
610 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
611 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
612 # Older modutils do not support --package option
613 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
614
615 # remove fake handle
616 if [ -n "$fake_root_lvm" ]; then
617     rm -f $rootdev
618 fi
619
620 # make some useful links
621 pushd /boot > /dev/null ; {
622         ln -sf config-%{KVERREL} config
623         ln -sf config-%{KVERREL} configsmp
624         ln -sf initrd-%{KVERREL}.img initrd-boot
625         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
626         ln -sf vmlinuz-%{KVERREL} kernel-boot
627         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
628 }
629 popd > /dev/null
630
631 # ask for a reboot
632 mkdir -p /etc/planetlab
633 touch /etc/planetlab/update-reboot
634
635 %post devel
636 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
637 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
638   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
639   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
640   popd > /dev/null
641 fi
642
643 %post xenU
644 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
645 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
646
647 %post xenU-devel
648 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
649 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
650   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
651   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
652   popd > /dev/null
653 fi
654
655 %post uml-modules
656 depmod -ae %{KVERREL}uml
657
658 %preun
659 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
660 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
661
662 %preun xenU
663 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
664 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
665
666 %preun uml-modules
667 rm -f /lib/modules/%{KVERREL}uml/modules.*
668
669
670 ###
671 ### file lists
672 ###
673
674 %if %{buildup}
675 %files 
676 %defattr(-,root,root)
677 /%{image_install_path}/vmlinuz-%{KVERREL}
678 /boot/System.map-%{KVERREL}
679 /boot/config-%{KVERREL}
680 %dir /lib/modules/%{KVERREL}
681 /lib/modules/%{KVERREL}/kernel
682 /lib/modules/%{KVERREL}/build
683 /lib/modules/%{KVERREL}/source
684 /lib/modules/%{KVERREL}/extra
685 /lib/modules/%{KVERREL}/updates
686
687 %files devel
688 %defattr(-,root,root)
689 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
690 %endif
691
692 %if %{builduml} && "%{_target_cpu}" == "i686"
693 %files uml
694 %defattr(-,root,root)
695 %{_bindir}/linux
696
697 %files uml-devel
698 %defattr(-,root,root)
699 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
700 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
701
702 %files uml-modules
703 %defattr(-,root,root)
704 /boot/System.map-%{KVERREL}uml
705 /boot/config-%{KVERREL}uml
706 %dir /lib/modules/%{KVERREL}uml
707 /lib/modules/%{KVERREL}uml/kernel
708 /lib/modules/%{KVERREL}uml/build
709 /lib/modules/%{KVERREL}uml/source
710 /lib/modules/%{KVERREL}uml/extra
711 /lib/modules/%{KVERREL}uml/updates
712 %endif
713
714 %if %{buildxen} && "%{_target_cpu}" == "i686"
715 %files xenU
716 %defattr(-,root,root)
717 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
718 /boot/System.map-%{KVERREL}xenU
719 /boot/config-%{KVERREL}xenU
720 %dir /lib/modules/%{KVERREL}xenU
721 /lib/modules/%{KVERREL}xenU/kernel
722 /lib/modules/%{KVERREL}xenU/build
723 /lib/modules/%{KVERREL}xenU/source
724 /lib/modules/%{KVERREL}xenU/extra
725 /lib/modules/%{KVERREL}xenU/updates
726 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
727
728 %files xenU-devel
729 %defattr(-,root,root)
730 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
731 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
732 %endif
733
734 %files vserver
735 %defattr(-,root,root)
736 # no files
737
738 # only some architecture builds need kernel-doc
739
740 %if %{builddoc}
741 %files doc
742 %defattr(-,root,root)
743 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
744 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
745 %dir %{_datadir}/doc/kernel-doc-%{kversion}
746 %endif
747
748 %changelog
749 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
750 - 2.6.17.4
751 - Disable split pagetable lock.
752
753 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
754 - Get rid of stack backtrace on panic, which in most
755   cases actually caused a loss of info instead of a gain.
756
757 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
758 - 2.6.17.3
759
760 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
761 - 2.6.17.2
762 - Fix up the alsa list_add bug.
763
764 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
765 - Fix up various stupidities incurred by the last big rebase.
766   - Reenable SMP x86-64 builds.
767   - Reenable SMBFS.
768 - Enable PCI fake hotplug driver.
769 - Enable gameport/joystick on i586 builds. (#196581)
770
771 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
772 - Enable profiling for 586 kernels.
773
774 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
775 - Rebuild with slab debug off.
776
777 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
778 - 2.6.17.1
779
780 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
781 - 2.6.16.20
782
783 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
784 - 2.6.16.19
785
786 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
787 - Improved list_head debugging.
788
789 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
790 - 2.6.16.18
791
792 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
793 - 2.6.16.17
794
795 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
796 - 2.6.16.16
797
798 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
799 - 2.6.16.15
800 - make 16C950 UARTs work (again). (#126403)
801 - Fix exec-shield default, which should fix a few programs that
802   stopped running.
803
804 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
805 - 2.6.16.14
806
807 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
808 - 2.6.16.13
809
810 * Mon May  1 2006 Dave Jones <davej@redhat.com>
811 - 2.6.16.12
812
813 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
814 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
815
816 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
817 - 2.6.16.11
818
819 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
820 - Enable PCI MSI support.
821
822 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
823 - 2.6.16.9
824
825 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
826 - 2.6.16.7
827
828 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
829 - 2.6.16.6
830
831 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
832 - 2.6.16.5
833
834 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
835 - 2.6.16.2
836
837 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
838 - Reenable non-standard serial ports. (#187466)
839 - Reenable snd-es18xx for x86-32 (#187733)
840
841 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
842 - ship the .kernelrelease file in -devel too.
843 - Disable EDAC debug.
844
845 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
846 - 2.6.16.1
847
848 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
849 - Include patches posted for review for inclusion in 2.6.16.1
850 - Updated new audit msg types.
851 - Reenable HDLC driver (#186257)
852 - Make acpi-cpufreq 'sticky'
853 - Fix broken x86-64 32bit vDSO (#186924)
854
855 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
856 - Improve spinlock scalability on big machines.
857
858 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
859 - Sync with FC5's 2.6.16 kernel.
860 - Update Tux & Exec-shield to latest.
861