Disable mmconfig by default, it breaks quite often.
[linux-2.6.git] / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 #
14 # Polite request for people who spin their own kernel rpms:
15 # please modify the "release" field in a way that identifies
16 # that the kernel isn't the stock distribution kernel, for example by
17 # adding some text to the end of the version number.
18 #
19 %define sublevel 22
20 %define patchlevel 14
21 %define kversion 2.6.%{sublevel}
22 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
23
24 %define vsversion 2.3.0.29
25
26 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
27 # updated every time the PL kernel is updated.
28 %define vini_pl_patch 561
29
30 %define specrelease 1
31
32 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
33
34 %{!?pldistro:%global pldistro planetlab}
35
36 %define signmodules 0
37 %define make_target bzImage
38 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
39
40 # Override generic defaults with per-arch defaults
41
42 %define image_install_path boot
43
44 #
45 # Three sets of minimum package version requirements in the form of Conflicts:
46 # to versions below the minimum
47 #
48
49 #
50 # First the general kernel 2.6 required versions as per
51 # Documentation/Changes
52 #
53 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
54
55
56 # Then a series of requirements that are distribution specific, either 
57 # because we add patches for something, or the older versions have 
58 # problems with the newer kernel or lack certain things that make 
59 # integration in the distro harder than needed.
60 #
61 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
62
63 #
64 # Several packages had bugs in them that became obvious when the NPTL
65 # threading code got integrated.
66 #
67 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
68
69 #
70 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
71 #
72
73 # MEF commented out
74 # %define xen_conflicts glibc < 2.3.5-1
75
76 #
77 # Packages that need to be installed before the kernel is, because the %post
78 # scripts use them.
79 #
80 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
81
82 URL: http://svn.planet-lab.org/wiki/linux-2.6
83
84 Name: kernel
85 Group: System Environment/Kernel
86 License: GPLv2
87 Version: %{rpmversion}
88 Release: %{release}
89 ExclusiveOS: Linux
90 Provides: kernel = %{version}
91 Provides: kernel-drm = 4.3.0
92 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
93 Provides: kernel-smp = %{rpmversion}-%{release}
94 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
95 Prereq: %{kernel_prereq}
96 Conflicts: %{kernel_dot_org_conflicts}
97 Conflicts: %{package_conflicts}
98 Conflicts: %{nptl_conflicts}
99 # We can't let RPM do the dependencies automatic because it'll then pick up
100 # a correct but undesirable perl dependency from the module headers which
101 # isn't required for the kernel proper to function
102 AutoReqProv: no
103
104 #
105 # List the packages used during the kernel build
106 #
107 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
108 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
109 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
110 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
111
112
113 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
114
115 Source10: kernel-%{kversion}-i586-%{pldistro}.config
116 Source11: kernel-%{kversion}-i686-%{pldistro}.config
117 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
118 %if %{builduml}
119 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
120 %endif
121 %if %{buildxen}
122 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
123 %endif
124
125 # Mainline patches
126 %if "0%{patchlevel}"
127 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
128 %endif
129
130 Patch010: linux-2.6-010-e1000e.patch
131 Patch020: linux-2.6-020-build-id.patch
132 Patch030: linux-2.6-030-netns.patch
133
134 # These are patches picked up from Fedora/RHEL
135 Patch100: linux-2.6-100-build-nonintconfig.patch
136
137 # Linux-VServer
138 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
139
140 # IP sets
141 Patch250: linux-2.6-250-ipsets.patch
142
143 # PlanetLab
144 Patch500: linux-2.6-500-vserver-filesharing.patch
145 Patch510: linux-2.6-510-ipod.patch
146 Patch520: linux-2.6-520-vnet+.patch
147 Patch530: linux-2.6-530-built-by-support.patch
148 Patch540: linux-2.6-540-oom-kill.patch
149 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
150 Patch560: linux-2.6-560-mmconf.patch
151
152 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
153
154 %description
155 The kernel package contains the Linux kernel (vmlinuz), the core of any
156 Linux operating system.  The kernel handles the basic functions
157 of the operating system:  memory allocation, process allocation, device
158 input and output, etc.
159
160 %package devel
161 Summary: Development package for building kernel modules to match the kernel.
162 Group: System Environment/Kernel
163 AutoReqProv: no
164 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
165 Provides: kernel-smp-devel = %{rpmversion}-%{release}
166 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
167 Prereq: /usr/bin/find
168
169 %description devel
170 This package provides kernel headers and makefiles sufficient to build modules
171 against the kernel package.
172
173
174 %package doc
175 Summary: Various documentation bits found in the kernel source.
176 Group: Documentation
177
178 %description doc
179 This package contains documentation files from the kernel
180 source. Various bits of information about the Linux kernel and the
181 device drivers shipped with it are documented in these files.
182
183 You'll want to install this package if you need a reference to the
184 options that can be passed to Linux kernel modules at load time.
185
186 %package xenU
187 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
188
189 Group: System Environment/Kernel
190 Provides: kernel = %{version}
191 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
192 Prereq: %{kernel_prereq}
193 Conflicts: %{kernel_dot_org_conflicts}
194 Conflicts: %{package_conflicts}
195 Conflicts: %{nptl_conflicts}
196
197 # MEF commented out 
198 # Conflicts: %{xen_conflicts}
199
200 # We can't let RPM do the dependencies automatic because it'll then pick up
201 # a correct but undesirable perl dependency from the module headers which
202 # isn't required for the kernel proper to function
203 AutoReqProv: no
204
205 %description xenU
206 This package includes a version of the Linux kernel which
207 runs in Xen unprivileged guest VMs.  This should be installed
208 both inside the unprivileged guest (for the modules) and in
209 the guest0 domain.
210
211 %package xenU-devel
212 Summary: Development package for building kernel modules to match the kernel.
213 Group: System Environment/Kernel
214 AutoReqProv: no
215 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
216 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
217 Provides: kernel-devel = %{rpmversion}-%{release}xenU
218 Prereq: /usr/sbin/hardlink, /usr/bin/find
219
220 %description xenU-devel
221 This package provides kernel headers and makefiles sufficient to build modules
222 against the kernel package.
223
224 %package uml
225 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
226
227 Group: System Environment/Kernel
228
229 %description uml
230 This package includes a user mode version of the Linux kernel.
231
232 %package uml-devel
233 Summary: Development package for building kernel modules to match the UML kernel.
234 Group: System Environment/Kernel
235 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
236 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
237 Provides: kernel-devel = %{rpmversion}-%{release}smp
238 AutoReqProv: no
239 Prereq: /usr/sbin/hardlink, /usr/bin/find
240
241 %description uml-devel
242 This package provides kernel headers and makefiles sufficient to build modules
243 against the User Mode Linux kernel package.
244
245 %package uml-modules
246 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
247
248 Group: System Environment/Kernel
249
250 %description uml-modules
251 This package includes a user mode version of the Linux kernel modules.
252
253 %package vserver
254 Summary: A placeholder RPM that provides kernel and kernel-drm
255
256 Group: System Environment/Kernel
257 Provides: kernel = %{version}
258 Provides: kernel-drm = 4.3.0
259 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
260
261 %description vserver
262 VServers do not require and cannot use kernels, but some RPMs have
263 implicit or explicit dependencies on the "kernel" package
264 (e.g. tcpdump). This package installs no files but provides the
265 necessary dependencies to make rpm and yum happy.
266
267
268 %prep
269 # First we unpack the kernel tarball.
270 # If this isn't the first make prep, we use links to the existing clean tarball
271 # which speeds things up quite a bit.
272 if [ ! -d kernel-%{kversion}/vanilla ]; then
273   # Ok, first time we do a make prep.
274   rm -f pax_global_header
275 %setup -q -n %{name}-%{kversion} -c
276   mv linux-%{kversion} vanilla
277 else
278   # We already have a vanilla dir.
279   cd kernel-%{kversion}
280 fi
281
282 KERNEL_PREVIOUS=vanilla
283 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
284 %define ApplyPatch() \
285   rm -fr linux-%{kversion}-%1                           \
286   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
287   patchflag=-p1                                         \
288   test "%2" != "%%2" && patchflag="%2"                  \
289   PATCH="%{expand:%{PATCH%1}}"                          \
290   if test ! -e "$PATCH"; then                           \
291     echo "Patch %1 does not exist!"                     \
292     exit 1                                              \
293   fi                                                    \
294   case "$PATCH" in                                      \
295     *.bz2)  bzcat "$PATCH";;                            \
296     *.gz)   zcat "$PATCH";;                             \
297     *)      cat "$PATCH";;                              \
298   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
299   KERNEL_PREVIOUS=linux-%{kversion}-%1
300
301 # This is where the patches get applied
302 %if "0%{patchlevel}"
303 %ApplyPatch 0
304 %endif
305
306 %ApplyPatch 10
307 %ApplyPatch 20
308
309 # NetNS patch for VINI
310 %if 0%{?with_netns}
311 %ApplyPatch 30
312 %endif
313
314 %ApplyPatch 100
315
316 %ApplyPatch 200
317
318 %ApplyPatch 250
319
320 %ApplyPatch 500
321 %ApplyPatch 510
322 %ApplyPatch 520
323 %ApplyPatch 530
324 %ApplyPatch 540
325 %ApplyPatch 550
326 %ApplyPatch 560
327
328 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
329 # break with later patches.
330
331 %if 0%{?with_netns}
332 %ApplyPatch %vini_pl_patch
333 %endif
334
335 rm -fr linux-%{kversion}
336 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
337 cd linux-%{kversion}
338
339
340 # make sure the kernel has the sublevel we know it has. This looks weird
341 # but for -pre and -rc versions we need it since we only want to use
342 # the higher version when the final kernel is released.
343 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
344 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
345
346 # get rid of unwanted files resulting from patch fuzz
347 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
348
349
350 ###
351 ### build
352 ###
353 %build
354
355 BuildKernel() {
356     MakeTarget=$1
357     Arch=$2
358     Flavour=$3
359
360     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
361     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
362     cd linux-%{_target_cpu}-%{kversion}$Flavour
363
364     # Pick the right config file for the kernel we're building
365     if [ -n "$Flavour" ] ; then
366       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
367       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
368       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
369     else
370       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
371       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
372       DevelLink=
373     fi
374
375     KernelVer=%{version}-%{release}$Flavour
376     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
377
378     # make sure EXTRAVERSION says what we want it to say
379     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
380
381     # and now to start the build process
382
383     make -s mrproper
384     cp %{_sourcedir}/$Config .config
385
386     #Arch=`head -1 .config | cut -b 3-`
387     echo USING ARCH=$Arch
388
389     make -s ARCH=$Arch nonint_oldconfig > /dev/null
390     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
391     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
392
393     # Start installing the results
394
395 %if "%{_enable_debug_packages}" == "1"
396     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
397 %endif
398     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
399     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
400     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
401     if [ -f arch/$Arch/boot/bzImage ]; then
402       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
403     fi
404     if [ -f arch/$Arch/boot/zImage.stub ]; then
405       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
406     fi
407     if [ "$Flavour" = "uml" ] ; then
408         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
409     fi
410
411     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
412     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
413
414     # And save the headers/makefiles etc for building modules against
415     #
416     # This all looks scary, but the end result is supposed to be:
417     # * all arch relevant include/ files
418     # * all Makefile/Kconfig files
419     # * all script/ files
420
421     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
422     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
423     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
424     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
425     # dirs for additional modules per module-init-tools, kbuild/modules.txt
426     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
427     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
428     # first copy everything
429     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
430         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
431     if [ "$Flavour" = "uml" ] ; then
432       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
433     fi
434     # then drop all but the needed Makefiles/Kconfig files
435     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
436     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
437     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
438     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
439     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
440     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
441     if [ -d arch/%{_arch}/scripts ]; then
442       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
443     fi
444     if [ -f arch/%{_arch}/*lds ]; then
445       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
446     fi
447     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
448     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
449     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
450     cd include
451     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
452     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
453     if [ "$Arch" = "x86_64" ]; then
454       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
455     fi
456 %if %{buildxen}
457     if [ "$Flavour" = "xenU" ]; then
458       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
459       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
460     fi
461 %endif
462 %if %{builduml}
463     if [ "$Flavour" = "uml" ] ; then
464       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
465     fi
466 %endif
467     # While arch/powerpc/include/asm is still a symlink to the old
468     # include/asm-ppc{64,} directory, include that in kernel-devel too.
469     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
470       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
471       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
472       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
473       ln -sf ../../../include/asm-ppc* asm
474       popd
475     fi
476
477     # Make sure the Makefile and version.h have a matching timestamp so that
478     # external modules can be built
479     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
480     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
481     cd ..
482
483     #
484     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
485     #
486 %if "%{_enable_debug_packages}" == "1"
487     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
488     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
489 %endif
490 %if %{buildxen}
491     if [ -f vmlinuz ]; then
492       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
493     fi
494 %endif
495
496     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
497
498     # mark modules executable so that strip-to-file can strip them
499     cat modnames | xargs chmod u+x
500
501     # remove files that will be auto generated by depmod at rpm -i time
502     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
503
504     # Move the devel headers out of the root file system
505     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
506     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
507     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
508     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
509 }
510
511 ###
512 # DO it...
513 ###
514
515 # prepare directories
516 rm -rf $RPM_BUILD_ROOT
517 mkdir -p $RPM_BUILD_ROOT/boot
518
519 %if "%{_target_cpu}" == "x86_64"
520 %define kernel_arch %{_target_cpu}
521 %endif
522 %if "%{_target_cpu}" == "i586"
523 %define kernel_arch i386
524 %endif
525 %if "%{_target_cpu}" == "i686"
526 %define kernel_arch i386
527 %endif
528
529 %if %{buildup}
530 BuildKernel %make_target %kernel_arch
531 %endif
532
533 %ifarch i686
534 %if %{builduml}
535 BuildKernel linux um uml
536 %endif
537
538 %if %{buildxen}
539 BuildKernel vmlinuz %kernel_arch xenU
540 %endif
541 %endif
542
543 ###
544 ### install
545 ###
546
547 %install
548
549 cd vanilla
550
551 %if %{buildxen} && "%{_target_cpu}" == "i686"
552 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
553 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
554 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
555 # This directive teaches ldconfig to search in nosegneg subdirectories
556 # and cache the DSOs there with extra bit 0 set in their hwcap match
557 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
558 # search in nosegneg subdirectories and to match this extra hwcap bit
559 # in the ld.so.cache file.
560 hwcap 0 nosegneg
561 EOF
562 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
563 %endif
564
565 %if %{builddoc}
566 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
567
568 # sometimes non-world-readable files sneak into the kernel source tree
569 chmod -R a+r *
570 # copy the source over
571 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
572 %endif
573
574 ###
575 ### clean
576 ###
577
578 %clean
579 rm -rf $RPM_BUILD_ROOT
580
581 ###
582 ### scripts
583 ###
584
585 # load the loop module for upgrades...in case the old modules get removed we have
586 # loopback in the kernel so that mkinitrd will work.
587 %pre
588 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
589 exit 0
590
591 %post
592 if [ -f /etc/sysconfig/kernel ]; then
593   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
594 fi
595
596 # trick mkinitrd in case the current environment does not have device mapper
597 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
598 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
599     if [ ! -f $rootdev ]; then
600         fake_root_lvm=1
601         mkdir -p $(dirname $rootdev)
602         touch $rootdev
603     fi
604 fi
605
606 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
607 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
608 # Older modutils do not support --package option
609 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
610
611 # remove fake handle
612 if [ -n "$fake_root_lvm" ]; then
613     rm -f $rootdev
614 fi
615
616 # make some useful links
617 pushd /boot > /dev/null ; {
618         ln -sf config-%{KVERREL} config
619         ln -sf config-%{KVERREL} configsmp
620         ln -sf initrd-%{KVERREL}.img initrd-boot
621         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
622         ln -sf vmlinuz-%{KVERREL} kernel-boot
623         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
624 }
625 popd > /dev/null
626
627 # ask for a reboot
628 mkdir -p /etc/planetlab
629 touch /etc/planetlab/update-reboot
630
631 %post devel
632 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
633 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
634   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
635   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
636   popd > /dev/null
637 fi
638
639 %post xenU
640 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
641 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
642
643 %post xenU-devel
644 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
645 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
646   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
647   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
648   popd > /dev/null
649 fi
650
651 %post uml-modules
652 depmod -ae %{KVERREL}uml
653
654 %preun
655 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
656 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
657
658 %preun xenU
659 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
660 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
661
662 %preun uml-modules
663 rm -f /lib/modules/%{KVERREL}uml/modules.*
664
665
666 ###
667 ### file lists
668 ###
669
670 %if %{buildup}
671 %files 
672 %defattr(-,root,root)
673 /%{image_install_path}/vmlinuz-%{KVERREL}
674 /boot/System.map-%{KVERREL}
675 /boot/config-%{KVERREL}
676 %dir /lib/modules/%{KVERREL}
677 /lib/modules/%{KVERREL}/kernel
678 /lib/modules/%{KVERREL}/build
679 /lib/modules/%{KVERREL}/source
680 /lib/modules/%{KVERREL}/extra
681 /lib/modules/%{KVERREL}/updates
682
683 %files devel
684 %defattr(-,root,root)
685 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
686 %endif
687
688 %if %{builduml} && "%{_target_cpu}" == "i686"
689 %files uml
690 %defattr(-,root,root)
691 %{_bindir}/linux
692
693 %files uml-devel
694 %defattr(-,root,root)
695 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
696 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
697
698 %files uml-modules
699 %defattr(-,root,root)
700 /boot/System.map-%{KVERREL}uml
701 /boot/config-%{KVERREL}uml
702 %dir /lib/modules/%{KVERREL}uml
703 /lib/modules/%{KVERREL}uml/kernel
704 /lib/modules/%{KVERREL}uml/build
705 /lib/modules/%{KVERREL}uml/source
706 /lib/modules/%{KVERREL}uml/extra
707 /lib/modules/%{KVERREL}uml/updates
708 %endif
709
710 %if %{buildxen} && "%{_target_cpu}" == "i686"
711 %files xenU
712 %defattr(-,root,root)
713 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
714 /boot/System.map-%{KVERREL}xenU
715 /boot/config-%{KVERREL}xenU
716 %dir /lib/modules/%{KVERREL}xenU
717 /lib/modules/%{KVERREL}xenU/kernel
718 /lib/modules/%{KVERREL}xenU/build
719 /lib/modules/%{KVERREL}xenU/source
720 /lib/modules/%{KVERREL}xenU/extra
721 /lib/modules/%{KVERREL}xenU/updates
722 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
723
724 %files xenU-devel
725 %defattr(-,root,root)
726 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
727 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
728 %endif
729
730 %files vserver
731 %defattr(-,root,root)
732 # no files
733
734 # only some architecture builds need kernel-doc
735
736 %if %{builddoc}
737 %files doc
738 %defattr(-,root,root)
739 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
740 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
741 %dir %{_datadir}/doc/kernel-doc-%{kversion}
742 %endif
743
744 %changelog
745 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
746 - 2.6.17.4
747 - Disable split pagetable lock.
748
749 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
750 - Get rid of stack backtrace on panic, which in most
751   cases actually caused a loss of info instead of a gain.
752
753 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
754 - 2.6.17.3
755
756 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
757 - 2.6.17.2
758 - Fix up the alsa list_add bug.
759
760 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
761 - Fix up various stupidities incurred by the last big rebase.
762   - Reenable SMP x86-64 builds.
763   - Reenable SMBFS.
764 - Enable PCI fake hotplug driver.
765 - Enable gameport/joystick on i586 builds. (#196581)
766
767 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
768 - Enable profiling for 586 kernels.
769
770 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
771 - Rebuild with slab debug off.
772
773 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
774 - 2.6.17.1
775
776 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
777 - 2.6.16.20
778
779 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
780 - 2.6.16.19
781
782 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
783 - Improved list_head debugging.
784
785 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
786 - 2.6.16.18
787
788 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
789 - 2.6.16.17
790
791 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
792 - 2.6.16.16
793
794 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
795 - 2.6.16.15
796 - make 16C950 UARTs work (again). (#126403)
797 - Fix exec-shield default, which should fix a few programs that
798   stopped running.
799
800 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
801 - 2.6.16.14
802
803 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
804 - 2.6.16.13
805
806 * Mon May  1 2006 Dave Jones <davej@redhat.com>
807 - 2.6.16.12
808
809 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
810 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
811
812 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
813 - 2.6.16.11
814
815 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
816 - Enable PCI MSI support.
817
818 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
819 - 2.6.16.9
820
821 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
822 - 2.6.16.7
823
824 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
825 - 2.6.16.6
826
827 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
828 - 2.6.16.5
829
830 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
831 - 2.6.16.2
832
833 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
834 - Reenable non-standard serial ports. (#187466)
835 - Reenable snd-es18xx for x86-32 (#187733)
836
837 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
838 - ship the .kernelrelease file in -devel too.
839 - Disable EDAC debug.
840
841 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
842 - 2.6.16.1
843
844 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
845 - Include patches posted for review for inclusion in 2.6.16.1
846 - Updated new audit msg types.
847 - Reenable HDLC driver (#186257)
848 - Make acpi-cpufreq 'sticky'
849 - Fix broken x86-64 32bit vDSO (#186924)
850
851 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
852 - Improve spinlock scalability on big machines.
853
854 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
855 - Sync with FC5's 2.6.16 kernel.
856 - Update Tux & Exec-shield to latest.
857