Activate IDLELIMIT
[linux-2.6.git] / kernel-2.6.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 %define _with_netns 1
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 22
22 %define patchlevel 14
23 %define kversion 2.6.%{sublevel}
24 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
25
26 %define vsversion 2.3.0.32
27
28 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
29 # updated every time the PL kernel is updated.
30 %define vini_pl_patch 561
31
32 %define specrelease 1
33
34 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
35
36 %{!?pldistro:%global pldistro planetlab}
37
38 %define signmodules 0
39 %define make_target bzImage
40 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
41
42 # Override generic defaults with per-arch defaults
43
44 %define image_install_path boot
45
46 #
47 # Three sets of minimum package version requirements in the form of Conflicts:
48 # to versions below the minimum
49 #
50
51 #
52 # First the general kernel 2.6 required versions as per
53 # Documentation/Changes
54 #
55 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
56
57
58 # Then a series of requirements that are distribution specific, either 
59 # because we add patches for something, or the older versions have 
60 # problems with the newer kernel or lack certain things that make 
61 # integration in the distro harder than needed.
62 #
63 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
64
65 #
66 # Several packages had bugs in them that became obvious when the NPTL
67 # threading code got integrated.
68 #
69 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
70
71 #
72 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
73 #
74
75 # MEF commented out
76 # %define xen_conflicts glibc < 2.3.5-1
77
78 #
79 # Packages that need to be installed before the kernel is, because the %post
80 # scripts use them.
81 #
82 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
83
84 URL: http://svn.planet-lab.org/wiki/linux-2.6
85
86 Name: kernel
87 Group: System Environment/Kernel
88 License: GPLv2
89 Version: %{rpmversion}
90 Release: %{release}
91 ExclusiveOS: Linux
92 Provides: kernel = %{version}
93 Provides: kernel-drm = 4.3.0
94 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
95 Provides: kernel-smp = %{rpmversion}-%{release}
96 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
97 Prereq: %{kernel_prereq}
98 Conflicts: %{kernel_dot_org_conflicts}
99 Conflicts: %{package_conflicts}
100 Conflicts: %{nptl_conflicts}
101 # We can't let RPM do the dependencies automatic because it'll then pick up
102 # a correct but undesirable perl dependency from the module headers which
103 # isn't required for the kernel proper to function
104 AutoReqProv: no
105
106 #
107 # List the packages used during the kernel build
108 #
109 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
110 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
111 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
112 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
113
114
115 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
116
117 Source10: kernel-%{kversion}-i586-%{pldistro}.config
118 Source11: kernel-%{kversion}-i686-%{pldistro}.config
119 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
120 %if %{builduml}
121 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
122 %endif
123 %if %{buildxen}
124 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
125 %endif
126
127 # Mainline patches
128 %if "0%{patchlevel}"
129 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
130 %endif
131
132 Patch010: linux-2.6-010-e1000e.patch
133 Patch020: linux-2.6-020-build-id.patch
134 Patch030: linux-2.6-030-netns.patch
135
136 # These are patches picked up from Fedora/RHEL
137 Patch100: linux-2.6-100-build-nonintconfig.patch
138
139 # Linux-VServer
140 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
141 Patch210: linux-2.6-210-vserver-cpu-sched.patch
142 Patch220: linux-2.6-220-lback-feat02.diff
143
144 # IP sets
145 Patch250: linux-2.6-250-ipsets.patch
146
147 # PlanetLab
148 Patch500: linux-2.6-500-vserver-filesharing.patch
149 Patch510: linux-2.6-510-ipod.patch
150 Patch520: linux-2.6-520-vnet+.patch
151 Patch530: linux-2.6-530-built-by-support.patch
152 Patch540: linux-2.6-540-oom-kill.patch
153 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
154 Patch560: linux-2.6-560-mmconf.patch
155 Patch570: linux-2.6-570-tagxid.patch
156 Patch590: linux-2.6-590-trellis-mm1-netns.patch
157 Patch591: linux-2.6-591-unshare-netns.patch
158 Patch592: linux-2.6-592-ztun-sb.patch
159 Patch593: linux-2.6-593-egre.patch
160 Patch594: linux-2.6-594-new_ns_pid.patch
161 Patch595: linux-2.6-595-vserver-setspace.patch
162 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
163
164 %description
165 The kernel package contains the Linux kernel (vmlinuz), the core of any
166 Linux operating system.  The kernel handles the basic functions
167 of the operating system:  memory allocation, process allocation, device
168 input and output, etc.
169
170 %package devel
171 Summary: Development package for building kernel modules to match the kernel.
172 Group: System Environment/Kernel
173 AutoReqProv: no
174 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
175 Provides: kernel-smp-devel = %{rpmversion}-%{release}
176 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
177 Prereq: /usr/bin/find
178
179 %description devel
180 This package provides kernel headers and makefiles sufficient to build modules
181 against the kernel package.
182
183
184 %package doc
185 Summary: Various documentation bits found in the kernel source.
186 Group: Documentation
187
188 %description doc
189 This package contains documentation files from the kernel
190 source. Various bits of information about the Linux kernel and the
191 device drivers shipped with it are documented in these files.
192
193 You'll want to install this package if you need a reference to the
194 options that can be passed to Linux kernel modules at load time.
195
196 %package xenU
197 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
198
199 Group: System Environment/Kernel
200 Provides: kernel = %{version}
201 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
202 Prereq: %{kernel_prereq}
203 Conflicts: %{kernel_dot_org_conflicts}
204 Conflicts: %{package_conflicts}
205 Conflicts: %{nptl_conflicts}
206
207 # MEF commented out 
208 # Conflicts: %{xen_conflicts}
209
210 # We can't let RPM do the dependencies automatic because it'll then pick up
211 # a correct but undesirable perl dependency from the module headers which
212 # isn't required for the kernel proper to function
213 AutoReqProv: no
214
215 %description xenU
216 This package includes a version of the Linux kernel which
217 runs in Xen unprivileged guest VMs.  This should be installed
218 both inside the unprivileged guest (for the modules) and in
219 the guest0 domain.
220
221 %package xenU-devel
222 Summary: Development package for building kernel modules to match the kernel.
223 Group: System Environment/Kernel
224 AutoReqProv: no
225 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
226 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
227 Provides: kernel-devel = %{rpmversion}-%{release}xenU
228 Prereq: /usr/sbin/hardlink, /usr/bin/find
229
230 %description xenU-devel
231 This package provides kernel headers and makefiles sufficient to build modules
232 against the kernel package.
233
234 %package uml
235 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
236
237 Group: System Environment/Kernel
238
239 %description uml
240 This package includes a user mode version of the Linux kernel.
241
242 %package uml-devel
243 Summary: Development package for building kernel modules to match the UML kernel.
244 Group: System Environment/Kernel
245 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
246 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
247 Provides: kernel-devel = %{rpmversion}-%{release}smp
248 AutoReqProv: no
249 Prereq: /usr/sbin/hardlink, /usr/bin/find
250
251 %description uml-devel
252 This package provides kernel headers and makefiles sufficient to build modules
253 against the User Mode Linux kernel package.
254
255 %package uml-modules
256 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
257
258 Group: System Environment/Kernel
259
260 %description uml-modules
261 This package includes a user mode version of the Linux kernel modules.
262
263 %package vserver
264 Summary: A placeholder RPM that provides kernel and kernel-drm
265
266 Group: System Environment/Kernel
267 Provides: kernel = %{version}
268 Provides: kernel-drm = 4.3.0
269 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
270
271 %description vserver
272 VServers do not require and cannot use kernels, but some RPMs have
273 implicit or explicit dependencies on the "kernel" package
274 (e.g. tcpdump). This package installs no files but provides the
275 necessary dependencies to make rpm and yum happy.
276
277
278 %prep
279 # First we unpack the kernel tarball.
280 # If this isn't the first make prep, we use links to the existing clean tarball
281 # which speeds things up quite a bit.
282 if [ ! -d kernel-%{kversion}/vanilla ]; then
283   # Ok, first time we do a make prep.
284   rm -f pax_global_header
285 %setup -q -n %{name}-%{kversion} -c
286   mv linux-%{kversion} vanilla
287 else
288   # We already have a vanilla dir.
289   cd kernel-%{kversion}
290 fi
291
292 KERNEL_PREVIOUS=vanilla
293 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
294 %define ApplyPatch() \
295   rm -fr linux-%{kversion}-%1                           \
296   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
297   patchflag=-p1                                         \
298   test "%2" != "%%2" && patchflag="%2"                  \
299   PATCH="%{expand:%{PATCH%1}}"                          \
300   if test ! -e "$PATCH"; then                           \
301     echo "Patch %1 does not exist!"                     \
302     exit 1                                              \
303   fi                                                    \
304   case "$PATCH" in                                      \
305     *.bz2)  bzcat "$PATCH";;                            \
306     *.gz)   zcat "$PATCH";;                             \
307     *)      cat "$PATCH";;                              \
308   esac | patch -s -d linux-%{kversion}-%1 $patchflag \
309   KERNEL_PREVIOUS=linux-%{kversion}-%1
310
311 # This is where the patches get applied
312 %if "0%{patchlevel}"
313 %ApplyPatch 0
314 %endif
315
316 %ApplyPatch 10
317 %ApplyPatch 20
318
319 %ApplyPatch 100
320
321 %ApplyPatch 200
322 %ApplyPatch 210
323 %ApplyPatch 220
324
325 %ApplyPatch 250
326
327 %ApplyPatch 500
328 %ApplyPatch 510
329 %ApplyPatch 520
330 %ApplyPatch 530
331 %ApplyPatch 540
332 %ApplyPatch 550
333 %ApplyPatch 560
334 %ApplyPatch 570
335
336
337 %if 0%{?_with_netns}
338 %ApplyPatch 590
339 %ApplyPatch 591
340 %ApplyPatch 592
341 %ApplyPatch 593
342 %ApplyPatch 594
343 %ApplyPatch 595
344 %endif
345
346 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
347 # break with later patches.
348
349 rm -fr linux-%{kversion}
350 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
351 cd linux-%{kversion}
352
353
354 # make sure the kernel has the sublevel we know it has. This looks weird
355 # but for -pre and -rc versions we need it since we only want to use
356 # the higher version when the final kernel is released.
357 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
358 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
359
360 # get rid of unwanted files resulting from patch fuzz
361 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
362
363
364 ###
365 ### build
366 ###
367 %build
368
369 BuildKernel() {
370     MakeTarget=$1
371     Arch=$2
372     Flavour=$3
373
374     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
375     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
376     cd linux-%{_target_cpu}-%{kversion}$Flavour
377
378     # Pick the right config file for the kernel we're building
379     if [ -n "$Flavour" ] ; then
380       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
381       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
382       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
383     else
384       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
385       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
386       DevelLink=
387     fi
388
389     KernelVer=%{version}-%{release}$Flavour
390     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
391
392     # make sure EXTRAVERSION says what we want it to say
393     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
394
395     # and now to start the build process
396
397     make -s mrproper
398     cp %{_sourcedir}/$Config .config
399
400     #Arch=`head -1 .config | cut -b 3-`
401     echo USING ARCH=$Arch
402
403     make -s ARCH=$Arch nonint_oldconfig > /dev/null
404     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
405     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
406
407     # Start installing the results
408
409 %if "%{_enable_debug_packages}" == "1"
410     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
411 %endif
412     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
413     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
414     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
415     if [ -f arch/$Arch/boot/bzImage ]; then
416       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
417     fi
418     if [ -f arch/$Arch/boot/zImage.stub ]; then
419       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
420     fi
421     if [ "$Flavour" = "uml" ] ; then
422         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
423     fi
424
425     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
426     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
427
428     # And save the headers/makefiles etc for building modules against
429     #
430     # This all looks scary, but the end result is supposed to be:
431     # * all arch relevant include/ files
432     # * all Makefile/Kconfig files
433     # * all script/ files
434
435     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
436     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
437     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
438     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
439     # dirs for additional modules per module-init-tools, kbuild/modules.txt
440     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
441     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
442     # first copy everything
443     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
444         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
445     if [ "$Flavour" = "uml" ] ; then
446       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
447     fi
448     # then drop all but the needed Makefiles/Kconfig files
449     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
450     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
451     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
452     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
453     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
454     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
455     if [ -d arch/%{_arch}/scripts ]; then
456       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
457     fi
458     if [ -f arch/%{_arch}/*lds ]; then
459       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
460     fi
461     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
462     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
463     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
464     cd include
465     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
466     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
467     if [ "$Arch" = "x86_64" ]; then
468       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
469     fi
470 %if %{buildxen}
471     if [ "$Flavour" = "xenU" ]; then
472       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
473       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
474     fi
475 %endif
476 %if %{builduml}
477     if [ "$Flavour" = "uml" ] ; then
478       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
479     fi
480 %endif
481     # While arch/powerpc/include/asm is still a symlink to the old
482     # include/asm-ppc{64,} directory, include that in kernel-devel too.
483     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
484       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
485       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
486       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
487       ln -sf ../../../include/asm-ppc* asm
488       popd
489     fi
490
491     # Make sure the Makefile and version.h have a matching timestamp so that
492     # external modules can be built
493     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
494     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
495     cd ..
496
497     #
498     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
499     #
500 %if "%{_enable_debug_packages}" == "1"
501     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
502     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
503 %endif
504 %if %{buildxen}
505     if [ -f vmlinuz ]; then
506       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
507     fi
508 %endif
509
510     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
511
512     # mark modules executable so that strip-to-file can strip them
513     cat modnames | xargs chmod u+x
514
515     # remove files that will be auto generated by depmod at rpm -i time
516     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
517
518     # Move the devel headers out of the root file system
519     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
520     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
521     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
522     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
523 }
524
525 ###
526 # DO it...
527 ###
528
529 # prepare directories
530 rm -rf $RPM_BUILD_ROOT
531 mkdir -p $RPM_BUILD_ROOT/boot
532
533 %if "%{_target_cpu}" == "x86_64"
534 %define kernel_arch %{_target_cpu}
535 %endif
536 %if "%{_target_cpu}" == "i586"
537 %define kernel_arch i386
538 %endif
539 %if "%{_target_cpu}" == "i686"
540 %define kernel_arch i386
541 %endif
542
543 %if %{buildup}
544 BuildKernel %make_target %kernel_arch
545 %endif
546
547 %ifarch i686
548 %if %{builduml}
549 BuildKernel linux um uml
550 %endif
551
552 %if %{buildxen}
553 BuildKernel vmlinuz %kernel_arch xenU
554 %endif
555 %endif
556
557 ###
558 ### install
559 ###
560
561 %install
562
563 cd vanilla
564
565 %if %{buildxen} && "%{_target_cpu}" == "i686"
566 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
567 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
568 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
569 # This directive teaches ldconfig to search in nosegneg subdirectories
570 # and cache the DSOs there with extra bit 0 set in their hwcap match
571 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
572 # search in nosegneg subdirectories and to match this extra hwcap bit
573 # in the ld.so.cache file.
574 hwcap 0 nosegneg
575 EOF
576 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
577 %endif
578
579 %if %{builddoc}
580 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
581
582 # sometimes non-world-readable files sneak into the kernel source tree
583 chmod -R a+r *
584 # copy the source over
585 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
586 %endif
587
588 ###
589 ### clean
590 ###
591
592 %clean
593 rm -rf $RPM_BUILD_ROOT
594
595 ###
596 ### scripts
597 ###
598
599 # load the loop module for upgrades...in case the old modules get removed we have
600 # loopback in the kernel so that mkinitrd will work.
601 %pre
602 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
603 exit 0
604
605 %post
606 if [ -f /etc/sysconfig/kernel ]; then
607   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
608 fi
609
610 # trick mkinitrd in case the current environment does not have device mapper
611 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
612 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
613     if [ ! -f $rootdev ]; then
614         fake_root_lvm=1
615         mkdir -p $(dirname $rootdev)
616         touch $rootdev
617     fi
618 fi
619
620 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
621 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
622 # Older modutils do not support --package option
623 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
624
625 # remove fake handle
626 if [ -n "$fake_root_lvm" ]; then
627     rm -f $rootdev
628 fi
629
630 # make some useful links
631 pushd /boot > /dev/null ; {
632         ln -sf config-%{KVERREL} config
633         ln -sf config-%{KVERREL} configsmp
634         ln -sf initrd-%{KVERREL}.img initrd-boot
635         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
636         ln -sf vmlinuz-%{KVERREL} kernel-boot
637         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
638 }
639 popd > /dev/null
640
641 # ask for a reboot
642 mkdir -p /etc/planetlab
643 touch /etc/planetlab/update-reboot
644
645 %post devel
646 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
647 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
648   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
649   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
650   popd > /dev/null
651 fi
652
653 %post xenU
654 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
655 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
656
657 %post xenU-devel
658 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
659 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
660   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
661   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
662   popd > /dev/null
663 fi
664
665 %post uml-modules
666 depmod -ae %{KVERREL}uml
667
668 %preun
669 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
670 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
671
672 %preun xenU
673 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
674 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
675
676 %preun uml-modules
677 rm -f /lib/modules/%{KVERREL}uml/modules.*
678
679
680 ###
681 ### file lists
682 ###
683
684 %if %{buildup}
685 %files 
686 %defattr(-,root,root)
687 /%{image_install_path}/vmlinuz-%{KVERREL}
688 /boot/System.map-%{KVERREL}
689 /boot/config-%{KVERREL}
690 %dir /lib/modules/%{KVERREL}
691 /lib/modules/%{KVERREL}/kernel
692 /lib/modules/%{KVERREL}/build
693 /lib/modules/%{KVERREL}/source
694 /lib/modules/%{KVERREL}/extra
695 /lib/modules/%{KVERREL}/updates
696
697 %files devel
698 %defattr(-,root,root)
699 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
700 %endif
701
702 %if %{builduml} && "%{_target_cpu}" == "i686"
703 %files uml
704 %defattr(-,root,root)
705 %{_bindir}/linux
706
707 %files uml-devel
708 %defattr(-,root,root)
709 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
710 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
711
712 %files uml-modules
713 %defattr(-,root,root)
714 /boot/System.map-%{KVERREL}uml
715 /boot/config-%{KVERREL}uml
716 %dir /lib/modules/%{KVERREL}uml
717 /lib/modules/%{KVERREL}uml/kernel
718 /lib/modules/%{KVERREL}uml/build
719 /lib/modules/%{KVERREL}uml/source
720 /lib/modules/%{KVERREL}uml/extra
721 /lib/modules/%{KVERREL}uml/updates
722 %endif
723
724 %if %{buildxen} && "%{_target_cpu}" == "i686"
725 %files xenU
726 %defattr(-,root,root)
727 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
728 /boot/System.map-%{KVERREL}xenU
729 /boot/config-%{KVERREL}xenU
730 %dir /lib/modules/%{KVERREL}xenU
731 /lib/modules/%{KVERREL}xenU/kernel
732 /lib/modules/%{KVERREL}xenU/build
733 /lib/modules/%{KVERREL}xenU/source
734 /lib/modules/%{KVERREL}xenU/extra
735 /lib/modules/%{KVERREL}xenU/updates
736 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
737
738 %files xenU-devel
739 %defattr(-,root,root)
740 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
741 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
742 %endif
743
744 %files vserver
745 %defattr(-,root,root)
746 # no files
747
748 # only some architecture builds need kernel-doc
749
750 %if %{builddoc}
751 %files doc
752 %defattr(-,root,root)
753 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
754 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
755 %dir %{_datadir}/doc/kernel-doc-%{kversion}
756 %endif
757
758 %changelog
759 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
760 - 2.6.17.4
761 - Disable split pagetable lock.
762
763 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
764 - Get rid of stack backtrace on panic, which in most
765   cases actually caused a loss of info instead of a gain.
766
767 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
768 - 2.6.17.3
769
770 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
771 - 2.6.17.2
772 - Fix up the alsa list_add bug.
773
774 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
775 - Fix up various stupidities incurred by the last big rebase.
776   - Reenable SMP x86-64 builds.
777   - Reenable SMBFS.
778 - Enable PCI fake hotplug driver.
779 - Enable gameport/joystick on i586 builds. (#196581)
780
781 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
782 - Enable profiling for 586 kernels.
783
784 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
785 - Rebuild with slab debug off.
786
787 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
788 - 2.6.17.1
789
790 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
791 - 2.6.16.20
792
793 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
794 - 2.6.16.19
795
796 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
797 - Improved list_head debugging.
798
799 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
800 - 2.6.16.18
801
802 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
803 - 2.6.16.17
804
805 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
806 - 2.6.16.16
807
808 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
809 - 2.6.16.15
810 - make 16C950 UARTs work (again). (#126403)
811 - Fix exec-shield default, which should fix a few programs that
812   stopped running.
813
814 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
815 - 2.6.16.14
816
817 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
818 - 2.6.16.13
819
820 * Mon May  1 2006 Dave Jones <davej@redhat.com>
821 - 2.6.16.12
822
823 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
824 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
825
826 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
827 - 2.6.16.11
828
829 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
830 - Enable PCI MSI support.
831
832 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
833 - 2.6.16.9
834
835 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
836 - 2.6.16.7
837
838 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
839 - 2.6.16.6
840
841 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
842 - 2.6.16.5
843
844 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
845 - 2.6.16.2
846
847 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
848 - Reenable non-standard serial ports. (#187466)
849 - Reenable snd-es18xx for x86-32 (#187733)
850
851 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
852 - ship the .kernelrelease file in -devel too.
853 - Disable EDAC debug.
854
855 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
856 - 2.6.16.1
857
858 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
859 - Include patches posted for review for inclusion in 2.6.16.1
860 - Updated new audit msg types.
861 - Reenable HDLC driver (#186257)
862 - Make acpi-cpufreq 'sticky'
863 - Fix broken x86-64 32bit vDSO (#186924)
864
865 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
866 - Improve spinlock scalability on big machines.
867
868 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
869 - Sync with FC5's 2.6.16 kernel.
870 - Update Tux & Exec-shield to latest.
871