iwlwifi : conditional build, and upgrade to 1.2.25
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1 
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
21
22 # Versions of various parts
23
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
27 %define taglevel 1
28
29 #
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
34 #
35 %define sublevel 22
36 %define patchlevel 19
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
39
40 %define vsversion 2.3.0.34
41
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
45
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
47
48 %{!?pldistro:%global pldistro planetlab}
49
50 %define signmodules 0
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
53
54 # Override generic defaults with per-arch defaults
55
56 %define image_install_path boot
57
58 #
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
61 #
62
63 #
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
66 #
67 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
68
69
70 # Then a series of requirements that are distribution specific, either 
71 # because we add patches for something, or the older versions have 
72 # problems with the newer kernel or lack certain things that make 
73 # integration in the distro harder than needed.
74 #
75 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
76
77 #
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
80 #
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
82
83 #
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
85 #
86
87 # MEF commented out
88 # %define xen_conflicts glibc < 2.3.5-1
89
90 #
91 # Packages that need to be installed before the kernel is, because the %post
92 # scripts use them.
93 #
94 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
95
96 Vendor: PlanetLab
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
100
101 Name: kernel
102 Group: System Environment/Kernel
103 License: GPLv2
104 Version: %{rpmversion}
105 Release: %{release}
106 ExclusiveOS: Linux
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
119 AutoReqProv: no
120
121 #
122 # List the packages used during the kernel build
123 #
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
128
129
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
131
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
135 %if %{builduml}
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
137 %endif
138 %if %{buildxen}
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
140 %endif
141
142 # Mainline patches
143 %if "0%{patchlevel}"
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
145 %endif
146
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
151
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
154
155 # Linux-VServer
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158
159 # IP sets
160 Patch250: linux-2.6-250-ipsets.patch
161
162 # PlanetLab
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch520: linux-2.6-520-vnet+.patch
166 Patch530: linux-2.6-530-built-by-support.patch
167 Patch540: linux-2.6-540-oom-kill.patch
168 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
169 Patch560: linux-2.6-560-mmconf.patch
170 Patch570: linux-2.6-570-tagxid.patch
171 Patch580: linux-2.6-580-show-proc-virt.patch
172 Patch590: linux-2.6-590-chopstix-intern.patch
173 Patch620: linux-2.6-620-kdb.patch
174
175 # See also the file named 'sources' here for the related checksums
176 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
177 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
178 %if %{build_iwlwifi}
179 %define mac80211_version 10.0.4
180 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
181 %define iwlwifi_version 1.2.25
182 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
183 %endif
184
185 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
186
187 %description
188 The kernel package contains the Linux kernel (vmlinuz), the core of any
189 Linux operating system.  The kernel handles the basic functions
190 of the operating system:  memory allocation, process allocation, device
191 input and output, etc.
192
193 %package devel
194 Summary: Development package for building kernel modules to match the kernel.
195 Group: System Environment/Kernel
196 AutoReqProv: no
197 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
198 Provides: kernel-smp-devel = %{rpmversion}-%{release}
199 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
200 Prereq: /usr/bin/find
201
202 %description devel
203 This package provides kernel headers and makefiles sufficient to build modules
204 against the kernel package.
205
206
207 %package doc
208 Summary: Various documentation bits found in the kernel source.
209 Group: Documentation
210
211 %description doc
212 This package contains documentation files from the kernel
213 source. Various bits of information about the Linux kernel and the
214 device drivers shipped with it are documented in these files.
215
216 You'll want to install this package if you need a reference to the
217 options that can be passed to Linux kernel modules at load time.
218
219 %package xenU
220 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
221
222 Group: System Environment/Kernel
223 Provides: kernel = %{version}
224 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
225 Prereq: %{kernel_prereq}
226 Conflicts: %{kernel_dot_org_conflicts}
227 Conflicts: %{package_conflicts}
228 Conflicts: %{nptl_conflicts}
229
230 # MEF commented out 
231 # Conflicts: %{xen_conflicts}
232
233 # We can't let RPM do the dependencies automatic because it'll then pick up
234 # a correct but undesirable perl dependency from the module headers which
235 # isn't required for the kernel proper to function
236 AutoReqProv: no
237
238 %description xenU
239 This package includes a version of the Linux kernel which
240 runs in Xen unprivileged guest VMs.  This should be installed
241 both inside the unprivileged guest (for the modules) and in
242 the guest0 domain.
243
244 %package xenU-devel
245 Summary: Development package for building kernel modules to match the kernel.
246 Group: System Environment/Kernel
247 AutoReqProv: no
248 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
249 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
250 Provides: kernel-devel = %{rpmversion}-%{release}xenU
251 Prereq: /usr/sbin/hardlink, /usr/bin/find
252
253 %description xenU-devel
254 This package provides kernel headers and makefiles sufficient to build modules
255 against the kernel package.
256
257 %package uml
258 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
259
260 Group: System Environment/Kernel
261
262 %description uml
263 This package includes a user mode version of the Linux kernel.
264
265 %package uml-devel
266 Summary: Development package for building kernel modules to match the UML kernel.
267 Group: System Environment/Kernel
268 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
269 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
270 Provides: kernel-devel = %{rpmversion}-%{release}smp
271 AutoReqProv: no
272 Prereq: /usr/sbin/hardlink, /usr/bin/find
273
274 %description uml-devel
275 This package provides kernel headers and makefiles sufficient to build modules
276 against the User Mode Linux kernel package.
277
278 %package uml-modules
279 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
280
281 Group: System Environment/Kernel
282
283 %description uml-modules
284 This package includes a user mode version of the Linux kernel modules.
285
286 %package vserver
287 Summary: A placeholder RPM that provides kernel and kernel-drm
288
289 Group: System Environment/Kernel
290 Provides: kernel = %{version}
291 Provides: kernel-drm = 4.3.0
292 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
293
294 %description vserver
295 VServers do not require and cannot use kernels, but some RPMs have
296 implicit or explicit dependencies on the "kernel" package
297 (e.g. tcpdump). This package installs no files but provides the
298 necessary dependencies to make rpm and yum happy.
299
300
301 %prep
302 # First we unpack the kernel tarball.
303 # If this isn't the first make prep, we use links to the existing clean tarball
304 # which speeds things up quite a bit.
305 if [ ! -d kernel-%{kversion}/vanilla ]; then
306   # Ok, first time we do a make prep.
307   rm -f pax_global_header
308 %setup -q -n %{name}-%{kversion} -c
309   mv linux-%{kversion} vanilla
310 else
311   # We already have a vanilla dir.
312   cd kernel-%{kversion}
313 fi
314
315 KERNEL_PREVIOUS=vanilla
316 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
317 %define ApplyPatch() \
318   rm -fr linux-%{kversion}-%1                           \
319   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
320   patchflag=-p1                                         \
321   test "%2" != "%%2" && patchflag="%2"                  \
322   PATCH="%{expand:%{PATCH%1}}"                          \
323   if test ! -e "$PATCH"; then                           \
324     echo "Patch %1 does not exist!"                     \
325     exit 1                                              \
326   fi                                                    \
327   case "$PATCH" in                                      \
328     *.bz2)  bzcat "$PATCH";;                            \
329     *.gz)   zcat "$PATCH";;                             \
330     *)      cat "$PATCH";;                              \
331   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
332   KERNEL_PREVIOUS=linux-%{kversion}-%1
333
334 # This is where the patches get applied
335 %if 0%{?patchlevel}
336 %ApplyPatch 0
337 %endif
338
339 %ApplyPatch 10
340 %ApplyPatch 20
341
342 # NetNS patch for VINI
343 %if 0%{?with_netns}
344 %ApplyPatch 30
345 %endif
346 %ApplyPatch 40
347
348 %ApplyPatch 100
349
350 %ApplyPatch 200
351 %ApplyPatch 210
352
353 %ApplyPatch 250
354
355 %ApplyPatch 500
356 %ApplyPatch 510
357 %ApplyPatch 520
358 %ApplyPatch 530
359 %ApplyPatch 540
360 %ApplyPatch 550
361 %ApplyPatch 560
362 %ApplyPatch 570
363 %ApplyPatch 580
364 %ApplyPatch 590
365 %ApplyPatch 620
366
367 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
368 # break with later patches.
369
370 %if 0%{?with_netns}
371 %ApplyPatch %vini_pl_patch
372 %endif
373
374 %if %{build_iwlwifi}
375 # Run the mac80211 stuff in the kernel tree holding the last patch
376 tar -xzf %{PATCH600}
377 pushd mac80211-%{mac80211_version}
378 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
379 make $mac80211_makeflags modified
380 make $mac80211_makeflags source
381 make $mac80211_makeflags patch_kernel
382 popd
383
384 # Untar iwlwifi in the same place - needs to be compiled later
385 tar -xzf %{PATCH601}
386 # the install target is broken: first it does not pass the right -b flag to depmod
387 # second we do not need to invoke depmod at this stage anyway
388 # let's add our own patch/stuff in this Makefile for manual install later on
389 pushd iwlwifi-%{iwlwifi_version}
390 cat >> Makefile <<EOF
391 module-list:
392         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
393 EOF
394 popd
395 %endif
396
397 rm -fr linux-%{kversion}
398 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
399 cd linux-%{kversion}
400
401
402 # make sure the kernel has the sublevel we know it has. This looks weird
403 # but for -pre and -rc versions we need it since we only want to use
404 # the higher version when the final kernel is released.
405 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
406 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
407
408 # get rid of unwanted files resulting from patch fuzz
409 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
410
411
412 ###
413 ### build
414 ###
415 %build
416
417 BuildKernel() {
418     MakeTarget=$1
419     Arch=$2
420     Flavour=$3
421
422     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
423     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
424     cd linux-%{_target_cpu}-%{kversion}$Flavour
425
426     # Pick the right config file for the kernel we're building
427     if [ -n "$Flavour" ] ; then
428       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
429       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
430       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
431     else
432       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
433       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
434       DevelLink=
435     fi
436
437     KernelVer=%{version}-%{release}$Flavour
438     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
439
440     # make sure EXTRAVERSION says what we want it to say
441     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
442
443     # and now to start the build process
444
445     make -s mrproper
446     cp %{_sourcedir}/$Config .config
447
448     #Arch=`head -1 .config | cut -b 3-`
449     echo USING ARCH=$Arch
450
451     make -s ARCH=$Arch nonint_oldconfig > /dev/null
452     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
453     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
454
455 %if %{build_iwlwifi}
456     # build the iwlwifi driver
457     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
458       KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
459 %endif
460
461     # Start installing the results
462
463 %if "%{_enable_debug_packages}" == "1"
464     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
465 %endif
466     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
467     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
468     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
469     if [ -f arch/$Arch/boot/bzImage ]; then
470       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
471     fi
472     if [ -f arch/$Arch/boot/zImage.stub ]; then
473       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
474     fi
475     if [ "$Flavour" = "uml" ] ; then
476         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
477     fi
478
479     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
480     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
481
482 %if %{build_iwlwifi}
483     # install iwlwifi
484 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
485 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
486 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
487     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
488     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
489     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
490     iwlwifi_modules=$(make --no-print-directory module-list)
491     install -d $iwlwifi_dest
492     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
493     popd
494 %endif
495
496     # And save the headers/makefiles etc for building modules against
497     #
498     # This all looks scary, but the end result is supposed to be:
499     # * all arch relevant include/ files
500     # * all Makefile/Kconfig files
501     # * all script/ files
502
503     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
504     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
505     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
506     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
507     # dirs for additional modules per module-init-tools, kbuild/modules.txt
508     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
509     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
510     # first copy everything
511     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
512         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
513     if [ "$Flavour" = "uml" ] ; then
514       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
515     fi
516     # then drop all but the needed Makefiles/Kconfig files
517     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
518     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
519     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
520     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
521     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
522     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
523     if [ -d arch/%{_arch}/scripts ]; then
524       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
525     fi
526     if [ -f arch/%{_arch}/*lds ]; then
527       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
528     fi
529     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
530     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
531     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
532     cd include
533     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
534     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
535     if [ "$Arch" = "x86_64" ]; then
536       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
537     fi
538 %if %{buildxen}
539     if [ "$Flavour" = "xenU" ]; then
540       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
541       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
542     fi
543 %endif
544 %if %{builduml}
545     if [ "$Flavour" = "uml" ] ; then
546       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
547     fi
548 %endif
549     # While arch/powerpc/include/asm is still a symlink to the old
550     # include/asm-ppc{64,} directory, include that in kernel-devel too.
551     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
552       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
553       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
554       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
555       ln -sf ../../../include/asm-ppc* asm
556       popd
557     fi
558
559     # Make sure the Makefile and version.h have a matching timestamp so that
560     # external modules can be built
561     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
562     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
563     cd ..
564
565     #
566     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
567     #
568 %if "%{_enable_debug_packages}" == "1"
569     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
570     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
571 %endif
572 %if %{buildxen}
573     if [ -f vmlinuz ]; then
574       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
575     fi
576 %endif
577
578     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
579
580     # mark modules executable so that strip-to-file can strip them
581     cat modnames | xargs chmod u+x
582
583     # remove files that will be auto generated by depmod at rpm -i time
584     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
585
586     # Move the devel headers out of the root file system
587     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
588     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
589     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
590     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
591 }
592
593 ###
594 # DO it...
595 ###
596
597 # prepare directories
598 rm -rf $RPM_BUILD_ROOT
599 mkdir -p $RPM_BUILD_ROOT/boot
600
601 %if "%{_target_cpu}" == "x86_64"
602 %define kernel_arch %{_target_cpu}
603 %endif
604 %if "%{_target_cpu}" == "i586"
605 %define kernel_arch i386
606 %endif
607 %if "%{_target_cpu}" == "i686"
608 %define kernel_arch i386
609 %endif
610
611 %if %{buildup}
612 BuildKernel %make_target %kernel_arch
613 %endif
614
615 %ifarch i686
616 %if %{builduml}
617 BuildKernel linux um uml
618 %endif
619
620 %if %{buildxen}
621 BuildKernel vmlinuz %kernel_arch xenU
622 %endif
623 %endif
624
625 ###
626 ### install
627 ###
628
629 %install
630
631 cd vanilla
632
633 %if %{buildxen} && "%{_target_cpu}" == "i686"
634 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
635 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
636 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
637 # This directive teaches ldconfig to search in nosegneg subdirectories
638 # and cache the DSOs there with extra bit 0 set in their hwcap match
639 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
640 # search in nosegneg subdirectories and to match this extra hwcap bit
641 # in the ld.so.cache file.
642 hwcap 0 nosegneg
643 EOF
644 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
645 %endif
646
647 %if %{builddoc}
648 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
649
650 # sometimes non-world-readable files sneak into the kernel source tree
651 chmod -R a+r *
652 # copy the source over
653 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
654 %endif
655
656 ###
657 ### clean
658 ###
659
660 %clean
661 rm -rf $RPM_BUILD_ROOT
662
663 ###
664 ### scripts
665 ###
666
667 # load the loop module for upgrades...in case the old modules get removed we have
668 # loopback in the kernel so that mkinitrd will work.
669 %pre
670 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
671 exit 0
672
673 %post
674 if [ -f /etc/sysconfig/kernel ]; then
675   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
676 fi
677
678 # trick mkinitrd in case the current environment does not have device mapper
679 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
680 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
681     if [ ! -f $rootdev ]; then
682         fake_root_lvm=1
683         mkdir -p $(dirname $rootdev)
684         touch $rootdev
685     fi
686 fi
687
688 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
689 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
690 # Older modutils do not support --package option
691 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
692
693 # remove fake handle
694 if [ -n "$fake_root_lvm" ]; then
695     rm -f $rootdev
696 fi
697
698 # make some useful links
699 pushd /boot > /dev/null ; {
700         ln -sf config-%{KVERREL} config
701         ln -sf config-%{KVERREL} configsmp
702         ln -sf initrd-%{KVERREL}.img initrd-boot
703         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
704         ln -sf vmlinuz-%{KVERREL} kernel-boot
705         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
706 }
707 popd > /dev/null
708
709 # ask for a reboot
710 mkdir -p /etc/planetlab
711 touch /etc/planetlab/update-reboot
712
713 %post devel
714 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
715 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
716   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
717   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
718   popd > /dev/null
719 fi
720
721 %post xenU
722 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
723 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
724
725 %post xenU-devel
726 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
727 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
728   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
729   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
730   popd > /dev/null
731 fi
732
733 %post uml-modules
734 depmod -ae %{KVERREL}uml
735
736 %preun
737 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
738 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
739
740 %preun xenU
741 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
742 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
743
744 %preun uml-modules
745 rm -f /lib/modules/%{KVERREL}uml/modules.*
746
747
748 ###
749 ### file lists
750 ###
751
752 %if %{buildup}
753 %files 
754 %defattr(-,root,root)
755 /%{image_install_path}/vmlinuz-%{KVERREL}
756 /boot/System.map-%{KVERREL}
757 /boot/config-%{KVERREL}
758 %dir /lib/modules/%{KVERREL}
759 /lib/modules/%{KVERREL}/kernel
760 /lib/modules/%{KVERREL}/build
761 /lib/modules/%{KVERREL}/source
762 /lib/modules/%{KVERREL}/extra
763 /lib/modules/%{KVERREL}/updates
764
765 %files devel
766 %defattr(-,root,root)
767 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
768 %endif
769
770 %if %{builduml} && "%{_target_cpu}" == "i686"
771 %files uml
772 %defattr(-,root,root)
773 %{_bindir}/linux
774
775 %files uml-devel
776 %defattr(-,root,root)
777 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
778 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
779
780 %files uml-modules
781 %defattr(-,root,root)
782 /boot/System.map-%{KVERREL}uml
783 /boot/config-%{KVERREL}uml
784 %dir /lib/modules/%{KVERREL}uml
785 /lib/modules/%{KVERREL}uml/kernel
786 /lib/modules/%{KVERREL}uml/build
787 /lib/modules/%{KVERREL}uml/source
788 /lib/modules/%{KVERREL}uml/extra
789 /lib/modules/%{KVERREL}uml/updates
790 %endif
791
792 %if %{buildxen} && "%{_target_cpu}" == "i686"
793 %files xenU
794 %defattr(-,root,root)
795 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
796 /boot/System.map-%{KVERREL}xenU
797 /boot/config-%{KVERREL}xenU
798 %dir /lib/modules/%{KVERREL}xenU
799 /lib/modules/%{KVERREL}xenU/kernel
800 /lib/modules/%{KVERREL}xenU/build
801 /lib/modules/%{KVERREL}xenU/source
802 /lib/modules/%{KVERREL}xenU/extra
803 /lib/modules/%{KVERREL}xenU/updates
804 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
805
806 %files xenU-devel
807 %defattr(-,root,root)
808 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
809 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
810 %endif
811
812 %files vserver
813 %defattr(-,root,root)
814 # no files
815
816 # only some architecture builds need kernel-doc
817
818 %if %{builddoc}
819 %files doc
820 %defattr(-,root,root)
821 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
822 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
823 %dir %{_datadir}/doc/kernel-doc-%{kversion}
824 %endif
825
826 %changelog
827 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
828 - 2.6.17.4
829 - Disable split pagetable lock.
830
831 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
832 - Get rid of stack backtrace on panic, which in most
833   cases actually caused a loss of info instead of a gain.
834
835 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
836 - 2.6.17.3
837
838 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
839 - 2.6.17.2
840 - Fix up the alsa list_add bug.
841
842 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
843 - Fix up various stupidities incurred by the last big rebase.
844   - Reenable SMP x86-64 builds.
845   - Reenable SMBFS.
846 - Enable PCI fake hotplug driver.
847 - Enable gameport/joystick on i586 builds. (#196581)
848
849 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
850 - Enable profiling for 586 kernels.
851
852 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
853 - Rebuild with slab debug off.
854
855 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
856 - 2.6.17.1
857
858 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
859 - 2.6.16.20
860
861 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
862 - 2.6.16.19
863
864 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
865 - Improved list_head debugging.
866
867 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
868 - 2.6.16.18
869
870 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
871 - 2.6.16.17
872
873 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
874 - 2.6.16.16
875
876 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
877 - 2.6.16.15
878 - make 16C950 UARTs work (again). (#126403)
879 - Fix exec-shield default, which should fix a few programs that
880   stopped running.
881
882 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
883 - 2.6.16.14
884
885 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
886 - 2.6.16.13
887
888 * Mon May  1 2006 Dave Jones <davej@redhat.com>
889 - 2.6.16.12
890
891 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
892 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
893
894 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
895 - 2.6.16.11
896
897 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
898 - Enable PCI MSI support.
899
900 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
901 - 2.6.16.9
902
903 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
904 - 2.6.16.7
905
906 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
907 - 2.6.16.6
908
909 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
910 - 2.6.16.5
911
912 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
913 - 2.6.16.2
914
915 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
916 - Reenable non-standard serial ports. (#187466)
917 - Reenable snd-es18xx for x86-32 (#187733)
918
919 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
920 - ship the .kernelrelease file in -devel too.
921 - Disable EDAC debug.
922
923 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
924 - 2.6.16.1
925
926 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
927 - Include patches posted for review for inclusion in 2.6.16.1
928 - Updated new audit msg types.
929 - Reenable HDLC driver (#186257)
930 - Make acpi-cpufreq 'sticky'
931 - Fix broken x86-64 32bit vDSO (#186924)
932
933 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
934 - Improve spinlock scalability on big machines.
935
936 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
937 - Sync with FC5's 2.6.16 kernel.
938 - Update Tux & Exec-shield to latest.
939