Bump to 512.
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # Versions of various parts
17
18 # for module-tag.py - sublevel is used for the version (middle) part of tag names
19 %define name linux-2.6
20 %define module_version_varname sublevel
21 %define taglevel 1
22
23 #
24 # Polite request for people who spin their own kernel rpms:
25 # please modify the "release" field in a way that identifies
26 # that the kernel isn't the stock distribution kernel, for example by
27 # adding some text to the end of the version number.
28 #
29 %define sublevel 22
30 %define patchlevel 19
31 %define kversion 2.6.%{sublevel}
32 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
33
34 %define vsversion 2.3.0.34
35
36 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
37 # updated every time the PL kernel is updated.
38 %define vini_pl_patch 561
39
40 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 %{!?pldistro:%global pldistro planetlab}
43
44 %define signmodules 0
45 %define make_target bzImage
46 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
47
48 # Override generic defaults with per-arch defaults
49
50 %define image_install_path boot
51
52 #
53 # Three sets of minimum package version requirements in the form of Conflicts:
54 # to versions below the minimum
55 #
56
57 #
58 # First the general kernel 2.6 required versions as per
59 # Documentation/Changes
60 #
61 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
62
63
64 # Then a series of requirements that are distribution specific, either 
65 # because we add patches for something, or the older versions have 
66 # problems with the newer kernel or lack certain things that make 
67 # integration in the distro harder than needed.
68 #
69 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
70
71 #
72 # Several packages had bugs in them that became obvious when the NPTL
73 # threading code got integrated.
74 #
75 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
76
77 #
78 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
79 #
80
81 # MEF commented out
82 # %define xen_conflicts glibc < 2.3.5-1
83
84 #
85 # Packages that need to be installed before the kernel is, because the %post
86 # scripts use them.
87 #
88 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
89
90 Vendor: PlanetLab
91 Packager: PlanetLab Central <support@planet-lab.org>
92 Distribution: PlanetLab %{plrelease}
93 URL: %(echo %{url} | cut -d ' ' -f 2)
94
95 Name: kernel
96 Group: System Environment/Kernel
97 License: GPLv2
98 Version: %{rpmversion}
99 Release: %{release}
100 ExclusiveOS: Linux
101 Provides: kernel = %{version}
102 Provides: kernel-drm = 4.3.0
103 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
104 Provides: kernel-smp = %{rpmversion}-%{release}
105 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
106 Prereq: %{kernel_prereq}
107 Conflicts: %{kernel_dot_org_conflicts}
108 Conflicts: %{package_conflicts}
109 Conflicts: %{nptl_conflicts}
110 # We can't let RPM do the dependencies automatic because it'll then pick up
111 # a correct but undesirable perl dependency from the module headers which
112 # isn't required for the kernel proper to function
113 AutoReqProv: no
114
115 #
116 # List the packages used during the kernel build
117 #
118 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
119 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
120 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
121 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
122
123
124 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
125
126 Source10: %{pldistro}-%{kversion}-i586.config
127 Source11: %{pldistro}-%{kversion}-i686.config
128 Source12: %{pldistro}-%{kversion}-x86_64.config
129 %if %{builduml}
130 Source20: %{pldistro}-%{kversion}-i686-uml.config
131 %endif
132 %if %{buildxen}
133 Source30: %{pldistro}-%{kversion}-i686-xenU.config
134 %endif
135
136 # Mainline patches
137 %if "0%{patchlevel}"
138 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
139 %endif
140
141 Patch010: linux-2.6-010-e1000e.patch
142 Patch020: linux-2.6-020-build-id.patch
143 Patch030: linux-2.6-030-netns.patch
144 Patch040: linux-2.6-040-i_mutex-check.patch
145
146 # These are patches picked up from Fedora/RHEL
147 Patch100: linux-2.6-100-build-nonintconfig.patch
148
149 # Linux-VServer
150 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
151 Patch210: linux-2.6-210-vserver-cpu-sched.patch
152
153 # IP sets
154 Patch250: linux-2.6-250-ipsets.patch
155
156 # PlanetLab
157 Patch500: linux-2.6-500-vserver-filesharing.patch
158 Patch510: linux-2.6-510-ipod.patch
159 Patch520: linux-2.6-520-vnet+.patch
160 Patch530: linux-2.6-530-built-by-support.patch
161 Patch540: linux-2.6-540-oom-kill.patch
162 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
163 Patch560: linux-2.6-560-mmconf.patch
164 Patch570: linux-2.6-570-tagxid.patch
165 Patch580: linux-2.6-580-show-proc-virt.patch
166 Patch590: linux-2.6-590-chopstix-intern.patch
167 Patch620: linux-2.6-620-kdb.patch
168
169 # See also the file named 'sources' here for the related checksums
170 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
171 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
172 %define mac80211_version 10.0.4
173 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
174 %define iwlwifi_version 1.2.23
175 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
176
177 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
178
179 %description
180 The kernel package contains the Linux kernel (vmlinuz), the core of any
181 Linux operating system.  The kernel handles the basic functions
182 of the operating system:  memory allocation, process allocation, device
183 input and output, etc.
184
185 %package devel
186 Summary: Development package for building kernel modules to match the kernel.
187 Group: System Environment/Kernel
188 AutoReqProv: no
189 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
190 Provides: kernel-smp-devel = %{rpmversion}-%{release}
191 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
192 Prereq: /usr/bin/find
193
194 %description devel
195 This package provides kernel headers and makefiles sufficient to build modules
196 against the kernel package.
197
198
199 %package doc
200 Summary: Various documentation bits found in the kernel source.
201 Group: Documentation
202
203 %description doc
204 This package contains documentation files from the kernel
205 source. Various bits of information about the Linux kernel and the
206 device drivers shipped with it are documented in these files.
207
208 You'll want to install this package if you need a reference to the
209 options that can be passed to Linux kernel modules at load time.
210
211 %package xenU
212 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
213
214 Group: System Environment/Kernel
215 Provides: kernel = %{version}
216 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
217 Prereq: %{kernel_prereq}
218 Conflicts: %{kernel_dot_org_conflicts}
219 Conflicts: %{package_conflicts}
220 Conflicts: %{nptl_conflicts}
221
222 # MEF commented out 
223 # Conflicts: %{xen_conflicts}
224
225 # We can't let RPM do the dependencies automatic because it'll then pick up
226 # a correct but undesirable perl dependency from the module headers which
227 # isn't required for the kernel proper to function
228 AutoReqProv: no
229
230 %description xenU
231 This package includes a version of the Linux kernel which
232 runs in Xen unprivileged guest VMs.  This should be installed
233 both inside the unprivileged guest (for the modules) and in
234 the guest0 domain.
235
236 %package xenU-devel
237 Summary: Development package for building kernel modules to match the kernel.
238 Group: System Environment/Kernel
239 AutoReqProv: no
240 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
241 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
242 Provides: kernel-devel = %{rpmversion}-%{release}xenU
243 Prereq: /usr/sbin/hardlink, /usr/bin/find
244
245 %description xenU-devel
246 This package provides kernel headers and makefiles sufficient to build modules
247 against the kernel package.
248
249 %package uml
250 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
251
252 Group: System Environment/Kernel
253
254 %description uml
255 This package includes a user mode version of the Linux kernel.
256
257 %package uml-devel
258 Summary: Development package for building kernel modules to match the UML kernel.
259 Group: System Environment/Kernel
260 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
261 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
262 Provides: kernel-devel = %{rpmversion}-%{release}smp
263 AutoReqProv: no
264 Prereq: /usr/sbin/hardlink, /usr/bin/find
265
266 %description uml-devel
267 This package provides kernel headers and makefiles sufficient to build modules
268 against the User Mode Linux kernel package.
269
270 %package uml-modules
271 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
272
273 Group: System Environment/Kernel
274
275 %description uml-modules
276 This package includes a user mode version of the Linux kernel modules.
277
278 %package vserver
279 Summary: A placeholder RPM that provides kernel and kernel-drm
280
281 Group: System Environment/Kernel
282 Provides: kernel = %{version}
283 Provides: kernel-drm = 4.3.0
284 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
285
286 %description vserver
287 VServers do not require and cannot use kernels, but some RPMs have
288 implicit or explicit dependencies on the "kernel" package
289 (e.g. tcpdump). This package installs no files but provides the
290 necessary dependencies to make rpm and yum happy.
291
292
293 %prep
294 # First we unpack the kernel tarball.
295 # If this isn't the first make prep, we use links to the existing clean tarball
296 # which speeds things up quite a bit.
297 if [ ! -d kernel-%{kversion}/vanilla ]; then
298   # Ok, first time we do a make prep.
299   rm -f pax_global_header
300 %setup -q -n %{name}-%{kversion} -c
301   mv linux-%{kversion} vanilla
302 else
303   # We already have a vanilla dir.
304   cd kernel-%{kversion}
305 fi
306
307 KERNEL_PREVIOUS=vanilla
308 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
309 %define ApplyPatch() \
310   rm -fr linux-%{kversion}-%1                           \
311   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
312   patchflag=-p1                                         \
313   test "%2" != "%%2" && patchflag="%2"                  \
314   PATCH="%{expand:%{PATCH%1}}"                          \
315   if test ! -e "$PATCH"; then                           \
316     echo "Patch %1 does not exist!"                     \
317     exit 1                                              \
318   fi                                                    \
319   case "$PATCH" in                                      \
320     *.bz2)  bzcat "$PATCH";;                            \
321     *.gz)   zcat "$PATCH";;                             \
322     *)      cat "$PATCH";;                              \
323   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
324   KERNEL_PREVIOUS=linux-%{kversion}-%1
325
326 # This is where the patches get applied
327 %if 0%{?patchlevel}
328 %ApplyPatch 0
329 %endif
330
331 %ApplyPatch 10
332 %ApplyPatch 20
333
334 # NetNS patch for VINI
335 %if 0%{?with_netns}
336 %ApplyPatch 30
337 %endif
338 %ApplyPatch 40
339
340 %ApplyPatch 100
341
342 %ApplyPatch 200
343 %ApplyPatch 210
344
345 %ApplyPatch 250
346
347 %ApplyPatch 500
348 %ApplyPatch 510
349 %ApplyPatch 520
350 %ApplyPatch 530
351 %ApplyPatch 540
352 %ApplyPatch 550
353 %ApplyPatch 560
354 %ApplyPatch 570
355 %ApplyPatch 580
356 %ApplyPatch 590
357 %ApplyPatch 620
358
359 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
360 # break with later patches.
361
362 %if 0%{?with_netns}
363 %ApplyPatch %vini_pl_patch
364 %endif
365
366 # Run the mac80211 stuff in the kernel tree holding the last patch
367 # tar -xzf %{PATCH600}
368 # pushd mac80211-%{mac80211_version}
369 # mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
370 # make $mac80211_makeflags modified
371 # make $mac80211_makeflags source
372 # make $mac80211_makeflags patch_kernel
373 # popd
374
375 # Untar iwlwifi in the same place - needs to be compiled later
376 # tar -xzf %{PATCH601}
377 # the install target is broken: first it does not pass the right -b flag to depmod
378 # second we do not need to invoke depmod at this stage anyway
379 # let's add our own patch/stuff in this Makefile for manual install later on
380 # pushd iwlwifi-%{iwlwifi_version}
381 # cat >> Makefile <<EOF
382 # module-list:
383 #       @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
384 # EOF
385 # popd
386
387 rm -fr linux-%{kversion}
388 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
389 cd linux-%{kversion}
390
391
392 # make sure the kernel has the sublevel we know it has. This looks weird
393 # but for -pre and -rc versions we need it since we only want to use
394 # the higher version when the final kernel is released.
395 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
396 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
397
398 # get rid of unwanted files resulting from patch fuzz
399 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
400
401
402 ###
403 ### build
404 ###
405 %build
406
407 BuildKernel() {
408     MakeTarget=$1
409     Arch=$2
410     Flavour=$3
411
412     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
413     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
414     cd linux-%{_target_cpu}-%{kversion}$Flavour
415
416     # Pick the right config file for the kernel we're building
417     if [ -n "$Flavour" ] ; then
418       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
419       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
420       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
421     else
422       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
423       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
424       DevelLink=
425     fi
426
427     KernelVer=%{version}-%{release}$Flavour
428     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
429
430     # make sure EXTRAVERSION says what we want it to say
431     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
432
433     # and now to start the build process
434
435     make -s mrproper
436     cp %{_sourcedir}/$Config .config
437
438     #Arch=`head -1 .config | cut -b 3-`
439     echo USING ARCH=$Arch
440
441     make -s ARCH=$Arch nonint_oldconfig > /dev/null
442     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
443     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
444
445     # build the iwlwifi driver
446 #     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
447 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
448
449     # Start installing the results
450
451 %if "%{_enable_debug_packages}" == "1"
452     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
453 %endif
454     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
455     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
456     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
457     if [ -f arch/$Arch/boot/bzImage ]; then
458       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
459     fi
460     if [ -f arch/$Arch/boot/zImage.stub ]; then
461       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
462     fi
463     if [ "$Flavour" = "uml" ] ; then
464         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
465     fi
466
467     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
468     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
469
470     # install iwlwifi
471 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
472 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
473 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
474 #    pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
475 #    iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
476     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
477 #    iwlwifi_modules=$(make --no-print-directory module-list)
478 #    install -d $iwlwifi_dest
479 #    install -m 644 -c $iwlwifi_modules $iwlwifi_dest
480 #    popd
481
482     # And save the headers/makefiles etc for building modules against
483     #
484     # This all looks scary, but the end result is supposed to be:
485     # * all arch relevant include/ files
486     # * all Makefile/Kconfig files
487     # * all script/ files
488
489     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
490     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
491     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
492     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
493     # dirs for additional modules per module-init-tools, kbuild/modules.txt
494     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
495     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
496     # first copy everything
497     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
498         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
499     if [ "$Flavour" = "uml" ] ; then
500       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
501     fi
502     # then drop all but the needed Makefiles/Kconfig files
503     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
504     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
505     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
506     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
507     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
508     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
509     if [ -d arch/%{_arch}/scripts ]; then
510       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
511     fi
512     if [ -f arch/%{_arch}/*lds ]; then
513       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
514     fi
515     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
516     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
517     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
518     cd include
519     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
520     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
521     if [ "$Arch" = "x86_64" ]; then
522       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
523     fi
524 %if %{buildxen}
525     if [ "$Flavour" = "xenU" ]; then
526       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
527       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
528     fi
529 %endif
530 %if %{builduml}
531     if [ "$Flavour" = "uml" ] ; then
532       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
533     fi
534 %endif
535     # While arch/powerpc/include/asm is still a symlink to the old
536     # include/asm-ppc{64,} directory, include that in kernel-devel too.
537     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
538       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
539       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
540       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
541       ln -sf ../../../include/asm-ppc* asm
542       popd
543     fi
544
545     # Make sure the Makefile and version.h have a matching timestamp so that
546     # external modules can be built
547     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
548     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
549     cd ..
550
551     #
552     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
553     #
554 %if "%{_enable_debug_packages}" == "1"
555     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
556     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
557 %endif
558 %if %{buildxen}
559     if [ -f vmlinuz ]; then
560       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
561     fi
562 %endif
563
564     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
565
566     # mark modules executable so that strip-to-file can strip them
567     cat modnames | xargs chmod u+x
568
569     # remove files that will be auto generated by depmod at rpm -i time
570     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
571
572     # Move the devel headers out of the root file system
573     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
574     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
575     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
576     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
577 }
578
579 ###
580 # DO it...
581 ###
582
583 # prepare directories
584 rm -rf $RPM_BUILD_ROOT
585 mkdir -p $RPM_BUILD_ROOT/boot
586
587 %if "%{_target_cpu}" == "x86_64"
588 %define kernel_arch %{_target_cpu}
589 %endif
590 %if "%{_target_cpu}" == "i586"
591 %define kernel_arch i386
592 %endif
593 %if "%{_target_cpu}" == "i686"
594 %define kernel_arch i386
595 %endif
596
597 %if %{buildup}
598 BuildKernel %make_target %kernel_arch
599 %endif
600
601 %ifarch i686
602 %if %{builduml}
603 BuildKernel linux um uml
604 %endif
605
606 %if %{buildxen}
607 BuildKernel vmlinuz %kernel_arch xenU
608 %endif
609 %endif
610
611 ###
612 ### install
613 ###
614
615 %install
616
617 cd vanilla
618
619 %if %{buildxen} && "%{_target_cpu}" == "i686"
620 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
621 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
622 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
623 # This directive teaches ldconfig to search in nosegneg subdirectories
624 # and cache the DSOs there with extra bit 0 set in their hwcap match
625 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
626 # search in nosegneg subdirectories and to match this extra hwcap bit
627 # in the ld.so.cache file.
628 hwcap 0 nosegneg
629 EOF
630 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
631 %endif
632
633 %if %{builddoc}
634 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
635
636 # sometimes non-world-readable files sneak into the kernel source tree
637 chmod -R a+r *
638 # copy the source over
639 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
640 %endif
641
642 ###
643 ### clean
644 ###
645
646 %clean
647 rm -rf $RPM_BUILD_ROOT
648
649 ###
650 ### scripts
651 ###
652
653 # load the loop module for upgrades...in case the old modules get removed we have
654 # loopback in the kernel so that mkinitrd will work.
655 %pre
656 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
657 exit 0
658
659 %post
660 if [ -f /etc/sysconfig/kernel ]; then
661   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
662 fi
663
664 # trick mkinitrd in case the current environment does not have device mapper
665 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
666 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
667     if [ ! -f $rootdev ]; then
668         fake_root_lvm=1
669         mkdir -p $(dirname $rootdev)
670         touch $rootdev
671     fi
672 fi
673
674 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
675 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
676 # Older modutils do not support --package option
677 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
678
679 # remove fake handle
680 if [ -n "$fake_root_lvm" ]; then
681     rm -f $rootdev
682 fi
683
684 # make some useful links
685 pushd /boot > /dev/null ; {
686         ln -sf config-%{KVERREL} config
687         ln -sf config-%{KVERREL} configsmp
688         ln -sf initrd-%{KVERREL}.img initrd-boot
689         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
690         ln -sf vmlinuz-%{KVERREL} kernel-boot
691         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
692 }
693 popd > /dev/null
694
695 # ask for a reboot
696 mkdir -p /etc/planetlab
697 touch /etc/planetlab/update-reboot
698
699 %post devel
700 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
701 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
702   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
703   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
704   popd > /dev/null
705 fi
706
707 %post xenU
708 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
709 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
710
711 %post xenU-devel
712 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
713 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
714   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
715   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
716   popd > /dev/null
717 fi
718
719 %post uml-modules
720 depmod -ae %{KVERREL}uml
721
722 %preun
723 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
724 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
725
726 %preun xenU
727 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
728 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
729
730 %preun uml-modules
731 rm -f /lib/modules/%{KVERREL}uml/modules.*
732
733
734 ###
735 ### file lists
736 ###
737
738 %if %{buildup}
739 %files 
740 %defattr(-,root,root)
741 /%{image_install_path}/vmlinuz-%{KVERREL}
742 /boot/System.map-%{KVERREL}
743 /boot/config-%{KVERREL}
744 %dir /lib/modules/%{KVERREL}
745 /lib/modules/%{KVERREL}/kernel
746 /lib/modules/%{KVERREL}/build
747 /lib/modules/%{KVERREL}/source
748 /lib/modules/%{KVERREL}/extra
749 /lib/modules/%{KVERREL}/updates
750
751 %files devel
752 %defattr(-,root,root)
753 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
754 %endif
755
756 %if %{builduml} && "%{_target_cpu}" == "i686"
757 %files uml
758 %defattr(-,root,root)
759 %{_bindir}/linux
760
761 %files uml-devel
762 %defattr(-,root,root)
763 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
764 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
765
766 %files uml-modules
767 %defattr(-,root,root)
768 /boot/System.map-%{KVERREL}uml
769 /boot/config-%{KVERREL}uml
770 %dir /lib/modules/%{KVERREL}uml
771 /lib/modules/%{KVERREL}uml/kernel
772 /lib/modules/%{KVERREL}uml/build
773 /lib/modules/%{KVERREL}uml/source
774 /lib/modules/%{KVERREL}uml/extra
775 /lib/modules/%{KVERREL}uml/updates
776 %endif
777
778 %if %{buildxen} && "%{_target_cpu}" == "i686"
779 %files xenU
780 %defattr(-,root,root)
781 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
782 /boot/System.map-%{KVERREL}xenU
783 /boot/config-%{KVERREL}xenU
784 %dir /lib/modules/%{KVERREL}xenU
785 /lib/modules/%{KVERREL}xenU/kernel
786 /lib/modules/%{KVERREL}xenU/build
787 /lib/modules/%{KVERREL}xenU/source
788 /lib/modules/%{KVERREL}xenU/extra
789 /lib/modules/%{KVERREL}xenU/updates
790 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
791
792 %files xenU-devel
793 %defattr(-,root,root)
794 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
795 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
796 %endif
797
798 %files vserver
799 %defattr(-,root,root)
800 # no files
801
802 # only some architecture builds need kernel-doc
803
804 %if %{builddoc}
805 %files doc
806 %defattr(-,root,root)
807 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
808 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
809 %dir %{_datadir}/doc/kernel-doc-%{kversion}
810 %endif
811
812 %changelog
813 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
814 - 2.6.17.4
815 - Disable split pagetable lock.
816
817 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
818 - Get rid of stack backtrace on panic, which in most
819   cases actually caused a loss of info instead of a gain.
820
821 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
822 - 2.6.17.3
823
824 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
825 - 2.6.17.2
826 - Fix up the alsa list_add bug.
827
828 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
829 - Fix up various stupidities incurred by the last big rebase.
830   - Reenable SMP x86-64 builds.
831   - Reenable SMBFS.
832 - Enable PCI fake hotplug driver.
833 - Enable gameport/joystick on i586 builds. (#196581)
834
835 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
836 - Enable profiling for 586 kernels.
837
838 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
839 - Rebuild with slab debug off.
840
841 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
842 - 2.6.17.1
843
844 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
845 - 2.6.16.20
846
847 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
848 - 2.6.16.19
849
850 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
851 - Improved list_head debugging.
852
853 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
854 - 2.6.16.18
855
856 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
857 - 2.6.16.17
858
859 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
860 - 2.6.16.16
861
862 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
863 - 2.6.16.15
864 - make 16C950 UARTs work (again). (#126403)
865 - Fix exec-shield default, which should fix a few programs that
866   stopped running.
867
868 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
869 - 2.6.16.14
870
871 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
872 - 2.6.16.13
873
874 * Mon May  1 2006 Dave Jones <davej@redhat.com>
875 - 2.6.16.12
876
877 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
878 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
879
880 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
881 - 2.6.16.11
882
883 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
884 - Enable PCI MSI support.
885
886 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
887 - 2.6.16.9
888
889 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
890 - 2.6.16.7
891
892 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
893 - 2.6.16.6
894
895 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
896 - 2.6.16.5
897
898 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
899 - 2.6.16.2
900
901 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
902 - Reenable non-standard serial ports. (#187466)
903 - Reenable snd-es18xx for x86-32 (#187733)
904
905 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
906 - ship the .kernelrelease file in -devel too.
907 - Disable EDAC debug.
908
909 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
910 - 2.6.16.1
911
912 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
913 - Include patches posted for review for inclusion in 2.6.16.1
914 - Updated new audit msg types.
915 - Reenable HDLC driver (#186257)
916 - Make acpi-cpufreq 'sticky'
917 - Fix broken x86-64 32bit vDSO (#186924)
918
919 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
920 - Improve spinlock scalability on big machines.
921
922 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
923 - Sync with FC5's 2.6.16 kernel.
924 - Update Tux & Exec-shield to latest.
925