6 Summary: The Linux kernel (the core of the Linux operating system)
8 # What parts do we want to build? We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
22 # Versions of various parts
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
40 %define vsversion 2.3.0.34
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
48 %{!?pldistro:%global pldistro planetlab}
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
54 # Override generic defaults with per-arch defaults
56 %define image_install_path boot
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
67 %define kernel_dot_org_conflicts ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
70 # Then a series of requirements that are distribution specific, either
71 # because we add patches for something, or the older versions have
72 # problems with the newer kernel or lack certain things that make
73 # integration in the distro harder than needed.
75 %define package_conflicts cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x, cups < 1.1.17-13
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
88 # %define xen_conflicts glibc < 2.3.5-1
91 # Packages that need to be installed before the kernel is, because the %post
94 %define kernel_prereq fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
102 Group: System Environment/Kernel
104 Version: %{rpmversion}
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
122 # List the packages used during the kernel build
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
132 Source11: %{pldistro}-%{kversion}-i686.config
133 Source12: %{pldistro}-%{kversion}-x86_64.config
135 Source20: %{pldistro}-%{kversion}-i686-uml.config
138 Source30: %{pldistro}-%{kversion}-i686-xenU.config
143 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
146 Patch010: linux-2.6-010-e1000e.patch
147 Patch020: linux-2.6-020-build-id.patch
148 Patch030: linux-2.6-030-netns.patch
149 Patch040: linux-2.6-040-i_mutex-check.patch
151 # These are patches picked up from Fedora/RHEL
152 Patch100: linux-2.6-100-build-nonintconfig.patch
155 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
156 Patch210: linux-2.6-210-vserver-cpu-sched.patch
157 Patch220: delta-ptrace-fix01.diff
160 Patch250: linux-2.6-250-ipsets.patch
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch521: linux-2.6-521-packet-tagging.patch
166 Patch522: linux-2.6-522-iptables-connection-tagging.patch
167 Patch523: linux-2.6-523-raw-sockets.patch
168 Patch524: linux-2.6-524-peercred.patch
169 Patch525: linux-2.6-525-sknid-elevator.patch
170 Patch526: linux-2.6-526-tun-tap.patch
171 Patch527: linux-2.6-527-iptables-classify-add-mark.patch
172 Patch530: linux-2.6-530-built-by-support.patch
173 Patch540: linux-2.6-540-oom-kill.patch
174 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
175 Patch560: linux-2.6-560-mmconf.patch
176 Patch570: linux-2.6-570-tagxid.patch
177 Patch580: linux-2.6-580-show-proc-virt.patch
178 Patch590: linux-2.6-590-chopstix-intern.patch
179 Patch620: linux-2.6-620-kdb.patch
180 Patch630: linux-2.6-630-sched-fix.patch
181 Patch640: linux-2.6-640-netlink-audit-hack.patch
182 Patch650: linux-2.6-650-hangcheck-reboot.patch
183 Patch660: linux-2.6-660-nmi-watchdog-default.patch
184 %if "%{distroname}" == "f9" || "%{distroname}" == "f10"
185 Patch670: linux-2.6-670-gcc43.patch
187 Patch680: linux-2.6-680-htb-hysteresis-tso.patch
188 Patch690: linux-2.6-690-web100.patch
190 # See also the file named 'sources' here for the related checksums
191 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
192 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
194 %define mac80211_version 10.0.4
195 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
196 %define iwlwifi_version 1.2.25
197 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
200 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
203 The kernel package contains the Linux kernel (vmlinuz), the core of any
204 Linux operating system. The kernel handles the basic functions
205 of the operating system: memory allocation, process allocation, device
206 input and output, etc.
209 Summary: Development package for building kernel modules to match the kernel.
210 Group: System Environment/Kernel
212 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
213 Provides: kernel-smp-devel = %{rpmversion}-%{release}
214 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
215 Prereq: /usr/bin/find
218 This package provides kernel headers and makefiles sufficient to build modules
219 against the kernel package.
223 Summary: Various documentation bits found in the kernel source.
227 This package contains documentation files from the kernel
228 source. Various bits of information about the Linux kernel and the
229 device drivers shipped with it are documented in these files.
231 You'll want to install this package if you need a reference to the
232 options that can be passed to Linux kernel modules at load time.
235 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
237 Group: System Environment/Kernel
238 Provides: kernel = %{version}
239 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
240 Prereq: %{kernel_prereq}
241 Conflicts: %{kernel_dot_org_conflicts}
242 Conflicts: %{package_conflicts}
243 Conflicts: %{nptl_conflicts}
246 # Conflicts: %{xen_conflicts}
248 # We can't let RPM do the dependencies automatic because it'll then pick up
249 # a correct but undesirable perl dependency from the module headers which
250 # isn't required for the kernel proper to function
254 This package includes a version of the Linux kernel which
255 runs in Xen unprivileged guest VMs. This should be installed
256 both inside the unprivileged guest (for the modules) and in
260 Summary: Development package for building kernel modules to match the kernel.
261 Group: System Environment/Kernel
263 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
264 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
265 Provides: kernel-devel = %{rpmversion}-%{release}xenU
266 Prereq: /usr/sbin/hardlink, /usr/bin/find
268 %description xenU-devel
269 This package provides kernel headers and makefiles sufficient to build modules
270 against the kernel package.
273 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
275 Group: System Environment/Kernel
278 This package includes a user mode version of the Linux kernel.
281 Summary: Development package for building kernel modules to match the UML kernel.
282 Group: System Environment/Kernel
283 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
284 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
285 Provides: kernel-devel = %{rpmversion}-%{release}smp
287 Prereq: /usr/sbin/hardlink, /usr/bin/find
289 %description uml-devel
290 This package provides kernel headers and makefiles sufficient to build modules
291 against the User Mode Linux kernel package.
294 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
296 Group: System Environment/Kernel
298 %description uml-modules
299 This package includes a user mode version of the Linux kernel modules.
302 Summary: A placeholder RPM that provides kernel and kernel-drm
304 Group: System Environment/Kernel
305 Provides: kernel = %{version}
306 Provides: kernel-drm = 4.3.0
307 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
310 VServers do not require and cannot use kernels, but some RPMs have
311 implicit or explicit dependencies on the "kernel" package
312 (e.g. tcpdump). This package installs no files but provides the
313 necessary dependencies to make rpm and yum happy.
317 # First we unpack the kernel tarball.
318 # If this isn't the first make prep, we use links to the existing clean tarball
319 # which speeds things up quite a bit.
320 if [ ! -d kernel-%{kversion}/vanilla ]; then
321 # Ok, first time we do a make prep.
322 rm -f pax_global_header
323 %setup -q -n %{name}-%{kversion} -c
324 mv linux-%{kversion} vanilla
326 # We already have a vanilla dir.
327 cd kernel-%{kversion}
330 KERNEL_PREVIOUS=vanilla
331 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
332 %define ApplyPatch() \
333 rm -fr linux-%{kversion}-%1 \
334 cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1 \
336 test "%2" != "%%2" && patchflag="%2" \
337 PATCH="%{expand:%{PATCH%1}}" \
338 if test ! -e "$PATCH"; then \
339 echo "Patch %1 does not exist!" \
343 *.bz2) bzcat "$PATCH";; \
344 *.gz) zcat "$PATCH";; \
346 esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
347 KERNEL_PREVIOUS=linux-%{kversion}-%1
349 # This is where the patches get applied
389 %if "%{distroname}" == "f9" || "%{distroname}" == "f10"
396 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
397 # break with later patches.
400 %ApplyPatch %vini_pl_patch
404 # Run the mac80211 stuff in the kernel tree holding the last patch
406 pushd mac80211-%{mac80211_version}
407 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
408 make $mac80211_makeflags modified
409 make $mac80211_makeflags source
410 make $mac80211_makeflags patch_kernel
413 # Untar iwlwifi in the same place - needs to be compiled later
415 # the install target is broken: first it does not pass the right -b flag to depmod
416 # second we do not need to invoke depmod at this stage anyway
417 # let's add our own patch/stuff in this Makefile for manual install later on
418 pushd iwlwifi-%{iwlwifi_version}
419 cat >> Makefile <<EOF
421 @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
426 rm -fr linux-%{kversion}
427 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
431 # make sure the kernel has the sublevel we know it has. This looks weird
432 # but for -pre and -rc versions we need it since we only want to use
433 # the higher version when the final kernel is released.
434 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
435 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
437 # get rid of unwanted files resulting from patch fuzz
438 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
451 rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
452 cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
453 cd linux-%{_target_cpu}-%{kversion}$Flavour
455 # Pick the right config file for the kernel we're building
456 if [ -n "$Flavour" ] ; then
457 Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
458 DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
459 DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
461 Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
462 DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
466 KernelVer=%{version}-%{release}$Flavour
467 echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
469 # make sure EXTRAVERSION says what we want it to say
470 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
472 # and now to start the build process
475 cp %{_sourcedir}/$Config .config
477 #Arch=`head -1 .config | cut -b 3-`
478 echo USING ARCH=$Arch
480 make -s ARCH=$Arch nonint_oldconfig > /dev/null
481 make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
482 make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
485 # build the iwlwifi driver
486 make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
487 KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
490 # Start installing the results
492 %if "%{_enable_debug_packages}" == "1"
493 mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
495 mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
496 install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
497 install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
498 if [ -f arch/$Arch/boot/bzImage ]; then
499 cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
501 if [ -f arch/$Arch/boot/zImage.stub ]; then
502 cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
504 if [ "$Flavour" = "uml" ] ; then
505 install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
508 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
509 make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
513 # make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
514 # KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
515 # KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
516 pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
517 iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
518 # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
519 iwlwifi_modules=$(make --no-print-directory module-list)
520 install -d $iwlwifi_dest
521 install -m 644 -c $iwlwifi_modules $iwlwifi_dest
525 # And save the headers/makefiles etc for building modules against
527 # This all looks scary, but the end result is supposed to be:
528 # * all arch relevant include/ files
529 # * all Makefile/Kconfig files
530 # * all script/ files
532 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
533 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
534 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
535 (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
536 # dirs for additional modules per module-init-tools, kbuild/modules.txt
537 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
538 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
539 # first copy everything
540 cp --parents `find -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
541 cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
542 if [ "$Flavour" = "uml" ] ; then
543 cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
545 # then drop all but the needed Makefiles/Kconfig files
546 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
547 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
548 rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
549 cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
550 cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
551 cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
552 if [ -d arch/%{_arch}/scripts ]; then
553 cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
555 if [ -f arch/%{_arch}/*lds ]; then
556 cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
558 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
559 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
560 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
562 cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
563 cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
564 if [ "$Arch" = "x86_64" ]; then
565 cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
568 if [ "$Flavour" = "xenU" ]; then
569 cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
570 cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
574 if [ "$Flavour" = "uml" ] ; then
575 cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
578 # While arch/powerpc/include/asm is still a symlink to the old
579 # include/asm-ppc{64,} directory, include that in kernel-devel too.
580 if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
581 cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
582 mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
583 pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
584 ln -sf ../../../include/asm-ppc* asm
588 # Make sure the Makefile and version.h have a matching timestamp so that
589 # external modules can be built
590 touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
591 touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
595 # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
597 %if "%{_enable_debug_packages}" == "1"
598 mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
599 cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
602 if [ -f vmlinuz ]; then
603 cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
607 find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
609 # mark modules executable so that strip-to-file can strip them
610 cat modnames | xargs chmod u+x
612 # remove files that will be auto generated by depmod at rpm -i time
613 rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
615 # Move the devel headers out of the root file system
616 mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
617 mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
618 ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
619 [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
626 # prepare directories
627 rm -rf $RPM_BUILD_ROOT
628 mkdir -p $RPM_BUILD_ROOT/boot
630 %if "%{_target_cpu}" == "x86_64"
631 %define kernel_arch %{_target_cpu}
633 %if "%{_target_cpu}" == "i586"
634 %define kernel_arch i386
636 %if "%{_target_cpu}" == "i686"
637 %define kernel_arch i386
641 BuildKernel %make_target %kernel_arch
646 BuildKernel linux um uml
650 BuildKernel vmlinuz %kernel_arch xenU
662 %if %{buildxen} && "%{_target_cpu}" == "i686"
663 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
664 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
665 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
666 # This directive teaches ldconfig to search in nosegneg subdirectories
667 # and cache the DSOs there with extra bit 0 set in their hwcap match
668 # fields. In Xen guest kernels, the vDSO tells the dynamic linker to
669 # search in nosegneg subdirectories and to match this extra hwcap bit
670 # in the ld.so.cache file.
673 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
677 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
679 # sometimes non-world-readable files sneak into the kernel source tree
681 # copy the source over
682 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
690 rm -rf $RPM_BUILD_ROOT
696 # load the loop module for upgrades...in case the old modules get removed we have
697 # loopback in the kernel so that mkinitrd will work.
699 /sbin/modprobe loop 2> /dev/null > /dev/null || :
703 if [ -f /etc/sysconfig/kernel ]; then
704 /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
707 # trick mkinitrd in case the current environment does not have device mapper
708 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
709 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
710 if [ ! -f $rootdev ]; then
712 mkdir -p $(dirname $rootdev)
717 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
718 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
719 # Older modutils do not support --package option
720 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
723 if [ -n "$fake_root_lvm" ]; then
727 # make some useful links
728 pushd /boot > /dev/null ; {
729 ln -sf config-%{KVERREL} config
730 ln -sf config-%{KVERREL} configsmp
731 ln -sf initrd-%{KVERREL}.img initrd-boot
732 ln -sf initrd-%{KVERREL}.img initrd-bootsmp
733 ln -sf vmlinuz-%{KVERREL} kernel-boot
734 ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
739 mkdir -p /etc/planetlab
740 touch /etc/planetlab/update-reboot
743 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
744 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
745 pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
746 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
751 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
752 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
755 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
756 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
757 pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
758 /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
763 depmod -ae %{KVERREL}uml
766 /sbin/modprobe loop 2> /dev/null > /dev/null || :
767 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
770 /sbin/modprobe loop 2> /dev/null > /dev/null || :
771 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
774 rm -f /lib/modules/%{KVERREL}uml/modules.*
783 %defattr(-,root,root)
784 /%{image_install_path}/vmlinuz-%{KVERREL}
785 /boot/System.map-%{KVERREL}
786 /boot/config-%{KVERREL}
787 %dir /lib/modules/%{KVERREL}
788 /lib/modules/%{KVERREL}/kernel
789 /lib/modules/%{KVERREL}/build
790 /lib/modules/%{KVERREL}/source
791 /lib/modules/%{KVERREL}/extra
792 /lib/modules/%{KVERREL}/updates
795 %defattr(-,root,root)
796 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
799 %if %{builduml} && "%{_target_cpu}" == "i686"
801 %defattr(-,root,root)
805 %defattr(-,root,root)
806 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
807 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
810 %defattr(-,root,root)
811 /boot/System.map-%{KVERREL}uml
812 /boot/config-%{KVERREL}uml
813 %dir /lib/modules/%{KVERREL}uml
814 /lib/modules/%{KVERREL}uml/kernel
815 /lib/modules/%{KVERREL}uml/build
816 /lib/modules/%{KVERREL}uml/source
817 /lib/modules/%{KVERREL}uml/extra
818 /lib/modules/%{KVERREL}uml/updates
821 %if %{buildxen} && "%{_target_cpu}" == "i686"
823 %defattr(-,root,root)
824 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
825 /boot/System.map-%{KVERREL}xenU
826 /boot/config-%{KVERREL}xenU
827 %dir /lib/modules/%{KVERREL}xenU
828 /lib/modules/%{KVERREL}xenU/kernel
829 /lib/modules/%{KVERREL}xenU/build
830 /lib/modules/%{KVERREL}xenU/source
831 /lib/modules/%{KVERREL}xenU/extra
832 /lib/modules/%{KVERREL}xenU/updates
833 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
836 %defattr(-,root,root)
837 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
838 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
842 %defattr(-,root,root)
845 # only some architecture builds need kernel-doc
849 %defattr(-,root,root)
850 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
851 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
852 %dir %{_datadir}/doc/kernel-doc-%{kversion}
856 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-32
857 - support building on fedora 10
859 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-31
860 - add patches for m-lab and drl
862 * Tue Nov 11 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-30
863 - Use Intel's e1000e driver.
865 * Thu Oct 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-29
866 - added drivers for OPTION's globetrotter (gt 3g+ emea) umts cards
867 - + cleanup outdated configs
869 * Wed Sep 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-28
870 - Recovering a hunk that I accidentally ommited out of the last commit. Should not entail retesting, because the commits
873 * Sun Sep 14 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-27
874 - Fixing the accounting issue that causes certain connections to be misaccounted, and that causes NM/peercreds to
875 - intermittently break.
877 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-26
878 - patch for building on f9/gcc-4.3, no functional change on other distros
880 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-25
883 * Tue Aug 12 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-24
884 - Enable nmi watchdog by default.
886 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-23
887 - Fixed a bug in my previous commit.
889 * Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-22
890 - * 1 fix for using udp/listening sockets via raw
891 - * 1 fix to help codemux divide traffic in PlanetFlow
893 * Fri Aug 01 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-21
894 - Codemux calls setsockopt/SO_PEERCRED to set peer credentials on a socket, so that the connections it proxies to its clients are tagged for PlanetFlow. This hunk got lost somewhere along the way.
896 * Thu Jul 31 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-20
897 - Removed a debugging statement. Shows up a lot in the debug logs.
899 * Wed Jul 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-19
900 - Unbroke peercred setting.
902 * Mon Jul 28 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-18
903 - Now you can write your own TCP using packet sockets. As a side effect, tcptraceroute runs to completion including the
906 * Mon Jul 28 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-17
907 - Optimize packet socket support to eliminate a packet copy.
909 * Sun Jul 27 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-16
910 - Missed this header file, which broke the compile.
911 - I'll be doing another tag to include an optimization I left out of this version. This version is for Build only.
913 * Sun Jul 27 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-15
914 - Fixes to tcpdump-related problems reported recently.
916 * Wed Jul 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-14
917 - added fix to process visibility so when ncontext/vcontext run netstat in
918 - xid=1, it can see all ports & processes.
920 * Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-13
921 - fix for tcpdump/tcp payloads
923 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-12
925 - * Attempt to fix TCP-payload-related problems with tcpdump
927 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-11
928 - * Split up VNET+ module into its component patches
929 - * Added tun/tap support
931 * Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
932 - Filling a statically allocated buffer cannot fail, right?
934 * Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
935 - Enable the hangcheck timer driver, and build it in to the kernel.
936 - Dump relevant data on the scheduler bug instead of BUGing.
938 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
939 - * Partial fix for the UDP-packet-pollution problem
940 - * Support for PF_PACKET sockets
941 - * Support for SOCK_PACKET sockets
942 - * Disabled Chopstix with mutexes
943 - * Tested VNET+ under heavy loads
947 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
948 - Bringing this fix in for tcpdump and ping
951 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
952 - Updated configuration to include COW again.
954 - Patches from Sapan to fix ping losses.
956 - Still need help with tcpdump traffic.
959 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
960 - Patch needs to be applied.
962 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
965 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
966 - Fix bug with looping in schedule()
968 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
969 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
970 - Should be safe to try a second deployment.
973 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
975 - Disable split pagetable lock.
977 * Wed Jul 5 2006 Dave Jones <davej@redhat.com>
978 - Get rid of stack backtrace on panic, which in most
979 cases actually caused a loss of info instead of a gain.
981 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
984 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
986 - Fix up the alsa list_add bug.
988 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
989 - Fix up various stupidities incurred by the last big rebase.
990 - Reenable SMP x86-64 builds.
992 - Enable PCI fake hotplug driver.
993 - Enable gameport/joystick on i586 builds. (#196581)
995 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
996 - Enable profiling for 586 kernels.
998 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
999 - Rebuild with slab debug off.
1001 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
1004 * Mon Jun 5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
1007 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
1010 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
1011 - Improved list_head debugging.
1013 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
1016 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
1019 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
1022 * Tue May 9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
1024 - make 16C950 UARTs work (again). (#126403)
1025 - Fix exec-shield default, which should fix a few programs that
1028 * Thu May 4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
1031 * Tue May 2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
1034 * Mon May 1 2006 Dave Jones <davej@redhat.com>
1037 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
1038 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
1040 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
1043 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
1044 - Enable PCI MSI support.
1046 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
1049 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
1052 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
1055 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
1058 * Fri Apr 7 2006 Dave Jones <davej@redhat.com>
1061 * Tue Apr 4 2006 Dave Jones <davej@redhat.com>
1062 - Reenable non-standard serial ports. (#187466)
1063 - Reenable snd-es18xx for x86-32 (#187733)
1065 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
1066 - ship the .kernelrelease file in -devel too.
1067 - Disable EDAC debug.
1069 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
1072 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
1073 - Include patches posted for review for inclusion in 2.6.16.1
1074 - Updated new audit msg types.
1075 - Reenable HDLC driver (#186257)
1076 - Make acpi-cpufreq 'sticky'
1077 - Fix broken x86-64 32bit vDSO (#186924)
1079 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
1080 - Improve spinlock scalability on big machines.
1082 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
1083 - Sync with FC5's 2.6.16 kernel.
1084 - Update Tux & Exec-shield to latest.
1087 %define module_current_branch 22