Added ocaml and inotify RPMs for vsys [wiki:vsys vsys].
[myplc.git] / myplc-devel-native.spec
1 Vendor: PlanetLab
2 Packager: PlanetLab Central <support@planet-lab.org>
3 Distribution: PlanetLab 4.0
4 URL: http://svn.planet-lab.org/svn/MyPLC
5
6 Summary: PlanetLab Central (PLC) Development Environment
7 Name: myplc-devel-native
8 Version: 0.1
9 Release: 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 License: PlanetLab
11 Group: Development/Tools
12 Source0: %{name}-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14 AutoReqProv: no
15
16 Requires: beecrypt-devel
17 Requires: bzip2
18 Requires: coreutils
19 Requires: cpio
20 Requires: createrepo
21 Requires: curl
22 Requires: curl-devel
23 Requires: cvs
24 Requires: db4-devel
25 Requires: dev
26 Requires: diffutils
27 Requires: dnsmasq
28 Requires: docbook-utils-pdf
29 Requires: dosfstools
30 Requires: doxygen
31 Requires: expect
32 Requires: gcc-c++
33 Requires: gd
34 Requires: glibc
35 Requires: glibc-common
36 Requires: gnupg
37 Requires: gperf
38 Requires: gzip
39 Requires: httpd
40 Requires: install
41 Requires: iptables
42 Requires: less
43 Requires: libpcap
44 Requires: libpcap-devel
45 Requires: libtool
46 Requires: linuxdoc-tools
47 Requires: mailx
48 Requires: make
49 Requires: metadata
50 Requires: mkisofs
51 Requires: mod_python
52 Requires: mod_ssl
53 Requires: mysql
54 Requires: mysql-devel
55 Requires: mysql-server
56 Requires: nasm
57 Requires: ncurses-devel
58 Requires: openssh
59 Requires: openssl
60 Requires: php
61 Requires: php-devel
62 Requires: php-gd
63 Requires: php-pgsql
64 Requires: postgresql
65 Requires: postgresql-devel
66 Requires: postgresql-python
67 Requires: postgresql-server
68 Requires: python
69 Requires: python-devel
70 Requires: PyXML
71 Requires: readline-devel
72 Requires: redhat-rpm-config
73 Requires: rpm
74 Requires: rpm-build
75 Requires: rpm-devel
76 Requires: rsync
77 Requires: sendmail
78 Requires: sendmail-cf
79 Requires: sharutils
80 Requires: sudo
81 Requires: svn
82 Requires: tar
83 Requires: tetex-latex
84 Requires: time
85 Requires: vconfig
86 Requires: vixie-cron
87 Requires: wget
88 Requires: xmlsec1
89 Requires: xmlsec1-openssl
90 Requires: yum
91
92 %define debug_package %{nil}
93
94 %description
95 This package installs a complete PlanetLab development
96 environment. The default installation consists of all the packages
97 necessary to compile MyPLC.
98
99 %prep
100 %setup -q
101
102 %build
103 rm -rf $RPM_BUILD_ROOT
104 mkdir -p $RPM_BUILD_ROOT/etc
105
106 %install
107 touch $RPM_BUILD_ROOT/etc/myplc-devel-native
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 # If run under sudo
113 if [ -n "$SUDO_USER" ] ; then
114     # Allow user to delete the build directory
115     chown -h -R $SUDO_USER .
116     # Some temporary cdroot files like /var/empty/sshd and
117     # /usr/bin/sudo get created with non-readable permissions.
118     find . -not -perm +0600 -exec chmod u+rw {} \;
119     # Allow user to delete the built RPM(s)
120     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
121 fi
122
123 %pre
124
125 %post
126
127 uid=2000
128 gid=2000
129
130 builduser=$(grep "^build" /etc/passwd | wc -l)
131 if [ $builduser -eq 0 ] ; then
132         groupadd -o -g $gid build;
133         useradd -o -c 'Automated Build' -u $uid -g $gid -n -M -s /bin/bash build;
134 fi
135
136 # Allow build user to build certain RPMs as root
137 buildsudo=$(grep "^build.*ALL=(ALL).*NOPASSWD:.*ALL"  /etc/sudoers | wc -l)
138 if [ $buildsudo -eq 0 ] ; then
139         echo "build   ALL=(ALL)       NOPASSWD: ALL" >> /etc/sudoers
140 fi
141
142
143 %preun
144 # 0 = erase, 1 = upgrade
145 if [ $1 -eq 0 ] ; then
146 fi
147
148 %files
149 %defattr(-,root,root,-)
150 /etc/myplc-devel-native
151
152 %changelog
153 * Fri Oct 05 2007 Marc E. Fiuczynski <mef@cs.princeton.edu>
154 - Initial build.