6 %define name myplc-native
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 Summary: PlanetLab Central (PLC) Portable Installation
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
38 Requires: python-pycurl
39 Requires: python-psycopg2
45 Requires: python-devel
52 Requires: python >= 2.4
54 Requires: postgresql-python
56 Requires: postgresql-server
59 Requires: xmlsec1-openssl
62 Requires: bootcd-%{pldistro}-%{_arch}
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
76 %define debug_package %{nil}
79 MyPLC is a complete PlanetLab Central (PLC) portable installation
80 contained within a chroot jail. The default installation consists of a
81 web server, an XML-RPC API server, a boot server, and a database
82 server: the core components of PLC. The installation may be customized
83 through a graphical interface. All PLC services are started up and
84 shut down through a single System V init script installed in the host
92 rm -rf $RPM_BUILD_ROOT
93 ./build-native.sh %{pldistro} $RPM_BUILD_ROOT
100 rm -rf $RPM_BUILD_ROOT
103 if [ -n "$SUDO_USER" ] ; then
104 # Allow user to delete the build directory
105 chown -h -R $SUDO_USER .
106 # Some temporary cdroot files like /var/empty/sshd and
107 # /usr/bin/sudo get created with non-readable permissions.
108 find . -not -perm +0600 -exec chmod u+rw {} \;
109 # Allow user to delete the built RPM(s)
110 chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
114 if [ -x %{_sysconfdir}/init.d/plc ] ; then
115 %{_sysconfdir}/init.d/plc stop
118 # Old versions of myplc used to ship with a bootstrapped database and
119 # /etc/planetlab directory. Including generated files in the manifest
120 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
121 # names from one RPM build to another, it would be rpmsaved and thus
122 # effectively deleted. Now we do not include these files in the
123 # manifest. However, to avoid deleting these files in the process of
124 # upgrading from one of these old versions of myplc, we must back up
125 # the database and /etc/planetlab and restore them after the old
126 # version has been uninstalled in %triggerpostun (also in %post, in
127 # case we are force upgrading to the same version).
129 # This code can be removed once all myplc-0.4-1 installations have
130 # been upgraded to at least myplc-0.4-2.
132 # 0 = install, 1 = upgrade
133 if [ $1 -gt 0 ] ; then
134 for dir in /var/lib/pgsql/data /etc/planetlab ; do
135 if [ -d $dir ] ; then
136 echo "Preserving $dir"
137 mkdir -p $dir.rpmsave
138 tar -C $dir -cpf - . | \
139 tar -C $dir.rpmsave -xpf -
141 # Except for the default configuration file and DTD, which
142 # really should be considered for upgrade.
143 rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
149 if [ -x /sbin/chkconfig ] ; then
150 /sbin/chkconfig --add plc
151 /sbin/chkconfig plc on
153 pushd /usr/share/myplc &> /dev/null
154 python plc_config.py build
155 python plc_config.py install
158 %triggerpostun -- %{name}
159 # 0 = erase, 1 = upgrade
160 if [ $1 -gt 0 ] ; then
161 for dir in /var/lib/pgsql/data /etc/planetlab ; do
162 if [ -d $dir.rpmsave -a -d $dir ] ; then
164 if tar -C $dir.rpmsave -cpf - . | \
165 tar -C $dir -xpf - ; then
173 # 0 = erase, 1 = upgrade
174 if [ $1 -eq 0 ] ; then
175 %{_sysconfdir}/init.d/plc stop
176 if [ -x /sbin/chkconfig ] ; then
177 /sbin/chkconfig plc off
178 /sbin/chkconfig --del plc
183 %defattr(-,root,root,-)
184 # Host startup script and configuration file
189 /etc/plc_sliceinitscripts/sirius
190 /etc/support-scripts/gen_aliases.py*
191 /etc/support-scripts/renew_reminder.py*
193 /usr/bin/plc-config-tty
198 /usr/bin/refresh-peer.py*
199 /usr/bin/clean-empty-dirs.py*
201 /usr/bin/check-ssl-peering.py*
203 /var/www/html/install-rpms/%{pldistro}-%{_arch}
204 /var/www/html/install-rpms/planetlab
207 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
208 - Removed proper ops from planetflow slice.
210 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
211 - myplc-native requires myplc-docs
212 - fixed doc build by locating locally installed DTDs at build-time
214 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
215 - turn myplc-docs off for now
217 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
218 - figures in doc package
220 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
221 - no more doc packaged outside of myplc-docs - doc/ cleaned up
222 - chroot packaging does not have docs anymore
223 - 'cvs' and 'dev' not required from myplc-native anymore
224 - cosmetic change in kml output
226 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
227 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
228 - gethostbyname uses python rather than perl (hope this shrinks deps)
229 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
230 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
231 - make sync now works towards vserver-based myplc only
233 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
235 - added vsys 'pfmount' script to the default netflow slice attributes.
238 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
239 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
240 - to new bootcd packaging
242 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
243 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
245 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
246 - packaging of mplc-release in myplc-native
247 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
248 - resolv file in /etc/resolv.conf, not plc_resolv.conf
249 - improved sirius script
250 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
251 - expires more properly set
253 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
256 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
257 - renew_reminder script moved to support-scripts/
258 - gen-aliases script added in support-scripts/
259 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
260 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
261 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
262 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
263 - new setting 'Mom list address' for sending emails to a separate destination
264 - starts rsyslogd/syslogd as appropriate
265 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
266 - convenience generation of yum.conf in resulting image based on build/mirroring
268 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
269 - refresh-peer.py removed (duplicate with PLCAPI)
270 - plc.d/ scripts cleaned up
271 - sirius initscript updated
272 - slice auto renewal fixed
274 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
277 %define module_current_branch 4.2