10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
17 Source0: %{name}-%{version}.tar.gz
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
28 ####################### myplc
29 Summary: PlanetLab Central (PLC) Portable Installation
30 Group: Applications/Systems
32 # as much as possible, requires should go in the subpackages specfile
43 Requires: python-devel
57 Requires: xmlsec1-openssl
58 %if "%{distro}" == "Fedora" && %{distrorelease} >= 10
65 Requires: bootcd-%{pldistro}-%{_arch}
67 Requires: www-register-wizard
71 Requires: bootstrapfs-%{pldistro}-%{_arch}
73 Requires: myplc-release
74 Requires: myplc-config
76 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
77 %if "%{pldistro}" == "onelab"
78 Requires: dummynet_image
81 %define debug_package %{nil}
84 MyPLC is a complete PlanetLab Central (PLC) portable installation
85 contained within a chroot jail. The default installation consists of a
86 web server, an XML-RPC API server, a boot server, and a database
87 server: the core components of PLC. The installation may be customized
88 through a graphical interface. All PLC services are started up and
89 shut down through a single System V init script installed in the host
92 ####################### myplc-config
96 Summary: PlanetLab Central (PLC) configuration python module
97 Group: Applications/Systems
101 This package provides the Python module to configure MyPLC.
111 rm -rf $RPM_BUILD_ROOT
112 ./build.sh %{pldistro} $RPM_BUILD_ROOT
116 rm -rf $RPM_BUILD_ROOT
119 if [ -n "$SUDO_USER" ] ; then
120 # Allow user to delete the build directory
121 chown -h -R $SUDO_USER .
122 # Some temporary cdroot files like /var/empty/sshd and
123 # /usr/bin/sudo get created with non-readable permissions.
124 find . -not -perm +0600 -exec chmod u+rw {} \;
125 # Allow user to delete the built RPM(s)
126 [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
130 if [ -x %{_sysconfdir}/init.d/plc ] ; then
131 %{_sysconfdir}/init.d/plc stop
134 # Old versions of myplc used to ship with a bootstrapped database and
135 # /etc/planetlab directory. Including generated files in the manifest
136 # was dangerous; if /plc/data/var/lib/pgsql/data/base/1/16676 changed
137 # names from one RPM build to another, it would be rpmsaved and thus
138 # effectively deleted. Now we do not include these files in the
139 # manifest. However, to avoid deleting these files in the process of
140 # upgrading from one of these old versions of myplc, we must back up
141 # the database and /etc/planetlab and restore them after the old
142 # version has been uninstalled in %triggerpostun (also in %post, in
143 # case we are force upgrading to the same version).
145 # This code can be removed once all myplc-0.4-1 installations have
146 # been upgraded to at least myplc-0.4-2.
148 # 0 = install, 1 = upgrade
149 if [ $1 -gt 0 ] ; then
150 for dir in /var/lib/pgsql/data /etc/planetlab ; do
151 if [ -d $dir ] ; then
152 echo "Preserving $dir"
153 mkdir -p $dir.rpmsave
154 tar -C $dir -cpf - . | \
155 tar -C $dir.rpmsave -xpf -
157 # Except for the default configuration file and DTD, which
158 # really should be considered for upgrade.
159 rm -f $dir.rpmsave/{default_config.xml,plc_config.dtd}
165 if [ -x /sbin/chkconfig ] ; then
166 /sbin/chkconfig --add plc
167 /sbin/chkconfig plc on
170 %triggerpostun -- %{name}
171 # 0 = erase, 1 = upgrade
172 if [ $1 -gt 0 ] ; then
173 for dir in /var/lib/pgsql/data /etc/planetlab ; do
174 if [ -d $dir.rpmsave -a -d $dir ] ; then
176 if tar -C $dir.rpmsave -cpf - . | \
177 tar -C $dir -xpf - ; then
185 # 0 = erase, 1 = upgrade
186 if [ $1 -eq 0 ] ; then
187 %{_sysconfdir}/init.d/plc stop
188 if [ -x /sbin/chkconfig ] ; then
189 /sbin/chkconfig plc off
190 /sbin/chkconfig --del plc
195 %defattr(-,root,root,-)
196 # Host startup script and configuration file
200 /etc/plc_sliceinitscripts/sirius
201 /etc/support-scripts/gen_aliases.py*
202 /etc/support-scripts/renew_reminder.py*
203 /etc/support-scripts/renew_reminder_logrotate
204 /usr/bin/plc-config-tty
209 /usr/bin/refresh-peer.py*
210 /usr/bin/clean-empty-dirs.py*
212 /usr/bin/plc-check-ssl-peering.py*
213 /usr/bin/plc-orphan-accounts.py*
214 /usr/share/myplc/bashrc
217 %defattr(-,root,root,-)
219 %{python_sitearch}/plc_config.py*
223 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
224 - Allow dnsmasq configuration to be extended.
226 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
228 - Generalize bootcd-kernel.
230 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
231 - support for fedora 12
232 - new package myplc-config for use by sfa
233 - drupal user registration turned off
235 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
236 - - fix to make sure when API, BOOT, MONITOR are on the same
237 - machine as WWW that the SSL key,cert for WWW takes precedence.
238 - - Do proper setup for SSL CA certficate to be used as the server
241 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
242 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
244 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
245 - depend on pcucontrol
247 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
248 - * validate input according to type in plc_config
249 - * added the _genicw system slice
250 - * add tag types for sites and persons
251 - * add new tags for nodes and slices for exemption from myops
253 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
254 - turn off drupal on a box that acts as BOOT server but not as WWW server
255 - cleanup some obsolete code for old chroot-jail packaging in the process
256 - new bootcd-kernel script for keeping bootcd variants up2date
258 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
259 - Make the /etc/hosts manipulation optional.
261 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
264 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
265 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
267 - - Added the root ssh key handling support back into plc.d/ssh and the
268 - default xml file. This should be identical to the way it was in
270 - - Added support in the db-config.d/01-init script to register the root
271 - ssh public key with the default administrator. In this way the root
272 - ssh key will make it into the root account on the nodes by means of
273 - NodeManager's specialaccounts plugin.
275 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
276 - db-config ignores sliver tags
277 - sirius's db-config script renamed (was sirious)
279 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
280 - fix for silverauth - missing tag types now created at plc startup time
282 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
283 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
285 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
286 - companion to NM's specialaccounts plugin
287 - do not generate /etc/planetlab/root_ssh_key* anymore
288 - remove related config. variables and conf_files
290 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
291 - clarified description text to refer only to plcrt and not other optional
294 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
295 - fixed a bug setting slice multiple attributes with the same tag name
297 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
298 - SSL setup for monitor box, and related new config variables
299 - new conf_file for /etc/planetlab/extensions
300 - various tweaks in db-config internals, about initscripts among others
301 - also more messages defined in the db
303 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
304 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
306 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
307 - bugfix in db-config, tag 4.3-19 would not fly
309 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
310 - Refactored db-config into snippets in db-config.d/.
312 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
313 - oops, tag 4.3-17 was broken and would not work
315 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
316 - bugfix - escape sequences inserted in xml configs
318 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
319 - Handle db-config.d files properly.
321 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
322 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
324 - - Fix db-config to be a bit more cautious when
325 - /etc/planetlab/db-config.d doesn't exist
326 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
328 - - Refactor generic plc-config-tty code into plc_config.py.
329 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
330 - and the list of validated variables and the corresponding
331 - validator() function. This refactoring lets one reuse plc_config.py
332 - as a generic cmdline configuration tool for highly customer MyPLC
335 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
336 - update PCU Type descriptions.
337 - updates to init scripts
339 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
340 - requires monitor-pcucontrol so register-wizard can work
342 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
343 - cleaned up plc-config-tty, no more need to configure plc-devel
345 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
346 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
348 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
349 - fix issue in db-config that prevented correct operation
351 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
352 - remove support for chroot-based packaging - no crond nor syslog step anymore
353 - plc init script now named plc.init instead of former guest.init
355 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
356 - add Monitor to docs build
358 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
359 - plc_config.py and plc-config-tty: generalized to work for more diverse
360 - MyPLC configurations.
361 - plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
362 - deployments and increase the memory limits in php.ini
363 - plc.d/crond: add --full option to vacuumdb
365 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
366 - avoid generating ssl certificates for disabled services among www api boot
368 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
369 - cleaned up old entries in db-config
372 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
373 - php include path tweaked for plekit includes
374 - reviewed myplc (fka native) packaging dependencies
377 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
378 - rename myplc into myplc-chroot and myplc-native into myplc
379 - new settings (shortname & hrn_root) for local peer
381 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
382 - First iteration of new data model
383 - Bunch of various fixes
385 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
386 - Removed proper ops from planetflow slice.
388 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
389 - myplc-native requires myplc-docs
390 - fixed doc build by locating locally installed DTDs at build-time
392 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
393 - turn myplc-docs off for now
395 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
396 - figures in doc package
398 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
399 - no more doc packaged outside of myplc-docs - doc/ cleaned up
400 - chroot packaging does not have docs anymore
401 - 'cvs' and 'dev' not required from myplc-native anymore
402 - cosmetic change in kml output
404 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
405 - defaults for *_IP conf vars now void, expect more accurate /etc/hosts
406 - gethostbyname uses python rather than perl (hope this shrinks deps)
407 - doc: reviewed myplc doc - deprecated everything related to myplc-devel
408 - doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
409 - make sync now works towards vserver-based myplc only
411 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
413 - added vsys 'pfmount' script to the default netflow slice attributes.
416 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
417 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
418 - to new bootcd packaging
420 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
421 - changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
423 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
424 - packaging of mplc-release in myplc-native
425 - sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
426 - resolv file in /etc/resolv.conf, not plc_resolv.conf
427 - improved sirius script
428 - remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
429 - expires more properly set
431 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
434 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
435 - renew_reminder script moved to support-scripts/
436 - gen-aliases script added in support-scripts/
437 - sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
438 - plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
439 - nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
440 - new native slice attributes 'capabilities', 'vsys' and 'codemux'
441 - new setting 'Mom list address' for sending emails to a separate destination
442 - starts rsyslogd/syslogd as appropriate
443 - expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
444 - convenience generation of yum.conf in resulting image based on build/mirroring
446 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
447 - refresh-peer.py removed (duplicate with PLCAPI)
448 - plc.d/ scripts cleaned up
449 - sirius initscript updated
450 - slice auto renewal fixed
452 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
455 %define module_current_branch 4.2