2 # in real-life we use a debian packaging, so this fedora packaging is very rough
3 # it turns out we need to have one specfile for the PL build..
4 # in any case the contents here should be more carefully split
5 # into several components pieces for generic and plugins and all that...
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 Summary: MySlice Frontend
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22 Packager: OpenLab <thierry.parmentelat@inria.fr>
25 Requires: python >= 2.7
26 # in f14 this used to be called Django
27 Requires: python-django
31 Requires: openssl-perl
32 BuildRequires: python-setuptools make
35 The MySlice frontend provides a django application that interacts with
36 a manifold backend to provide a User-Interface to a federation of
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
50 rm -rf $RPM_BUILD_ROOT
53 %defattr(-,root,root,-)
54 %dir %{_datadir}/myslice
58 * Wed Sep 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-4
59 - move to bootstrap v3 complete - hopefully
60 - static files directory is now plain static/
61 - templates files directory is now plain templates/
62 - packaging for debian should be working fine, using apache+wsgi
64 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-3
65 - checkpoint for deployment on test.myslice.info
67 * Mon Sep 09 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-2
68 - cleaner tag, using module-tag for consistent numbering
70 * Mon Apr 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-3
71 - a small number of representative plugins are available
72 - next step is to correlate a Get query with its corresponding Update like in slice.php
74 * Mon Mar 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-2
75 - new pluing 'hazelnut' which is a tmpname for the former datatables one
76 - querycode is syntaxhighlighter-enabled