- restore accidentally removed "%define signmodules 0"
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 7
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # groups of related archs
31 %define all_x86 i586 i686
32
33 # Override generic defaults with per-arch defaults 
34
35 %ifarch %{all_x86}
36 %define image_install_path boot
37 %endif
38
39 #
40 # Three sets of minimum package version requirements in the form of Conflicts:
41 # to versions below the minimum
42 #
43
44 #
45 # First the general kernel 2.6 required versions as per
46 # Documentation/Changes
47 #
48 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
49
50
51 # Then a series of requirements that are distribution specific, either 
52 # because we add patches for something, or the older versions have 
53 # problems with the newer kernel or lack certain things that make 
54 # integration in the distro harder than needed.
55 #
56 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
57
58 #
59 # Several packages had bugs in them that became obvious when the NPTL
60 # threading code got integrated. 
61 #
62 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
63
64 #
65 # Packages that need to be installed before the kernel is, because the %post
66 # scripts use them.
67 #
68 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
69
70 Name: kernel
71 Group: System Environment/Kernel
72 License: GPLv2
73 Version: %{rpmversion}
74 Release: %{release}
75 ExclusiveOS: Linux
76 Provides: kernel = %{version}
77 Provides: kernel-drm = 4.3.0
78 Prereq: %{kernel_prereq}
79 Conflicts: %{kernel_dot_org_conflicts}
80 Conflicts: %{package_conflicts}
81 Conflicts: %{nptl_conflicts}
82 # We can't let RPM do the dependencies automatic because it'll then pick up
83 # a correct but undesirable perl dependency from the module headers which
84 # isn't required for the kernel proper to function
85 AutoReqProv: no
86
87 #
88 # List the packages used during the kernel build
89 #
90 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
91 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, kernel-utils >= 2.4-12.1.139
92 # temporary req since modutils changed output format 
93 #BuildPreReq: modutils >= 2.4.26-14
94 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
95 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
96
97
98
99 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
100
101 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
102
103 %description 
104 The kernel package contains the Linux kernel (vmlinuz), the core of any
105 Linux operating system.  The kernel handles the basic functions
106 of the operating system:  memory allocation, process allocation, device
107 input and output, etc.
108
109
110 %package sourcecode
111 Summary: The source code for the Linux kernel.
112 Group: Development/System
113 Prereq: fileutils
114 Requires: make >= 3.78
115 Requires: gcc >= 3.2
116 Requires: /usr/bin/strip
117 # for xconfig and gconfig
118 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
119 Provides: kernel-source
120 Obsoletes: kernel-source <= 2.6.6
121
122 %description sourcecode
123 The kernel-sourcecode package contains the source code files for the Linux
124 kernel. The source files can be used to build a custom kernel that is
125 smaller by virtue of only including drivers for your particular hardware, if
126 you are so inclined (and you know what you're doing). The customisation
127 guide in the documentation describes in detail how to do this. This package
128 is neither needed nor usable for building external kernel modules for
129 linking such modules into the default operating system kernels.
130
131 %package doc
132 Summary: Various documentation bits found in the kernel source.
133 Group: Documentation
134 %if !%{buildsource}
135 Obsoletes: kernel-source <= 2.6.6
136 Obsoletes: kernel-sourcecode <= 2.6.6
137 %endif
138
139 %description doc
140 This package contains documentation files from the kernel
141 source. Various bits of information about the Linux kernel and the
142 device drivers shipped with it are documented in these files. 
143
144 You'll want to install this package if you need a reference to the
145 options that can be passed to Linux kernel modules at load time.
146
147
148 %package smp
149 Summary: The Linux kernel compiled for SMP machines.
150
151 Group: System Environment/Kernel
152 Provides: kernel = %{version}
153 Provides: kernel-drm = 4.3.0
154 Prereq: %{kernel_prereq}
155 Conflicts: %{kernel_dot_org_conflicts}
156 Conflicts: %{package_conflicts}
157 Conflicts: %{nptl_conflicts}
158 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
159 # now that the smp kernel offers this capability, obsolete the old kernel
160 Obsoletes: kernel-enterprise < 2.4.10
161 # We can't let RPM do the dependencies automatic because it'll then pick up
162 # a correct but undesirable perl dependency from the module headers which
163 # isn't required for the kernel proper to function
164 AutoReqProv: no
165
166 %description smp
167 This package includes a SMP version of the Linux kernel. It is
168 required only on machines with two or more CPUs as well as machines with
169 hyperthreading technology.
170
171 Install the kernel-smp package if your machine uses two or more CPUs.
172
173 %package uml
174 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
175
176 Group: System Environment/Kernel
177
178 %description uml
179 This package includes a user mode version of the Linux kernel.
180
181 %prep
182
183 %setup -n linux-%{kversion}
184
185 # make sure the kernel has the sublevel we know it has. This looks weird
186 # but for -pre and -rc versions we need it since we only want to use
187 # the higher version when the final kernel is released.
188 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
189 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
190
191 # get rid of unwanted files resulting from patch fuzz
192 find . -name "*.orig" -exec rm -fv {} \;
193 find . -name "*~" -exec rm -fv {} \;
194
195 ###
196 ### build
197 ###
198 %build
199
200 BuildKernel() {
201
202     # Pick the right config file for the kernel we're building
203     if [ -n "$1" ] ; then
204         Config=kernel-%{kversion}-i686-$1-planetlab.config
205     else
206         Config=kernel-%{kversion}-i686-planetlab.config
207     fi
208
209     KernelVer=%{version}-%{release}$1
210     echo BUILDING A KERNEL FOR $1 i686...
211
212     # make sure EXTRAVERSION says what we want it to say
213     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
214
215     # override ARCH in the case of UML
216     if [ "$1" = "uml" ] ; then
217         export ARCH=um
218     fi
219
220     # and now to start the build process
221
222     make -s mrproper
223     cp configs/$Config .config
224
225     make -s nonint_oldconfig > /dev/null
226     make -s include/linux/version.h 
227
228     make -s %{?_smp_mflags} bzImage 
229     make -s %{?_smp_mflags} modules || exit 1
230     make buildcheck
231     
232     # Start installing the results
233
234     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
235     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
236     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
237     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
238     echo "_stext" >> exported
239     echo "_end" >> exported
240     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
241     for i in `cat exported` 
242     do 
243          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
244          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
245          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
246     done
247     rm -f exported
248     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
249     rm -f System.map
250     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
251
252     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
253     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
254  
255     # And save the headers/makefiles etc for building modules against
256     #
257     # This all looks scary, but the end result is supposed to be:
258     # * all arch relevant include/ files
259     # * all Makefile/Kconfig files
260     # * all script/ files 
261
262     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
263     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
264     # first copy everything
265     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
266     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
267     # then drop all but the needed Makefiles/Kconfig files
268     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
269     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
270     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
271     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
272     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
273     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
274     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
275     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
276     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
277     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
278     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
279     cd include
280     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
281     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
282     # Make sure the Makefile and version.h have a matching timestamp so that
283     # external modules can be built
284     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
285     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
286     cd .. 
287
288     #
289     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
290     #
291     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
292     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
293
294     # mark modules executable so that strip-to-file can strip them
295     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
296
297     # detect missing or incorrect license tags
298     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
299     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
300     rm -f modinfo
301     # remove files that will be auto generated by depmod at rpm -i time
302     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
303
304 }
305
306 ###
307 # DO it...
308 ###
309
310 # prepare directories
311 rm -rf $RPM_BUILD_ROOT
312 mkdir -p $RPM_BUILD_ROOT/boot
313
314 %if %{buildup}
315 BuildKernel
316 %endif
317
318 %if %{buildsmp}
319 BuildKernel smp
320 %endif
321
322 %if %{builduml}
323 BuildKernel uml
324 %endif
325
326 ###
327 ### install
328 ###
329
330 %install
331
332 # architectures that don't get kernel-source (i586/i686/athlon) dont need
333 # much of an install because the build phase already copied the needed files
334
335 %if %{builddoc}
336 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
337
338 # sometimes non-world-readable files sneak into the kernel source tree
339 chmod -R a+r *
340 # copy the source over
341 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
342 %endif
343
344 %if %{buildsource}
345
346 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
347 chmod -R a+r *
348
349 # clean up the source tree so that it is ready for users to build their own
350 # kernel
351 make -s mrproper
352 # copy the source over
353 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
354
355 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
356 # don't accidentally overwrite their currently working moduleset and hose
357 # their system
358 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
359
360 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
361 # change those to values that are more appropriate as defeault for people who build their own kernel.
362 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
363 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
364 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
365 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
366 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
367 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
368
369 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
370 %endif
371
372 ###
373 ### clean
374 ###
375
376 %clean
377 rm -rf $RPM_BUILD_ROOT
378
379 ###
380 ### scripts
381 ###
382
383 # load the loop module for upgrades...in case the old modules get removed we have
384 # loopback in the kernel so that mkinitrd will work.
385 %pre 
386 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
387 exit 0
388
389 %pre smp
390 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
391 exit 0
392
393 %post 
394 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
395 if [ -x /usr/sbin/hardlink ] ; then
396 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
397         cd /lib/modules/%{KVERREL}/build
398         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
399 }
400 popd
401 fi
402
403 # make some useful links
404 pushd /boot > /dev/null ; {
405         ln -sf System.map-%{KVERREL} System.map
406         ln -sf initrd-%{KVERREL}.img initrd-boot
407         ln -sf vmlinuz-%{KVERREL} kernel-boot
408 }
409 popd
410
411 # ask for a reboot
412 mkdir -p /etc/planetlab
413 touch /etc/planetlab/update-reboot
414
415 %post smp
416 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
417 if [ -x /usr/sbin/hardlink ] ; then
418 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
419         cd /lib/modules/%{KVERREL}smp/build
420         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
421 }
422 popd
423 fi
424
425
426 %preun 
427 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
428 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
429
430 %preun smp
431 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
432 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
433
434
435 ###
436 ### file lists
437 ###
438
439 %if %{buildup}
440 %files 
441 %defattr(-,root,root)
442 /%{image_install_path}/vmlinuz-%{KVERREL}
443 /boot/System.map-%{KVERREL}
444 /boot/config-%{KVERREL}
445 %dir /lib/modules/%{KVERREL}
446 /lib/modules/%{KVERREL}/kernel
447 %verify(not mtime) /lib/modules/%{KVERREL}/build
448
449 %endif
450
451 %if %{buildsmp}
452 %files smp
453 %defattr(-,root,root)
454 /%{image_install_path}/vmlinuz-%{KVERREL}smp
455 /boot/System.map-%{KVERREL}smp
456 /boot/config-%{KVERREL}smp
457 %dir /lib/modules/%{KVERREL}smp
458 /lib/modules/%{KVERREL}smp/kernel
459 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
460
461 %endif
462
463 %if %{builduml}
464 %files uml
465 %defattr(-,root,root)
466
467 %endif
468
469 # only some architecture builds need kernel-source and kernel-doc
470
471 %if %{buildsource}
472 %files sourcecode
473 %defattr(-,root,root)
474 /usr/src/linux-%{KVERREL}/
475 %endif
476
477
478 %if %{builddoc}
479 %files doc
480 %defattr(-,root,root)
481 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
482 %endif
483
484 %changelog
485 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
486 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
487   sections, most non-x86 sections, and GPG sections)
488
489 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
490 - ppc32 embedded updates
491
492 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
493 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
494 - 2.6.8-rc1-bk4
495
496 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
497 - 2.6.8-rc1-bk3
498
499 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
500 - add "enforcemodulesig" boot option to make the kernel load signed modules only
501
502 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
503 - updated voluntary preempt
504 - 2.6.8-rc1
505
506 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
507 - fix boot breakage that was hitting lots of people (Dave Jones)
508
509 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
510 - add voluntary preemption patch from Ingo
511 - 2.6.7-bk19
512
513 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
514 - make a start at gpg signed modules support
515
516 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
517 - experiment with making the hardlink call in post more efficient
518 - 2.6.7-bk9
519
520 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
521 - 2.6.7-bk7
522 - Add wli's patch to allocate memory bottom up not top down
523 - change some config options in the kernel-sourcecode package that are
524   good for rpm kernel builds but not for custom user builds to more appropriate 
525   default values.
526 - reenable kernel-sourcecode again for a few builds 
527
528 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
529 - 2.6.7-bk5
530 - fix tux unresolved symbols (#126532)
531
532 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
533 - make kernel-doc and kernel-sourcecode builds independent of eachother
534 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
535   on how to use the src.rpm instead for building your own kernel.
536
537 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
538 - 2.6.7-bk2
539
540 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
541 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
542
543 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
544 - add fix from Andi Kleen/Linus for the fpu-DoS
545
546 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
547 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
548 - revert airo driver to the FC2 one since the new one breaks
549
550 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
551 - Update to 2.6.7rc3
552
553 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
554 - fix the mlock-uses-rlimit patch
555
556 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
557 - Add ppc64 (Mac G5)
558
559 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
560 - add a forward port of the mlock-uses-rlimit patch
561 - add NX support for x86 (Intel, Ingo)
562
563 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
564 - refresh ext3 reservation patch
565
566 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
567 - 2.6.7-rc2
568 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
569
570 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
571 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
572
573 * Thu May 27 2004 Dave Jones <davej@redhat.com>
574 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
575
576 * Wed May 26 2004 Dave Jones <davej@redhat.com>
577 - Lots more updates to the SCSI whitelist for various
578   USB card readers. (#112778, among others..)
579
580 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
581 - back out ehci suspend/resume patch, it breaks
582 - add fix for 3c59x-meets-kudzu bug from Alan
583
584 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
585 - try improving suspend/resume by restoring more PCI state
586 - 2.6.7-rc1-bk1
587
588 * Mon May 24 2004 Dave Jones <davej@redhat.com>
589 - Add yet another multi-card reader to the whitelist (#85851)
590
591 * Sun May 23 2004 Dave Jones <davej@redhat.com>
592 - Add another multi-card reader to the whitelist (#124048)
593
594 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
595 - put firewire race fix in (datacorruptor)
596
597 * Tue May 18 2004 Dave Jones <davej@redhat.com>
598 - Fix typo in ibmtr driver preventing compile (#123391)
599
600 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
601 - update to 2.6.6-bk3
602 - made kernel-source and kernel-doc noarch.rpm's since they are not
603   architecture specific.
604
605 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
606 - fix non-booting on Transmeta cpus (Peter Anvin)
607 - fix count leak in message queues
608
609 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
610 - more ide cache flush work
611 - patch from scsi-bk to fix sd refcounting
612
613 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
614 - some more ide cache flush fixes 
615
616 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
617 - fix bug 122504
618 - convert b44 to ethtool ops (jgarzik)
619 - make IDE do a cache-flush on shutdown (me/Alan)
620
621 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
622 - work around i810/i830 DRM issue
623
624 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
625 - 2.6.6-rc3-bk1
626 - make amd64 boot again
627 - fix vm86-vs-4g4g interaction (Ingo)
628
629 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
630 - 2.6.6-rc2
631  
632 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
633 - add the ext3 online resize patch
634
635 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
636 - 2.6.6-rc1-bk3
637 - add the objrmap vm from the -mm tree; it needs testing
638
639 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
640 - 2.6.5-bk2
641 - disable DISCONTIGMEM on ia64 for performance
642 - fix sleep_on use in reiserfs (Chris Mason)
643
644 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
645 - 2.6.5-mc4
646 - reenable sg driver for scsi tape changers and such
647 - the sk98lin driver oopses on module unload, preven that
648
649 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
650 - fix "bad pmd" bug with patch from Ingo
651
652 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
653 - 2.6.5-mc3
654 - finish up the -mc2 merge
655 - latest 4g/4g patch from Ingo
656 - latest execshield patch from Ingo
657 - fix a few framebuffer bugs
658
659 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
660 - first attempt at a 2.6.5-mc2 merge
661
662 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
663 - Add in missing SiS AGP fix.
664
665 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
666 - More agpgart fixes.
667
668 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
669 - fix another 4g/4g-vs-resume bug
670
671 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
672 - 2.6.5-rc3
673 - fix PCI posting bug in i830 DRM
674
675 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
676 - 2.6.5-rc2-bk8
677
678 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
679 - Include latest agpgart fixes.
680
681 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
682 - more DRM fixes
683 - add the fsync patches from akpm
684
685 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
686 - 2.6.5-rc2-bk3
687 - fix direct userspace memory access in i830 drm driver
688
689 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
690 - 2.6.5-rc2-bk2
691 - some stackbloat reductions from Dave and me
692
693 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
694 - 2.6.5-rc2
695
696 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
697 - 2.6.5-rc1
698
699 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
700 - 2.6.4-bk3
701 - fix oops in toshiba_acpi (Barry K. Nathan)
702
703 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
704 - 2.6.4-bk2 merge 
705
706 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
707 - renable sonypi driver that was off accidentally
708 - 2.6.4-final 
709 - fix the oops on alsa module unloads
710
711 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
712 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
713 - 2.6.4-rc3 
714
715 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
716 - 2.6.4-rc2-bk5
717 - fix nfs-vs-selinux issue
718 - fix typo in URL as per #117849
719
720 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
721 - fix race in lp.c (#117710)
722 - 2.6.4-rc2-bk3
723 - attempt to fix S3 suspend-to-ram with 4g/4g split
724
725 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
726 - fix reiserfs
727 - set HZ to 1000 again for some tests
728
729 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
730 - merge back a bunch of fedora fixes
731 - disable audit
732
733 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
734 - audit bugfixes
735 - update tux to a working version
736 - 2.6.3-bk5 merge
737
738 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
739 - re-add and enable the Auditing patch
740 - switch several cpufreq modules to built in since detecting in userspace
741   which to use is unpleasant
742 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
743 - 2.6 start 
744