Merge to Fedora Core 2 kernel-2.6.8-1.521
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 8
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Name: kernel
66 Group: System Environment/Kernel
67 License: GPLv2
68 Version: %{rpmversion}
69 Release: %{release}
70 ExclusiveOS: Linux
71 Provides: kernel = %{version}
72 Provides: kernel-drm = 4.3.0
73 Prereq: %{kernel_prereq}
74 Conflicts: %{kernel_dot_org_conflicts}
75 Conflicts: %{package_conflicts}
76 Conflicts: %{nptl_conflicts}
77 # We can't let RPM do the dependencies automatic because it'll then pick up
78 # a correct but undesirable perl dependency from the module headers which
79 # isn't required for the kernel proper to function
80 AutoReqProv: no
81
82 #
83 # List the packages used during the kernel build
84 #
85 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
86 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, kernel-utils >= 1:2.4-12.1.142
87 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
88 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
89 BuildArchitectures: i686
90
91
92
93 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
94
95 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
96
97 %description 
98 The kernel package contains the Linux kernel (vmlinuz), the core of any
99 Linux operating system.  The kernel handles the basic functions
100 of the operating system:  memory allocation, process allocation, device
101 input and output, etc.
102
103
104 %package sourcecode
105 Summary: The source code for the Linux kernel.
106 Group: Development/System
107 Prereq: fileutils
108 Requires: make >= 3.78
109 Requires: gcc >= 3.2
110 Requires: /usr/bin/strip
111 # for xconfig and gconfig
112 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
113 Provides: kernel-source
114 Obsoletes: kernel-source <= 2.6.6
115
116 %description sourcecode
117 The kernel-sourcecode package contains the source code files for the Linux
118 kernel. The source files can be used to build a custom kernel that is
119 smaller by virtue of only including drivers for your particular hardware, if
120 you are so inclined (and you know what you're doing). The customisation
121 guide in the documentation describes in detail how to do this. This package
122 is neither needed nor usable for building external kernel modules for
123 linking such modules into the default operating system kernels.
124
125 %package doc
126 Summary: Various documentation bits found in the kernel source.
127 Group: Documentation
128 %if !%{buildsource}
129 Obsoletes: kernel-source <= 2.6.6
130 Obsoletes: kernel-sourcecode <= 2.6.6
131 %endif
132
133 %description doc
134 This package contains documentation files from the kernel
135 source. Various bits of information about the Linux kernel and the
136 device drivers shipped with it are documented in these files. 
137
138 You'll want to install this package if you need a reference to the
139 options that can be passed to Linux kernel modules at load time.
140
141
142 %package smp
143 Summary: The Linux kernel compiled for SMP machines.
144
145 Group: System Environment/Kernel
146 Provides: kernel = %{version}
147 Provides: kernel-drm = 4.3.0
148 Prereq: %{kernel_prereq}
149 Conflicts: %{kernel_dot_org_conflicts}
150 Conflicts: %{package_conflicts}
151 Conflicts: %{nptl_conflicts}
152 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
153 # now that the smp kernel offers this capability, obsolete the old kernel
154 Obsoletes: kernel-enterprise < 2.4.10
155 # We can't let RPM do the dependencies automatic because it'll then pick up
156 # a correct but undesirable perl dependency from the module headers which
157 # isn't required for the kernel proper to function
158 AutoReqProv: no
159
160 %description smp
161 This package includes a SMP version of the Linux kernel. It is
162 required only on machines with two or more CPUs as well as machines with
163 hyperthreading technology.
164
165 Install the kernel-smp package if your machine uses two or more CPUs.
166
167 %package uml
168 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
169
170 Group: System Environment/Kernel
171
172 %description uml
173 This package includes a user mode version of the Linux kernel.
174
175 %prep
176
177 %setup -n linux-%{kversion}
178
179 # make sure the kernel has the sublevel we know it has. This looks weird
180 # but for -pre and -rc versions we need it since we only want to use
181 # the higher version when the final kernel is released.
182 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
183 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
184
185 # get rid of unwanted files resulting from patch fuzz
186 find . -name "*.orig" -exec rm -fv {} \;
187 find . -name "*~" -exec rm -fv {} \;
188
189 ###
190 ### build
191 ###
192 %build
193
194 BuildKernel() {
195
196     # Pick the right config file for the kernel we're building
197     if [ -n "$1" ] ; then
198         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
199     else
200         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
201     fi
202
203     KernelVer=%{version}-%{release}$1
204     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
205
206     # make sure EXTRAVERSION says what we want it to say
207     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
208
209     # override ARCH in the case of UML
210     if [ "$1" = "uml" ] ; then
211         export ARCH=um
212     fi
213
214     # and now to start the build process
215
216     make -s mrproper
217     cp configs/$Config .config
218
219     make -s nonint_oldconfig > /dev/null
220     make -s include/linux/version.h 
221
222     make -s %{?_smp_mflags} bzImage 
223     make -s %{?_smp_mflags} modules || exit 1
224     make buildcheck
225     
226     # Start installing the results
227
228     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
229     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
230     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
231     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
232     echo "_stext" >> exported
233     echo "_end" >> exported
234     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
235     for i in `cat exported` 
236     do 
237          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
238          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
239          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
240     done
241     rm -f exported
242     install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
243     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
244     rm -f System.map
245     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
246
247     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
248     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
249  
250     # And save the headers/makefiles etc for building modules against
251     #
252     # This all looks scary, but the end result is supposed to be:
253     # * all arch relevant include/ files
254     # * all Makefile/Kconfig files
255     # * all script/ files 
256
257     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
258     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
259     # first copy everything
260     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
261     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
262     # then drop all but the needed Makefiles/Kconfig files
263     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
264     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
265     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
266     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
267     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
268     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
269     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
270     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
271     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
272     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
273     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
274     cd include
275     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
276     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
277     # Make sure the Makefile and version.h have a matching timestamp so that
278     # external modules can be built
279     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
280     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
281     cd .. 
282
283     #
284     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
285     #
286     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
287     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
288
289     # mark modules executable so that strip-to-file can strip them
290     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
291
292     # detect missing or incorrect license tags
293     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
294     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
295     rm -f modinfo
296     # remove files that will be auto generated by depmod at rpm -i time
297     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
298
299 }
300
301 ###
302 # DO it...
303 ###
304
305 # prepare directories
306 rm -rf $RPM_BUILD_ROOT
307 mkdir -p $RPM_BUILD_ROOT/boot
308
309 %if %{buildup}
310 BuildKernel
311 %endif
312
313 %if %{buildsmp}
314 BuildKernel smp
315 %endif
316
317 %if %{builduml}
318 BuildKernel uml
319 %endif
320
321 ###
322 ### install
323 ###
324
325 %install
326
327 # architectures that don't get kernel-source (i586/i686/athlon) dont need
328 # much of an install because the build phase already copied the needed files
329
330 %if %{builddoc}
331 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
332
333 # sometimes non-world-readable files sneak into the kernel source tree
334 chmod -R a+r *
335 # copy the source over
336 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
337 %endif
338
339 %if %{buildsource}
340
341 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
342 chmod -R a+r *
343
344 # clean up the source tree so that it is ready for users to build their own
345 # kernel
346 make -s mrproper
347 # copy the source over
348 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
349
350 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
351 # don't accidentally overwrite their currently working moduleset and hose
352 # their system
353 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
354
355 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
356 # change those to values that are more appropriate as defeault for people who build their own kernel.
357 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
358 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
359 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
360 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
361 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
362 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
363
364 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
365 %endif
366
367 ###
368 ### clean
369 ###
370
371 %clean
372 rm -rf $RPM_BUILD_ROOT
373
374 ###
375 ### scripts
376 ###
377
378 # load the loop module for upgrades...in case the old modules get removed we have
379 # loopback in the kernel so that mkinitrd will work.
380 %pre 
381 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
382 exit 0
383
384 %pre smp
385 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
386 exit 0
387
388 %post 
389 # trick mkinitrd in case the current environment does not have device mapper
390 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
391 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
392     if [ ! -f $rootdev ]; then
393         fake_root_lvm=1
394         mkdir -p $(dirname $rootdev)
395         touch $rootdev
396     fi
397 fi
398 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
399 if [ -n "$fake_root_lvm" ]; then
400     rm -f $rootdev
401 fi
402 if [ -x /usr/sbin/hardlink ] ; then
403 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
404         cd /lib/modules/%{KVERREL}/build
405         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
406 }
407 popd
408 fi
409
410 # make some useful links
411 pushd /boot > /dev/null ; {
412         ln -sf System.map-%{KVERREL} System.map
413         ln -sf Kerntypes-%{KVERREL} Kerntypes
414         ln -sf config-%{KVERREL} config
415         ln -sf initrd-%{KVERREL}.img initrd-boot
416         ln -sf vmlinuz-%{KVERREL} kernel-boot
417 }
418 popd
419
420 # ask for a reboot
421 mkdir -p /etc/planetlab
422 touch /etc/planetlab/update-reboot
423
424 %post smp
425 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
426 if [ -x /usr/sbin/hardlink ] ; then
427 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
428         cd /lib/modules/%{KVERREL}smp/build
429         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
430 }
431 popd
432 fi
433
434
435 %preun 
436 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
437 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
438
439 %preun smp
440 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
441 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
442
443
444 ###
445 ### file lists
446 ###
447
448 %if %{buildup}
449 %files 
450 %defattr(-,root,root)
451 /%{image_install_path}/vmlinuz-%{KVERREL}
452 /boot/Kerntypes-%{KVERREL}
453 /boot/System.map-%{KVERREL}
454 /boot/config-%{KVERREL}
455 %dir /lib/modules/%{KVERREL}
456 /lib/modules/%{KVERREL}/kernel
457 %verify(not mtime) /lib/modules/%{KVERREL}/build
458
459 %endif
460
461 %if %{buildsmp}
462 %files smp
463 %defattr(-,root,root)
464 /%{image_install_path}/vmlinuz-%{KVERREL}smp
465 /boot/Kerntypes-%{KVERREL}smp
466 /boot/System.map-%{KVERREL}smp
467 /boot/config-%{KVERREL}smp
468 %dir /lib/modules/%{KVERREL}smp
469 /lib/modules/%{KVERREL}smp/kernel
470 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
471
472 %endif
473
474 %if %{builduml}
475 %files uml
476 %defattr(-,root,root)
477
478 %endif
479
480 # only some architecture builds need kernel-source and kernel-doc
481
482 %if %{buildsource}
483 %files sourcecode
484 %defattr(-,root,root)
485 /usr/src/linux-%{KVERREL}/
486 %endif
487
488
489 %if %{builddoc}
490 %files doc
491 %defattr(-,root,root)
492 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
493 %endif
494
495 %changelog
496 * Thu Sep 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
497 - merge to Fedora Core 2 2.6.8-1.521
498
499 * Tue Aug 31 2004 Arjan van de Ven <arjanv@redhat.com>
500 - fix execshield buglet with legacy binaries
501 - 2.6.9-rc1-bk7
502
503 * Mon Aug 30 2004 Arjan van de Ven <arjanv@redhat.com>
504 - 2.6.9-rc1-bk6
505
506 * Sat Aug 28 2004 Arjan van de Ven <arjanv@redhat.com>
507 - 2.6.9-rc1-bk4, now with i915 DRM driver
508
509 * Fri Aug 27 2004 Arjan van de Ven <arjanv@redhat.com>
510 - 2.6.9-rc1-bk2 
511
512 * Mon Aug 23 2004 Arjan van de Ven <arjanv@redhat.com>
513 - 2.6.8.1-bk2
514
515 * Sat Aug 21 2004 Arjan van de Ven <arjanv@redhat.com>
516 - attempt to fix early-udev bug
517
518 * Fri Aug 13 2004 Arjan van de Ven <arjanv@redhat.com>
519 - 2.6.8-rc4-bk3
520 - split execshield up some more
521
522 * Fri Aug 13 2004 Dave Jones <davej@redhat.com>
523 - Update SCSI whitelist again with some more card readers.
524
525 * Mon Aug 9 2004 Arjan van de Ven <arjanv@redhat.com>
526 - 2.6.8-rc3-bk3
527
528 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
529 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
530   sections, most non-x86 sections, and GPG sections)
531
532 * Wed Aug 4 2004 Arjan van de Ven <arjanv@redhat.com>
533 - Add the flex-mmap bits for s390/s390x (Pete Zaitcev)
534 - Add flex-mmap for x86-64 32 bit emulation
535 - 2.6.8-rc3
536
537 * Mon Aug 2 2004 Arjan van de Ven <arjanv@redhat.com>
538 - Add Rik's token trashing control patch
539
540 * Sun Aug 1 2004 Arjan van de Ven <arjanv@redhat.com>
541 - 2.6.8-rc2-bk11
542
543 * Fri Jul 30 2004 Arjan van de Ven <arjanv@redhat.com>
544 - 2.6.8-rc2-bk8
545
546 * Wed Jul 28 2004 Arjan van de Ven <arjanv@redhat.com>
547 - 2.6.8-rc2-bk6
548 - make a start at splitting up the execshield patchkit
549
550 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
551 - ppc32 embedded updates
552
553 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
554 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
555 - 2.6.8-rc1-bk4
556
557 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
558 - 2.6.8-rc1-bk3
559
560 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
561 - add "enforcemodulesig" boot option to make the kernel load signed modules only
562
563 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
564 - updated voluntary preempt
565 - 2.6.8-rc1
566
567 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
568 - fix boot breakage that was hitting lots of people (Dave Jones)
569
570 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
571 - add voluntary preemption patch from Ingo
572 - 2.6.7-bk19
573
574 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
575 - make a start at gpg signed modules support
576
577 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
578 - experiment with making the hardlink call in post more efficient
579 - 2.6.7-bk9
580
581 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
582 - 2.6.7-bk7
583 - Add wli's patch to allocate memory bottom up not top down
584 - change some config options in the kernel-sourcecode package that are
585   good for rpm kernel builds but not for custom user builds to more appropriate 
586   default values.
587 - reenable kernel-sourcecode again for a few builds 
588
589 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
590 - 2.6.7-bk5
591 - fix tux unresolved symbols (#126532)
592
593 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
594 - make kernel-doc and kernel-sourcecode builds independent of eachother
595 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
596   on how to use the src.rpm instead for building your own kernel.
597
598 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
599 - 2.6.7-bk2
600
601 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
602 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
603
604 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
605 - add fix from Andi Kleen/Linus for the fpu-DoS
606
607 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
608 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
609 - revert airo driver to the FC2 one since the new one breaks
610
611 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
612 - Update to 2.6.7rc3
613
614 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
615 - fix the mlock-uses-rlimit patch
616
617 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
618 - Add ppc64 (Mac G5)
619
620 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
621 - add a forward port of the mlock-uses-rlimit patch
622 - add NX support for x86 (Intel, Ingo)
623
624 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
625 - refresh ext3 reservation patch
626
627 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
628 - 2.6.7-rc2
629 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
630
631 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
632 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
633
634 * Thu May 27 2004 Dave Jones <davej@redhat.com>
635 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
636
637 * Wed May 26 2004 Dave Jones <davej@redhat.com>
638 - Lots more updates to the SCSI whitelist for various
639   USB card readers. (#112778, among others..)
640
641 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
642 - back out ehci suspend/resume patch, it breaks
643 - add fix for 3c59x-meets-kudzu bug from Alan
644
645 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
646 - try improving suspend/resume by restoring more PCI state
647 - 2.6.7-rc1-bk1
648
649 * Mon May 24 2004 Dave Jones <davej@redhat.com>
650 - Add yet another multi-card reader to the whitelist (#85851)
651
652 * Sun May 23 2004 Dave Jones <davej@redhat.com>
653 - Add another multi-card reader to the whitelist (#124048)
654
655 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
656 - put firewire race fix in (datacorruptor)
657
658 * Tue May 18 2004 Dave Jones <davej@redhat.com>
659 - Fix typo in ibmtr driver preventing compile (#123391)
660
661 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
662 - update to 2.6.6-bk3
663 - made kernel-source and kernel-doc noarch.rpm's since they are not
664   architecture specific.
665
666 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
667 - fix non-booting on Transmeta cpus (Peter Anvin)
668 - fix count leak in message queues
669
670 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
671 - more ide cache flush work
672 - patch from scsi-bk to fix sd refcounting
673
674 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
675 - some more ide cache flush fixes 
676
677 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
678 - fix bug 122504
679 - convert b44 to ethtool ops (jgarzik)
680 - make IDE do a cache-flush on shutdown (me/Alan)
681
682 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
683 - work around i810/i830 DRM issue
684
685 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
686 - 2.6.6-rc3-bk1
687 - make amd64 boot again
688 - fix vm86-vs-4g4g interaction (Ingo)
689
690 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
691 - 2.6.6-rc2
692  
693 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
694 - add the ext3 online resize patch
695
696 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
697 - 2.6.6-rc1-bk3
698 - add the objrmap vm from the -mm tree; it needs testing
699
700 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
701 - 2.6.5-bk2
702 - disable DISCONTIGMEM on ia64 for performance
703 - fix sleep_on use in reiserfs (Chris Mason)
704
705 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
706 - 2.6.5-mc4
707 - reenable sg driver for scsi tape changers and such
708 - the sk98lin driver oopses on module unload, preven that
709
710 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
711 - fix "bad pmd" bug with patch from Ingo
712
713 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
714 - 2.6.5-mc3
715 - finish up the -mc2 merge
716 - latest 4g/4g patch from Ingo
717 - latest execshield patch from Ingo
718 - fix a few framebuffer bugs
719
720 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
721 - first attempt at a 2.6.5-mc2 merge
722
723 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
724 - Add in missing SiS AGP fix.
725
726 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
727 - More agpgart fixes.
728
729 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
730 - fix another 4g/4g-vs-resume bug
731
732 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
733 - 2.6.5-rc3
734 - fix PCI posting bug in i830 DRM
735
736 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
737 - 2.6.5-rc2-bk8
738
739 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
740 - Include latest agpgart fixes.
741
742 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
743 - more DRM fixes
744 - add the fsync patches from akpm
745
746 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
747 - 2.6.5-rc2-bk3
748 - fix direct userspace memory access in i830 drm driver
749
750 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
751 - 2.6.5-rc2-bk2
752 - some stackbloat reductions from Dave and me
753
754 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
755 - 2.6.5-rc2
756
757 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
758 - 2.6.5-rc1
759
760 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
761 - 2.6.4-bk3
762 - fix oops in toshiba_acpi (Barry K. Nathan)
763
764 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
765 - 2.6.4-bk2 merge 
766
767 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
768 - renable sonypi driver that was off accidentally
769 - 2.6.4-final 
770 - fix the oops on alsa module unloads
771
772 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
773 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
774 - 2.6.4-rc3 
775
776 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
777 - 2.6.4-rc2-bk5
778 - fix nfs-vs-selinux issue
779 - fix typo in URL as per #117849
780
781 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
782 - fix race in lp.c (#117710)
783 - 2.6.4-rc2-bk3
784 - attempt to fix S3 suspend-to-ram with 4g/4g split
785
786 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
787 - fix reiserfs
788 - set HZ to 1000 again for some tests
789
790 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
791 - merge back a bunch of fedora fixes
792 - disable audit
793
794 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
795 - audit bugfixes
796 - update tux to a working version
797 - 2.6.3-bk5 merge
798
799 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
800 - re-add and enable the Auditing patch
801 - switch several cpufreq modules to built in since detecting in userspace
802   which to use is unpleasant
803 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
804 - 2.6 start 
805