Merge Fedora Core 2 Updates kernel-2.6.10-1.771_FC2
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 10
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25
26 %define release 1.771_FC2.1.planetlab%{?date:.%{date}}
27
28 %define signmodules 0
29 %define make_target bzImage
30
31 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
32
33 # Override generic defaults with per-arch defaults 
34
35 %define image_install_path boot
36
37 #
38 # Three sets of minimum package version requirements in the form of Conflicts:
39 # to versions below the minimum
40 #
41
42 #
43 # First the general kernel 2.6 required versions as per
44 # Documentation/Changes
45 #
46 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
47
48
49 # Then a series of requirements that are distribution specific, either 
50 # because we add patches for something, or the older versions have 
51 # problems with the newer kernel or lack certain things that make 
52 # integration in the distro harder than needed.
53 #
54 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
55
56 #
57 # Several packages had bugs in them that became obvious when the NPTL
58 # threading code got integrated. 
59 #
60 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
61
62 #
63 # Packages that need to be installed before the kernel is, because the %post
64 # scripts use them.
65 #
66 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
67
68 Vendor: PlanetLab
69 Packager: PlanetLab Central <support@planet-lab.org>
70 Distribution: PlanetLab 3.0
71 URL: http://cvs.planet-lab.org/cvs/linux-2.6
72
73 Name: kernel
74 Group: System Environment/Kernel
75 License: GPLv2
76 Version: %{rpmversion}
77 Release: %{release}
78 ExclusiveOS: Linux
79 Provides: kernel = %{version}
80 Provides: kernel-drm = 4.3.0
81 Prereq: %{kernel_prereq}
82 Conflicts: %{kernel_dot_org_conflicts}
83 Conflicts: %{package_conflicts}
84 Conflicts: %{nptl_conflicts}
85 # We can't let RPM do the dependencies automatic because it'll then pick up
86 # a correct but undesirable perl dependency from the module headers which
87 # isn't required for the kernel proper to function
88 AutoReqProv: no
89
90 #
91 # List the packages used during the kernel build
92 #
93 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
94 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg
95 #BuildPreReq: kernel-utils >= 1:2.4-12.1.142
96 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
97 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
98 BuildArchitectures: i686
99
100
101
102 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
103
104 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
105
106 %description 
107 The kernel package contains the Linux kernel (vmlinuz), the core of any
108 Linux operating system.  The kernel handles the basic functions
109 of the operating system:  memory allocation, process allocation, device
110 input and output, etc.
111
112
113 %package sourcecode
114 Summary: The source code for the Linux kernel.
115 Group: Development/System
116 Prereq: fileutils
117 Requires: make >= 3.78
118 Requires: gcc >= 3.2
119 Requires: /usr/bin/strip
120 # for xconfig and gconfig
121 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
122 Provides: kernel-source
123 Obsoletes: kernel-source <= 2.6.6
124
125 %description sourcecode
126 The kernel-sourcecode package contains the source code files for the Linux
127 kernel. The source files can be used to build a custom kernel that is
128 smaller by virtue of only including drivers for your particular hardware, if
129 you are so inclined (and you know what you're doing). The customisation
130 guide in the documentation describes in detail how to do this. This package
131 is neither needed nor usable for building external kernel modules for
132 linking such modules into the default operating system kernels.
133
134 %package doc
135 Summary: Various documentation bits found in the kernel source.
136 Group: Documentation
137 %if !%{buildsource}
138 Obsoletes: kernel-source <= 2.6.6
139 Obsoletes: kernel-sourcecode <= 2.6.6
140 %endif
141
142 %description doc
143 This package contains documentation files from the kernel
144 source. Various bits of information about the Linux kernel and the
145 device drivers shipped with it are documented in these files. 
146
147 You'll want to install this package if you need a reference to the
148 options that can be passed to Linux kernel modules at load time.
149
150
151 %package smp
152 Summary: The Linux kernel compiled for SMP machines.
153
154 Group: System Environment/Kernel
155 Provides: kernel = %{version}
156 Provides: kernel-drm = 4.3.0
157 Prereq: %{kernel_prereq}
158 Conflicts: %{kernel_dot_org_conflicts}
159 Conflicts: %{package_conflicts}
160 Conflicts: %{nptl_conflicts}
161 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
162 # now that the smp kernel offers this capability, obsolete the old kernel
163 Obsoletes: kernel-enterprise < 2.4.10
164 # We can't let RPM do the dependencies automatic because it'll then pick up
165 # a correct but undesirable perl dependency from the module headers which
166 # isn't required for the kernel proper to function
167 AutoReqProv: no
168
169 %description smp
170 This package includes a SMP version of the Linux kernel. It is
171 required only on machines with two or more CPUs as well as machines with
172 hyperthreading technology.
173
174 Install the kernel-smp package if your machine uses two or more CPUs.
175
176 %package uml
177 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
178
179 Group: System Environment/Kernel
180
181 %description uml
182 This package includes a user mode version of the Linux kernel.
183
184 %package vserver
185 Summary: A placeholder RPM that provides kernel and kernel-drm
186
187 Group: System Environment/Kernel
188 Provides: kernel = %{version}
189 Provides: kernel-drm = 4.3.0
190
191 %description vserver
192 VServers do not require and cannot use kernels, but some RPMs have
193 implicit or explicit dependencies on the "kernel" package
194 (e.g. tcpdump). This package installs no files but provides the
195 necessary dependencies to make rpm and yum happy.
196
197 %prep
198
199 %setup -n linux-%{kversion}
200
201 # make sure the kernel has the sublevel we know it has. This looks weird
202 # but for -pre and -rc versions we need it since we only want to use
203 # the higher version when the final kernel is released.
204 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
205 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
206
207 # get rid of unwanted files resulting from patch fuzz
208 find . -name "*.orig" -exec rm -fv {} \;
209 find . -name "*~" -exec rm -fv {} \;
210
211 ###
212 ### build
213 ###
214 %build
215
216 BuildKernel() {
217
218     # Pick the right config file for the kernel we're building
219     if [ -n "$1" ] ; then
220         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
221     else
222         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
223     fi
224
225     KernelVer=%{version}-%{release}$1
226     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
227
228     # make sure EXTRAVERSION says what we want it to say
229     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
230
231     # override ARCH in the case of UML
232     if [ "$1" = "uml" ] ; then
233         export ARCH=um
234     fi
235
236     # and now to start the build process
237
238     make -s mrproper
239     cp configs/$Config .config
240
241     make -s nonint_oldconfig > /dev/null
242     make -s include/linux/version.h 
243
244     make -s %{?_smp_mflags} %{make_target}
245     make -s %{?_smp_mflags} modules || exit 1
246     make buildcheck
247     
248     # Start installing the results
249
250     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
251     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
252     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
253     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
254     echo "_stext" >> exported
255     echo "_end" >> exported
256     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
257     for i in `cat exported` 
258     do 
259          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
260          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
261          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
262     done
263     rm -f exported
264 #    install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
265     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
266     rm -f System.map
267     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
268
269     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
270     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
271  
272     # And save the headers/makefiles etc for building modules against
273     #
274     # This all looks scary, but the end result is supposed to be:
275     # * all arch relevant include/ files
276     # * all Makefile/Kconfig files
277     # * all script/ files 
278
279     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
280     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
281     # first copy everything
282     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
283     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
284     # then drop all but the needed Makefiles/Kconfig files
285     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
286     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
287     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
288     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
289     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
290     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
291     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
292     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
293     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
294     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
295     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
296     cd include
297     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
298     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
299     # Make sure the Makefile and version.h have a matching timestamp so that
300     # external modules can be built
301     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
302     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
303     cd .. 
304
305     #
306     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
307     #
308     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
309     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
310
311     # mark modules executable so that strip-to-file can strip them
312     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
313
314     # detect missing or incorrect license tags
315     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
316     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
317     rm -f modinfo
318     # remove files that will be auto generated by depmod at rpm -i time
319     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
320
321 }
322
323 ###
324 # DO it...
325 ###
326
327 # prepare directories
328 rm -rf $RPM_BUILD_ROOT
329 mkdir -p $RPM_BUILD_ROOT/boot
330
331 %if %{buildup}
332 BuildKernel
333 %endif
334
335 %if %{buildsmp}
336 BuildKernel smp
337 %endif
338
339 %if %{builduml}
340 BuildKernel uml
341 %endif
342
343 ###
344 ### install
345 ###
346
347 %install
348
349 # architectures that don't get kernel-source (i586/i686/athlon) dont need
350 # much of an install because the build phase already copied the needed files
351
352 %if %{builddoc}
353 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
354
355 # sometimes non-world-readable files sneak into the kernel source tree
356 chmod -R a+r *
357 # copy the source over
358 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
359 %endif
360
361 %if %{buildsource}
362
363 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
364 chmod -R a+r *
365
366 # clean up the source tree so that it is ready for users to build their own
367 # kernel
368 make -s mrproper
369 # copy the source over
370 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
371
372 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
373 # don't accidentally overwrite their currently working moduleset and hose
374 # their system
375 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
376
377 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
378 # change those to values that are more appropriate as defeault for people who build their own kernel.
379 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
380 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
381 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
382 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
383 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
384 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
385
386 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
387 %endif
388
389 ###
390 ### clean
391 ###
392
393 %clean
394 rm -rf $RPM_BUILD_ROOT
395
396 ###
397 ### scripts
398 ###
399
400 # load the loop module for upgrades...in case the old modules get removed we have
401 # loopback in the kernel so that mkinitrd will work.
402 %pre 
403 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
404 exit 0
405
406 %pre smp
407 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
408 exit 0
409
410 %post 
411 # trick mkinitrd in case the current environment does not have device mapper
412 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
413 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
414     if [ ! -f $rootdev ]; then
415         fake_root_lvm=1
416         mkdir -p $(dirname $rootdev)
417         touch $rootdev
418     fi
419 fi
420 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
421 if [ -n "$fake_root_lvm" ]; then
422     rm -f $rootdev
423 fi
424 if [ -x /usr/sbin/hardlink ] ; then
425 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
426         cd /lib/modules/%{KVERREL}/build
427         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
428 }
429 popd
430 fi
431
432 # make some useful links
433 pushd /boot > /dev/null ; {
434         ln -sf System.map-%{KVERREL} System.map
435 #       ln -sf Kerntypes-%{KVERREL} Kerntypes
436         ln -sf config-%{KVERREL} config
437         ln -sf initrd-%{KVERREL}.img initrd-boot
438         ln -sf vmlinuz-%{KVERREL} kernel-boot
439 }
440 popd
441
442 # ask for a reboot
443 mkdir -p /etc/planetlab
444 touch /etc/planetlab/update-reboot
445
446 %post smp
447 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
448 if [ -x /usr/sbin/hardlink ] ; then
449 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
450         cd /lib/modules/%{KVERREL}smp/build
451         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
452 }
453 popd
454 fi
455
456
457 %preun 
458 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
459 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
460
461 %preun smp
462 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
463 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
464
465
466 ###
467 ### file lists
468 ###
469
470 %if %{buildup}
471 %files 
472 %defattr(-,root,root)
473 /%{image_install_path}/vmlinuz-%{KVERREL}
474 #/boot/Kerntypes-%{KVERREL}
475 /boot/System.map-%{KVERREL}
476 /boot/config-%{KVERREL}
477 %dir /lib/modules/%{KVERREL}
478 /lib/modules/%{KVERREL}/kernel
479 %verify(not mtime) /lib/modules/%{KVERREL}/build
480
481 %endif
482
483 %if %{buildsmp}
484 %files smp
485 %defattr(-,root,root)
486 /%{image_install_path}/vmlinuz-%{KVERREL}smp
487 #/boot/Kerntypes-%{KVERREL}smp
488 /boot/System.map-%{KVERREL}smp
489 /boot/config-%{KVERREL}smp
490 %dir /lib/modules/%{KVERREL}smp
491 /lib/modules/%{KVERREL}smp/kernel
492 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
493
494 %endif
495
496 %if %{builduml}
497 %files uml
498 %defattr(-,root,root)
499
500 %endif
501
502 # only some architecture builds need kernel-source and kernel-doc
503
504 %if %{buildsource}
505 %files sourcecode
506 %defattr(-,root,root)
507 /usr/src/linux-%{KVERREL}/
508 %endif
509
510
511 %if %{builddoc}
512 %files doc
513 %defattr(-,root,root)
514 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
515 %endif
516
517
518 %files vserver
519 %defattr(-,root,root)
520 # no files
521
522 %changelog
523 * Thu Feb 17 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
524 - merge to Fedora Core 2 2.6.10-1.14_FC2
525
526 * Tue Feb 8 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
527 - merge to Fedora Core 2 2.6.10-1.12_FC2
528
529 * Tue Jan 18 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
530 - merge to Fedora Core 2 2.6.9-1.11_FC2
531
532 * Thu Sep 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
533 - merge to Fedora Core 2 2.6.8-1.521
534
535 * Tue Aug 31 2004 Arjan van de Ven <arjanv@redhat.com>
536 - fix execshield buglet with legacy binaries
537 - 2.6.9-rc1-bk7
538
539 * Mon Aug 30 2004 Arjan van de Ven <arjanv@redhat.com>
540 - 2.6.9-rc1-bk6
541
542 * Sat Aug 28 2004 Arjan van de Ven <arjanv@redhat.com>
543 - 2.6.9-rc1-bk4, now with i915 DRM driver
544
545 * Fri Aug 27 2004 Arjan van de Ven <arjanv@redhat.com>
546 - 2.6.9-rc1-bk2 
547
548 * Mon Aug 23 2004 Arjan van de Ven <arjanv@redhat.com>
549 - 2.6.8.1-bk2
550
551 * Sat Aug 21 2004 Arjan van de Ven <arjanv@redhat.com>
552 - attempt to fix early-udev bug
553
554 * Fri Aug 13 2004 Arjan van de Ven <arjanv@redhat.com>
555 - 2.6.8-rc4-bk3
556 - split execshield up some more
557
558 * Fri Aug 13 2004 Dave Jones <davej@redhat.com>
559 - Update SCSI whitelist again with some more card readers.
560
561 * Mon Aug 9 2004 Arjan van de Ven <arjanv@redhat.com>
562 - 2.6.8-rc3-bk3
563
564 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
565 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
566   sections, most non-x86 sections, and GPG sections)
567
568 * Wed Aug 4 2004 Arjan van de Ven <arjanv@redhat.com>
569 - Add the flex-mmap bits for s390/s390x (Pete Zaitcev)
570 - Add flex-mmap for x86-64 32 bit emulation
571 - 2.6.8-rc3
572
573 * Mon Aug 2 2004 Arjan van de Ven <arjanv@redhat.com>
574 - Add Rik's token trashing control patch
575
576 * Sun Aug 1 2004 Arjan van de Ven <arjanv@redhat.com>
577 - 2.6.8-rc2-bk11
578
579 * Fri Jul 30 2004 Arjan van de Ven <arjanv@redhat.com>
580 - 2.6.8-rc2-bk8
581
582 * Wed Jul 28 2004 Arjan van de Ven <arjanv@redhat.com>
583 - 2.6.8-rc2-bk6
584 - make a start at splitting up the execshield patchkit
585
586 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
587 - ppc32 embedded updates
588
589 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
590 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
591 - 2.6.8-rc1-bk4
592
593 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
594 - 2.6.8-rc1-bk3
595
596 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
597 - add "enforcemodulesig" boot option to make the kernel load signed modules only
598
599 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
600 - updated voluntary preempt
601 - 2.6.8-rc1
602
603 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
604 - fix boot breakage that was hitting lots of people (Dave Jones)
605
606 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
607 - add voluntary preemption patch from Ingo
608 - 2.6.7-bk19
609
610 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
611 - make a start at gpg signed modules support
612
613 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
614 - experiment with making the hardlink call in post more efficient
615 - 2.6.7-bk9
616
617 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
618 - 2.6.7-bk7
619 - Add wli's patch to allocate memory bottom up not top down
620 - change some config options in the kernel-sourcecode package that are
621   good for rpm kernel builds but not for custom user builds to more appropriate 
622   default values.
623 - reenable kernel-sourcecode again for a few builds 
624
625 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
626 - 2.6.7-bk5
627 - fix tux unresolved symbols (#126532)
628
629 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
630 - make kernel-doc and kernel-sourcecode builds independent of eachother
631 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
632   on how to use the src.rpm instead for building your own kernel.
633
634 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
635 - 2.6.7-bk2
636
637 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
638 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
639
640 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
641 - add fix from Andi Kleen/Linus for the fpu-DoS
642
643 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
644 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
645 - revert airo driver to the FC2 one since the new one breaks
646
647 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
648 - Update to 2.6.7rc3
649
650 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
651 - fix the mlock-uses-rlimit patch
652
653 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
654 - Add ppc64 (Mac G5)
655
656 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
657 - add a forward port of the mlock-uses-rlimit patch
658 - add NX support for x86 (Intel, Ingo)
659
660 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
661 - refresh ext3 reservation patch
662
663 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
664 - 2.6.7-rc2
665 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
666
667 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
668 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
669
670 * Thu May 27 2004 Dave Jones <davej@redhat.com>
671 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
672
673 * Wed May 26 2004 Dave Jones <davej@redhat.com>
674 - Lots more updates to the SCSI whitelist for various
675   USB card readers. (#112778, among others..)
676
677 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
678 - back out ehci suspend/resume patch, it breaks
679 - add fix for 3c59x-meets-kudzu bug from Alan
680
681 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
682 - try improving suspend/resume by restoring more PCI state
683 - 2.6.7-rc1-bk1
684
685 * Mon May 24 2004 Dave Jones <davej@redhat.com>
686 - Add yet another multi-card reader to the whitelist (#85851)
687
688 * Sun May 23 2004 Dave Jones <davej@redhat.com>
689 - Add another multi-card reader to the whitelist (#124048)
690
691 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
692 - put firewire race fix in (datacorruptor)
693
694 * Tue May 18 2004 Dave Jones <davej@redhat.com>
695 - Fix typo in ibmtr driver preventing compile (#123391)
696
697 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
698 - update to 2.6.6-bk3
699 - made kernel-source and kernel-doc noarch.rpm's since they are not
700   architecture specific.
701
702 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
703 - fix non-booting on Transmeta cpus (Peter Anvin)
704 - fix count leak in message queues
705
706 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
707 - more ide cache flush work
708 - patch from scsi-bk to fix sd refcounting
709
710 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
711 - some more ide cache flush fixes 
712
713 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
714 - fix bug 122504
715 - convert b44 to ethtool ops (jgarzik)
716 - make IDE do a cache-flush on shutdown (me/Alan)
717
718 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
719 - work around i810/i830 DRM issue
720
721 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
722 - 2.6.6-rc3-bk1
723 - make amd64 boot again
724 - fix vm86-vs-4g4g interaction (Ingo)
725
726 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
727 - 2.6.6-rc2
728  
729 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
730 - add the ext3 online resize patch
731
732 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
733 - 2.6.6-rc1-bk3
734 - add the objrmap vm from the -mm tree; it needs testing
735
736 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
737 - 2.6.5-bk2
738 - disable DISCONTIGMEM on ia64 for performance
739 - fix sleep_on use in reiserfs (Chris Mason)
740
741 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
742 - 2.6.5-mc4
743 - reenable sg driver for scsi tape changers and such
744 - the sk98lin driver oopses on module unload, preven that
745
746 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
747 - fix "bad pmd" bug with patch from Ingo
748
749 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
750 - 2.6.5-mc3
751 - finish up the -mc2 merge
752 - latest 4g/4g patch from Ingo
753 - latest execshield patch from Ingo
754 - fix a few framebuffer bugs
755
756 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
757 - first attempt at a 2.6.5-mc2 merge
758
759 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
760 - Add in missing SiS AGP fix.
761
762 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
763 - More agpgart fixes.
764
765 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
766 - fix another 4g/4g-vs-resume bug
767
768 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
769 - 2.6.5-rc3
770 - fix PCI posting bug in i830 DRM
771
772 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
773 - 2.6.5-rc2-bk8
774
775 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
776 - Include latest agpgart fixes.
777
778 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
779 - more DRM fixes
780 - add the fsync patches from akpm
781
782 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
783 - 2.6.5-rc2-bk3
784 - fix direct userspace memory access in i830 drm driver
785
786 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
787 - 2.6.5-rc2-bk2
788 - some stackbloat reductions from Dave and me
789
790 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
791 - 2.6.5-rc2
792
793 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
794 - 2.6.5-rc1
795
796 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
797 - 2.6.4-bk3
798 - fix oops in toshiba_acpi (Barry K. Nathan)
799
800 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
801 - 2.6.4-bk2 merge 
802
803 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
804 - renable sonypi driver that was off accidentally
805 - 2.6.4-final 
806 - fix the oops on alsa module unloads
807
808 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
809 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
810 - 2.6.4-rc3 
811
812 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
813 - 2.6.4-rc2-bk5
814 - fix nfs-vs-selinux issue
815 - fix typo in URL as per #117849
816
817 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
818 - fix race in lp.c (#117710)
819 - 2.6.4-rc2-bk3
820 - attempt to fix S3 suspend-to-ram with 4g/4g split
821
822 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
823 - fix reiserfs
824 - set HZ to 1000 again for some tests
825
826 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
827 - merge back a bunch of fedora fixes
828 - disable audit
829
830 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
831 - audit bugfixes
832 - update tux to a working version
833 - 2.6.3-bk5 merge
834
835 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
836 - re-add and enable the Auditing patch
837 - switch several cpufreq modules to built in since detecting in userspace
838   which to use is unpleasant
839 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
840 - 2.6 start 
841