- include the Fedora release number so that Fedora kernels don't defeat
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 8
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.521.1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Name: kernel
66 Group: System Environment/Kernel
67 License: GPLv2
68 Version: %{rpmversion}
69 Release: %{release}
70 ExclusiveOS: Linux
71 Provides: kernel = %{version}
72 Provides: kernel-drm = 4.3.0
73 Prereq: %{kernel_prereq}
74 Conflicts: %{kernel_dot_org_conflicts}
75 Conflicts: %{package_conflicts}
76 Conflicts: %{nptl_conflicts}
77 # We can't let RPM do the dependencies automatic because it'll then pick up
78 # a correct but undesirable perl dependency from the module headers which
79 # isn't required for the kernel proper to function
80 AutoReqProv: no
81
82 #
83 # List the packages used during the kernel build
84 #
85 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
86 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg
87 #BuildPreReq: kernel-utils >= 1:2.4-12.1.142
88 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
89 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
90 BuildArchitectures: i686
91
92
93
94 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
95
96 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
97
98 %description 
99 The kernel package contains the Linux kernel (vmlinuz), the core of any
100 Linux operating system.  The kernel handles the basic functions
101 of the operating system:  memory allocation, process allocation, device
102 input and output, etc.
103
104
105 %package sourcecode
106 Summary: The source code for the Linux kernel.
107 Group: Development/System
108 Prereq: fileutils
109 Requires: make >= 3.78
110 Requires: gcc >= 3.2
111 Requires: /usr/bin/strip
112 # for xconfig and gconfig
113 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
114 Provides: kernel-source
115 Obsoletes: kernel-source <= 2.6.6
116
117 %description sourcecode
118 The kernel-sourcecode package contains the source code files for the Linux
119 kernel. The source files can be used to build a custom kernel that is
120 smaller by virtue of only including drivers for your particular hardware, if
121 you are so inclined (and you know what you're doing). The customisation
122 guide in the documentation describes in detail how to do this. This package
123 is neither needed nor usable for building external kernel modules for
124 linking such modules into the default operating system kernels.
125
126 %package doc
127 Summary: Various documentation bits found in the kernel source.
128 Group: Documentation
129 %if !%{buildsource}
130 Obsoletes: kernel-source <= 2.6.6
131 Obsoletes: kernel-sourcecode <= 2.6.6
132 %endif
133
134 %description doc
135 This package contains documentation files from the kernel
136 source. Various bits of information about the Linux kernel and the
137 device drivers shipped with it are documented in these files. 
138
139 You'll want to install this package if you need a reference to the
140 options that can be passed to Linux kernel modules at load time.
141
142
143 %package smp
144 Summary: The Linux kernel compiled for SMP machines.
145
146 Group: System Environment/Kernel
147 Provides: kernel = %{version}
148 Provides: kernel-drm = 4.3.0
149 Prereq: %{kernel_prereq}
150 Conflicts: %{kernel_dot_org_conflicts}
151 Conflicts: %{package_conflicts}
152 Conflicts: %{nptl_conflicts}
153 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
154 # now that the smp kernel offers this capability, obsolete the old kernel
155 Obsoletes: kernel-enterprise < 2.4.10
156 # We can't let RPM do the dependencies automatic because it'll then pick up
157 # a correct but undesirable perl dependency from the module headers which
158 # isn't required for the kernel proper to function
159 AutoReqProv: no
160
161 %description smp
162 This package includes a SMP version of the Linux kernel. It is
163 required only on machines with two or more CPUs as well as machines with
164 hyperthreading technology.
165
166 Install the kernel-smp package if your machine uses two or more CPUs.
167
168 %package uml
169 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
170
171 Group: System Environment/Kernel
172
173 %description uml
174 This package includes a user mode version of the Linux kernel.
175
176 %prep
177
178 %setup -n linux-%{kversion}
179
180 # make sure the kernel has the sublevel we know it has. This looks weird
181 # but for -pre and -rc versions we need it since we only want to use
182 # the higher version when the final kernel is released.
183 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
184 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
185
186 # get rid of unwanted files resulting from patch fuzz
187 find . -name "*.orig" -exec rm -fv {} \;
188 find . -name "*~" -exec rm -fv {} \;
189
190 ###
191 ### build
192 ###
193 %build
194
195 BuildKernel() {
196
197     # Pick the right config file for the kernel we're building
198     if [ -n "$1" ] ; then
199         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
200     else
201         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
202     fi
203
204     KernelVer=%{version}-%{release}$1
205     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
206
207     # make sure EXTRAVERSION says what we want it to say
208     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
209
210     # override ARCH in the case of UML
211     if [ "$1" = "uml" ] ; then
212         export ARCH=um
213     fi
214
215     # and now to start the build process
216
217     make -s mrproper
218     cp configs/$Config .config
219
220     make -s nonint_oldconfig > /dev/null
221     make -s include/linux/version.h 
222
223     make -s %{?_smp_mflags} bzImage 
224     make -s %{?_smp_mflags} modules || exit 1
225     make buildcheck
226     
227     # Start installing the results
228
229     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
230     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
231     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
232     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
233     echo "_stext" >> exported
234     echo "_end" >> exported
235     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
236     for i in `cat exported` 
237     do 
238          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
239          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
240          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
241     done
242     rm -f exported
243     install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
244     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
245     rm -f System.map
246     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
247
248     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
249     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
250  
251     # And save the headers/makefiles etc for building modules against
252     #
253     # This all looks scary, but the end result is supposed to be:
254     # * all arch relevant include/ files
255     # * all Makefile/Kconfig files
256     # * all script/ files 
257
258     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
259     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
260     # first copy everything
261     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
262     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
263     # then drop all but the needed Makefiles/Kconfig files
264     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
265     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
266     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
267     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
268     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
269     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
270     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
271     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
272     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
273     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
274     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
275     cd include
276     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
277     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
278     # Make sure the Makefile and version.h have a matching timestamp so that
279     # external modules can be built
280     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
281     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
282     cd .. 
283
284     #
285     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
286     #
287     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
288     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
289
290     # mark modules executable so that strip-to-file can strip them
291     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
292
293     # detect missing or incorrect license tags
294     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
295     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
296     rm -f modinfo
297     # remove files that will be auto generated by depmod at rpm -i time
298     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
299
300 }
301
302 ###
303 # DO it...
304 ###
305
306 # prepare directories
307 rm -rf $RPM_BUILD_ROOT
308 mkdir -p $RPM_BUILD_ROOT/boot
309
310 %if %{buildup}
311 BuildKernel
312 %endif
313
314 %if %{buildsmp}
315 BuildKernel smp
316 %endif
317
318 %if %{builduml}
319 BuildKernel uml
320 %endif
321
322 ###
323 ### install
324 ###
325
326 %install
327
328 # architectures that don't get kernel-source (i586/i686/athlon) dont need
329 # much of an install because the build phase already copied the needed files
330
331 %if %{builddoc}
332 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
333
334 # sometimes non-world-readable files sneak into the kernel source tree
335 chmod -R a+r *
336 # copy the source over
337 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
338 %endif
339
340 %if %{buildsource}
341
342 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
343 chmod -R a+r *
344
345 # clean up the source tree so that it is ready for users to build their own
346 # kernel
347 make -s mrproper
348 # copy the source over
349 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
350
351 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
352 # don't accidentally overwrite their currently working moduleset and hose
353 # their system
354 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
355
356 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
357 # change those to values that are more appropriate as defeault for people who build their own kernel.
358 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
359 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
360 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
361 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
362 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
363 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
364
365 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
366 %endif
367
368 ###
369 ### clean
370 ###
371
372 %clean
373 rm -rf $RPM_BUILD_ROOT
374
375 ###
376 ### scripts
377 ###
378
379 # load the loop module for upgrades...in case the old modules get removed we have
380 # loopback in the kernel so that mkinitrd will work.
381 %pre 
382 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
383 exit 0
384
385 %pre smp
386 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
387 exit 0
388
389 %post 
390 # trick mkinitrd in case the current environment does not have device mapper
391 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
392 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
393     if [ ! -f $rootdev ]; then
394         fake_root_lvm=1
395         mkdir -p $(dirname $rootdev)
396         touch $rootdev
397     fi
398 fi
399 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
400 if [ -n "$fake_root_lvm" ]; then
401     rm -f $rootdev
402 fi
403 if [ -x /usr/sbin/hardlink ] ; then
404 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
405         cd /lib/modules/%{KVERREL}/build
406         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
407 }
408 popd
409 fi
410
411 # make some useful links
412 pushd /boot > /dev/null ; {
413         ln -sf System.map-%{KVERREL} System.map
414         ln -sf Kerntypes-%{KVERREL} Kerntypes
415         ln -sf config-%{KVERREL} config
416         ln -sf initrd-%{KVERREL}.img initrd-boot
417         ln -sf vmlinuz-%{KVERREL} kernel-boot
418 }
419 popd
420
421 # ask for a reboot
422 mkdir -p /etc/planetlab
423 touch /etc/planetlab/update-reboot
424
425 %post smp
426 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
427 if [ -x /usr/sbin/hardlink ] ; then
428 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
429         cd /lib/modules/%{KVERREL}smp/build
430         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
431 }
432 popd
433 fi
434
435
436 %preun 
437 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
438 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
439
440 %preun smp
441 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
442 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
443
444
445 ###
446 ### file lists
447 ###
448
449 %if %{buildup}
450 %files 
451 %defattr(-,root,root)
452 /%{image_install_path}/vmlinuz-%{KVERREL}
453 /boot/Kerntypes-%{KVERREL}
454 /boot/System.map-%{KVERREL}
455 /boot/config-%{KVERREL}
456 %dir /lib/modules/%{KVERREL}
457 /lib/modules/%{KVERREL}/kernel
458 %verify(not mtime) /lib/modules/%{KVERREL}/build
459
460 %endif
461
462 %if %{buildsmp}
463 %files smp
464 %defattr(-,root,root)
465 /%{image_install_path}/vmlinuz-%{KVERREL}smp
466 /boot/Kerntypes-%{KVERREL}smp
467 /boot/System.map-%{KVERREL}smp
468 /boot/config-%{KVERREL}smp
469 %dir /lib/modules/%{KVERREL}smp
470 /lib/modules/%{KVERREL}smp/kernel
471 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
472
473 %endif
474
475 %if %{builduml}
476 %files uml
477 %defattr(-,root,root)
478
479 %endif
480
481 # only some architecture builds need kernel-source and kernel-doc
482
483 %if %{buildsource}
484 %files sourcecode
485 %defattr(-,root,root)
486 /usr/src/linux-%{KVERREL}/
487 %endif
488
489
490 %if %{builddoc}
491 %files doc
492 %defattr(-,root,root)
493 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
494 %endif
495
496 %changelog
497 * Thu Sep 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
498 - merge to Fedora Core 2 2.6.8-1.521
499
500 * Tue Aug 31 2004 Arjan van de Ven <arjanv@redhat.com>
501 - fix execshield buglet with legacy binaries
502 - 2.6.9-rc1-bk7
503
504 * Mon Aug 30 2004 Arjan van de Ven <arjanv@redhat.com>
505 - 2.6.9-rc1-bk6
506
507 * Sat Aug 28 2004 Arjan van de Ven <arjanv@redhat.com>
508 - 2.6.9-rc1-bk4, now with i915 DRM driver
509
510 * Fri Aug 27 2004 Arjan van de Ven <arjanv@redhat.com>
511 - 2.6.9-rc1-bk2 
512
513 * Mon Aug 23 2004 Arjan van de Ven <arjanv@redhat.com>
514 - 2.6.8.1-bk2
515
516 * Sat Aug 21 2004 Arjan van de Ven <arjanv@redhat.com>
517 - attempt to fix early-udev bug
518
519 * Fri Aug 13 2004 Arjan van de Ven <arjanv@redhat.com>
520 - 2.6.8-rc4-bk3
521 - split execshield up some more
522
523 * Fri Aug 13 2004 Dave Jones <davej@redhat.com>
524 - Update SCSI whitelist again with some more card readers.
525
526 * Mon Aug 9 2004 Arjan van de Ven <arjanv@redhat.com>
527 - 2.6.8-rc3-bk3
528
529 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
530 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
531   sections, most non-x86 sections, and GPG sections)
532
533 * Wed Aug 4 2004 Arjan van de Ven <arjanv@redhat.com>
534 - Add the flex-mmap bits for s390/s390x (Pete Zaitcev)
535 - Add flex-mmap for x86-64 32 bit emulation
536 - 2.6.8-rc3
537
538 * Mon Aug 2 2004 Arjan van de Ven <arjanv@redhat.com>
539 - Add Rik's token trashing control patch
540
541 * Sun Aug 1 2004 Arjan van de Ven <arjanv@redhat.com>
542 - 2.6.8-rc2-bk11
543
544 * Fri Jul 30 2004 Arjan van de Ven <arjanv@redhat.com>
545 - 2.6.8-rc2-bk8
546
547 * Wed Jul 28 2004 Arjan van de Ven <arjanv@redhat.com>
548 - 2.6.8-rc2-bk6
549 - make a start at splitting up the execshield patchkit
550
551 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
552 - ppc32 embedded updates
553
554 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
555 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
556 - 2.6.8-rc1-bk4
557
558 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
559 - 2.6.8-rc1-bk3
560
561 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
562 - add "enforcemodulesig" boot option to make the kernel load signed modules only
563
564 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
565 - updated voluntary preempt
566 - 2.6.8-rc1
567
568 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
569 - fix boot breakage that was hitting lots of people (Dave Jones)
570
571 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
572 - add voluntary preemption patch from Ingo
573 - 2.6.7-bk19
574
575 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
576 - make a start at gpg signed modules support
577
578 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
579 - experiment with making the hardlink call in post more efficient
580 - 2.6.7-bk9
581
582 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
583 - 2.6.7-bk7
584 - Add wli's patch to allocate memory bottom up not top down
585 - change some config options in the kernel-sourcecode package that are
586   good for rpm kernel builds but not for custom user builds to more appropriate 
587   default values.
588 - reenable kernel-sourcecode again for a few builds 
589
590 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
591 - 2.6.7-bk5
592 - fix tux unresolved symbols (#126532)
593
594 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
595 - make kernel-doc and kernel-sourcecode builds independent of eachother
596 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
597   on how to use the src.rpm instead for building your own kernel.
598
599 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
600 - 2.6.7-bk2
601
602 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
603 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
604
605 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
606 - add fix from Andi Kleen/Linus for the fpu-DoS
607
608 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
609 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
610 - revert airo driver to the FC2 one since the new one breaks
611
612 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
613 - Update to 2.6.7rc3
614
615 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
616 - fix the mlock-uses-rlimit patch
617
618 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
619 - Add ppc64 (Mac G5)
620
621 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
622 - add a forward port of the mlock-uses-rlimit patch
623 - add NX support for x86 (Intel, Ingo)
624
625 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
626 - refresh ext3 reservation patch
627
628 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
629 - 2.6.7-rc2
630 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
631
632 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
633 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
634
635 * Thu May 27 2004 Dave Jones <davej@redhat.com>
636 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
637
638 * Wed May 26 2004 Dave Jones <davej@redhat.com>
639 - Lots more updates to the SCSI whitelist for various
640   USB card readers. (#112778, among others..)
641
642 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
643 - back out ehci suspend/resume patch, it breaks
644 - add fix for 3c59x-meets-kudzu bug from Alan
645
646 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
647 - try improving suspend/resume by restoring more PCI state
648 - 2.6.7-rc1-bk1
649
650 * Mon May 24 2004 Dave Jones <davej@redhat.com>
651 - Add yet another multi-card reader to the whitelist (#85851)
652
653 * Sun May 23 2004 Dave Jones <davej@redhat.com>
654 - Add another multi-card reader to the whitelist (#124048)
655
656 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
657 - put firewire race fix in (datacorruptor)
658
659 * Tue May 18 2004 Dave Jones <davej@redhat.com>
660 - Fix typo in ibmtr driver preventing compile (#123391)
661
662 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
663 - update to 2.6.6-bk3
664 - made kernel-source and kernel-doc noarch.rpm's since they are not
665   architecture specific.
666
667 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
668 - fix non-booting on Transmeta cpus (Peter Anvin)
669 - fix count leak in message queues
670
671 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
672 - more ide cache flush work
673 - patch from scsi-bk to fix sd refcounting
674
675 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
676 - some more ide cache flush fixes 
677
678 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
679 - fix bug 122504
680 - convert b44 to ethtool ops (jgarzik)
681 - make IDE do a cache-flush on shutdown (me/Alan)
682
683 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
684 - work around i810/i830 DRM issue
685
686 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
687 - 2.6.6-rc3-bk1
688 - make amd64 boot again
689 - fix vm86-vs-4g4g interaction (Ingo)
690
691 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
692 - 2.6.6-rc2
693  
694 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
695 - add the ext3 online resize patch
696
697 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
698 - 2.6.6-rc1-bk3
699 - add the objrmap vm from the -mm tree; it needs testing
700
701 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
702 - 2.6.5-bk2
703 - disable DISCONTIGMEM on ia64 for performance
704 - fix sleep_on use in reiserfs (Chris Mason)
705
706 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
707 - 2.6.5-mc4
708 - reenable sg driver for scsi tape changers and such
709 - the sk98lin driver oopses on module unload, preven that
710
711 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
712 - fix "bad pmd" bug with patch from Ingo
713
714 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
715 - 2.6.5-mc3
716 - finish up the -mc2 merge
717 - latest 4g/4g patch from Ingo
718 - latest execshield patch from Ingo
719 - fix a few framebuffer bugs
720
721 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
722 - first attempt at a 2.6.5-mc2 merge
723
724 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
725 - Add in missing SiS AGP fix.
726
727 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
728 - More agpgart fixes.
729
730 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
731 - fix another 4g/4g-vs-resume bug
732
733 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
734 - 2.6.5-rc3
735 - fix PCI posting bug in i830 DRM
736
737 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
738 - 2.6.5-rc2-bk8
739
740 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
741 - Include latest agpgart fixes.
742
743 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
744 - more DRM fixes
745 - add the fsync patches from akpm
746
747 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
748 - 2.6.5-rc2-bk3
749 - fix direct userspace memory access in i830 drm driver
750
751 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
752 - 2.6.5-rc2-bk2
753 - some stackbloat reductions from Dave and me
754
755 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
756 - 2.6.5-rc2
757
758 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
759 - 2.6.5-rc1
760
761 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
762 - 2.6.4-bk3
763 - fix oops in toshiba_acpi (Barry K. Nathan)
764
765 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
766 - 2.6.4-bk2 merge 
767
768 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
769 - renable sonypi driver that was off accidentally
770 - 2.6.4-final 
771 - fix the oops on alsa module unloads
772
773 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
774 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
775 - 2.6.4-rc3 
776
777 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
778 - 2.6.4-rc2-bk5
779 - fix nfs-vs-selinux issue
780 - fix typo in URL as per #117849
781
782 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
783 - fix race in lp.c (#117710)
784 - 2.6.4-rc2-bk3
785 - attempt to fix S3 suspend-to-ram with 4g/4g split
786
787 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
788 - fix reiserfs
789 - set HZ to 1000 again for some tests
790
791 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
792 - merge back a bunch of fedora fixes
793 - disable audit
794
795 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
796 - audit bugfixes
797 - update tux to a working version
798 - 2.6.3-bk5 merge
799
800 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
801 - re-add and enable the Auditing patch
802 - switch several cpufreq modules to built in since detecting in userspace
803   which to use is unpleasant
804 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
805 - 2.6 start 
806