- nuke all_x86
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 7
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Name: kernel
66 Group: System Environment/Kernel
67 License: GPLv2
68 Version: %{rpmversion}
69 Release: %{release}
70 ExclusiveOS: Linux
71 Provides: kernel = %{version}
72 Provides: kernel-drm = 4.3.0
73 Prereq: %{kernel_prereq}
74 Conflicts: %{kernel_dot_org_conflicts}
75 Conflicts: %{package_conflicts}
76 Conflicts: %{nptl_conflicts}
77 # We can't let RPM do the dependencies automatic because it'll then pick up
78 # a correct but undesirable perl dependency from the module headers which
79 # isn't required for the kernel proper to function
80 AutoReqProv: no
81
82 #
83 # List the packages used during the kernel build
84 #
85 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
86 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, kernel-utils >= 2.4-12.1.139
87 # temporary req since modutils changed output format 
88 #BuildPreReq: modutils >= 2.4.26-14
89 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
90 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
91
92
93
94 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
95
96 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
97
98 %description 
99 The kernel package contains the Linux kernel (vmlinuz), the core of any
100 Linux operating system.  The kernel handles the basic functions
101 of the operating system:  memory allocation, process allocation, device
102 input and output, etc.
103
104
105 %package sourcecode
106 Summary: The source code for the Linux kernel.
107 Group: Development/System
108 Prereq: fileutils
109 Requires: make >= 3.78
110 Requires: gcc >= 3.2
111 Requires: /usr/bin/strip
112 # for xconfig and gconfig
113 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
114 Provides: kernel-source
115 Obsoletes: kernel-source <= 2.6.6
116
117 %description sourcecode
118 The kernel-sourcecode package contains the source code files for the Linux
119 kernel. The source files can be used to build a custom kernel that is
120 smaller by virtue of only including drivers for your particular hardware, if
121 you are so inclined (and you know what you're doing). The customisation
122 guide in the documentation describes in detail how to do this. This package
123 is neither needed nor usable for building external kernel modules for
124 linking such modules into the default operating system kernels.
125
126 %package doc
127 Summary: Various documentation bits found in the kernel source.
128 Group: Documentation
129 %if !%{buildsource}
130 Obsoletes: kernel-source <= 2.6.6
131 Obsoletes: kernel-sourcecode <= 2.6.6
132 %endif
133
134 %description doc
135 This package contains documentation files from the kernel
136 source. Various bits of information about the Linux kernel and the
137 device drivers shipped with it are documented in these files. 
138
139 You'll want to install this package if you need a reference to the
140 options that can be passed to Linux kernel modules at load time.
141
142
143 %package smp
144 Summary: The Linux kernel compiled for SMP machines.
145
146 Group: System Environment/Kernel
147 Provides: kernel = %{version}
148 Provides: kernel-drm = 4.3.0
149 Prereq: %{kernel_prereq}
150 Conflicts: %{kernel_dot_org_conflicts}
151 Conflicts: %{package_conflicts}
152 Conflicts: %{nptl_conflicts}
153 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
154 # now that the smp kernel offers this capability, obsolete the old kernel
155 Obsoletes: kernel-enterprise < 2.4.10
156 # We can't let RPM do the dependencies automatic because it'll then pick up
157 # a correct but undesirable perl dependency from the module headers which
158 # isn't required for the kernel proper to function
159 AutoReqProv: no
160
161 %description smp
162 This package includes a SMP version of the Linux kernel. It is
163 required only on machines with two or more CPUs as well as machines with
164 hyperthreading technology.
165
166 Install the kernel-smp package if your machine uses two or more CPUs.
167
168 %package uml
169 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
170
171 Group: System Environment/Kernel
172
173 %description uml
174 This package includes a user mode version of the Linux kernel.
175
176 %prep
177
178 %setup -n linux-%{kversion}
179
180 # make sure the kernel has the sublevel we know it has. This looks weird
181 # but for -pre and -rc versions we need it since we only want to use
182 # the higher version when the final kernel is released.
183 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
184 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
185
186 # get rid of unwanted files resulting from patch fuzz
187 find . -name "*.orig" -exec rm -fv {} \;
188 find . -name "*~" -exec rm -fv {} \;
189
190 ###
191 ### build
192 ###
193 %build
194
195 BuildKernel() {
196
197     # Pick the right config file for the kernel we're building
198     if [ -n "$1" ] ; then
199         Config=kernel-%{kversion}-i686-$1-planetlab.config
200     else
201         Config=kernel-%{kversion}-i686-planetlab.config
202     fi
203
204     KernelVer=%{version}-%{release}$1
205     echo BUILDING A KERNEL FOR $1 i686...
206
207     # make sure EXTRAVERSION says what we want it to say
208     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
209
210     # override ARCH in the case of UML
211     if [ "$1" = "uml" ] ; then
212         export ARCH=um
213     fi
214
215     # and now to start the build process
216
217     make -s mrproper
218     cp configs/$Config .config
219
220     make -s nonint_oldconfig > /dev/null
221     make -s include/linux/version.h 
222
223     make -s %{?_smp_mflags} bzImage 
224     make -s %{?_smp_mflags} modules || exit 1
225     make buildcheck
226     
227     # Start installing the results
228
229     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
230     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
231     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
232     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
233     echo "_stext" >> exported
234     echo "_end" >> exported
235     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
236     for i in `cat exported` 
237     do 
238          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
239          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
240          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
241     done
242     rm -f exported
243     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
244     rm -f System.map
245     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
246
247     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
248     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
249  
250     # And save the headers/makefiles etc for building modules against
251     #
252     # This all looks scary, but the end result is supposed to be:
253     # * all arch relevant include/ files
254     # * all Makefile/Kconfig files
255     # * all script/ files 
256
257     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
258     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
259     # first copy everything
260     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
261     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
262     # then drop all but the needed Makefiles/Kconfig files
263     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
264     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
265     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
266     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
267     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
268     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
269     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
270     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
271     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
272     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
273     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
274     cd include
275     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
276     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
277     # Make sure the Makefile and version.h have a matching timestamp so that
278     # external modules can be built
279     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
280     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
281     cd .. 
282
283     #
284     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
285     #
286     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
287     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
288
289     # mark modules executable so that strip-to-file can strip them
290     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
291
292     # detect missing or incorrect license tags
293     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
294     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
295     rm -f modinfo
296     # remove files that will be auto generated by depmod at rpm -i time
297     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
298
299 }
300
301 ###
302 # DO it...
303 ###
304
305 # prepare directories
306 rm -rf $RPM_BUILD_ROOT
307 mkdir -p $RPM_BUILD_ROOT/boot
308
309 %if %{buildup}
310 BuildKernel
311 %endif
312
313 %if %{buildsmp}
314 BuildKernel smp
315 %endif
316
317 %if %{builduml}
318 BuildKernel uml
319 %endif
320
321 ###
322 ### install
323 ###
324
325 %install
326
327 # architectures that don't get kernel-source (i586/i686/athlon) dont need
328 # much of an install because the build phase already copied the needed files
329
330 %if %{builddoc}
331 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
332
333 # sometimes non-world-readable files sneak into the kernel source tree
334 chmod -R a+r *
335 # copy the source over
336 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
337 %endif
338
339 %if %{buildsource}
340
341 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
342 chmod -R a+r *
343
344 # clean up the source tree so that it is ready for users to build their own
345 # kernel
346 make -s mrproper
347 # copy the source over
348 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
349
350 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
351 # don't accidentally overwrite their currently working moduleset and hose
352 # their system
353 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
354
355 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
356 # change those to values that are more appropriate as defeault for people who build their own kernel.
357 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
358 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
359 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
360 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
361 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
362 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
363
364 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
365 %endif
366
367 ###
368 ### clean
369 ###
370
371 %clean
372 rm -rf $RPM_BUILD_ROOT
373
374 ###
375 ### scripts
376 ###
377
378 # load the loop module for upgrades...in case the old modules get removed we have
379 # loopback in the kernel so that mkinitrd will work.
380 %pre 
381 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
382 exit 0
383
384 %pre smp
385 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
386 exit 0
387
388 %post 
389 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
390 if [ -x /usr/sbin/hardlink ] ; then
391 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
392         cd /lib/modules/%{KVERREL}/build
393         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
394 }
395 popd
396 fi
397
398 # make some useful links
399 pushd /boot > /dev/null ; {
400         ln -sf System.map-%{KVERREL} System.map
401         ln -sf initrd-%{KVERREL}.img initrd-boot
402         ln -sf vmlinuz-%{KVERREL} kernel-boot
403 }
404 popd
405
406 # ask for a reboot
407 mkdir -p /etc/planetlab
408 touch /etc/planetlab/update-reboot
409
410 %post smp
411 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
412 if [ -x /usr/sbin/hardlink ] ; then
413 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
414         cd /lib/modules/%{KVERREL}smp/build
415         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
416 }
417 popd
418 fi
419
420
421 %preun 
422 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
423 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
424
425 %preun smp
426 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
427 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
428
429
430 ###
431 ### file lists
432 ###
433
434 %if %{buildup}
435 %files 
436 %defattr(-,root,root)
437 /%{image_install_path}/vmlinuz-%{KVERREL}
438 /boot/System.map-%{KVERREL}
439 /boot/config-%{KVERREL}
440 %dir /lib/modules/%{KVERREL}
441 /lib/modules/%{KVERREL}/kernel
442 %verify(not mtime) /lib/modules/%{KVERREL}/build
443
444 %endif
445
446 %if %{buildsmp}
447 %files smp
448 %defattr(-,root,root)
449 /%{image_install_path}/vmlinuz-%{KVERREL}smp
450 /boot/System.map-%{KVERREL}smp
451 /boot/config-%{KVERREL}smp
452 %dir /lib/modules/%{KVERREL}smp
453 /lib/modules/%{KVERREL}smp/kernel
454 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
455
456 %endif
457
458 %if %{builduml}
459 %files uml
460 %defattr(-,root,root)
461
462 %endif
463
464 # only some architecture builds need kernel-source and kernel-doc
465
466 %if %{buildsource}
467 %files sourcecode
468 %defattr(-,root,root)
469 /usr/src/linux-%{KVERREL}/
470 %endif
471
472
473 %if %{builddoc}
474 %files doc
475 %defattr(-,root,root)
476 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
477 %endif
478
479 %changelog
480 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
481 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
482   sections, most non-x86 sections, and GPG sections)
483
484 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
485 - ppc32 embedded updates
486
487 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
488 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
489 - 2.6.8-rc1-bk4
490
491 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
492 - 2.6.8-rc1-bk3
493
494 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
495 - add "enforcemodulesig" boot option to make the kernel load signed modules only
496
497 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
498 - updated voluntary preempt
499 - 2.6.8-rc1
500
501 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
502 - fix boot breakage that was hitting lots of people (Dave Jones)
503
504 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
505 - add voluntary preemption patch from Ingo
506 - 2.6.7-bk19
507
508 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
509 - make a start at gpg signed modules support
510
511 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
512 - experiment with making the hardlink call in post more efficient
513 - 2.6.7-bk9
514
515 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
516 - 2.6.7-bk7
517 - Add wli's patch to allocate memory bottom up not top down
518 - change some config options in the kernel-sourcecode package that are
519   good for rpm kernel builds but not for custom user builds to more appropriate 
520   default values.
521 - reenable kernel-sourcecode again for a few builds 
522
523 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
524 - 2.6.7-bk5
525 - fix tux unresolved symbols (#126532)
526
527 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
528 - make kernel-doc and kernel-sourcecode builds independent of eachother
529 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
530   on how to use the src.rpm instead for building your own kernel.
531
532 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
533 - 2.6.7-bk2
534
535 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
536 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
537
538 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
539 - add fix from Andi Kleen/Linus for the fpu-DoS
540
541 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
542 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
543 - revert airo driver to the FC2 one since the new one breaks
544
545 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
546 - Update to 2.6.7rc3
547
548 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
549 - fix the mlock-uses-rlimit patch
550
551 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
552 - Add ppc64 (Mac G5)
553
554 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
555 - add a forward port of the mlock-uses-rlimit patch
556 - add NX support for x86 (Intel, Ingo)
557
558 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
559 - refresh ext3 reservation patch
560
561 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
562 - 2.6.7-rc2
563 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
564
565 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
566 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
567
568 * Thu May 27 2004 Dave Jones <davej@redhat.com>
569 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
570
571 * Wed May 26 2004 Dave Jones <davej@redhat.com>
572 - Lots more updates to the SCSI whitelist for various
573   USB card readers. (#112778, among others..)
574
575 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
576 - back out ehci suspend/resume patch, it breaks
577 - add fix for 3c59x-meets-kudzu bug from Alan
578
579 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
580 - try improving suspend/resume by restoring more PCI state
581 - 2.6.7-rc1-bk1
582
583 * Mon May 24 2004 Dave Jones <davej@redhat.com>
584 - Add yet another multi-card reader to the whitelist (#85851)
585
586 * Sun May 23 2004 Dave Jones <davej@redhat.com>
587 - Add another multi-card reader to the whitelist (#124048)
588
589 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
590 - put firewire race fix in (datacorruptor)
591
592 * Tue May 18 2004 Dave Jones <davej@redhat.com>
593 - Fix typo in ibmtr driver preventing compile (#123391)
594
595 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
596 - update to 2.6.6-bk3
597 - made kernel-source and kernel-doc noarch.rpm's since they are not
598   architecture specific.
599
600 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
601 - fix non-booting on Transmeta cpus (Peter Anvin)
602 - fix count leak in message queues
603
604 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
605 - more ide cache flush work
606 - patch from scsi-bk to fix sd refcounting
607
608 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
609 - some more ide cache flush fixes 
610
611 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
612 - fix bug 122504
613 - convert b44 to ethtool ops (jgarzik)
614 - make IDE do a cache-flush on shutdown (me/Alan)
615
616 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
617 - work around i810/i830 DRM issue
618
619 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
620 - 2.6.6-rc3-bk1
621 - make amd64 boot again
622 - fix vm86-vs-4g4g interaction (Ingo)
623
624 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
625 - 2.6.6-rc2
626  
627 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
628 - add the ext3 online resize patch
629
630 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
631 - 2.6.6-rc1-bk3
632 - add the objrmap vm from the -mm tree; it needs testing
633
634 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
635 - 2.6.5-bk2
636 - disable DISCONTIGMEM on ia64 for performance
637 - fix sleep_on use in reiserfs (Chris Mason)
638
639 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
640 - 2.6.5-mc4
641 - reenable sg driver for scsi tape changers and such
642 - the sk98lin driver oopses on module unload, preven that
643
644 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
645 - fix "bad pmd" bug with patch from Ingo
646
647 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
648 - 2.6.5-mc3
649 - finish up the -mc2 merge
650 - latest 4g/4g patch from Ingo
651 - latest execshield patch from Ingo
652 - fix a few framebuffer bugs
653
654 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
655 - first attempt at a 2.6.5-mc2 merge
656
657 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
658 - Add in missing SiS AGP fix.
659
660 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
661 - More agpgart fixes.
662
663 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
664 - fix another 4g/4g-vs-resume bug
665
666 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
667 - 2.6.5-rc3
668 - fix PCI posting bug in i830 DRM
669
670 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
671 - 2.6.5-rc2-bk8
672
673 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
674 - Include latest agpgart fixes.
675
676 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
677 - more DRM fixes
678 - add the fsync patches from akpm
679
680 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
681 - 2.6.5-rc2-bk3
682 - fix direct userspace memory access in i830 drm driver
683
684 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
685 - 2.6.5-rc2-bk2
686 - some stackbloat reductions from Dave and me
687
688 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
689 - 2.6.5-rc2
690
691 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
692 - 2.6.5-rc1
693
694 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
695 - 2.6.4-bk3
696 - fix oops in toshiba_acpi (Barry K. Nathan)
697
698 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
699 - 2.6.4-bk2 merge 
700
701 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
702 - renable sonypi driver that was off accidentally
703 - 2.6.4-final 
704 - fix the oops on alsa module unloads
705
706 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
707 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
708 - 2.6.4-rc3 
709
710 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
711 - 2.6.4-rc2-bk5
712 - fix nfs-vs-selinux issue
713 - fix typo in URL as per #117849
714
715 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
716 - fix race in lp.c (#117710)
717 - 2.6.4-rc2-bk3
718 - attempt to fix S3 suspend-to-ram with 4g/4g split
719
720 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
721 - fix reiserfs
722 - set HZ to 1000 again for some tests
723
724 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
725 - merge back a bunch of fedora fixes
726 - disable audit
727
728 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
729 - audit bugfixes
730 - update tux to a working version
731 - 2.6.3-bk5 merge
732
733 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
734 - re-add and enable the Auditing patch
735 - switch several cpufreq modules to built in since detecting in userspace
736   which to use is unpleasant
737 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
738 - 2.6 start 
739