- don't install Kerntypes until we can fix LKCD
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 8
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.521.1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Vendor: PlanetLab
66 Packager: PlanetLab Central <support@planet-lab.org>
67 Distribution: PlanetLab 3.0
68 URL: http://cvs.planet-lab.org/cvs/linux-2.6
69
70 Name: kernel
71 Group: System Environment/Kernel
72 License: GPLv2
73 Version: %{rpmversion}
74 Release: %{release}
75 ExclusiveOS: Linux
76 Provides: kernel = %{version}
77 Provides: kernel-drm = 4.3.0
78 Prereq: %{kernel_prereq}
79 Conflicts: %{kernel_dot_org_conflicts}
80 Conflicts: %{package_conflicts}
81 Conflicts: %{nptl_conflicts}
82 # We can't let RPM do the dependencies automatic because it'll then pick up
83 # a correct but undesirable perl dependency from the module headers which
84 # isn't required for the kernel proper to function
85 AutoReqProv: no
86
87 #
88 # List the packages used during the kernel build
89 #
90 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
91 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg
92 #BuildPreReq: kernel-utils >= 1:2.4-12.1.142
93 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
94 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
95 BuildArchitectures: i686
96
97
98
99 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
100
101 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
102
103 %description 
104 The kernel package contains the Linux kernel (vmlinuz), the core of any
105 Linux operating system.  The kernel handles the basic functions
106 of the operating system:  memory allocation, process allocation, device
107 input and output, etc.
108
109
110 %package sourcecode
111 Summary: The source code for the Linux kernel.
112 Group: Development/System
113 Prereq: fileutils
114 Requires: make >= 3.78
115 Requires: gcc >= 3.2
116 Requires: /usr/bin/strip
117 # for xconfig and gconfig
118 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
119 Provides: kernel-source
120 Obsoletes: kernel-source <= 2.6.6
121
122 %description sourcecode
123 The kernel-sourcecode package contains the source code files for the Linux
124 kernel. The source files can be used to build a custom kernel that is
125 smaller by virtue of only including drivers for your particular hardware, if
126 you are so inclined (and you know what you're doing). The customisation
127 guide in the documentation describes in detail how to do this. This package
128 is neither needed nor usable for building external kernel modules for
129 linking such modules into the default operating system kernels.
130
131 %package doc
132 Summary: Various documentation bits found in the kernel source.
133 Group: Documentation
134 %if !%{buildsource}
135 Obsoletes: kernel-source <= 2.6.6
136 Obsoletes: kernel-sourcecode <= 2.6.6
137 %endif
138
139 %description doc
140 This package contains documentation files from the kernel
141 source. Various bits of information about the Linux kernel and the
142 device drivers shipped with it are documented in these files. 
143
144 You'll want to install this package if you need a reference to the
145 options that can be passed to Linux kernel modules at load time.
146
147
148 %package smp
149 Summary: The Linux kernel compiled for SMP machines.
150
151 Group: System Environment/Kernel
152 Provides: kernel = %{version}
153 Provides: kernel-drm = 4.3.0
154 Prereq: %{kernel_prereq}
155 Conflicts: %{kernel_dot_org_conflicts}
156 Conflicts: %{package_conflicts}
157 Conflicts: %{nptl_conflicts}
158 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
159 # now that the smp kernel offers this capability, obsolete the old kernel
160 Obsoletes: kernel-enterprise < 2.4.10
161 # We can't let RPM do the dependencies automatic because it'll then pick up
162 # a correct but undesirable perl dependency from the module headers which
163 # isn't required for the kernel proper to function
164 AutoReqProv: no
165
166 %description smp
167 This package includes a SMP version of the Linux kernel. It is
168 required only on machines with two or more CPUs as well as machines with
169 hyperthreading technology.
170
171 Install the kernel-smp package if your machine uses two or more CPUs.
172
173 %package uml
174 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
175
176 Group: System Environment/Kernel
177
178 %description uml
179 This package includes a user mode version of the Linux kernel.
180
181 %prep
182
183 %setup -n linux-%{kversion}
184
185 # make sure the kernel has the sublevel we know it has. This looks weird
186 # but for -pre and -rc versions we need it since we only want to use
187 # the higher version when the final kernel is released.
188 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
189 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
190
191 # get rid of unwanted files resulting from patch fuzz
192 find . -name "*.orig" -exec rm -fv {} \;
193 find . -name "*~" -exec rm -fv {} \;
194
195 ###
196 ### build
197 ###
198 %build
199
200 BuildKernel() {
201
202     # Pick the right config file for the kernel we're building
203     if [ -n "$1" ] ; then
204         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
205     else
206         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
207     fi
208
209     KernelVer=%{version}-%{release}$1
210     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
211
212     # make sure EXTRAVERSION says what we want it to say
213     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
214
215     # override ARCH in the case of UML
216     if [ "$1" = "uml" ] ; then
217         export ARCH=um
218     fi
219
220     # and now to start the build process
221
222     make -s mrproper
223     cp configs/$Config .config
224
225     make -s nonint_oldconfig > /dev/null
226     make -s include/linux/version.h 
227
228     make -s %{?_smp_mflags} bzImage 
229     make -s %{?_smp_mflags} modules || exit 1
230     make buildcheck
231     
232     # Start installing the results
233
234     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
235     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
236     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
237     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
238     echo "_stext" >> exported
239     echo "_end" >> exported
240     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
241     for i in `cat exported` 
242     do 
243          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
244          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
245          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
246     done
247     rm -f exported
248 #    install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
249     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
250     rm -f System.map
251     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
252
253     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
254     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
255  
256     # And save the headers/makefiles etc for building modules against
257     #
258     # This all looks scary, but the end result is supposed to be:
259     # * all arch relevant include/ files
260     # * all Makefile/Kconfig files
261     # * all script/ files 
262
263     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
264     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
265     # first copy everything
266     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
267     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
268     # then drop all but the needed Makefiles/Kconfig files
269     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
270     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
271     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
272     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
273     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
274     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
275     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
276     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
277     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
278     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
279     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
280     cd include
281     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
282     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
283     # Make sure the Makefile and version.h have a matching timestamp so that
284     # external modules can be built
285     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
286     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
287     cd .. 
288
289     #
290     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
291     #
292     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
293     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
294
295     # mark modules executable so that strip-to-file can strip them
296     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
297
298     # detect missing or incorrect license tags
299     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
300     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
301     rm -f modinfo
302     # remove files that will be auto generated by depmod at rpm -i time
303     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
304
305 }
306
307 ###
308 # DO it...
309 ###
310
311 # prepare directories
312 rm -rf $RPM_BUILD_ROOT
313 mkdir -p $RPM_BUILD_ROOT/boot
314
315 %if %{buildup}
316 BuildKernel
317 %endif
318
319 %if %{buildsmp}
320 BuildKernel smp
321 %endif
322
323 %if %{builduml}
324 BuildKernel uml
325 %endif
326
327 ###
328 ### install
329 ###
330
331 %install
332
333 # architectures that don't get kernel-source (i586/i686/athlon) dont need
334 # much of an install because the build phase already copied the needed files
335
336 %if %{builddoc}
337 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
338
339 # sometimes non-world-readable files sneak into the kernel source tree
340 chmod -R a+r *
341 # copy the source over
342 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
343 %endif
344
345 %if %{buildsource}
346
347 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
348 chmod -R a+r *
349
350 # clean up the source tree so that it is ready for users to build their own
351 # kernel
352 make -s mrproper
353 # copy the source over
354 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
355
356 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
357 # don't accidentally overwrite their currently working moduleset and hose
358 # their system
359 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
360
361 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
362 # change those to values that are more appropriate as defeault for people who build their own kernel.
363 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
364 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
365 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
366 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
367 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
368 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
369
370 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
371 %endif
372
373 ###
374 ### clean
375 ###
376
377 %clean
378 rm -rf $RPM_BUILD_ROOT
379
380 ###
381 ### scripts
382 ###
383
384 # load the loop module for upgrades...in case the old modules get removed we have
385 # loopback in the kernel so that mkinitrd will work.
386 %pre 
387 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
388 exit 0
389
390 %pre smp
391 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
392 exit 0
393
394 %post 
395 # trick mkinitrd in case the current environment does not have device mapper
396 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
397 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
398     if [ ! -f $rootdev ]; then
399         fake_root_lvm=1
400         mkdir -p $(dirname $rootdev)
401         touch $rootdev
402     fi
403 fi
404 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
405 if [ -n "$fake_root_lvm" ]; then
406     rm -f $rootdev
407 fi
408 if [ -x /usr/sbin/hardlink ] ; then
409 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
410         cd /lib/modules/%{KVERREL}/build
411         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
412 }
413 popd
414 fi
415
416 # make some useful links
417 pushd /boot > /dev/null ; {
418         ln -sf System.map-%{KVERREL} System.map
419 #       ln -sf Kerntypes-%{KVERREL} Kerntypes
420         ln -sf config-%{KVERREL} config
421         ln -sf initrd-%{KVERREL}.img initrd-boot
422         ln -sf vmlinuz-%{KVERREL} kernel-boot
423 }
424 popd
425
426 # ask for a reboot
427 mkdir -p /etc/planetlab
428 touch /etc/planetlab/update-reboot
429
430 %post smp
431 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
432 if [ -x /usr/sbin/hardlink ] ; then
433 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
434         cd /lib/modules/%{KVERREL}smp/build
435         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
436 }
437 popd
438 fi
439
440
441 %preun 
442 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
443 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
444
445 %preun smp
446 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
447 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
448
449
450 ###
451 ### file lists
452 ###
453
454 %if %{buildup}
455 %files 
456 %defattr(-,root,root)
457 /%{image_install_path}/vmlinuz-%{KVERREL}
458 #/boot/Kerntypes-%{KVERREL}
459 /boot/System.map-%{KVERREL}
460 /boot/config-%{KVERREL}
461 %dir /lib/modules/%{KVERREL}
462 /lib/modules/%{KVERREL}/kernel
463 %verify(not mtime) /lib/modules/%{KVERREL}/build
464
465 %endif
466
467 %if %{buildsmp}
468 %files smp
469 %defattr(-,root,root)
470 /%{image_install_path}/vmlinuz-%{KVERREL}smp
471 #/boot/Kerntypes-%{KVERREL}smp
472 /boot/System.map-%{KVERREL}smp
473 /boot/config-%{KVERREL}smp
474 %dir /lib/modules/%{KVERREL}smp
475 /lib/modules/%{KVERREL}smp/kernel
476 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
477
478 %endif
479
480 %if %{builduml}
481 %files uml
482 %defattr(-,root,root)
483
484 %endif
485
486 # only some architecture builds need kernel-source and kernel-doc
487
488 %if %{buildsource}
489 %files sourcecode
490 %defattr(-,root,root)
491 /usr/src/linux-%{KVERREL}/
492 %endif
493
494
495 %if %{builddoc}
496 %files doc
497 %defattr(-,root,root)
498 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
499 %endif
500
501 %changelog
502 * Thu Sep 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
503 - merge to Fedora Core 2 2.6.8-1.521
504
505 * Tue Aug 31 2004 Arjan van de Ven <arjanv@redhat.com>
506 - fix execshield buglet with legacy binaries
507 - 2.6.9-rc1-bk7
508
509 * Mon Aug 30 2004 Arjan van de Ven <arjanv@redhat.com>
510 - 2.6.9-rc1-bk6
511
512 * Sat Aug 28 2004 Arjan van de Ven <arjanv@redhat.com>
513 - 2.6.9-rc1-bk4, now with i915 DRM driver
514
515 * Fri Aug 27 2004 Arjan van de Ven <arjanv@redhat.com>
516 - 2.6.9-rc1-bk2 
517
518 * Mon Aug 23 2004 Arjan van de Ven <arjanv@redhat.com>
519 - 2.6.8.1-bk2
520
521 * Sat Aug 21 2004 Arjan van de Ven <arjanv@redhat.com>
522 - attempt to fix early-udev bug
523
524 * Fri Aug 13 2004 Arjan van de Ven <arjanv@redhat.com>
525 - 2.6.8-rc4-bk3
526 - split execshield up some more
527
528 * Fri Aug 13 2004 Dave Jones <davej@redhat.com>
529 - Update SCSI whitelist again with some more card readers.
530
531 * Mon Aug 9 2004 Arjan van de Ven <arjanv@redhat.com>
532 - 2.6.8-rc3-bk3
533
534 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
535 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
536   sections, most non-x86 sections, and GPG sections)
537
538 * Wed Aug 4 2004 Arjan van de Ven <arjanv@redhat.com>
539 - Add the flex-mmap bits for s390/s390x (Pete Zaitcev)
540 - Add flex-mmap for x86-64 32 bit emulation
541 - 2.6.8-rc3
542
543 * Mon Aug 2 2004 Arjan van de Ven <arjanv@redhat.com>
544 - Add Rik's token trashing control patch
545
546 * Sun Aug 1 2004 Arjan van de Ven <arjanv@redhat.com>
547 - 2.6.8-rc2-bk11
548
549 * Fri Jul 30 2004 Arjan van de Ven <arjanv@redhat.com>
550 - 2.6.8-rc2-bk8
551
552 * Wed Jul 28 2004 Arjan van de Ven <arjanv@redhat.com>
553 - 2.6.8-rc2-bk6
554 - make a start at splitting up the execshield patchkit
555
556 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
557 - ppc32 embedded updates
558
559 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
560 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
561 - 2.6.8-rc1-bk4
562
563 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
564 - 2.6.8-rc1-bk3
565
566 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
567 - add "enforcemodulesig" boot option to make the kernel load signed modules only
568
569 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
570 - updated voluntary preempt
571 - 2.6.8-rc1
572
573 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
574 - fix boot breakage that was hitting lots of people (Dave Jones)
575
576 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
577 - add voluntary preemption patch from Ingo
578 - 2.6.7-bk19
579
580 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
581 - make a start at gpg signed modules support
582
583 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
584 - experiment with making the hardlink call in post more efficient
585 - 2.6.7-bk9
586
587 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
588 - 2.6.7-bk7
589 - Add wli's patch to allocate memory bottom up not top down
590 - change some config options in the kernel-sourcecode package that are
591   good for rpm kernel builds but not for custom user builds to more appropriate 
592   default values.
593 - reenable kernel-sourcecode again for a few builds 
594
595 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
596 - 2.6.7-bk5
597 - fix tux unresolved symbols (#126532)
598
599 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
600 - make kernel-doc and kernel-sourcecode builds independent of eachother
601 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
602   on how to use the src.rpm instead for building your own kernel.
603
604 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
605 - 2.6.7-bk2
606
607 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
608 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
609
610 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
611 - add fix from Andi Kleen/Linus for the fpu-DoS
612
613 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
614 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
615 - revert airo driver to the FC2 one since the new one breaks
616
617 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
618 - Update to 2.6.7rc3
619
620 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
621 - fix the mlock-uses-rlimit patch
622
623 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
624 - Add ppc64 (Mac G5)
625
626 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
627 - add a forward port of the mlock-uses-rlimit patch
628 - add NX support for x86 (Intel, Ingo)
629
630 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
631 - refresh ext3 reservation patch
632
633 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
634 - 2.6.7-rc2
635 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
636
637 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
638 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
639
640 * Thu May 27 2004 Dave Jones <davej@redhat.com>
641 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
642
643 * Wed May 26 2004 Dave Jones <davej@redhat.com>
644 - Lots more updates to the SCSI whitelist for various
645   USB card readers. (#112778, among others..)
646
647 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
648 - back out ehci suspend/resume patch, it breaks
649 - add fix for 3c59x-meets-kudzu bug from Alan
650
651 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
652 - try improving suspend/resume by restoring more PCI state
653 - 2.6.7-rc1-bk1
654
655 * Mon May 24 2004 Dave Jones <davej@redhat.com>
656 - Add yet another multi-card reader to the whitelist (#85851)
657
658 * Sun May 23 2004 Dave Jones <davej@redhat.com>
659 - Add another multi-card reader to the whitelist (#124048)
660
661 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
662 - put firewire race fix in (datacorruptor)
663
664 * Tue May 18 2004 Dave Jones <davej@redhat.com>
665 - Fix typo in ibmtr driver preventing compile (#123391)
666
667 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
668 - update to 2.6.6-bk3
669 - made kernel-source and kernel-doc noarch.rpm's since they are not
670   architecture specific.
671
672 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
673 - fix non-booting on Transmeta cpus (Peter Anvin)
674 - fix count leak in message queues
675
676 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
677 - more ide cache flush work
678 - patch from scsi-bk to fix sd refcounting
679
680 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
681 - some more ide cache flush fixes 
682
683 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
684 - fix bug 122504
685 - convert b44 to ethtool ops (jgarzik)
686 - make IDE do a cache-flush on shutdown (me/Alan)
687
688 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
689 - work around i810/i830 DRM issue
690
691 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
692 - 2.6.6-rc3-bk1
693 - make amd64 boot again
694 - fix vm86-vs-4g4g interaction (Ingo)
695
696 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
697 - 2.6.6-rc2
698  
699 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
700 - add the ext3 online resize patch
701
702 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
703 - 2.6.6-rc1-bk3
704 - add the objrmap vm from the -mm tree; it needs testing
705
706 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
707 - 2.6.5-bk2
708 - disable DISCONTIGMEM on ia64 for performance
709 - fix sleep_on use in reiserfs (Chris Mason)
710
711 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
712 - 2.6.5-mc4
713 - reenable sg driver for scsi tape changers and such
714 - the sk98lin driver oopses on module unload, preven that
715
716 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
717 - fix "bad pmd" bug with patch from Ingo
718
719 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
720 - 2.6.5-mc3
721 - finish up the -mc2 merge
722 - latest 4g/4g patch from Ingo
723 - latest execshield patch from Ingo
724 - fix a few framebuffer bugs
725
726 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
727 - first attempt at a 2.6.5-mc2 merge
728
729 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
730 - Add in missing SiS AGP fix.
731
732 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
733 - More agpgart fixes.
734
735 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
736 - fix another 4g/4g-vs-resume bug
737
738 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
739 - 2.6.5-rc3
740 - fix PCI posting bug in i830 DRM
741
742 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
743 - 2.6.5-rc2-bk8
744
745 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
746 - Include latest agpgart fixes.
747
748 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
749 - more DRM fixes
750 - add the fsync patches from akpm
751
752 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
753 - 2.6.5-rc2-bk3
754 - fix direct userspace memory access in i830 drm driver
755
756 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
757 - 2.6.5-rc2-bk2
758 - some stackbloat reductions from Dave and me
759
760 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
761 - 2.6.5-rc2
762
763 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
764 - 2.6.5-rc1
765
766 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
767 - 2.6.4-bk3
768 - fix oops in toshiba_acpi (Barry K. Nathan)
769
770 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
771 - 2.6.4-bk2 merge 
772
773 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
774 - renable sonypi driver that was off accidentally
775 - 2.6.4-final 
776 - fix the oops on alsa module unloads
777
778 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
779 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
780 - 2.6.4-rc3 
781
782 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
783 - 2.6.4-rc2-bk5
784 - fix nfs-vs-selinux issue
785 - fix typo in URL as per #117849
786
787 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
788 - fix race in lp.c (#117710)
789 - 2.6.4-rc2-bk3
790 - attempt to fix S3 suspend-to-ram with 4g/4g split
791
792 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
793 - fix reiserfs
794 - set HZ to 1000 again for some tests
795
796 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
797 - merge back a bunch of fedora fixes
798 - disable audit
799
800 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
801 - audit bugfixes
802 - update tux to a working version
803 - 2.6.3-bk5 merge
804
805 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
806 - re-add and enable the Auditing patch
807 - switch several cpufreq modules to built in since detecting in userspace
808   which to use is unpleasant
809 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
810 - 2.6 start 
811