- force BuildArchitecture to i686
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define buildsmp 0
8 %define builduml 0
9 %define buildsource 0
10 %define builddoc 0
11
12
13 # Versions of various parts
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 7
22 %define kversion 2.6.%{sublevel}
23 %define rpmversion 2.6.%{sublevel}
24 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
25 %define release 1.planetlab%{?date:.%{date}}
26 %define signmodules 0
27
28 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
29
30 # Override generic defaults with per-arch defaults 
31
32 %define image_install_path boot
33
34 #
35 # Three sets of minimum package version requirements in the form of Conflicts:
36 # to versions below the minimum
37 #
38
39 #
40 # First the general kernel 2.6 required versions as per
41 # Documentation/Changes
42 #
43 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
44
45
46 # Then a series of requirements that are distribution specific, either 
47 # because we add patches for something, or the older versions have 
48 # problems with the newer kernel or lack certain things that make 
49 # integration in the distro harder than needed.
50 #
51 %define package_conflicts  cipe < 1.4.5, tux < 2.1.0, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0
52
53 #
54 # Several packages had bugs in them that became obvious when the NPTL
55 # threading code got integrated. 
56 #
57 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
58
59 #
60 # Packages that need to be installed before the kernel is, because the %post
61 # scripts use them.
62 #
63 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
64
65 Name: kernel
66 Group: System Environment/Kernel
67 License: GPLv2
68 Version: %{rpmversion}
69 Release: %{release}
70 ExclusiveOS: Linux
71 Provides: kernel = %{version}
72 Provides: kernel-drm = 4.3.0
73 Prereq: %{kernel_prereq}
74 Conflicts: %{kernel_dot_org_conflicts}
75 Conflicts: %{package_conflicts}
76 Conflicts: %{nptl_conflicts}
77 # We can't let RPM do the dependencies automatic because it'll then pick up
78 # a correct but undesirable perl dependency from the module headers which
79 # isn't required for the kernel proper to function
80 AutoReqProv: no
81
82 #
83 # List the packages used during the kernel build
84 #
85 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
86 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, kernel-utils >= 2.4-12.1.139
87 # temporary req since modutils changed output format 
88 #BuildPreReq: modutils >= 2.4.26-14
89 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
90 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
91 BuildArchitectures: i686
92
93
94
95 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
96
97 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
98
99 %description 
100 The kernel package contains the Linux kernel (vmlinuz), the core of any
101 Linux operating system.  The kernel handles the basic functions
102 of the operating system:  memory allocation, process allocation, device
103 input and output, etc.
104
105
106 %package sourcecode
107 Summary: The source code for the Linux kernel.
108 Group: Development/System
109 Prereq: fileutils
110 Requires: make >= 3.78
111 Requires: gcc >= 3.2
112 Requires: /usr/bin/strip
113 # for xconfig and gconfig
114 Requires: qt-devel, gtk2-devel readline-devel ncurses-devel
115 Provides: kernel-source
116 Obsoletes: kernel-source <= 2.6.6
117
118 %description sourcecode
119 The kernel-sourcecode package contains the source code files for the Linux
120 kernel. The source files can be used to build a custom kernel that is
121 smaller by virtue of only including drivers for your particular hardware, if
122 you are so inclined (and you know what you're doing). The customisation
123 guide in the documentation describes in detail how to do this. This package
124 is neither needed nor usable for building external kernel modules for
125 linking such modules into the default operating system kernels.
126
127 %package doc
128 Summary: Various documentation bits found in the kernel source.
129 Group: Documentation
130 %if !%{buildsource}
131 Obsoletes: kernel-source <= 2.6.6
132 Obsoletes: kernel-sourcecode <= 2.6.6
133 %endif
134
135 %description doc
136 This package contains documentation files from the kernel
137 source. Various bits of information about the Linux kernel and the
138 device drivers shipped with it are documented in these files. 
139
140 You'll want to install this package if you need a reference to the
141 options that can be passed to Linux kernel modules at load time.
142
143
144 %package smp
145 Summary: The Linux kernel compiled for SMP machines.
146
147 Group: System Environment/Kernel
148 Provides: kernel = %{version}
149 Provides: kernel-drm = 4.3.0
150 Prereq: %{kernel_prereq}
151 Conflicts: %{kernel_dot_org_conflicts}
152 Conflicts: %{package_conflicts}
153 Conflicts: %{nptl_conflicts}
154 # upto and including kernel 2.4.9 rpms, the 4Gb+ kernel was called kernel-enterprise
155 # now that the smp kernel offers this capability, obsolete the old kernel
156 Obsoletes: kernel-enterprise < 2.4.10
157 # We can't let RPM do the dependencies automatic because it'll then pick up
158 # a correct but undesirable perl dependency from the module headers which
159 # isn't required for the kernel proper to function
160 AutoReqProv: no
161
162 %description smp
163 This package includes a SMP version of the Linux kernel. It is
164 required only on machines with two or more CPUs as well as machines with
165 hyperthreading technology.
166
167 Install the kernel-smp package if your machine uses two or more CPUs.
168
169 %package uml
170 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
171
172 Group: System Environment/Kernel
173
174 %description uml
175 This package includes a user mode version of the Linux kernel.
176
177 %prep
178
179 %setup -n linux-%{kversion}
180
181 # make sure the kernel has the sublevel we know it has. This looks weird
182 # but for -pre and -rc versions we need it since we only want to use
183 # the higher version when the final kernel is released.
184 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
185 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
186
187 # get rid of unwanted files resulting from patch fuzz
188 find . -name "*.orig" -exec rm -fv {} \;
189 find . -name "*~" -exec rm -fv {} \;
190
191 ###
192 ### build
193 ###
194 %build
195
196 BuildKernel() {
197
198     # Pick the right config file for the kernel we're building
199     if [ -n "$1" ] ; then
200         Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
201     else
202         Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
203     fi
204
205     KernelVer=%{version}-%{release}$1
206     echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
207
208     # make sure EXTRAVERSION says what we want it to say
209     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
210
211     # override ARCH in the case of UML
212     if [ "$1" = "uml" ] ; then
213         export ARCH=um
214     fi
215
216     # and now to start the build process
217
218     make -s mrproper
219     cp configs/$Config .config
220
221     make -s nonint_oldconfig > /dev/null
222     make -s include/linux/version.h 
223
224     make -s %{?_smp_mflags} bzImage 
225     make -s %{?_smp_mflags} modules || exit 1
226     make buildcheck
227     
228     # Start installing the results
229
230     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
231     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
232     install -m 644 System.map $RPM_BUILD_ROOT/usr/lib/debug/boot/System.map-$KernelVer
233     objdump -t vmlinux | grep ksymtab | cut -f2 | cut -d" " -f2 | cut -c11- | sort -u  > exported
234     echo "_stext" >> exported
235     echo "_end" >> exported
236     touch $RPM_BUILD_ROOT/boot/System.map-$KernelVer
237     for i in `cat exported` 
238     do 
239          grep " $i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
240          grep "tab_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer || :
241          grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
242     done
243     rm -f exported
244     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
245     rm -f System.map
246     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
247
248     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
249     make -s INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
250  
251     # And save the headers/makefiles etc for building modules against
252     #
253     # This all looks scary, but the end result is supposed to be:
254     # * all arch relevant include/ files
255     # * all Makefile/Kconfig files
256     # * all script/ files 
257
258     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
259     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
260     # first copy everything
261     cp --parents `find  -type f -name Makefile -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
262     cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
263     # then drop all but the needed Makefiles/Kconfig files
264     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
265     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
266     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
267     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
268     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
269     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
270     cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
271     cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
272     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
273     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
274     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
275     cd include
276     cp -a acpi config linux math-emu media net pcmcia rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
277     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
278     # Make sure the Makefile and version.h have a matching timestamp so that
279     # external modules can be built
280     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
281     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
282     cd .. 
283
284     #
285     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
286     #
287     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
288     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
289
290     # mark modules executable so that strip-to-file can strip them
291     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f  | xargs chmod u+x
292
293     # detect missing or incorrect license tags
294     for i in `find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" ` ; do echo -n "$i " ; /sbin/modinfo -l $i >> modinfo ; done
295     cat modinfo | grep -v "^GPL" | grep -v "^Dual BSD/GPL" | grep -v "^Dual MPL/GPL" | grep -v "^GPL and additional rights" | grep -v "^GPL v2" && exit 1 
296     rm -f modinfo
297     # remove files that will be auto generated by depmod at rpm -i time
298     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
299
300 }
301
302 ###
303 # DO it...
304 ###
305
306 # prepare directories
307 rm -rf $RPM_BUILD_ROOT
308 mkdir -p $RPM_BUILD_ROOT/boot
309
310 %if %{buildup}
311 BuildKernel
312 %endif
313
314 %if %{buildsmp}
315 BuildKernel smp
316 %endif
317
318 %if %{builduml}
319 BuildKernel uml
320 %endif
321
322 ###
323 ### install
324 ###
325
326 %install
327
328 # architectures that don't get kernel-source (i586/i686/athlon) dont need
329 # much of an install because the build phase already copied the needed files
330
331 %if %{builddoc}
332 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
333
334 # sometimes non-world-readable files sneak into the kernel source tree
335 chmod -R a+r *
336 # copy the source over
337 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
338 %endif
339
340 %if %{buildsource}
341
342 mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
343 chmod -R a+r *
344
345 # clean up the source tree so that it is ready for users to build their own
346 # kernel
347 make -s mrproper
348 # copy the source over
349 tar cf - . | tar xf - -C $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
350
351 # set the EXTRAVERSION to <version>custom, so that people who follow a kernel building howto
352 # don't accidentally overwrite their currently working moduleset and hose
353 # their system
354 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}custom/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/Makefile
355
356 # some config options may be appropriate for an rpm kernel build but are less so for custom user builds,
357 # change those to values that are more appropriate as defeault for people who build their own kernel.
358 perl -p -i -e "s/^CONFIG_DEBUG_INFO.*/# CONFIG_DEBUG_INFO is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
359 perl -p -i -e "s/^.*CONFIG_DEBUG_PAGEALLOC.*/# CONFIG_DEBUG_PAGEALLOC is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
360 perl -p -i -e "s/^.*CONFIG_DEBUG_SLAB.*/# CONFIG_DEBUG_SLAB is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
361 perl -p -i -e "s/^.*CONFIG_DEBUG_SPINLOCK.*/# CONFIG_DEBUG_SPINLOCK is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
362 perl -p -i -e "s/^.*CONFIG_DEBUG_HIGHMEM.*/# CONFIG_DEBUG_HIGHMEM is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
363 perl -p -i -e "s/^.*CONFIG_MODULE_SIG.*/# CONFIG_MODULE_SIG is not set/" $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs/*
364
365 install -m 644 %{SOURCE10}  $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}
366 %endif
367
368 ###
369 ### clean
370 ###
371
372 %clean
373 rm -rf $RPM_BUILD_ROOT
374
375 ###
376 ### scripts
377 ###
378
379 # load the loop module for upgrades...in case the old modules get removed we have
380 # loopback in the kernel so that mkinitrd will work.
381 %pre 
382 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
383 exit 0
384
385 %pre smp
386 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
387 exit 0
388
389 %post 
390 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
391 if [ -x /usr/sbin/hardlink ] ; then
392 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
393         cd /lib/modules/%{KVERREL}/build
394         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
395 }
396 popd
397 fi
398
399 # make some useful links
400 pushd /boot > /dev/null ; {
401         ln -sf System.map-%{KVERREL} System.map
402         ln -sf initrd-%{KVERREL}.img initrd-boot
403         ln -sf vmlinuz-%{KVERREL} kernel-boot
404 }
405 popd
406
407 # ask for a reboot
408 mkdir -p /etc/planetlab
409 touch /etc/planetlab/update-reboot
410
411 %post smp
412 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}smp
413 if [ -x /usr/sbin/hardlink ] ; then
414 pushd /lib/modules/%{KVERREL}smp/build > /dev/null ; {
415         cd /lib/modules/%{KVERREL}smp/build
416         find . -type f | while read f; do hardlink -c /lib/modules/*/build/$f $f ; done
417 }
418 popd
419 fi
420
421
422 %preun 
423 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
424 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
425
426 %preun smp
427 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
428 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}smp
429
430
431 ###
432 ### file lists
433 ###
434
435 %if %{buildup}
436 %files 
437 %defattr(-,root,root)
438 /%{image_install_path}/vmlinuz-%{KVERREL}
439 /boot/System.map-%{KVERREL}
440 /boot/config-%{KVERREL}
441 %dir /lib/modules/%{KVERREL}
442 /lib/modules/%{KVERREL}/kernel
443 %verify(not mtime) /lib/modules/%{KVERREL}/build
444
445 %endif
446
447 %if %{buildsmp}
448 %files smp
449 %defattr(-,root,root)
450 /%{image_install_path}/vmlinuz-%{KVERREL}smp
451 /boot/System.map-%{KVERREL}smp
452 /boot/config-%{KVERREL}smp
453 %dir /lib/modules/%{KVERREL}smp
454 /lib/modules/%{KVERREL}smp/kernel
455 %verify(not mtime) /lib/modules/%{KVERREL}smp/build
456
457 %endif
458
459 %if %{builduml}
460 %files uml
461 %defattr(-,root,root)
462
463 %endif
464
465 # only some architecture builds need kernel-source and kernel-doc
466
467 %if %{buildsource}
468 %files sourcecode
469 %defattr(-,root,root)
470 /usr/src/linux-%{KVERREL}/
471 %endif
472
473
474 %if %{builddoc}
475 %files doc
476 %defattr(-,root,root)
477 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
478 %endif
479
480 %changelog
481 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
482 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
483   sections, most non-x86 sections, and GPG sections)
484
485 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
486 - ppc32 embedded updates
487
488 * Thu Jul 15 2004 Arjan van de Ven <arjanv@redhat.com>
489 - make USB modules again and add Alan's real fix for the SMM-meets-USB bug
490 - 2.6.8-rc1-bk4
491
492 * Wed Jul 14 2004 Arjan van de Ven <arjanv@redhat.com>
493 - 2.6.8-rc1-bk3
494
495 * Tue Jul 13 2004 Arjan van de Ven <arjanv@redhat.com>
496 - add "enforcemodulesig" boot option to make the kernel load signed modules only
497
498 * Mon Jul 12 2004 Arjan van de Ven <arjanv@redhat.com>
499 - updated voluntary preempt
500 - 2.6.8-rc1
501
502 * Wed Jul 7 2004 Arjan van de Ven <arjanv@redhat.com>
503 - fix boot breakage that was hitting lots of people (Dave Jones)
504
505 * Tue Jul 6 2004 Arjan van de Ven <arjanv@redhat.com>
506 - add voluntary preemption patch from Ingo
507 - 2.6.7-bk19
508
509 * Tue Jun 29 2004 Arjan van de Ven <arjanv@redhat.com>
510 - make a start at gpg signed modules support
511
512 * Sat Jun 27 2004 Arjan van de Ven <arjanv@redhat.com>
513 - experiment with making the hardlink call in post more efficient
514 - 2.6.7-bk9
515
516 * Thu Jun 24 2004 Arjan van de Ven <arjanv@redhat.com>
517 - 2.6.7-bk7
518 - Add wli's patch to allocate memory bottom up not top down
519 - change some config options in the kernel-sourcecode package that are
520   good for rpm kernel builds but not for custom user builds to more appropriate 
521   default values.
522 - reenable kernel-sourcecode again for a few builds 
523
524 * Wed Jun 23 2004 Arjan van de Ven <arjanv@redhat.com>
525 - 2.6.7-bk5
526 - fix tux unresolved symbols (#126532)
527
528 * Mon Jun 21 2004 Arjan van de Ven <arjanv@redhat.com>
529 - make kernel-doc and kernel-sourcecode builds independent of eachother
530 - disable kernel-sourcecode builds entirely, we'll be replacing it with documentation
531   on how to use the src.rpm instead for building your own kernel.
532
533 * Sat Jun 19 2004 Arjan van de Ven <arjanv@redhat.com>
534 - 2.6.7-bk2
535
536 * Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
537 - add patch from DaveM to fix the ppp-keeps-iface-busy bug
538
539 * Sat Jun 12 2004 Arjan van de Ven <arjanv@redhat.com>
540 - add fix from Andi Kleen/Linus for the fpu-DoS
541
542 * Thu Jun 10 2004 Arjan van de Ven <arjanv@redhat.com>
543 - disable mlock-uses-rlimit patch, it has a security hole and needs more thought
544 - revert airo driver to the FC2 one since the new one breaks
545
546 * Tue Jun 8 2004 Dave Jones <davej@redhat.com>
547 - Update to 2.6.7rc3
548
549 * Fri Jun 4 2004 Arjan van de Ven <arjanv@redhat.com>
550 - fix the mlock-uses-rlimit patch
551
552 * Wed Jun 2 2004 David Woodhouse <dwmw2@redhat.com>
553 - Add ppc64 (Mac G5)
554
555 * Wed Jun 2 2004 Arjan van de Ven <arjanv@redhat.com>
556 - add a forward port of the mlock-uses-rlimit patch
557 - add NX support for x86 (Intel, Ingo)
558
559 * Tue Jun 1 2004 Arjan van de Ven <arjanv@redhat.com>
560 - refresh ext3 reservation patch
561
562 * Sun May 30 2004 Arjan van de Ven <arjanv@redhat.com>
563 - 2.6.7-rc2
564 - set the ACPI OS name to "Microsoft Windows XP" for better compatibility
565
566 * Thu May 27 2004 Pete Zaitcev <zaitcev@redhat.com>
567 - Fix qeth and zfcp (s390 drivers): align qib by 256, embedded into qdio_irq.
568
569 * Thu May 27 2004 Dave Jones <davej@redhat.com>
570 - Fix the crashes on boot on Asus P4P800 boards. (#121819)
571
572 * Wed May 26 2004 Dave Jones <davej@redhat.com>
573 - Lots more updates to the SCSI whitelist for various
574   USB card readers. (#112778, among others..)
575
576 * Wed May 26 2004 Arjan van de Ven <arjanv@redhat.com>
577 - back out ehci suspend/resume patch, it breaks
578 - add fix for 3c59x-meets-kudzu bug from Alan
579
580 * Tue May 25 2004 Arjan van de Ven <arjanv@redhat.com>
581 - try improving suspend/resume by restoring more PCI state
582 - 2.6.7-rc1-bk1
583
584 * Mon May 24 2004 Dave Jones <davej@redhat.com>
585 - Add yet another multi-card reader to the whitelist (#85851)
586
587 * Sun May 23 2004 Dave Jones <davej@redhat.com>
588 - Add another multi-card reader to the whitelist (#124048)
589
590 * Wed May 19 2004 Arjan van de Ven <arjanv@redhat.com>
591 - put firewire race fix in (datacorruptor)
592
593 * Tue May 18 2004 Dave Jones <davej@redhat.com>
594 - Fix typo in ibmtr driver preventing compile (#123391)
595
596 * Mon May 17 2004 Arjan van de Ven <arjanv@redhat.com>
597 - update to 2.6.6-bk3
598 - made kernel-source and kernel-doc noarch.rpm's since they are not
599   architecture specific.
600
601 * Sat May 08 2004 Arjan van de Ven <arjanv@redhat.com>
602 - fix non-booting on Transmeta cpus (Peter Anvin)
603 - fix count leak in message queues
604
605 * Fri May 07 2004 Arjan van de Ven <arjanv@redhat.com>
606 - more ide cache flush work
607 - patch from scsi-bk to fix sd refcounting
608
609 * Thu May 06 2004 Arjan van de Ven <arjanv@redhat.com>
610 - some more ide cache flush fixes 
611
612 * Wed May 05 2004 Arjan van de Ven <arjanv@redhat.com>
613 - fix bug 122504
614 - convert b44 to ethtool ops (jgarzik)
615 - make IDE do a cache-flush on shutdown (me/Alan)
616
617 * Tue May 04 2004 Arjan van de Ven <arjanv@redhat.com>
618 - work around i810/i830 DRM issue
619
620 * Fri Apr 30 2004 Arjan van de Ven <arjanv@redhat.com>
621 - 2.6.6-rc3-bk1
622 - make amd64 boot again
623 - fix vm86-vs-4g4g interaction (Ingo)
624
625 * Thu Apr 22 2004 Arjan van de Ven <arjanv@redhat.com>
626 - 2.6.6-rc2
627  
628 * Tue Apr 20 2004 Arjan van de Ven <arjanv@redhat.com>
629 - add the ext3 online resize patch
630
631 * Mon Apr 19 2004 Arjan van de Ven <arjanv@redhat.com>
632 - 2.6.6-rc1-bk3
633 - add the objrmap vm from the -mm tree; it needs testing
634
635 * Thu Apr 15 2004 Arjan van de Ven <arjanv@redhat.com>
636 - 2.6.5-bk2
637 - disable DISCONTIGMEM on ia64 for performance
638 - fix sleep_on use in reiserfs (Chris Mason)
639
640 * Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>
641 - 2.6.5-mc4
642 - reenable sg driver for scsi tape changers and such
643 - the sk98lin driver oopses on module unload, preven that
644
645 * Mon Apr 12 2004 Arjan van de Ven <arjanv@redhat.com>
646 - fix "bad pmd" bug with patch from Ingo
647
648 * Fri Apr 09 2004 Arjan van de Ven <arjanv@redhat.com>
649 - 2.6.5-mc3
650 - finish up the -mc2 merge
651 - latest 4g/4g patch from Ingo
652 - latest execshield patch from Ingo
653 - fix a few framebuffer bugs
654
655 * Thu Apr 08 2004 Arjan van de Ven <arjanv@redhat.com>
656 - first attempt at a 2.6.5-mc2 merge
657
658 * Thu Apr 08 2004 Dave Jones <davej@redhat.com>
659 - Add in missing SiS AGP fix.
660
661 * Tue Apr 06 2004 Dave Jones <davej@redhat.com>
662 - More agpgart fixes.
663
664 * Fri Apr 02 2004 Arjan van de Ven <arjanv@redhat.com>
665 - fix another 4g/4g-vs-resume bug
666
667 * Tue Mar 30 2004 Arjan van de Ven <arjanv@redhat.com>
668 - 2.6.5-rc3
669 - fix PCI posting bug in i830 DRM
670
671 * Mon Mar 29 2004 Arjan van de Ven <arjanv@redhat.com>
672 - 2.6.5-rc2-bk8
673
674 * Mon Mar 29 2004 Dave Jones <davej@redhat.com>
675 - Include latest agpgart fixes.
676
677 * Thu Mar 25 2004 Arjan van de Ven <arjanv@redhat.com>
678 - more DRM fixes
679 - add the fsync patches from akpm
680
681 * Tue Mar 23 2004 Arjan van de Ven <arjanv@redhat.com>
682 - 2.6.5-rc2-bk3
683 - fix direct userspace memory access in i830 drm driver
684
685 * Mon Mar 22 2004 Arjan van de Ven <arjanv@redhat.com>
686 - 2.6.5-rc2-bk2
687 - some stackbloat reductions from Dave and me
688
689 * Sat Mar 20 2004 Arjan van de Ven <arjanv@redhat.com>
690 - 2.6.5-rc2
691
692 * Tue Mar 16 2004 Dave Jones <davej@redhat.com>
693 - 2.6.5-rc1
694
695 * Mon Mar 15 2004 Arjan van de Ven <arjanv@redhat.com>
696 - 2.6.4-bk3
697 - fix oops in toshiba_acpi (Barry K. Nathan)
698
699 * Sat Mar 13 2004 Arjan van de Ven <arjanv@redhat.com>
700 - 2.6.4-bk2 merge 
701
702 * Thu Mar 11 2004 Arjan van de Ven <arjanv@redhat.com>
703 - renable sonypi driver that was off accidentally
704 - 2.6.4-final 
705 - fix the oops on alsa module unloads
706
707 * Wed Mar 10 2004 Arjan van de Ven <arjanv@redhat.com>
708 - add ppc64/iseries, ppc32 (powermac/ibook) and ia64 architectures
709 - 2.6.4-rc3 
710
711 * Tue Mar 09 2004 Arjan van de Ven <arjanv@redhat.com>
712 - 2.6.4-rc2-bk5
713 - fix nfs-vs-selinux issue
714 - fix typo in URL as per #117849
715
716 * Mon Mar 08 2004 Arjan van de Ven <arjanv@redhat.com>
717 - fix race in lp.c (#117710)
718 - 2.6.4-rc2-bk3
719 - attempt to fix S3 suspend-to-ram with 4g/4g split
720
721 * Sat Mar 06 2004 Arjan van de Ven <arjanv@redhat.com>
722 - fix reiserfs
723 - set HZ to 1000 again for some tests
724
725 * Wed Feb 25 2004 Arjan van de Ven <arjanv@redhat.com>
726 - merge back a bunch of fedora fixes
727 - disable audit
728
729 * Tue Feb 24 2004 Arjan van de Ven <arjanv@redhat.com>
730 - audit bugfixes
731 - update tux to a working version
732 - 2.6.3-bk5 merge
733
734 * Fri Feb 20 2004 Arjan van de Ven <arjanv@redhat.com>
735 - re-add and enable the Auditing patch
736 - switch several cpufreq modules to built in since detecting in userspace
737   which to use is unpleasant
738 * Thu Jul 03 2003 Arjan van de Ven <arjanv@redhat.com>
739 - 2.6 start 
740