11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
18 Source0: %{name}-%{version}.tar.bz2
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
31 Requires: python >= 2.5
33 Requires: xmlsec1-openssl-devel
34 Requires: libxslt-python
36 # xmlbuilder depends on lxml
38 Requires: python-setuptools
39 Requires: python-dateutil
41 # python 2.5 has uuid module added, for python 2.4 we still need it.
42 # we can't really check for if we can load uuid as a python module,
43 # it'll be installed by "devel.pkgs". we have the epel repository so
44 # python-uuid will be provided. but we can test for the python
46 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
49 # this also didn't work very well. I'll just check for distroname - baris
50 #%if %{distroname} == "centos5"
51 #Requires: python-uuid
55 Summary: the SFA wrapper around MyPLC's NodeManager
56 Group: Applications/System
58 Requires: pyOpenSSL >= 0.6
61 Summary: the SFA wrapper arounf MyPLC
62 Group: Applications/System
64 Requires: python-psycopg2
65 Requires: myplc-config
66 Requires: pyOpenSSL >= 0.7
69 Summary: the SFA experimenter-side CLI
70 Group: Applications/System
72 Requires: pyOpenSSL >= 0.7
75 Summary: sfatables policy tool for SFA
76 Group: Applications/System
80 This package provides the python libraries that the SFA implementation requires
83 This package implements the SFA interface which serves as a layer
84 between the existing PlanetLab NodeManager interfaces and the SFA API.
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab interfaces and the SFA API.
91 This package provides the client side of the SFA API, in particular
92 sfi.py, together with other utilities.
94 %description sfatables
95 sfatables is a tool for defining access and admission control policies
96 in an SFA network, in much the same way as iptables is for ip
97 networks. This is the command line interface to manage sfatables
106 rm -rf $RPM_BUILD_ROOT
107 make install DESTDIR="$RPM_BUILD_ROOT"
110 rm -rf $RPM_BUILD_ROOT
113 # sfa and sfatables depend each other.
114 %{_bindir}/sfa-server.py*
117 %{_bindir}/keyconvert.py*
118 /var/www/html/wsdl/*.wsdl
122 %{_bindir}/sfa_component_setup.py*
126 %defattr(-,root,root)
127 %config /etc/sfa/default_config.xml
128 %config (noreplace) /etc/sfa/aggregates.xml
129 %config (noreplace) /etc/sfa/registries.xml
132 %{_bindir}/sfa-config-tty
133 %{_bindir}/sfa-import-plc.py*
134 %{_bindir}/sfa-clean-peer-records.py*
135 %{_bindir}/sfa-nuke-plc.py*
136 %{_bindir}/gen-sfa-cm-config.py*
137 %{_bindir}/sfa-ca.py*
140 %config (noreplace) /etc/sfa/sfi_config
142 %{_bindir}/getNodes.py*
143 %{_bindir}/getRecord.py*
144 %{_bindir}/setRecord.py*
145 %{_bindir}/sfadump.py*
151 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
154 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
160 chkconfig --add sfa-cm
163 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
164 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
165 to avoid returning a PLCAPI exception that might confuse users.
166 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.
169 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
170 - (Architecture) Credential format changed to match ProtoGENI xml format
171 - (Architecture) All interfaces export a new set of methods that are compatible
172 with the ProtoGeni Aggregate spec. These new methods are considered a
173 replacement for the pervious methods exported by the interfaces. All
174 previous methods are still exported and work as normal, but they are
175 considered deprecated and will not be supported in future releases.
176 - (Architecture) SFI has been updated to use the new interface methods.
177 - (Architecture) Changed keyconvet implementation from c to python.
178 - (Architecture) Slice Manager now attempts looks for a delegated credential
179 provided by the client before using its own server credential.
180 - (Archiceture) Slice Interface no longers stores cache of resources on disk.
181 This cache now exists only in memory and is cleared when service is restarted
182 or cache lifetime is exceeded.
183 - (Performance) SliceManager sends request to Aggregates in parallel instead
185 - (Bug fix) SFA tickets now support the new rspec format.
186 - (Bug fix) SFI only uses cahced credential if they aren't expired.
187 - (Bug fix) Cerdential delegation modified to work with new credential format.
188 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
189 Aggregate instead of relaying through the Slice Manager.
190 - (Enhancement) Simplified caching. Accociated a global cache instance with
191 the api handler on every new server request, making it easier to access the
192 cache and use in more general ways.
195 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
196 - SfaServer now uses a pool of threads to handle requests concurrently
197 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
198 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
199 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
200 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir
201 - Component manager does not install gid files if slice already has them
202 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
203 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
204 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
206 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
207 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support. Other features are:
208 - - sfa-config-tty now has the same features like plc-config-tty
209 - - Contains code to support both urn and hrn
210 - - Cleaned up request_hash related stuff
211 - - SM, AM and Registry code is organized under respective managers
212 - - Site and Slice synchronization across federated aggregates
213 - - Script to generate sfa_component_config
215 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
216 - sfa-config-tty now has the same features like plc-config-tty
217 - Contains code to support both urn and hrn
218 - Cleaned up request_hash related stuff
219 - SM, AM and Registry code is organized under respective managers
220 - Slice synchronization across federated aggregates
221 - some bugs are fixed
223 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
224 - checkpoint with fewer mentions of geni
226 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
228 - this is believed to pass the tests; among other things:
229 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
231 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
234 - - Preliminary version of hash based authentication
235 - - Initial code for Component Manager
236 - - Authority structure is moved to /var/lib/sfa/
239 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
240 - Create_slice and get_resources methods are connected to sfatables.
241 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
243 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
244 - Bug fix on update and remove_peer_object methods
245 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
247 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
248 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
250 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
251 - compatibility with RefreshPeer
252 - incremental mechanism for importing PLC records into SFA tables
253 - unified single database (still inside the underlying PLC db postgresql server)
254 - includes/improves call traceability and logging features
257 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
258 - added libxslt-python dependency
260 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
261 - unified single SFA database in the PLC-DB
262 - upcalls from PLCAPI to SFA methods
263 - SFA call traceability and logging features
265 - includes first/rough version of sfatables for policy implementation
267 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
268 - snapshot after the GEC5 demo
269 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
271 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
272 - snapshot july 15 - has gone through superficial manual testing
273 - hopefully a good basis for gec5 demo
274 - multi-dir sfi client tested as well
276 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
277 - rename geniwrapper.spec into sfa.spec
279 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
280 - clean up in xmlrpc/soap, --protocol option to chose between both
281 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
282 - hopefully more helpful context in case of crashes when importing
283 - bugfixes for using only /etc/sfa for site-dep files
284 - bugfixes in wsdl generation
286 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
287 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
288 - config variables in sfa_config now start with SFA_ and not GENI_
289 - config.py can be loaded even with no config present
291 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
292 - first step for cleanup and reorganization
293 - mass-renaming from geni to sfa (some are still needed)
294 - sfa/trust implements the security architecture
296 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
297 - snapshot for reproducible builds
299 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
300 - snapshot for the convenience of alpha users
302 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
303 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
305 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
306 - ongoing work - snapshot for 4.3-rc9
308 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
311 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
312 - bugfixes - still a work in progress
314 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
318 %define module_current_branch 0.2