setting the sfa-0.9-15 tag
[sfa.git] / sfa.spec
1 #
2 # $Id: sfa.spec 18414 2010-06-29 20:34:20Z baris $
3 #
4
5 %define url $URL: http://svn.planet-lab.org/svn/sfa/trunk/sfa.spec $
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 15
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: xmlsec1-openssl-devel
34 Requires: libxslt-python
35 Requires: python-ZSI
36 # xmlbuilder depends on  lxml
37 Requires: python-lxml
38 Requires: python-setuptools
39 Requires: python-dateutil
40  
41 # python 2.5 has uuid module added, for python 2.4 we still need it.
42 # we can't really check for if we can load uuid as a python module,
43 # it'll be installed by "devel.pkgs". we have the epel repository so
44 # python-uuid will be provided. but we can test for the python
45 # version.
46 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
47 # %if %has_py24
48 #
49 # this also didn't work very well. I'll just check for distroname - baris
50 %if %{distroname} == "centos5"
51 Requires: python-uuid
52 %endif
53
54 %package cm
55 Summary: the SFA wrapper around MyPLC's NodeManager
56 Group: Applications/System
57 Requires: sfa
58 Requires: pyOpenSSL >= 0.6
59
60 %package plc
61 Summary: the SFA wrapper arounf MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65 Requires: myplc-config
66 Requires: pyOpenSSL >= 0.7
67
68 %package client
69 Summary: the SFA experimenter-side CLI
70 Group: Applications/System
71 Requires: sfa
72 Requires: pyOpenSSL >= 0.7
73
74 %package sfatables
75 Summary: sfatables policy tool for SFA
76 Group: Applications/System
77 Requires: sfa
78
79 %description
80 This package provides the python libraries that the SFA implementation requires
81
82 %description cm
83 This package implements the SFA interface which serves as a layer
84 between the existing PlanetLab NodeManager interfaces and the SFA API.
85  
86 %description plc
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab interfaces and the SFA API.
89
90 %description client
91 This package provides the client side of the SFA API, in particular
92 sfi.py, together with other utilities.
93
94 %description sfatables
95 sfatables is a tool for defining access and admission control policies
96 in an SFA network, in much the same way as iptables is for ip
97 networks. This is the command line interface to manage sfatables
98
99 %prep
100 %setup -q
101
102 %build
103 make
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 make install DESTDIR="$RPM_BUILD_ROOT"
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 # sfa and sfatables depend each other.
114 %{_bindir}/sfa-server.py*
115 /etc/sfatables/*
116 %{python_sitelib}/*
117 %{_bindir}/keyconvert.py*
118 /var/www/html/wsdl/*.wsdl
119
120 %files cm
121 /etc/init.d/sfa-cm
122 %{_bindir}/sfa_component_setup.py*
123 # cron jobs here 
124
125 %files plc
126 %defattr(-,root,root)
127 %config /etc/sfa/default_config.xml
128 %config (noreplace) /etc/sfa/aggregates.xml
129 %config (noreplace) /etc/sfa/registries.xml
130 /etc/init.d/sfa
131 /etc/sfa/pl.rng
132 %{_bindir}/sfa-config-tty
133 %{_bindir}/sfa-import-plc.py*
134 %{_bindir}/sfa-clean-peer-records.py*
135 %{_bindir}/sfa-nuke-plc.py*
136 %{_bindir}/gen-sfa-cm-config.py*
137 %{_bindir}/sfa-ca.py*
138
139 %files client
140 %config (noreplace) /etc/sfa/sfi_config
141 %{_bindir}/sfi*
142 %{_bindir}/getNodes.py*
143 %{_bindir}/getRecord.py*
144 %{_bindir}/setRecord.py*
145 %{_bindir}/sfadump.py*
146
147 %files sfatables
148 %{_bindir}/sfatables
149
150 %pre plc
151 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
152
153 %pre cm
154 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
155
156 %post plc
157 chkconfig --add sfa
158
159 %post cm
160 chkconfig --add sfa-cm
161
162 %changelog
163 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
164 - (Architecture) Credential format changed to match ProtoGENI xml format
165 - (Architecture) All interfaces export a new set of methods that are compatible
166    with the ProtoGeni Aggregate spec. These new methods are considered a 
167    replacement  for the pervious methods exported by the interfaces. All 
168    previous methods are still exported and work as normal, but they are 
169    considered deprecated and will not be supported in future releases.  
170 - (Architecture) SFI has been updated to use the new interface methods.
171 - (Architecture) Changed keyconvet implementation from c to python.
172 - (Architecture) Slice Manager now attempts looks for a delegated credential
173   provided by the client before using its own server credential.
174 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
175   This cache now exists only in memory and is cleared when service is restarted
176   or cache lifetime is exceeded.  
177 - (Performance) SliceManager sends request to Aggregates in parallel instead 
178   of sequentially.
179 - (Bug fix) SFA tickets now support the new rspec format.
180 - (Bug fix) SFI only uses cahced credential if they aren't expired.
181 - (Bug fix) Cerdential delegation modified to work with new credential format.
182 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
183   Aggregate instead of relaying through the Slice Manager.
184 - (Enhancement) Simplified caching. Accociated a global cache instance with
185   the api handler on every new server request, making it easier to access the 
186   cache and use in more general ways.     
187
188 %changelog
189 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
190 - SfaServer now uses a pool of threads to handle requests concurrently
191 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
192 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
193 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
194 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
195 - Component manager does not install gid files if slice already has them  
196 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
197 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
198 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
199      
200 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
201 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
202 - - sfa-config-tty now has the same features like plc-config-tty
203 - - Contains code to support both urn and hrn
204 - - Cleaned up request_hash related stuff
205 - - SM, AM and Registry code is organized under respective managers
206 - - Site and Slice synchronization across federated aggregates
207 - - Script to generate sfa_component_config
208
209 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
210 - sfa-config-tty now has the same features like plc-config-tty
211 - Contains code to support both urn and hrn
212 - Cleaned up request_hash related stuff
213 - SM, AM and Registry code is organized under respective managers
214 - Slice synchronization across federated aggregates
215 - some bugs are fixed
216
217 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
218 - checkpoint with fewer mentions of geni
219
220 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
221 - checkpointing
222 - this is believed to pass the tests; among other things:
223 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
224
225 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
226 - This tag includes:
227 - - Sfatables
228 - - Preliminary version of hash based authentication
229 - - Initial code for Component Manager
230 - - Authority structure is moved to /var/lib/sfa/
231 - - some bug-fixes
232
233 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
234 - Create_slice and get_resources methods are connected to sfatables.
235 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
236
237 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
238 - Bug fix on update and remove_peer_object methods
239 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
240
241 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
242 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
243
244 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
245 - compatibility with RefreshPeer
246 - incremental mechanism for importing PLC records into SFA tables
247 - unified single database (still inside the underlying PLC db postgresql server)
248 - includes/improves call traceability and logging features
249 - several bug fixes
250
251 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
252 - added libxslt-python dependency
253
254 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
255 - unified single SFA database in the PLC-DB
256 - upcalls from  PLCAPI to SFA methods
257 - SFA call traceability and logging features
258 - many bug fixes
259 - includes first/rough version of sfatables for policy implementation
260
261 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
262 - snapshot after the GEC5 demo
263 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
264
265 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
266 - snapshot july 15 - has gone through superficial manual testing
267 - hopefully a good basis for gec5 demo
268 - multi-dir sfi client tested as well
269
270 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
271 - rename geniwrapper.spec into sfa.spec
272
273 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
274 - clean up in xmlrpc/soap, --protocol option to chose between both
275 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
276 - hopefully more helpful context in case of crashes when importing
277 - bugfixes for using only /etc/sfa for site-dep files
278 - bugfixes in wsdl generation
279
280 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
281 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
282 - config variables in sfa_config now start with SFA_ and not GENI_
283 - config.py can be loaded even with no config present
284
285 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
286 - first step for cleanup and reorganization
287 - mass-renaming from geni to sfa (some are still needed)
288 - sfa/trust implements the security architecture
289
290 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
291 - snapshot for reproducible builds
292
293 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
294 - snapshot for the convenience of alpha users
295
296 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
297 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
298
299 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
300 - ongoing work - snapshot for 4.3-rc9
301
302 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
303 - various fixes
304
305 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
306 - bugfixes - still a work in progress
307
308 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
309 - initial package
310
311
312 %define module_current_branch 0.2