Fix references to vswitch-idl.ovsschema to refer to vswitch.ovsschema.
[sliver-openvswitch.git] / xenserver / vswitch-xen.spec
1 # Spec file for vswitch and related programs.
2
3 # Copyright (C) 2009, 2010 Nicira Networks, Inc.
4 #
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved.  This file is offered as-is,
8 # without warranty of any kind.
9
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
12 # for example:
13 #
14 #    rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
15 #
16 %define version %{vswitch_version}-%{xen_version}
17
18 Name: vswitch
19 Summary: Virtual switch
20 Group: System Environment/Daemons
21 URL: http://www.openvswitch.org/
22 Version: %{vswitch_version}
23
24 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
25 License: ASL 2.0 and GPLv2
26 Release: 1
27 Source: openvswitch-%{vswitch_version}.tar.gz
28 Buildroot: /tmp/vswitch-xen-rpm
29 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
30 # The following Conflicts prevents the "vswitch" package generated by
31 # this spec file from installing at the same time as the "openvswitch"
32 # package shipped with XenServer 5.5.900.  In fact, the packages
33 # contain some files with identical names anyhow, so they will not
34 # coexist, but adding an explicit Conflicts makes this conflict more
35 # obvious.
36 Conflicts: openvswitch
37
38 %description
39 The vswitch provides standard network bridging functions augmented with
40 support for the OpenFlow protocol for remote per-flow control of
41 traffic.
42
43 %prep
44 %setup -q -n openvswitch-%{vswitch_version}
45
46 %build
47 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
48 make %{_smp_mflags}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make install DESTDIR=$RPM_BUILD_ROOT
53 install -d -m 755 $RPM_BUILD_ROOT/etc
54 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
55 install -m 755 xenserver/etc_init.d_vswitch \
56          $RPM_BUILD_ROOT/etc/init.d/vswitch
57 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
58          $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
59 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
60 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
61 install -m 755 xenserver/etc_logrotate.d_vswitch \
62          $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
63 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
64 install -m 755 xenserver/etc_profile.d_vswitch.sh \
65          $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
66 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
67 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
68          $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
69 install -d -m 755 $RPM_BUILD_ROOT/usr/share/vswitch/scripts
70 install -m 644 vswitchd/vswitch.ovsschema \
71          $RPM_BUILD_ROOT/usr/share/vswitch/vswitch.ovsschema
72 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
73              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/interface-reconfigure
74 install -m 755 xenserver/etc_xensource_scripts_vif \
75              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/vif
76 install -m 755 xenserver/usr_share_vswitch_scripts_dump-vif-details \
77                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/dump-vif-details
78 install -m 755 xenserver/usr_share_vswitch_scripts_refresh-xs-network-uuids \
79                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/refresh-xs-network-uuids
80 install -m 755 xenserver/usr_sbin_xen-bugtool \
81              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-bugtool
82 install -m 755 xenserver/usr_sbin_brctl \
83              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/brctl
84 install -m 755 xenserver/usr_share_vswitch_scripts_sysconfig.template \
85          $RPM_BUILD_ROOT/usr/share/vswitch/scripts/sysconfig.template
86 install -m 644 \
87         xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
88                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/XSFeatureVSwitch.py
89
90 install -d -m 755 $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch
91 find datapath/linux-2.6 -name *.ko -exec install -m 755  \{\} $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch \;
92
93 # Get rid of stuff we don't want to make RPM happy.
94 rm \
95     $RPM_BUILD_ROOT/usr/bin/ovs-controller \
96     $RPM_BUILD_ROOT/usr/bin/ovs-discover \
97     $RPM_BUILD_ROOT/usr/bin/ovs-kill \
98     $RPM_BUILD_ROOT/usr/bin/ovs-openflowd \
99     $RPM_BUILD_ROOT/usr/bin/ovs-pki \
100     $RPM_BUILD_ROOT/usr/bin/ovs-wdt \
101     $RPM_BUILD_ROOT/usr/sbin/ovs-monitor \
102     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-controller.8 \
103     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-discover.8 \
104     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-kill.8 \
105     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-openflowd.8 \
106     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-pki.8
107 rm -f $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch/veth_mod.ko
108
109 install -d -m 755 $RPM_BUILD_ROOT/var/lib/openvswitch
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 if [ ! -f /etc/xensource-inventory ]; then
116     printf "XenSource inventory not present in /etc/xensource-inventory"
117     exit 1
118 fi
119
120 if [ "$1" = "1" ]; then
121     if md5sum -c --status <<EOF
122 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
123 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
124 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
125 5654c8c36699fcc8744ca9cd5b855414  /usr/sbin/xen-bugtool
126 EOF
127     then
128         printf "\nVerified host scripts from XenServer 5.5.0.\n\n"
129     elif md5sum -c --status <<EOF
130 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
131 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
132 ce451d3c985fd1db6497a363f0d9dedb  /opt/xensource/libexec/interface-reconfigure
133 2b53f500431fcba5276c896e9e4281b9  /usr/sbin/xen-bugtool
134 EOF
135     then
136         printf "\nVerified host scripts from XenServer 5.5.900.\n\n"
137     else
138 cat <<EOF
139
140 The original XenServer scripts replaced by this package are not those
141 of any supported version of XenServer.  This could lead to unexpected
142 behavior of your server.  Unless you are sure you know what you are
143 doing, it is highly recommended that you remove this package
144 immediately after the install completes, which will restore the
145 XenServer scripts that you were previously using.
146
147 EOF
148     fi
149 fi
150
151 if test ! -e /var/lib/openvswitch/dbcache; then
152     if test "$1" = 1; then
153         printf "Creating xapi database cache...  "
154     else
155         printf "warning: Open vSwitch is being re-installed or upgraded,\n"
156         printf "         but the xapi database cache is missing.\n"
157         printf "Re-creating xapi database cache...  "
158     fi
159
160     if /usr/share/vswitch/scripts/interface-reconfigure rewrite; then
161         printf "done.\n"
162     else
163         printf "FAILED\n"
164         printf "Open vSwitch can only be installed on a XenServer that\n"
165         printf "has connectivity to xapi on the pool master.  Please\n"
166         printf "fix connectivity to the pool master, then try again.\n"
167         exit 1
168     fi
169 fi
170
171 # Ensure that modprobe will find our modules.
172 depmod %{xen_version}
173
174 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
175     cat >>/etc/sysctl.conf <<EOF
176 # This works around an issue in xhad, which binds to a particular
177 # Ethernet device, which in turn causes ICMP port unreachable messages
178 # if packets are received are on the wrong interface, which in turn
179 # can happen if we send out ARP replies on every interface (as Linux
180 # does by default) instead of just on the interface that has the IP
181 # address being ARPed for, which this sysctl setting in turn works
182 # around.
183 #
184 # Bug #1378.
185 net.ipv4.conf.all.arp_filter = 1
186 EOF
187 fi
188
189 if test ! -e /etc/ovs-vswitchd.conf.db; then
190     # Create ovs-vswitchd config database
191     ovsdb-tool -vANY:console:emer create /etc/ovs-vswitchd.conf.db \
192             /usr/share/vswitch/vswitch.ovsschema \
193
194     # Create initial table in config database
195     ovsdb-tool -vANY:console:emer transact /etc/ovs-vswitchd.conf.db \
196             '[{"op": "insert", "table": "Open_vSwitch", "row": {}}]' \
197             > /dev/null
198 fi
199
200 # Create default or update existing /etc/sysconfig/vswitch.
201 SYSCONFIG=/etc/sysconfig/vswitch
202 TEMPLATE=/usr/share/vswitch/scripts/sysconfig.template
203 if [ ! -e $SYSCONFIG ]; then
204     cp $TEMPLATE $SYSCONFIG
205 else
206     for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
207     do
208         if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
209             echo >> $SYSCONFIG
210             sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
211         fi
212     done
213 fi
214
215 # Replace XenServer files by our versions.
216 mkdir -p /usr/lib/vswitch/xs-original \
217     || printf "Could not create script backup directory.\n"
218 for f in \
219     /opt/xensource/libexec/interface-reconfigure \
220     /etc/xensource/scripts/vif \
221     /usr/sbin/xen-bugtool \
222     /usr/sbin/brctl
223 do
224     s=$(basename "$f")
225     t=$(readlink "$f")
226     if [ "$t" != "/usr/share/vswitch/scripts/$s" ]; then
227         mv "$f" /usr/lib/vswitch/xs-original/ \
228             || printf "Could not save original XenServer $s script\n"
229         ln -s "/usr/share/vswitch/scripts/$s" "$f" \
230             || printf "Could not link to vSwitch $s script\n"
231     fi
232 done
233
234 # Install xsconsole plugin
235 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
236 if [ "$plugin" != "/usr/share/vswitch/scripts/XSFeatureVSwitch.py" ]; then
237     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
238     ln -s /usr/share/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
239 fi
240
241 # Ensure all required services are set to run
242 for s in vswitch vswitch-xapi-update; do
243     if chkconfig --list $s >/dev/null 2>&1; then
244         chkconfig --del $s || printf "Could not remove $s init script."
245     fi
246     chkconfig --add $s || printf "Could not add $s init script."
247     chkconfig $s on || printf "Could not enable $s init script."
248 done
249
250 if [ "$1" = "1" ]; then    # $1 = 2 for upgrade
251     printf "\nYou MUST reboot the server NOW to complete the change to the\n"
252     printf "the vSwitch.  Attempts to modify networking on the server\n"
253     printf "or any hosted VM will fail until after the reboot and could\n"
254     printf "leave the server in an state requiring manual recovery.\n\n"
255 else
256     printf "\nTo use the new vSwitch, you should reboot the server\n"
257     printf "now.  Failure to do so may result in incorrect operation.\n\n"
258 fi
259
260 %preun
261 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
262     for s in vswitch vswitch-xapi-update; do
263         chkconfig --del $s || printf "Could not remove $s init script."
264     done
265 fi
266
267
268 %postun
269 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
270
271     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
272         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
273         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
274         || printf "Could not remove vSwitch xsconsole plugin.\n"
275
276     # Restore original XenServer scripts
277     for f in \
278         /opt/xensource/libexec/interface-reconfigure \
279         /etc/xensource/scripts/vif \
280         /usr/sbin/xen-bugtool \
281         /usr/sbin/brctl
282     do
283         s=$(basename "$f")
284         if [ ! -f "/usr/lib/vswitch/xs-original/$s" ]; then
285             printf "Original XenServer $s script not present in /usr/lib/vswitch/xs-original\n"
286             printf "Could not restore original XenServer script.\n"
287         else
288             (rm -f "$f" \
289                 && mv "/usr/lib/vswitch/xs-original/$s" "$f") \
290                 || printf "Could not restore original XenServer $s script.\n"
291         fi
292     done
293
294     # Remove all configuration files
295     rm -f /etc/ovs-vswitchd.conf.db
296     rm -f /etc/sysconfig/vswitch
297     rm -f /etc/ovs-vswitchd.cacert
298     rm -f /var/lib/openvswitch/dbcache
299
300     printf "\nYou MUST reboot the server now to complete the change to\n"
301     printf "standard Xen networking.  Attempts to modify networking on the\n"
302     printf "server or any hosted VM will fail until after the reboot and\n"
303     printf "could leave the server in a state requiring manual recovery.\n\n"
304 fi
305
306
307 %files
308 %defattr(-,root,root)
309 /etc/init.d/vswitch
310 /etc/init.d/vswitch-xapi-update
311 /etc/xapi.d/plugins/vswitch-cfg-update
312 /etc/logrotate.d/vswitch
313 /etc/profile.d/vswitch.sh
314 /lib/modules/%{xen_version}/kernel/net/vswitch/openvswitch_mod.ko
315 /lib/modules/%{xen_version}/kernel/net/vswitch/brcompat_mod.ko
316 %if %(echo '%{xen_version}'|awk -F"." '{if ($3>=18) print 1; else print 0;}')
317 /lib/modules/%{xen_version}/kernel/net/vswitch/ip_gre_mod.ko
318 %endif
319 /usr/share/vswitch/scripts/dump-vif-details
320 /usr/share/vswitch/scripts/refresh-xs-network-uuids
321 /usr/share/vswitch/scripts/interface-reconfigure
322 /usr/share/vswitch/scripts/vif
323 /usr/share/vswitch/scripts/xen-bugtool
324 /usr/share/vswitch/scripts/XSFeatureVSwitch.py
325 /usr/share/vswitch/scripts/brctl
326 /usr/share/vswitch/scripts/sysconfig.template
327 # Following two files are generated automatically by rpm.  We don't
328 # really need them and they won't be used on the XenServer, but there
329 # isn't an obvious place to get rid of them since they are generated
330 # after the install script runs.  Since they are small, we just
331 # include them.
332 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyc
333 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyo
334 /usr/share/vswitch/vswitch.ovsschema
335 /usr/sbin/ovs-brcompatd
336 /usr/sbin/ovs-vswitchd
337 /usr/sbin/ovsdb-server
338 /usr/bin/ovs-appctl
339 /usr/bin/ovs-dpctl
340 /usr/bin/ovs-ofctl
341 /usr/bin/ovs-vsctl
342 /usr/bin/ovsdb-client
343 /usr/bin/ovsdb-tool
344 /usr/share/man/man1/ovsdb-client.1.gz
345 /usr/share/man/man1/ovsdb-server.1.gz
346 /usr/share/man/man1/ovsdb-tool.1.gz
347 /usr/share/man/man8/ovs-appctl.8.gz
348 /usr/share/man/man8/ovs-brcompatd.8.gz
349 /usr/share/man/man8/ovs-dpctl.8.gz
350 /usr/share/man/man8/ovs-ofctl.8.gz
351 /usr/share/man/man8/ovs-vsctl.8.gz
352 /usr/share/man/man8/ovs-vswitchd.8.gz
353 /var/lib/openvswitch