Merge master branch into xs5.7.
[sliver-openvswitch.git] / xenserver / vswitch-xen.spec
1 # Spec file for vswitch and related programs.
2
3 # Copyright (C) 2009 Nicira Networks, Inc.
4 #
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved.  This file is offered as-is,
8 # without warranty of any kind.
9
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
12 # for example:
13 #
14 #    rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
15 #
16 %define version %{vswitch_version}-%{xen_version}
17
18 Name: vswitch
19 Summary: Virtual switch
20 Group: System Environment/Daemons
21 URL: http://www.openvswitch.org/
22 Version: %{vswitch_version}
23
24 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
25 License: ASL 2.0 and GPLv2
26 Release: 1
27 Source: openvswitch-%{vswitch_version}.tar.gz
28 Buildroot: /tmp/vswitch-xen-rpm
29 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
30 # The following Conflicts prevents the "vswitch" package generated by
31 # this spec file from installing at the same time as the "openvswitch"
32 # package shipped with XenServer 5.5.900.  In fact, the packages
33 # contain some files with identical names anyhow, so they will not
34 # coexist, but adding an explicit Conflicts makes this conflict more
35 # obvious.
36 Conflicts: openvswitch
37
38 %description
39 The vswitch provides standard network bridging functions augmented with
40 support for the OpenFlow protocol for remote per-flow control of
41 traffic.
42
43 %prep
44 %setup -q -n openvswitch-%{vswitch_version}
45
46 %build
47 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
48 make %{_smp_mflags}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 make install DESTDIR=$RPM_BUILD_ROOT
53 install -d -m 755 $RPM_BUILD_ROOT/etc
54 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
55 install -m 755 xenserver/etc_init.d_vswitch \
56          $RPM_BUILD_ROOT/etc/init.d/vswitch
57 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
58          $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
59 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
60 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
61 install -m 755 xenserver/etc_logrotate.d_vswitch \
62          $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
63 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
64 install -m 755 xenserver/etc_profile.d_vswitch.sh \
65          $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
66 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
67 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
68          $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
69 install -d -m 755 $RPM_BUILD_ROOT/usr/share/vswitch/scripts
70 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
71              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/interface-reconfigure
72 install -m 755 xenserver/etc_xensource_scripts_vif \
73              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/vif
74 install -m 755 xenserver/usr_share_vswitch_scripts_vif-on-internal-bridge \
75              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/vif-on-internal-bridge
76 install -m 755 xenserver/usr_share_vswitch_scripts_refresh-xs-network-uuids \
77                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/refresh-xs-network-uuids
78 install -m 755 xenserver/usr_sbin_xen-bugtool \
79              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-bugtool
80 install -m 755 xenserver/usr_sbin_brctl \
81              $RPM_BUILD_ROOT/usr/share/vswitch/scripts/brctl
82 install -m 755 xenserver/usr_share_vswitch_scripts_sysconfig.template \
83          $RPM_BUILD_ROOT/usr/share/vswitch/scripts/sysconfig.template
84 install -m 644 xenserver/etc_udev_xen-backend.rules \
85         $RPM_BUILD_ROOT/usr/share/vswitch/scripts/xen-backend.rules
86 install -m 644 \
87         xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
88                $RPM_BUILD_ROOT/usr/share/vswitch/scripts/XSFeatureVSwitch.py
89
90 install -d -m 755 $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch
91 find datapath/linux-2.6 -name *.ko -exec install -m 755  \{\} $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch \;
92
93 # Get rid of stuff we don't want to make RPM happy.
94 rm \
95     $RPM_BUILD_ROOT/usr/bin/ovs-controller \
96     $RPM_BUILD_ROOT/usr/bin/ovs-discover \
97     $RPM_BUILD_ROOT/usr/bin/ovs-kill \
98     $RPM_BUILD_ROOT/usr/bin/ovs-openflowd \
99     $RPM_BUILD_ROOT/usr/bin/ovs-pki \
100     $RPM_BUILD_ROOT/usr/bin/ovs-wdt \
101     $RPM_BUILD_ROOT/usr/sbin/ovs-monitor \
102     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-controller.8 \
103     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-discover.8 \
104     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-kill.8 \
105     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-openflowd.8 \
106     $RPM_BUILD_ROOT/usr/share/man/man8/ovs-pki.8
107 rm -f $RPM_BUILD_ROOT/lib/modules/%{xen_version}/kernel/net/vswitch/veth_mod.ko
108 rm -r \
109     $RPM_BUILD_ROOT/usr/share/openvswitch/commands
110
111 install -d -m 755 $RPM_BUILD_ROOT/var/lib/openvswitch
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 if [ ! -f /etc/xensource-inventory ]; then
118     printf "XenSource inventory not present in /etc/xensource-inventory"
119     exit 1
120 fi
121
122 if [ "$1" = "1" ]; then
123     if md5sum -c --status <<EOF
124 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
125 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
126 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
127 5654c8c36699fcc8744ca9cd5b855414  /usr/sbin/xen-bugtool
128 883820a78723ee21340f31099b18f18e  /etc/udev/xen-backend.rules
129 EOF
130     then
131         printf "\nVerified host scripts from XenServer 5.5.0.\n\n"
132     elif md5sum -c --status <<EOF
133 ca141d60061dcfdade73e75abc6529b5  /usr/sbin/brctl
134 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
135 ce451d3c985fd1db6497a363f0d9dedb  /opt/xensource/libexec/interface-reconfigure
136 2b53f500431fcba5276c896e9e4281b9  /usr/sbin/xen-bugtool
137 883820a78723ee21340f31099b18f18e  /etc/udev/xen-backend.rules
138 EOF
139     then
140         printf "\nVerified host scripts from XenServer 5.5.900.\n\n"
141     else
142 cat <<EOF
143
144 The original XenServer scripts replaced by this package are not those
145 of any supported version of XenServer.  This could lead to unexpected
146 behavior of your server.  Unless you are sure you know what you are
147 doing, it is highly recommended that you remove this package
148 immediately after the install completes, which will restore the
149 XenServer scripts that you were previously using.
150
151 EOF
152     fi
153 fi
154
155 if test ! -e /var/lib/openvswitch/dbcache; then
156     if test "$1" = 1; then
157         printf "Creating xapi database cache...  "
158     else
159         printf "warning: Open vSwitch is being re-installed or upgraded,\n"
160         printf "         but the xapi database cache is missing.\n"
161         printf "Re-creating xapi database cache...  "
162     fi
163
164     if /usr/share/vswitch/scripts/interface-reconfigure rewrite; then
165         printf "done.\n"
166     else
167         printf "FAILED\n"
168         printf "Open vSwitch can only be installed on a XenServer that\n"
169         printf "has connectivity to xapi on the pool master.  Please\n"
170         printf "fix connectivity to the pool master, then try again.\n"
171         exit 1
172     fi
173 fi
174
175 # Ensure that modprobe will find our modules.
176 depmod %{xen_version}
177
178 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
179     cat >>/etc/sysctl.conf <<EOF
180 # This works around an issue in xhad, which binds to a particular
181 # Ethernet device, which in turn causes ICMP port unreachable messages
182 # if packets are received are on the wrong interface, which in turn
183 # can happen if we send out ARP replies on every interface (as Linux
184 # does by default) instead of just on the interface that has the IP
185 # address being ARPed for, which this sysctl setting in turn works
186 # around.
187 #
188 # Bug #1378.
189 net.ipv4.conf.all.arp_filter = 1
190 EOF
191 fi
192
193 # Ensure ovs-vswitchd.conf exists
194 touch /etc/ovs-vswitchd.conf
195
196 # Create default or update existing /etc/sysconfig/vswitch.
197 SYSCONFIG=/etc/sysconfig/vswitch
198 TEMPLATE=/usr/share/vswitch/scripts/sysconfig.template
199 if [ ! -e $SYSCONFIG ]; then
200     cp $TEMPLATE $SYSCONFIG
201 else
202     for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
203     do
204         if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
205             echo >> $SYSCONFIG
206             sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
207         fi
208     done
209 fi
210
211 # Replace XenServer files by our versions.
212 mkdir -p /usr/lib/vswitch/xs-original \
213     || printf "Could not create script backup directory.\n"
214 for f in \
215     /opt/xensource/libexec/interface-reconfigure \
216     /etc/xensource/scripts/vif \
217     /usr/sbin/xen-bugtool \
218     /usr/sbin/brctl \
219     /etc/udev/xen-backend.rules
220 do
221     s=$(basename "$f")
222     t=$(readlink "$f")
223     if [ "$t" != "/usr/share/vswitch/scripts/$s" ]; then
224         mv "$f" /usr/lib/vswitch/xs-original/ \
225             || printf "Could not save original XenServer $s script\n"
226         ln -s "/usr/share/vswitch/scripts/$s" "$f" \
227             || printf "Could not link to vSwitch $s script\n"
228     fi
229 done
230
231 # Install xsconsole plugin
232 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
233 if [ "$plugin" != "/usr/share/vswitch/scripts/XSFeatureVSwitch.py" ]; then
234     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
235     ln -s /usr/share/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
236 fi
237
238 # Ensure all required services are set to run
239 for s in vswitch vswitch-xapi-update; do
240     if chkconfig --list $s >/dev/null 2>&1; then
241         chkconfig --del $s || printf "Could not remove $s init script."
242     fi
243     chkconfig --add $s || printf "Could not add $s init script."
244     chkconfig $s on || printf "Could not enable $s init script."
245 done
246
247 if [ "$1" = "1" ]; then    # $1 = 2 for upgrade
248     printf "\nYou MUST reboot the server NOW to complete the change to the\n"
249     printf "the vSwitch.  Attempts to modify networking on the server\n"
250     printf "or any hosted VM will fail until after the reboot and could\n"
251     printf "leave the server in an state requiring manual recovery.\n\n"
252 else
253     printf "\nTo use the new vSwitch, you should reboot the server\n"
254     printf "now.  Failure to do so may result in incorrect operation.\n\n"
255 fi
256
257 %preun
258 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
259     for s in vswitch vswitch-xapi-update; do
260         chkconfig --del $s || printf "Could not remove $s init script."
261     done
262 fi
263
264
265 %postun
266 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
267
268     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
269         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
270         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
271         || printf "Could not remove vSwitch xsconsole plugin.\n"
272
273     # Restore original XenServer scripts
274     for f in \
275         /opt/xensource/libexec/interface-reconfigure \
276         /etc/xensource/scripts/vif \
277         /usr/sbin/xen-bugtool \
278         /usr/sbin/brctl \
279         /etc/udev/xen-backend.rules
280     do
281         s=$(basename "$f")
282         if [ ! -f "/usr/lib/vswitch/xs-original/$s" ]; then
283             printf "Original XenServer $s script not present in /usr/lib/vswitch/xs-original\n"
284             printf "Could not restore original XenServer script.\n"
285         else
286             (rm -f "$f" \
287                 && mv "/usr/lib/vswitch/xs-original/$s" "$f") \
288                 || printf "Could not restore original XenServer $s script.\n"
289         fi
290     done
291
292     # Remove all configuration files
293     rm -f /etc/ovs-vswitchd.conf
294     rm -f /etc/sysconfig/vswitch
295     rm -f /etc/ovs-vswitchd.cacert
296     rm -f /var/lib/openvswitch/dbcache
297
298     printf "\nYou MUST reboot the server now to complete the change to\n"
299     printf "standard Xen networking.  Attempts to modify networking on the\n"
300     printf "server or any hosted VM will fail until after the reboot and\n"
301     printf "could leave the server in a state requiring manual recovery.\n\n"
302 fi
303
304
305 %files
306 %defattr(-,root,root)
307 /etc/init.d/vswitch
308 /etc/init.d/vswitch-xapi-update
309 /etc/xapi.d/plugins/vswitch-cfg-update
310 /etc/logrotate.d/vswitch
311 /etc/profile.d/vswitch.sh
312 /lib/modules/%{xen_version}/kernel/net/vswitch/openvswitch_mod.ko
313 /lib/modules/%{xen_version}/kernel/net/vswitch/brcompat_mod.ko
314 /usr/share/vswitch/scripts/refresh-xs-network-uuids
315 /usr/share/vswitch/scripts/interface-reconfigure
316 /usr/share/vswitch/scripts/vif
317 /usr/share/vswitch/scripts/xen-bugtool
318 /usr/share/vswitch/scripts/XSFeatureVSwitch.py
319 /usr/share/vswitch/scripts/brctl
320 /usr/share/vswitch/scripts/sysconfig.template
321 /usr/share/vswitch/scripts/vif-on-internal-bridge
322 /usr/share/vswitch/scripts/xen-backend.rules
323 # Following two files are generated automatically by rpm.  We don't
324 # really need them and they won't be used on the XenServer, but there
325 # isn't an obvious place to get rid of them since they are generated
326 # after the install script runs.  Since they are small, we just
327 # include them.
328 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyc
329 /usr/share/vswitch/scripts/XSFeatureVSwitch.pyo
330 /usr/sbin/ovs-brcompatd
331 /usr/sbin/ovs-vswitchd
332 /usr/bin/ovs-appctl
333 /usr/bin/ovs-cfg-mod
334 /usr/bin/ovs-dpctl
335 /usr/bin/ovs-ofctl
336 /usr/bin/ovs-vsctl
337 /usr/share/man/man5/ovs-vswitchd.conf.5.gz
338 /usr/share/man/man8/ovs-appctl.8.gz
339 /usr/share/man/man8/ovs-brcompatd.8.gz
340 /usr/share/man/man8/ovs-cfg-mod.8.gz
341 /usr/share/man/man8/ovs-dpctl.8.gz
342 /usr/share/man/man8/ovs-ofctl.8.gz
343 /usr/share/man/man8/ovs-vsctl.8.gz
344 /usr/share/man/man8/ovs-vswitchd.8.gz
345 /var/lib/openvswitch