Merge commit 'v0.90.6' into citrix
[sliver-openvswitch.git] / xenserver / vswitch-xen.spec
1 # Spec file for vswitch and related programs.
2
3 # Copyright (C) 2009 Nicira Networks, Inc.
4 #
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved.  This file is offered as-is,
8 # without warranty of any kind.
9
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
12 # for example:
13 #
14 #    rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
15 #
16 %define version %{vswitch_version}-%{xen_version}
17 %define _prefix /root/vswitch
18
19 Name: vswitch
20 Summary: Virtual switch
21 Group: System Environment/Daemons
22 URL: http://www.openvswitch.org/
23 Version: %{vswitch_version}
24
25 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
26 License: ASL 2.0 and GPLv2
27 Release: 1
28 Source: openvswitch-%{vswitch_version}.tar.gz
29 Buildroot: /tmp/vswitch-xen-rpm
30 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
31
32 %description
33 The vswitch provides standard network bridging functions augmented with
34 support for the OpenFlow protocol for remote per-flow control of
35 traffic.
36
37 %prep
38 %setup -q -n openvswitch-%{vswitch_version}
39
40 %build
41 ./configure --prefix=%{_prefix} --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
42 make %{_smp_mflags}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 make install DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix}
47 install -d -m 755 $RPM_BUILD_ROOT/etc
48 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
49 install -m 755 xenserver/etc_init.d_vswitch \
50          $RPM_BUILD_ROOT/etc/init.d/vswitch
51 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
52          $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
53 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
54 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
55 install -m 755 xenserver/etc_logrotate.d_vswitch \
56          $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
57 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
58 install -m 755 xenserver/etc_profile.d_vswitch.sh \
59          $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
60 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
61 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
62          $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
63 install -d -m 755 $RPM_BUILD_ROOT%{_prefix}/scripts
64 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
65              $RPM_BUILD_ROOT%{_prefix}/scripts/interface-reconfigure
66 install -m 755 xenserver/etc_xensource_scripts_vif \
67              $RPM_BUILD_ROOT%{_prefix}/scripts/vif
68 install -m 755 xenserver/root_vswitch_scripts_dump-vif-details \
69                $RPM_BUILD_ROOT%{_prefix}/scripts/dump-vif-details
70 install -m 755 xenserver/root_vswitch_scripts_refresh-xs-network-uuids \
71                $RPM_BUILD_ROOT%{_prefix}/scripts/refresh-xs-network-uuids
72 install -m 755 xenserver/usr_sbin_xen-bugtool \
73              $RPM_BUILD_ROOT%{_prefix}/scripts/xen-bugtool
74 install -m 755 xenserver/usr_sbin_brctl \
75              $RPM_BUILD_ROOT%{_prefix}/scripts/brctl
76 install -m 755 xenserver/root_vswitch_scripts_sysconfig.template \
77          $RPM_BUILD_ROOT/root/vswitch/scripts/sysconfig.template
78 install -m 644 \
79         xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
80                $RPM_BUILD_ROOT%{_prefix}/scripts/XSFeatureVSwitch.py
81
82 install -d -m 755 $RPM_BUILD_ROOT%{_prefix}/kernel_modules
83 find datapath/linux-2.6 -name *.ko -exec install -m 755  \{\} $RPM_BUILD_ROOT%{_prefix}/kernel_modules/ \;
84
85 # Get rid of stuff we don't want to make RPM happy.
86 rm -rf \
87     $RPM_BUILD_ROOT/root/vswitch/bin/ezio-term \
88     $RPM_BUILD_ROOT/root/vswitch/bin/ovs-controller \
89     $RPM_BUILD_ROOT/root/vswitch/bin/ovs-discover \
90     $RPM_BUILD_ROOT/root/vswitch/bin/ovs-kill \
91     $RPM_BUILD_ROOT/root/vswitch/bin/ovs-pki \
92     $RPM_BUILD_ROOT/root/vswitch/bin/ovs-switchui \
93     $RPM_BUILD_ROOT/root/vswitch/bin/ovs-wdt \
94     $RPM_BUILD_ROOT/root/vswitch/bin/secchan \
95     $RPM_BUILD_ROOT/root/vswitch/sbin/ovs-monitor \
96     $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-controller.8 \
97     $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-discover.8 \
98     $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-kill.8 \
99     $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-pki.8 \
100     $RPM_BUILD_ROOT/root/vswitch/share/man/man8/secchan.8 \
101     $RPM_BUILD_ROOT/root/vswitch/share/openvswitch
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %pre
107 if [ ! -f /etc/xensource-inventory ]; then
108     printf "XenSource inventory not present in /etc/xensource-inventory"
109     exit 1
110 fi
111
112 if [ "$1" = "1" ]; then
113     if ! md5sum -c --status <<EOF
114 b8e9835862ef1a9cec2a3f477d26c989  /etc/xensource/scripts/vif
115 51970ad613a3996d5997e18e44db47da  /opt/xensource/libexec/interface-reconfigure
116 5654c8c36699fcc8744ca9cd5b855414  /usr/sbin/xen-bugtool
117 EOF
118     then
119         printf "\nThe original XenServer scripts replaced by this package\n"
120         printf "are different than expected.  This could lead to unexpected\n"
121         printf "behavior of your server.  Unless you are sure you know what\n"
122         printf "you are doing, it is highly recommended that you remove this\n"
123         printf "package immediately after the install completes, which\n"
124         printf "will restore the XenServer scripts that you were previously\n"
125         printf "using.\n\n"
126     fi
127     if test "`/usr/sbin/brctl --version`" != "bridge-utils, 1.1"; then
128 cat <<EOF
129
130 /usr/sbin/brctl replaced by this package reports the following version:
131
132 `/usr/sbin/brctl --version`
133
134 The expected version was:
135
136 bridge-utils, 1.1
137
138 Unless you are sure you know what you are doing, it is highly recommended that
139 you remove this package immediately after the install completes, which will
140 restore the original /usr/sbin/brctl.
141
142 EOF
143     fi
144 fi
145
146 if test ! -e /etc/ovs-vswitch.dbcache; then
147     if test "$1" = 1; then
148         printf "Creating xapi database cache...  "
149     else
150         printf "warning: Open vSwitch is being re-installed or upgraded,\n"
151         printf "         but the xapi database cache is missing.\n"
152         printf "Re-creating xapi database cache...  "
153     fi
154
155     source /etc/xensource-inventory
156     if python - "$INSTALLATION_UUID" <<EOF
157 import XenAPI
158 import pickle
159 import sys
160
161 session = XenAPI.xapi_local()
162 try:
163     session.xenapi.login_with_password("root", "")
164
165     vlans = session.xenapi.VLAN.get_all_records()
166     bonds = session.xenapi.Bond.get_all_records()
167     pifs = session.xenapi.PIF.get_all_records()
168     networks = session.xenapi.network.get_all_records()
169     host = session.xenapi.host.get_by_uuid(sys.argv[1])
170 finally:
171     session.xenapi.session.logout()
172
173 dbcache_file = "/etc/ovs-vswitch.dbcache"
174 f = open(dbcache_file, 'w')
175 pickle.dump({'vlans': vlans,
176              'bonds': bonds,
177              'pifs': pifs,
178              'networks': networks}, f)
179 pickle.dump({'host': host}, f)
180 f.close()
181 EOF
182     then
183         printf "done.\n"
184     else
185         printf "FAILED\n"
186         printf "Open vSwitch can only be installed on a XenServer that\n"
187         printf "has connectivity to xapi on the pool master.  Please\n"
188         printf "fix connectivity to the pool master, then try again.\n"
189         exit 1
190     fi
191 fi
192
193 %post
194 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
195     cat >>/etc/sysctl.conf <<EOF
196 # This works around an issue in xhad, which binds to a particular
197 # Ethernet device, which in turn causes ICMP port unreachable messages
198 # if packets are received are on the wrong interface, which in turn
199 # can happen if we send out ARP replies on every interface (as Linux
200 # does by default) instead of just on the interface that has the IP
201 # address being ARPed for, which this sysctl setting in turn works
202 # around.
203 #
204 # Bug #1378.
205 net.ipv4.conf.all.arp_filter = 1
206 EOF
207 fi
208
209 # Ensure ovs-vswitchd.conf exists
210 touch /etc/ovs-vswitchd.conf
211
212 # Create default or update existing /etc/sysconfig/vswitch.
213 SYSCONFIG=/etc/sysconfig/vswitch
214 TEMPLATE=/root/vswitch/scripts/sysconfig.template
215 if [ ! -e $SYSCONFIG ]; then
216     cp $TEMPLATE $SYSCONFIG
217 else
218     for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
219     do
220         if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
221             echo >> $SYSCONFIG
222             sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
223         fi
224     done
225 fi
226
227 # Replace XenServer files by our versions.
228 mkdir -p %{_prefix}/xs-original \
229     || printf "Could not create script backup directory.\n"
230 for f in \
231     /opt/xensource/libexec/interface-reconfigure \
232     /etc/xensource/scripts/vif \
233     /usr/sbin/xen-bugtool \
234     /usr/sbin/brctl
235 do
236     s=$(basename "$f")
237     t=$(readlink "$f")
238     if [ "$t" != "%{_prefix}/scripts/$s" ]; then
239         mv "$f" %{_prefix}/xs-original/ \
240             || printf "Could not save original XenServer $s script\n"
241         ln -s "%{_prefix}/scripts/$s" "$f" \
242             || printf "Could not link to vSwitch $s script\n"
243     fi
244 done
245
246 # Install xsconsole plugin
247 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
248 if [ "$plugin" != "/root/vswitch/scripts/XSFeatureVSwitch.py" ]; then
249     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
250     ln -s /root/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
251 fi
252
253 # Ensure all required services are set to run
254 for s in vswitch vswitch-xapi-update; do
255     if chkconfig --list $s >/dev/null 2>&1; then
256         chkconfig --del $s || printf "Could not remove $s init script."
257     fi
258     chkconfig --add $s || printf "Could not add $s init script."
259     chkconfig $s on || printf "Could not enable $s init script."
260 done
261
262 if [ "$1" = "1" ]; then    # $1 = 2 for upgrade
263     printf "\nYou MUST reboot the server NOW to complete the change to the\n"
264     printf "the vSwitch.  Attempts to modify networking on the server\n"
265     printf "or any hosted VM will fail until after the reboot and could\n"
266     printf "leave the server in an state requiring manual recovery.\n\n"
267 else
268     printf "\nTo use the new vSwitch, you should reboot the server\n"
269     printf "now.  Failure to do so may result in incorrect operation.\n\n"
270 fi
271
272 %preun
273 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
274     for s in vswitch vswitch-xapi-update; do
275         chkconfig --del $s || printf "Could not remove $s init script."
276     done
277 fi
278
279
280 %postun
281 if [ "$1" = "0" ]; then     # $1 = 1 for upgrade
282
283     rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
284         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
285         /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
286         || printf "Could not remove vSwitch xsconsole plugin.\n"
287
288     # Restore original XenServer scripts
289     for f in \
290         /opt/xensource/libexec/interface-reconfigure \
291         /etc/xensource/scripts/vif \
292         /usr/sbin/xen-bugtool \
293         /usr/sbin/brctl
294     do
295         s=$(basename "$f")
296         if [ ! -f "%{_prefix}/xs-original/$s" ]; then
297             printf "Original XenServer $s script not present in %{_prefix}/xs-original\n"
298             printf "Could not restore original XenServer script.\n"
299         else
300             (rm -f "$f" \
301                 && mv "%{_prefix}/xs-original/$s" "$f") \
302                 || printf "Could not restore original XenServer $s script.\n"
303         fi
304     done
305
306     find  %{_prefix} -type d -depth -exec rmdir \{\} \; \
307         || printf "Could not remove vSwitch install directory.\n"
308
309     # Remove all configuration and log files
310     rm -f /etc/ovs-vswitchd.conf
311     rm -f /etc/sysconfig/vswitch
312     rm -f /var/log/vswitch*
313     rm -f /etc/ovs-vswitchd.cacert
314     rm -f /etc/ovs-vswitch.dbcache
315
316     printf "\nYou MUST reboot the server now to complete the change to\n"
317     printf "standard Xen networking.  Attempts to modify networking on the\n"
318     printf "server or any hosted VM will fail until after the reboot and\n"
319     printf "could leave the server in a state requiring manual recovery.\n\n"
320 fi
321
322
323 %files
324 %defattr(-,root,root)
325 /etc/init.d/vswitch
326 /etc/init.d/vswitch-xapi-update
327 /etc/xapi.d/plugins/vswitch-cfg-update
328 /etc/logrotate.d/vswitch
329 /etc/profile.d/vswitch.sh
330 /root/vswitch/kernel_modules/brcompat_mod.ko
331 /root/vswitch/kernel_modules/openvswitch_mod.ko
332 /root/vswitch/kernel_modules/veth_mod.ko
333 /root/vswitch/scripts/dump-vif-details
334 /root/vswitch/scripts/refresh-xs-network-uuids
335 /root/vswitch/scripts/interface-reconfigure
336 /root/vswitch/scripts/vif
337 /root/vswitch/scripts/xen-bugtool
338 /root/vswitch/scripts/XSFeatureVSwitch.py
339 /root/vswitch/scripts/brctl
340 /root/vswitch/scripts/sysconfig.template
341 # Following two files are generated automatically by rpm.  We don't
342 # really need them and they won't be used on the XenServer, but there
343 # isn't an obvious place to get rid of them since they are generated
344 # after the install script runs.  Since they are small, we just
345 # include them.
346 /root/vswitch/scripts/XSFeatureVSwitch.pyc
347 /root/vswitch/scripts/XSFeatureVSwitch.pyo
348 /root/vswitch/sbin/ovs-brcompatd
349 /root/vswitch/sbin/ovs-vswitchd
350 /root/vswitch/bin/ovs-appctl
351 /root/vswitch/bin/ovs-cfg-mod
352 /root/vswitch/bin/ovs-dpctl
353 /root/vswitch/bin/ovs-ofctl
354 /root/vswitch/share/man/man5/ovs-vswitchd.conf.5
355 /root/vswitch/share/man/man8/ovs-appctl.8
356 /root/vswitch/share/man/man8/ovs-brcompatd.8
357 /root/vswitch/share/man/man8/ovs-cfg-mod.8
358 /root/vswitch/share/man/man8/ovs-dpctl.8
359 /root/vswitch/share/man/man8/ovs-ofctl.8
360 /root/vswitch/share/man/man8/ovs-vswitchd.8