Set up different namespaces for match and target arguments.
[sfa.git] / sfa.spec
index d04af29..66185b0 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,8 +1,13 @@
-%define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
+
+#
+# $Id$
+#
+
+%define url $URL$
 
 %define name sfa
 
 %define name sfa
-%define version 0.8
-%define taglevel 6
+%define version 0.9
+%define taglevel 5
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -20,14 +25,21 @@ Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
+Summary: the SFA python libraries
+Group: Applications/System
 
 BuildRequires: make
 Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 
 BuildRequires: make
 Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
+Requires: libxslt-python
 
 
-Summary: the SFA python libraries
-Group: Applications/System
+# python 2.5 has uuid module added, for python 2.4 we still need it
+%define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
+%if has_uuid
+%else
+Requires: python-uuid
+%endif
 
 %package plc
 Summary: the SFA wrapper arounf MyPLC
 
 %package plc
 Summary: the SFA wrapper arounf MyPLC
@@ -39,6 +51,11 @@ Summary: the SFA experimenter-side CLI
 Group: Applications/System
 Requires: sfa
 
 Group: Applications/System
 Requires: sfa
 
+%package sfatables
+Summary: sfatables policy tool for SFA
+Group: Applications/System
+Requires: sfa
+
 %description
 This package provides the python libraries that the SFA implementation requires
 
 %description
 This package provides the python libraries that the SFA implementation requires
 
@@ -50,6 +67,11 @@ between the existing PlanetLab interfaces and the SFA API.
 This package provides the client side of the SFA API, in particular
 sfi.py, together with other utilities.
 
 This package provides the client side of the SFA API, in particular
 sfi.py, together with other utilities.
 
+%description sfatables
+sfatables is a tool for defining access and admission control policies
+in an SFA network, in much the same way as iptables is for ip
+networks. This is the command line interface to manage sfatables
+
 %prep
 %setup -q
 
 %prep
 %setup -q
 
@@ -64,10 +86,13 @@ make install DESTDIR="$RPM_BUILD_ROOT"
 rm -rf $RPM_BUILD_ROOT
 
 %files
 rm -rf $RPM_BUILD_ROOT
 
 %files
+# sfa and sfatables depend each other.
+/etc/sfatables/*
 %{python_sitelib}/*
 /usr/bin/keyconvert
 /var/www/html/wsdl/*.wsdl
 
 %{python_sitelib}/*
 /usr/bin/keyconvert
 /var/www/html/wsdl/*.wsdl
 
+
 %files plc
 %defattr(-,root,root)
 %config (noreplace) /etc/sfa/sfa_config
 %files plc
 %defattr(-,root,root)
 %config (noreplace) /etc/sfa/sfa_config
@@ -76,6 +101,7 @@ rm -rf $RPM_BUILD_ROOT
 /etc/init.d/sfa
 %{_bindir}/sfa-config-tty
 %{_bindir}/sfa-import-plc.py*
 /etc/init.d/sfa
 %{_bindir}/sfa-config-tty
 %{_bindir}/sfa-import-plc.py*
+%{_bindir}/sfa-clean-peer-records.py*
 %{_bindir}/sfa-nuke-plc.py*
 %{_bindir}/sfa-server.py*
 
 %{_bindir}/sfa-nuke-plc.py*
 %{_bindir}/sfa-server.py*
 
@@ -87,6 +113,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/setRecord.py*
 %{_bindir}/genidump.py*
 
 %{_bindir}/setRecord.py*
 %{_bindir}/genidump.py*
 
+%files sfatables
+%{_bindir}/sfatables
+
 %pre plc
 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
 
 %pre plc
 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
 
@@ -94,6 +123,34 @@ rm -rf $RPM_BUILD_ROOT
 chkconfig --add sfa
 
 %changelog
 chkconfig --add sfa
 
 %changelog
+* Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
+- Create_slice and get_resources methods are connected to sfatables.
+- Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
+
+* Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
+- Bug fix on update and remove_peer_object methods
+- Compatibility with RP, preliminiary version of sfatables, call tracability and logging
+
+* Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
+- Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
+
+* Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
+- compatibility with RefreshPeer
+- incremental mechanism for importing PLC records into SFA tables
+- unified single database (still inside the underlying PLC db postgresql server)
+- includes/improves call traceability and logging features
+- several bug fixes
+
+* Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
+- added libxslt-python dependency
+
+* Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
+- unified single SFA database in the PLC-DB
+- upcalls from  PLCAPI to SFA methods
+- SFA call traceability and logging features
+- many bug fixes
+- includes first/rough version of sfatables for policy implementation
+
 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
 - snapshot after the GEC5 demo
 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
 - snapshot after the GEC5 demo
 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module