cleanup
[sfa.git] / Makefile.debian
index 1c78bf5..1a48318 100644 (file)
@@ -1,35 +1,26 @@
-# $Id: Makefile,v 1.6 2008/10/29 01:01:35 ghantoos Exp $
-#
-
-PYTHON=`which python`
-DESTDIR=/
-BUILDIR=$(CURDIR)/debian/sfa
 PROJECT=sfa
-VERSION=0.2.0
+PYTHON=python
+DESTDIR=/
+SETUPOPTS=
 
-all:
-       @echo "make source - Create source package"
-       @echo "make install - Install on local system"
-       @echo "make buildrpm - Generate a rpm package"
-       @echo "make builddeb - Generate a deb package"
-       @echo "make clean - Get rid of scratch and byte files"
+all: builddeb 
 
 source:
-       $(PYTHON) setup.py sdist $(COMPILE)
+       $(PYTHON) setup.py sdist $(SETUPOPTS)
 
 install:
-       $(PYTHON) setup.py install --root $(DESTDIR) $(COMPILE)
+       $(PYTHON) setup.py install --root $(DESTDIR) $(SETUPOPTS)
 
-buildrpm:
-       $(PYTHON) setup.py bdist_rpm --post-install=rpm/postinstall --pre-uninstall=rpm/preuninstall
+#buildrpm:
+#      $(PYTHON) setup.py bdist_rpm --post-install=rpm/postinstall --pre-uninstall=rpm/preuninstall
 
+# build the source package in the parent directory
+# then rename it to project_version.orig.tar.gz as expected for debian packaging
+# finally build the package
 builddeb:
        rm -f sfaadmin sfascan sfi  
-       # build the source package in the parent directory
-       # then rename it to project_version.orig.tar.gz
-       $(PYTHON) setup.py sdist $(COMPILE) --dist-dir=../ --prune
+       $(PYTHON) setup.py sdist $(SETUPOPTS)  --formats=gztar --dist-dir=../ --prune
        rename -f 's/$(PROJECT)-(.*)\.tar\.gz/$(PROJECT)_$$1\.orig\.tar\.gz/' ../*
-       # build the package
        dpkg-buildpackage -i -I -rfakeroot
 
 clean:
@@ -37,3 +28,11 @@ clean:
        $(MAKE) -f $(CURDIR)/debian/rules clean
        rm -rf build/ MANIFEST
        find . -name '*.pyc' -delete
+
+help:
+       @echo "make source - Create source package"
+       @echo "make install - Install on local system"
+#      @echo "make buildrpm - Generate an rpm package"
+       @echo "make builddeb - Generate a deb package"
+       @echo "make clean - Get rid of scratch and byte files"
+