tweaks for reservable nodes
[plcapi.git] / PLCAPI.spec
index 22279ae..43e747e 100644 (file)
@@ -6,7 +6,7 @@
 
 %define name PLCAPI
 %define version 5.0
-%define taglevel 4
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -48,7 +48,9 @@ Requires: python-twisted-web
 Conflicts: MyPLC <= 4.3
 
 # We use psycopg2
-BuildRequires: postgresql-devel
+#
+# but we don't need to rebuild it as we depend on distro's packages - baris
+# BuildRequires: postgresql-devel
 
 # Standard xmlrpc.so that ships with PHP does not marshal NULL
 BuildRequires: php-devel
@@ -112,6 +114,7 @@ install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
 # Install omf_slicemgr.py
 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
+mkdir -p $RPM_BUILD_ROOT/var/log/omf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -121,6 +124,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root,-)
 %dir %{_datadir}/plc_api
+%dir /var/log/omf/
 %{_datadir}/plc_api/*
 %{_bindir}/plcsh
 %{php_extension_dir}/xmlrpc.so
@@ -132,7 +136,22 @@ rm -rf $RPM_BUILD_ROOT
 /usr/bin/omf_slicemgr.py*
 /usr/bin/reset_xmpp_pubsub_nodes.py*
 
+
 %changelog
+* Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
+- the leases system
+
+* Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
+- previous tag had gone wrong
+
+* Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
+- fix pubsub hostname
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
+- tweaks for the omf support (xmpp groups and RC-controlled slices)
+- BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
+- GetNodeFlavour exposes fcdistro
+
 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally