dont forget to import SessionAuth from Auth
[plcapi.git] / PLCAPI.spec
index 19673d6..4fd66d1 100644 (file)
@@ -5,10 +5,10 @@
 %define url $URL$
 
 %define name PLCAPI
-%define version 4.1
-%define subversion 2
+%define version 4.2
+%define taglevel 3
 
-%define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: PlanetLab Central API
 Name: %{name}
@@ -18,6 +18,10 @@ License: PlanetLab
 Group: System Environment/Daemons
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Obsoletes: plcapilib
@@ -55,8 +59,15 @@ through Apache mod_python.
 %setup -q
 
 %build
+# python-pycurl and python-psycopg2 avail. from fedora 5
+# make sure to check build/<pldistro>/plc.pkgs
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
 # Build __init__.py metafiles and PHP API. 
-%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc"
+%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc" modules="$modules"
 # Build documentation
 # beware that making the pdf file somehow overwrites the html
 %{__make} -C doc PLCAPI.pdf
@@ -65,7 +76,12 @@ rm -f doc/PLCAPI.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
 #someone out there skips doc installation - we DO want this installed
 for doc in PLCAPI.html PLCAPI.pdf ; do
     install -D -m 644 doc/$doc $RPM_BUILD_ROOT/"%{_datadir}"/plc_api/doc/$doc
@@ -98,5 +114,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/refresh-peer.py*
 
 %changelog
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
+- GetBootMedium support for build.sh full options, incl. serial & console_spec 
+- GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
+
+* Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
+- refresh peer script to use a month-dependent logfile
+- tracking the starting point for UniPi integration of the dummynet boxes
+
+* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
+- plcsh adds its own path to sys.path
+- fix so GetNodes can be called from a Node
+
 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
 - Initial build.