no longer check if slice is local or peer
[plcapi.git] / PLCAPI.spec
index 84d04a3..8ada335 100644 (file)
@@ -56,9 +56,9 @@ through Apache mod_python.
 
 %build
 # python-pycurl and python-psycopg2 avail. from fedora 5
-# make sure to check myplc/<pldistro>-plc.lst
+# make sure to check build/<pldistro>/plc.pkgs
 if [ "%{distrorelease}" -le 4 ] ; then
-    modules="build_psycopg2=true build_pycurl=true"
+    modules="psycopg2 pycurl"
 else
     modules=""
 fi
@@ -72,7 +72,12 @@ rm -f doc/PLCAPI.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
 #someone out there skips doc installation - we DO want this installed
 for doc in PLCAPI.html PLCAPI.pdf ; do
     install -D -m 644 doc/$doc $RPM_BUILD_ROOT/"%{_datadir}"/plc_api/doc/$doc