fix join tables, should be ['pcu_protocol_type']
[plcapi.git] / PLCAPI.spec
index 7f46bf3..8ada335 100644 (file)
@@ -72,7 +72,12 @@ rm -f doc/PLCAPI.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
 #someone out there skips doc installation - we DO want this installed
 for doc in PLCAPI.html PLCAPI.pdf ; do
     install -D -m 644 doc/$doc $RPM_BUILD_ROOT/"%{_datadir}"/plc_api/doc/$doc