more accessors, and site-local might work now
[plcapi.git] / PLCAPI.spec
index 57b064c..ac5e6fd 100644 (file)
@@ -55,23 +55,15 @@ through Apache mod_python.
 
 %build
 # python-pycurl and python-psycopg2 avail. from fedora 5
-# make sure to check build/<pldistro>/plc.pkgs
-if [ "%{distrorelease}" -le 4 ] ; then
-    modules="psycopg2 pycurl"
-else
-    modules=""
-fi
+# we used to ship our own version of psycopg2 and pycurl, for fedora4
+# starting with 5.0, support for these two modules is taken out
+# 
 # Build __init__.py metafiles and PHP API. 
-%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc" modules="$modules"
+%{__make} %{?_smp_mflags}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-if [ "%{distrorelease}" -le 4 ] ; then
-    modules="psycopg2 pycurl"
-else
-    modules=""
-fi
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
 
 # Install shell symlink
 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
@@ -95,7 +87,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/plcsh
 %{php_extension_dir}/xmlrpc.so
 %{_sysconfdir}/php.d/xmlrpc.ini
-%{_bindir}/refresh-peer.py*
+%config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
 
 %changelog
 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8