remove debugging print statement
[plcapi.git] / PLCAPI.spec
index 81d139e..cc08b3f 100644 (file)
@@ -2,11 +2,13 @@
 # $Id$
 #
 
+%define url $URL$
+
 %define name PLCAPI
-%define version 4.1
-%define subversion 2
+%define version 4.2
+%define taglevel 0
 
-%define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: PlanetLab Central API
 Name: %{name}
@@ -14,11 +16,14 @@ Version: %{version}
 Release: %{release}
 License: PlanetLab
 Group: System Environment/Daemons
-# too bad the spec syntax does not like this 
-#URL: $URL$
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+
 Obsoletes: plcapilib
 
 # We use set everywhere
@@ -54,8 +59,15 @@ through Apache mod_python.
 %setup -q
 
 %build
+# python-pycurl and python-psycopg2 avail. from fedora 5
+# make sure to check build/<pldistro>/plc.pkgs
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
 # Build __init__.py metafiles and PHP API. 
-%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc"
+%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc" modules="$modules"
 # Build documentation
 # beware that making the pdf file somehow overwrites the html
 %{__make} -C doc PLCAPI.pdf
@@ -64,7 +76,12 @@ rm -f doc/PLCAPI.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
 #someone out there skips doc installation - we DO want this installed
 for doc in PLCAPI.html PLCAPI.pdf ; do
     install -D -m 644 doc/$doc $RPM_BUILD_ROOT/"%{_datadir}"/plc_api/doc/$doc