remove debugging print statement
[plcapi.git] / PLCAPI.spec
index ff7723b..cc08b3f 100644 (file)
@@ -6,9 +6,9 @@
 
 %define name PLCAPI
 %define version 4.2
-%define subversion 0
+%define taglevel 0
 
-%define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: PlanetLab Central API
 Name: %{name}
@@ -18,6 +18,10 @@ License: PlanetLab
 Group: System Environment/Daemons
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Obsoletes: plcapilib
@@ -56,7 +60,7 @@ through Apache mod_python.
 
 %build
 # python-pycurl and python-psycopg2 avail. from fedora 5
-# make sure to check myplc/<pldistro>-plc.lst
+# make sure to check build/<pldistro>/plc.pkgs
 if [ "%{distrorelease}" -le 4 ] ; then
     modules="psycopg2 pycurl"
 else
@@ -72,7 +76,12 @@ rm -f doc/PLCAPI.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
 #someone out there skips doc installation - we DO want this installed
 for doc in PLCAPI.html PLCAPI.pdf ; do
     install -D -m 644 doc/$doc $RPM_BUILD_ROOT/"%{_datadir}"/plc_api/doc/$doc