new method next_id(...) returns next primary key id
[plcapi.git] / PLCAPI.spec
index 13ba2ce..d1f76cf 100644 (file)
@@ -5,8 +5,8 @@
 %define url $URL$
 
 %define name PLCAPI
-%define version 4.2
-%define taglevel 6
+%define version 5.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -37,11 +37,6 @@ BuildRequires: php-devel
 Obsoletes: php-xmlrpc
 Provides: php-xmlrpc
 
-# OpenJade does not honor XML catalog files and tries to access
-# www.oasis-open.org even if DTDs are locally installed. Disable
-# documentation generation for now.
-# BuildRequires: docbook-dtds, docbook-utils-pdf
-
 # PostgreSQL and SOAPpy are necessary to run the API server, but not
 # plcsh. Since the only supported method of running the server is via
 # MyPLC anyway, don't be so stringent about binary requirements, in
@@ -60,32 +55,15 @@ through Apache mod_python.
 
 %build
 # python-pycurl and python-psycopg2 avail. from fedora 5
-# make sure to check build/<pldistro>/plc.pkgs
-if [ "%{distrorelease}" -le 4 ] ; then
-    modules="psycopg2 pycurl"
-else
-    modules=""
-fi
+# we used to ship our own version of psycopg2 and pycurl, for fedora4
+# starting with 5.0, support for these two modules is taken out
+# 
 # Build __init__.py metafiles and PHP API. 
-%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc" modules="$modules"
-# Build documentation
-# beware that making the pdf file somehow overwrites the html
-%{__make} -C doc PLCAPI.pdf
-rm -f doc/PLCAPI.html
-%{__make} -C doc PLCAPI.html
+%{__make} %{?_smp_mflags}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-if [ "%{distrorelease}" -le 4 ] ; then
-    modules="psycopg2 pycurl"
-else
-    modules=""
-fi
-%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
-#someone out there skips doc installation - we DO want this installed
-for doc in PLCAPI.html PLCAPI.pdf ; do
-    install -D -m 644 doc/$doc $RPM_BUILD_ROOT/"%{_datadir}"/plc_api/doc/$doc
-done
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
 
 # Install shell symlink
 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
@@ -104,16 +82,21 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root,-)
-#someone out there skips doc installation - we DO want this installed
-#%doc doc/PLCAPI.xml doc/PLCAPI.pdf doc/PLCAPI.html
 %dir %{_datadir}/plc_api
 %{_datadir}/plc_api/*
 %{_bindir}/plcsh
 %{php_extension_dir}/xmlrpc.so
 %{_sysconfdir}/php.d/xmlrpc.ini
-%{_bindir}/refresh-peer.py*
 
 %changelog
+* Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
+- fixed doc build by locating locally installed DTDs at build-time
+
+* Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
+- no more doc packaged outside of myplc-docs - doc/ cleaned up
+- enhancements in doc on filters 
+- bootcd-aware GetBootMedium merged from onelab
+
 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
 - checkpoint while the new myplc-docs package is underway
 - bugfix: GetSlivers & conf files
@@ -143,3 +126,5 @@ rm -rf $RPM_BUILD_ROOT
 
 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
 - Initial build.
+
+%define module_current_branch 4.2