get them installed
[plcapi.git] / PLCAPI.spec
index 081c5d3..d69f4a3 100644 (file)
@@ -38,6 +38,10 @@ Requires: mod_ssl
 Requires: SOAPpy
 # for the RebootNodeWithPCU method
 Requires: pcucontrol
+# for OMF integration
+Requires: pyaspects
+Requires: python-twisted-words
+Requires: python-twisted-web
 
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/api
@@ -105,6 +109,9 @@ chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 echo "* Installing wsdl"
 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
 
+# Install omf-slicemgr.py
+install -D -m 744 omf/omf-slicemgr.py $RPM_BUILD_ROOT/usr/bin/
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -118,6 +125,7 @@ rm -rf $RPM_BUILD_ROOT
 %{php_extension_dir}/xmlrpc.so
 %{_sysconfdir}/php.d/xmlrpc.ini
 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
+/usr/bin/omf-slicemgr.py
 /etc/plc.d
 /etc/planetlab/db-config.d
 /var/www/html/wsdl/plcapi.wsdl