we'll need to import omf_slicemgr
[plcapi.git] / PLCAPI.spec
index 25361be..e834b59 100644 (file)
@@ -6,7 +6,7 @@
 
 %define name PLCAPI
 %define version 5.0
-%define taglevel 0
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -38,10 +38,14 @@ Requires: mod_ssl
 Requires: SOAPpy
 # for the RebootNodeWithPCU method
 Requires: pcucontrol
+# for OMF integration
+Requires: pyaspects
+Requires: python-twisted-words
+Requires: python-twisted-web
 
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/api
-Conflicts: MyPLC <= 4.3-37
+Conflicts: MyPLC <= 4.3
 
 # We use psycopg2
 BuildRequires: postgresql-devel
@@ -105,6 +109,9 @@ chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 echo "* Installing wsdl"
 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
 
+# Install omf_slicemgr.py
+install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -121,8 +128,26 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 /etc/planetlab/db-config.d
 /var/www/html/wsdl/plcapi.wsdl
+/usr/bin/omf_slicemgr.py*
 
 %changelog
+* Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
+- major cleanup
+- get rid of all 4.2-related legacy code
+- reset the migrations code, planetlab5.sql somes with (5,100)
+- uses hashlib module when available
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
+- first working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- nodefamily is 3-fold with pldistro-fcdistro-arch
+- site and person tags
+- new methods GetSliceFamily and GetNodeFlavour
+- deprecated the dummynet stuff that were for the external dummyboxes
+- tags definition : more consistency between db-config scripts and accessors
+- (get accessor to create the tag type too if absent)
+- logging an event for AddSliceToNodes
+
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
 - support for fedora 12
 - fix subtle bug in filtering with ] and quotes