Merge branch 'master' into funcaspect
[plcapi.git] / PLCAPI.spec
index b87fb4e..e9d036d 100644 (file)
@@ -1,6 +1,6 @@
 %define name PLCAPI
 %define version 5.0
-%define taglevel 28
+%define taglevel 30
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -44,6 +44,7 @@ Requires: python-ldap
 # for memcache
 Requires: python-memcached
 Requires: memcached
+Requires: Django
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/api
 Conflicts: MyPLC <= 4.3
@@ -121,6 +122,12 @@ mkdir -p $RPM_BUILD_ROOT/var/log/omf
 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
 
+# Create func directories
+mkdir -p $RPM_BUILD_ROOT/var/www/html/func
+mkdir -p $RPM_BUILD_ROOT/var/log/funcaspect/
+chmod apache:apache $RPM_BUILD_ROOT/var/www/html/func
+chmod apache:apache $RPM_BUILD_ROOT/var/log/funcaspect/
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -144,6 +151,13 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
+- working draft for GetSliceSshKeys
+
+* Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
+- trash getbootmedium tmp file if already exists but is longer than 5 minutes old
+- (this is for people who cancel their download)
+
 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
 - fix db-config sequence : accessors step now merged in, and occurs at the right time
 - db-config also more robust