Use the new bootcd's build.sh script, which does not need root.
[plcapi.git] / PLCAPI.spec
index 28c6703..ff7723b 100644 (file)
@@ -2,9 +2,11 @@
 # $Id$
 #
 
+%define url $URL$
+
 %define name PLCAPI
-%define version 4.1
-%define subversion 2
+%define version 4.2
+%define subversion 0
 
 %define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -14,9 +16,9 @@ Version: %{version}
 Release: %{release}
 License: PlanetLab
 Group: System Environment/Daemons
-URL: $URL$
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Obsoletes: plcapilib
 
@@ -53,8 +55,15 @@ through Apache mod_python.
 %setup -q
 
 %build
+# python-pycurl and python-psycopg2 avail. from fedora 5
+# make sure to check myplc/<pldistro>-plc.lst
+if [ "%{distrorelease}" -le 4 ] ; then
+    modules="psycopg2 pycurl"
+else
+    modules=""
+fi
 # Build __init__.py metafiles and PHP API. 
-%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc"
+%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc" modules="$modules"
 # Build documentation
 # beware that making the pdf file somehow overwrites the html
 %{__make} -C doc PLCAPI.pdf