svn:keywords
[plewww.git] / PLCWWW.spec
index 0c4b2d9..93544f4 100644 (file)
@@ -1,12 +1,13 @@
 #
-# $Id: PLCWWW.spec 1206 2008-03-03 15:49:07Z thierry $
+# $Id$
 #
-%define module_taglevel_varname subversion
 %define name PLCWWW
-%define version onelab.4.2
-%define subversion 8
+%define version PLE.5.0
+%define taglevel 0
 
-%define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+# no need to mention pldistro as this module differs in both distros
+#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?date:.%{date}}
 
 Summary: PlanetLab Central (PLC) Web Pages
 Name: %{name}
@@ -27,7 +28,7 @@ URL: http://svn.one-lab.org/svn/new_plc_www/
 #Requires: httpd >= 2.0
 Requires: php >= 5.0
 Requires: postgresql >= 8.0
-Requires: PLCAPI >= 4.2
+Requires: PLCAPI >= 5.0
 
 # on centos5, when rebuilding the full monty, we get:
 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
@@ -52,13 +53,13 @@ rm -rf $RPM_BUILD_ROOT
 # plcwww
 #
 
-echo "* PLCWWW: Installing web pages"
+echo "* PLEWWW: Installing web pages"
 mkdir -p $RPM_BUILD_ROOT/var/www/html
 # let's be conservative and exclude codebase files, though there should not be any
 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
 
-echo "* PLCWWW: Installing drupal config for httpd"
-install -D -m 644 drupal.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/drupal.conf
+echo "* PLEWWW: Installing config for httpd"
+install -D -m 644 planetlab.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/planetlab.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -66,9 +67,18 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root,-)
 /var/www/html
-/etc/httpd/conf.d/drupal.conf
+/etc/httpd/conf.d/planetlab.conf
 
 %changelog
+* Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
+- everyone is welcome to add nodes
+
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
+- node-specific bootcd images to include arch in their name
+
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
+- remove explicit dep to bootcd as the rpm name has changed
+
 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
 - noarch