support for multiple slice reference images
[nodeimage.git] / bootstrapfs.spec
index 06ebe12..bca657f 100644 (file)
@@ -3,18 +3,22 @@
 #
 %define url $URL$
 
-%define name bootstrapfs
+%define nodefamily %{pldistro}-%{_arch}
+
+%define name bootstrapfs-%{nodefamily}
 %define version 0.1
 %define taglevel 2
 
-%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+# pldistro already in the rpm name
+#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: The PlanetLab Bootstrap Filesystems
+Summary: The PlanetLab Bootstrap Filesystems for %{nodefamily}
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -40,7 +44,7 @@ BootManager to instantiate a node with a new filesystem.
 
 %build
 pushd BootstrapFS
-./build.sh %{distroname} %{pldistro} 
+./build.sh %{pldistro} 
 popd BootstrapFS
 
 %install