debian: Add support for GRE-over-IPsec
[sliver-openvswitch.git] / debian / automake.mk
index 1b64945..2043206 100644 (file)
@@ -4,8 +4,10 @@ EXTRA_DIST += \
        debian/control \
        debian/control.modules.in \
        debian/copyright \
+       debian/copyright.in \
        debian/corekeeper.cron.daily \
        debian/corekeeper.init \
+       debian/corekeeper.override \
        debian/dirs \
        debian/openvswitch-common.dirs \
        debian/openvswitch-common.install \
@@ -22,20 +24,14 @@ EXTRA_DIST += \
        debian/openvswitch-datapath-source.copyright \
        debian/openvswitch-datapath-source.dirs \
        debian/openvswitch-datapath-source.install \
-       debian/openvswitch-monitor.default \
-       debian/openvswitch-monitor.dirs \
-       debian/openvswitch-monitor.init \
-       debian/openvswitch-monitor.install \
+       debian/openvswitch-ipsec.dirs \
+       debian/openvswitch-ipsec.init \
+       debian/openvswitch-ipsec.install \
        debian/openvswitch-pki-server.apache2 \
        debian/openvswitch-pki-server.dirs \
        debian/openvswitch-pki-server.install \
        debian/openvswitch-pki-server.postinst \
        debian/openvswitch-pki.postinst \
-       debian/openvswitch-switch-config.dirs \
-       debian/openvswitch-switch-config.install \
-       debian/openvswitch-switch-config.manpages \
-       debian/openvswitch-switch-config.overrides \
-       debian/openvswitch-switch-config.templates \
        debian/openvswitch-switch.README.Debian \
        debian/openvswitch-switch.dirs \
        debian/openvswitch-switch.init \
@@ -45,19 +41,29 @@ EXTRA_DIST += \
        debian/openvswitch-switch.postinst \
        debian/openvswitch-switch.postrm \
        debian/openvswitch-switch.template \
-       debian/openvswitch-switchui.copyright \
-       debian/openvswitch-switchui.default \
-       debian/openvswitch-switchui.dirs \
-       debian/openvswitch-switchui.init \
-       debian/openvswitch-switchui.install \
-       debian/openvswitch-wdt.default \
-       debian/openvswitch-wdt.dirs \
-       debian/openvswitch-wdt.init \
-       debian/openvswitch-wdt.install \
-       debian/ovs-switch-setup \
-       debian/ovs-switch-setup.8 \
-       debian/po/POTFILES.in \
-       debian/po/templates.pot \
-       debian/reconfigure \
+       debian/ovs-bugtool \
+       debian/ovs-monitor-ipsec \
+       debian/python-openvswitch.dirs \
+       debian/python-openvswitch.install \
        debian/rules \
        debian/rules.modules
+
+check-debian-changelog-version:
+       @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
+       then                                                               \
+         :;                                                               \
+       else                                                               \
+         echo "Update debian/changelog to mention version $(VERSION)";    \
+         exit 1;                                                          \
+       fi
+ALL_LOCAL += check-debian-changelog-version
+DIST_HOOKS += check-debian-changelog-version
+
+$(srcdir)/debian/copyright: AUTHORS debian/copyright.in
+       { sed -n -e '/%AUTHORS%/q' -e p < $(srcdir)/debian/copyright.in;   \
+         sed '1,/^$$/d' $(srcdir)/AUTHORS |                               \
+               sed -n -e '/^$$/q' -e 's/^/  /p';                          \
+         sed -e '1,/%AUTHORS%/d' $(srcdir)/debian/copyright.in;           \
+       } > $@
+
+DISTCLEANFILES += debian/copyright