utilities: Remove ovs-wdt.
[sliver-openvswitch.git] / debian / automake.mk
index 80b66cc..51eeed5 100644 (file)
@@ -1,13 +1,12 @@
 EXTRA_DIST += \
        debian/changelog \
-       debian/commands/reconfigure \
-       debian/commands/update \
        debian/compat \
        debian/control \
        debian/control.modules.in \
        debian/copyright \
        debian/corekeeper.cron.daily \
        debian/corekeeper.init \
+       debian/corekeeper.override \
        debian/dirs \
        debian/openvswitch-common.dirs \
        debian/openvswitch-common.install \
@@ -24,10 +23,6 @@ EXTRA_DIST += \
        debian/openvswitch-datapath-source.copyright \
        debian/openvswitch-datapath-source.dirs \
        debian/openvswitch-datapath-source.install \
-       debian/openvswitch-monitor.default \
-       debian/openvswitch-monitor.dirs \
-       debian/openvswitch-monitor.init \
-       debian/openvswitch-monitor.install \
        debian/openvswitch-pki-server.apache2 \
        debian/openvswitch-pki-server.dirs \
        debian/openvswitch-pki-server.install \
@@ -47,18 +42,21 @@ EXTRA_DIST += \
        debian/openvswitch-switch.postinst \
        debian/openvswitch-switch.postrm \
        debian/openvswitch-switch.template \
-       debian/openvswitch-switchui.copyright \
-       debian/openvswitch-switchui.default \
-       debian/openvswitch-switchui.dirs \
-       debian/openvswitch-switchui.init \
-       debian/openvswitch-switchui.install \
-       debian/openvswitch-wdt.default \
-       debian/openvswitch-wdt.dirs \
-       debian/openvswitch-wdt.init \
-       debian/openvswitch-wdt.install \
        debian/ovs-switch-setup \
        debian/ovs-switch-setup.8 \
        debian/po/POTFILES.in \
        debian/po/templates.pot \
+       debian/reconfigure \
        debian/rules \
        debian/rules.modules
+
+check-debian-changelog-version:
+       @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
+       then                                                               \
+         :;                                                               \
+       else                                                               \
+         echo "Update debian/changelog to mention version $(VERSION)";    \
+         exit 1;                                                          \
+       fi
+ALL_LOCAL += check-debian-changelog-version
+DIST_HOOKS += check-debian-changelog-version